



<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8"/><script>/* <![CDATA[ */ ringDataLayer = {"context":{"variant":{"accelerator":"d3d3LnB1bHNlbGl2ZS5jby5rZTo6UFJPRF9WMQ=="},"publication_structure":{"root":"WWW_PULSELIVE_CO_KE","path":"APO/ARTICLE"},"id":{"aureus_offers":["7lsiaqnvx6"]}},"content":{"object":{"type":"story","kind":"article","id":"2b737070-0847-4ee7-af1f-df7da0c84a78"},"part":1,"publication":{"point":{"id":"8wgbeht"}},"source":{"system":"ring_content_space","id":"7dd277c7-e647-489d-a0cd-8c305073a877"}}}; /* ]]> */</script><script>/* <![CDATA[ */ accConf = {"rum":{"tid":"EA-4719209","cookieInfo":0,"pageType":"HTML","data":{"RTYPE":"{\"type\":\"story\",\"kind\":\"article\"}"}},"gtm":{"id":["GTM-MGFD5X"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}}; /* ]]> */</script>
        <script type="text/javascript">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</script>
        <script type="text/javascript">
        if(accConf&&accConf.rum&&accConf.rum.data)for(var key in window.dlRumData||(window.dlRumData=[]),accConf.rum.data)window.dlRumData.push({metricName:key,eventValue:accConf.rum.data[key]});
        </script>
        
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<!-- End Google Tag Manager -->

    <meta name="viewport" content="width=device-width, initial-scale=1">
    









    <title>Rwandan Minister of Foreign Affairs to visit Finland | Pulselive Kenya</title>





    <meta name="description" content="Minister for Foreign Affairs Haavisto will meet Rwanda’s Minister of Foreign Affairs Vincent Biruta in Helsinki on 6 October. | Pulselive Kenya">



    
        
            <meta name="robots" content="index,follow">
        
    



    <link rel="canonical" href="https://www.africa-newsroom.com/press/rwandan-minister-of-foreign-affairs-to-visit-finland?lang=en" />
    
        <link rel="amphtml" href="https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht.amp" />
    



    <meta name="ring-local-canonical" content="https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht" data-isExternal="true">



    <meta name="DC.Identifier" content="2b737070-0847-4ee7-af1f-df7da0c84a78">





    <meta name="theme-color" content="#AC2723"/>



    <link rel="apple-touch-icon" href="https://ocdn.eu/radp/pwa/512x512.png">



    <link rel="manifest" href="/manifest.json"  crossorigin="use-credentials" >

    


    

    
        
            <meta property="og:title" content="Rwandan Minister of Foreign Affairs to visit Finland" />
        
        
            <meta property="og:description" content="Minister for Foreign Affairs Haavisto will meet Rwanda’s Minister of Foreign Affairs Vincent Biruta in Helsinki on 6 October" />
        

        
            
            
            
            
            

            
                
                    
                        <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/taOktktTURBXy9mNDVhYmJmYi04ZmQ3LTQ1ZDAtYWMzMi00MmZlZGY3MjQzNzgucG5nkZMFzQSwzQJ2" />
                    
                
            

            
                <meta property="og:image:width" content="1200" />
            
            
                <meta property="og:image:height" content="630" />
            
            
                <meta property="og:image:type" content="png"/>
            
            
                <meta property="og:image:alt" content="Ministry of Foreign Affairs of Finland"/>
            
        

        
            <meta property="og:url" content="https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht" />
        
        
            <meta property="og:type" content="Article" />
        
        
            <meta property="og:site_name" content="Pulselive Kenya"/>
        
        
            <meta property="article:publisher" content="https://www.facebook.com/pulselivekenya"/>
        
        
            <meta property="og:locale" content="en_EN" />
        
        
            <meta property="article:published_time" content="2021-10-05 17:09:22+0200" />
        
        
            <meta property="article:modified_time" content="2021-10-05 17:09:22+0200" />
        
        
            <meta property="article:section" content="apo" />
        
        
            <meta property="og:updated_time" content="2021-10-05 17:09:22+0200" />
        
        
            <meta property="fb:app_id" content="715603858641973" />
        
        
            <meta property="fb:pages" content="252006125219593" />
        
    


<meta name="facebook-utm_source" content="facebook"/>
<meta name="facebook-utm_medium" content="social"/>
<meta name="facebook-utm_campaign" content="share-button"/>
    





<link id="init-styles" href="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/styles/project-init/light.css" type="text/css" rel="stylesheet"/>


    
        
            
            
            
            
            

            
                
                    <link class="cssSwitcher" href="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/styles/project-Common/light.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          data-style-type="partial-style-project-Common"
                          data-theme-variant="true"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
                
                    <link class="cssSwitcher" href="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/styles/project-Detail/light.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          data-style-type="partial-style-project-Detail"
                          data-theme-variant="true"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
    

    
    


    
    
    

    
        <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/EO5k9ktTURBXy9mNDVhYmJmYi04ZmQ3LTQ1ZDAtYWMzMi00MmZlZGY3MjQzNzgucG5nkZMFzQOYzQH0gaEwAA">
    

    <script>
    if ('serviceWorker' in navigator) {
        window.addEventListener('load', function () {
            navigator.serviceWorker.register('pwa-service-worker.js')
                .then(function (registration) {
                    
                }, function (err) {
                    
                });
        });
    }
</script>
    

<script type="text/javascript" data-static-amd-map="{&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;pulsembed&quot;:&quot;https://pulsembed.eu/amd/1.0.5/build&quot;,&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/162d5140a65ebc0fa2e96da195a4eb9b/build&quot;,&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/fbc3bd59219c65f9c312840c9743c691/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;adsinit&quot;:&quot;https://ty0lm9uz.onet.pl/e1BrazhrNzh9/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/js&quot;}">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</script>
    


<script type="text/javascript">
    const schemaOrgItemList = {
        "@type": "ItemList",
        "itemListElement": []
    };
</script>
    
        
    
















    <script>
        if (typeof dlApi === 'undefined') {
            dlApi = {
                async: 1,
                cookieInfo: '',
                no_gemius: 1,
                adsNoBanner: 1,
                noDfp: 1,
                mobile: '0',
                target: '',
                tid: 'EA-4719209',
                DV: "pulselive_co_ke/main"
            }
        }
    </script>

    
        <script>
                dlApi = Object.assign(dlApi, {
                    kropka: {
                        DX: "PV,puls,8wgbeht,7,a",
                        PU: "2b737070-0847-4ee7-af1f-df7da0c84a78"
                    }
                });
        </script>
    



    


    
    
    
    
    
    
    

    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>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</script>


    
    
    
    

    <script defer src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
    <script>
        window.addEventListener('DOMContentLoaded', function() {
            Sailthru.init({ "customerId": "e3bb91358ab42ece773022042c6cfd66", "iscustom": true, "autoTrackPageview": false, "useStoredTags": false });
            Sailthru.track('pageview', {
                url: "https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht",
                tags: "",
                onSuccess: function () {
                    
                },
                onError: function () {
                    
                }
            });
        });
    </script>


    
    
        
            <script type="text/javascript">var pulse2EmbedConfig = {    pulsevideo: {        player: "flowplayer",        params: {            autoplayNext: !0,            enableAds: !1        },        plugins: [{            script: "https://imasdk.googleapis.com/js/sdkloader/ima3.js"        }, {            script: "https://embed.videos.ringpublishing.com/flowplayer/plugins/ads.min.js",            config: {                ima: {                    ads: [{                        adTag: "https://pubads.g.doubleclick.net/gampad/live/ads?iu=/53159133/Pulsegh_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=",                        time: 0                    }]                }            }        }]    },    OnettvVideo: {        'MAIN_ELEMENT': {            preset: "mainVideoRADPGh",            enableGoogleAnalytics: 2,            volume: 0,            enableEndScreen: 1,            autoplayRelated: 1,            enableAds: 1,            adserverUrl: "https://pubads.g.doubleclick.net/gampad/live/ads?iu=/53159133/Pulsegh_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=",            floatingControls: 1,            embedType: 'inTextVideo',            showAdvertComment: 1        },        'INTEXT': {            preset: "mainVideoRADPGh",            enableGoogleAnalytics: 2,            volume: 0,            enableEndScreen: 1,            autoplayRelated: 1,            enableAds: 1,            adserverUrl: "https://pubads.g.doubleclick.net/gampad/live/ads?iu=/53159133/Pulsegh_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=",            floatingControls: 1,            embedType: 'inTextVideo',            showAdvertComment: 1        }    }}</script>
        
    


    
    
        
            <script>"use strict";document.addEventListener("DOMContentLoaded",function(e){var t=document.querySelector("#taboolaStartHook");if(t){var n=function(){var e,t,n;window._taboola=window._taboola||[],window._taboola.push({article:"auto"}),e=document.createElement("script"),t=document.getElementsByTagName("script")[0],n="tb_loader_script",document.getElementById(n)||(e.async=1,e.src="//cdn.taboola.com/libtrc/ringierkenya-network/loader.js",e.id=n,t.parentNode.insertBefore(e,t)),window.performance&&"function"==typeof window.performance.mark&&window.performance.mark("tbl_ic")};if("IntersectionObserver"in window)new IntersectionObserver(function(e,t){e[0].isIntersecting&&(n(),t.disconnect())},{threshold:1}).observe(t);else n()}});</script>
        
    


    
    
        
            <script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[],function(){var t=document.createElement("script");t.async=!0,t.type="text/javascript";var e="https:"==document.location.protocol;t.src=(e?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(t,o)}();</script><script type='text/javascript'>googletag.cmd.push(function () { var o = window.location.pathname.split("/"); switch (o[1]) { case "": o[1] = "home" }void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1)); var e = token.length; if (document.location.hostname == 'www.pulse.ng') { googletag.pubads().setTargeting('PulseNG_URL', [token]); } if (document.location.hostname == 'www.pulse.sn') { googletag.pubads().setTargeting('PulseSN_URL', [token]); } if (document.location.hostname == 'www.pulse.com.gh') { googletag.pubads().setTargeting('PulseGH_URL', [token]); } if (document.location.hostname == 'www.pulselive.co.ke') { googletag.pubads().setTargeting('PliveKE_URL', [token]); } if (document.location.hostname == 'africa.businessinsider.com') { googletag.pubads().setTargeting('PulseBI_URL', [token]); } googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices() });</script><script type='text/javascript'>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];(function () {var gads = document.createElement('script');gads.async = true;gads.type = 'text/javascript';var useSSL = 'https:' == document.location.protocol;gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';var node = document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads, node);})();</script>
        
    


    

    

            <script type="text/javascript">if ("undefined" === typeof dlApi) { dlApi = {"target":"unknown/unknown","cookieInfo":"","no_gemius":1,"adsNoBanner":1,"noDfp":1,"tid":"EA-4719209"}; }</script>
            <script src="https://lib.onet.pl/s.csr/build/dlApi/dl.boot.min.js" async></script>
            </head>
<body class="articleDetail story-type-article css-project withRightColumn desktop  flag-imported">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->


    
    


    





    
    <header id="main-page-header" >
        <div class="header-wrapper" >
            <div class="main-page-nav container">
                
                    <div class="page-logo-wrapper desktop-left mobile-center ">
                        <a class="main-page-logo"
                            id="main-page-logo"
                            title="Pulselive Kenya"
                            href="/"
                            data-logo-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"
                            data-logo-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"
                            
                                style="background: url('https://radp.ocdn.eu/images/60x30-KE-WHITE.svg') no-repeat center center / contain;"
                            >
                            
                        </a>
                    </div>
                

                
                    <div class="menu-buttons-wrapper buttons-desktop-right buttons-mobile-right ">
                        <div class="right-menu-wrapper">
                            
                            <div class="search-container-wrapper">
                                <div class="search-container" data-run-module="local/search.init">
                                    <form action="/search">
                                        <input type="search" placeholder="I’m looking for..." name="q" required data-placeholder-source="I’m looking for..." data-required-message="Please type your query and press search">
                                        <button type="submit">O</button>
                                    </form>
                                </div>
                            </div>
                            
                            
                            
                            
                        </div>
                    </div>
                

                
                    
                        
                            



        <ul class="menu-desktop menu-list-left  main-page-nav">
            
                
                    <li id="listMenuItem-0" class="menu-item  has-subMenu">
                        <a class="menu-title" title="News" href="/news" >
                            News
                        </a>
                        
                            <ul class="list-submenu">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Politics" href="/news/politics">
                                            Politics
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/news/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="World" href="/news/world">
                                            World
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
            
                
                    <li id="listMenuItem-1" class="menu-item  has-subMenu">
                        <a class="menu-title" title="Entertainment" href="/entertainment" >
                            Entertainment
                        </a>
                        
                            <ul class="list-submenu">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                            Celebrities
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Music" href="/entertainment/music">
                                            Music
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                            Movies
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
            
                
                    <li id="listMenuItem-2" class="menu-item  has-subMenu">
                        <a class="menu-title" title="Lifestyle" href="/lifestyle" >
                            Lifestyle
                        </a>
                        
                            <ul class="list-submenu">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                            Fashion
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                            Beauty &amp; Health
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-and-weddings">
                                            Relationships &amp; Weddings
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                            Food, Travel, Arts &amp; Culture
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
            
                
                    <li id="listMenuItem-3" class="menu-item  has-subMenu">
                        <a class="menu-title" title="Sports" href="/sports" >
                            Sports
                        </a>
                        
                            <ul class="list-submenu">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Football" href="/sports/football">
                                            Football
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="More" href="/sports/more">
                                            More
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
            
                
                    <li id="listMenuItem-4" class="menu-item  ">
                        <a class="menu-title" title="Business" href="/business" >
                            Business
                        </a>
                        
                    </li>
                
            
                
                    <li id="listMenuItem-5" class="menu-item  ">
                        <a class="menu-title" title="Quizzes" href="/quizzes" >
                            Quizzes
                        </a>
                        
                    </li>
                
            
                
                    <li id="listMenuItem-6" class="menu-item  ">
                        <a class="menu-title" title="Pulse Influencer Awards" href="/influencer-awards/home/n1rbe34" >
                            Pulse Influencer Awards
                        </a>
                        
                    </li>
                
            
            
        </ul>

                        
                    
                        
                            



    <div class="menu-mobile menu-hamburger-left ">
        <div class="menuToggle">
            <span></span>
            <span></span>
            <span></span>
        </div>
    </div>

    <div class="menu-mobile-container menu-mobile ">
        <a class="main-page-logo"
            title="Pulselive Kenya"
            href="/"
            data-logo-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"
            data-logo-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"
            
                style="background: url('https://radp.ocdn.eu/images/60x30-KE-WHITE.svg') no-repeat center center / contain;"
            >
            Pulselive Kenya
        </a>

        <div class="menuToggleInside">
            <span></span>
            <span></span>
            <span></span>
        </div>
        <ul class="hamburger-list-items">
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="News" href="/news" >
                            News
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="News" href="/news">
                                            News
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/news/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="World" href="/news/world">
                                            World
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Entertainment" href="/entertainment" >
                            Entertainment
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Entertainment" href="/entertainment">
                                            Entertainment
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                            Celebrities
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Music" href="/entertainment/music">
                                            Music
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Lifestyle" href="/lifestyle" >
                            Lifestyle
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Lifestyle" href="/lifestyle">
                                            Lifestyle
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                            Fashion
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                            Beauty &amp; Health
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-and-weddings">
                                            Relationships &amp; Weddings
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                            Food, Travel, Arts &amp; Culture
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Sports" href="/sports" >
                            Sports
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Sports" href="/sports">
                                            Sports
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Football" href="/sports/football">
                                            Football
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Business " href="/business" >
                            Business 
                        </a>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Quizzes" href="/quizzes" >
                            Quizzes
                        </a>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Pulse Influencer Awards" href="/influencer-awards/home/n1rbe34" >
                            Pulse Influencer Awards
                        </a>
                        
                    </li>
                
                
            
        </ul>
    </div>

                        
                    
                        
                    
                        
                    
                

                
                    
                
                    
                
                    
                        
    <div class="headerSocials">
        <ul class="profileList">
            
                <li class="facebook">
                    <a 
                        href="https://www.facebook.com/pulselivekenya" 
                        title="Follow us on Facebook" 
                        target="_blank" 
                    >
                        instagram
                    </a>
                </li> 
            
                <li class="twitter">
                    <a 
                        href="https://twitter.com/pulselivekenya" 
                        title="Follow us on Twitter" 
                        target="_blank" 
                    >
                        twitter
                    </a>
                </li> 
            
                <li class="instagram">
                    <a 
                        href="https://www.instagram.com/pulselivekenya/" 
                        title="Follow us on Instagram" 
                        target="_blank" 
                    >
                        instagram
                    </a>
                </li> 
            
                <li class="youtube">
                    <a 
                        href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" 
                        title="Watch us on YouTube" 
                        target="_blank" 
                    >
                        youtube
                    </a>
                </li> 
            
                <li class="tiktok">
                    <a 
                        href="https://www.tiktok.com/@pulselivekenya" 
                        title="Tiktok with us" 
                        target="_blank" 
                    >
                        tiktok
                    </a>
                </li> 
               
        </ul>
    </div>

                    
                
                    
                        <div id="search-button" data-run-module="local/project.menu_search">
    <div class="svg icon-search" style="background-image:url(https://ocdn.eu/radp/icons/header/search.svg)"></div>
</div>
                    
                
            </div>
        </div>
    </header>


    

    <div class="page-container " data-run-module="local/common.lazyLoadIS">
        
        <div class="container-full right-column-300 mt-4">
            <div class="container">
                <div class="page-wrapper row">
                    <div id="article" class="main-section col-md-9">
                        <div class="articleBox ">
                            <div data-article-id="8wgbeht">

                                
    

    
        <div class="container-wrapper ">
            

            
                <!-- LEFT content columns -->
                <section class="ring-grid-container container ">
                    
                    <div class="row">
                        <div class="ring-grid-left-box col-sm-12 col-md-12 col-lg-12">
                            
                                



    
        <div class="adSlot " id='div-gpt-ad-1621854609633-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PliveKE_DT_Sticky_Footer" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                



    
        <div class="adSlot " id='div-gpt-ad-1617224545705-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/plive_dt_floater" data-slot-size="[1, 1]" ></div>
    

                            
                                



    
        <div class="adSlot placeholder-90 " id='div-gpt-ad-1623221635248-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_970x90_a1" data-slot-size="[[728, 90], [970, 250], [970, 90]]" ></div>
    

                            
                                
                            
                                


    <div class="breadcrumbs-widget ">
        
            


    
        
            <a href="https://www.pulselive.co.ke/" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    <strong>
                        RADP / Pulse Kenya
                    </strong>
                </span>
            </a>

            
                <span class="breadcrumbs-item-sep">&nbsp;&gt;&nbsp;</span>
            
        
    
        
            <a href="https://www.pulselive.co.ke/apo" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    
                        APO
                    
                </span>
            </a>

            
        
    

        
    </div>

                            
                                





    
        <h1 class="article-headline ">
            

            Rwandan Minister of Foreign Affairs to visit Finland
        </h1>
    

                            
                                



    

    
        <div class="article-author-wrapper ">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    

                        <span class="author-item">
                            
                                <span class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                    

                                    
                                        <span class="author-name">APO Importer</span>
                                    

                                    
                                </span>

                                
                            
                        </span>
                
            </div>
        </div>
    

                            
                                


    

    <div class="ring-detail-article-date ">
        
            <time class="detail-article-date date-type-publicationDate" datetime="2021-10-05T18:09:22.000+03:00">
                
                    October 5, 2021 6:09 PM
                
            </time>
        
    </div>

                            
                                
    <div class="ring-detail-social-share " data-before-text="Tell your friends">
        
        
        

        
            
            
        
        
            
        

        
            
                <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook" data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
            
        
            
            
                <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter" data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
        
            
            
            
                <a href="mailto:?body=https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email" data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
            
            
            
            
            
        
    </div>

                            
                                







     <div id="lead" class="article-perex ">
          <p>Minister for Foreign Affairs Haavisto will meet Rwanda’s Minister of Foreign Affairs Vincent Biruta in Helsinki on 6 October.</p>
     </div>

                            
                                
                            
                                












    <div class="article-gallery " >
            <div  class="image-container" id="article-main-image">
                
                <picture data-image-source="article_photo" data-caption="Ministry of Foreign Affairs of Finland" class="image-wrapper"><source data-original="//ocdn.eu/pulscms-transforms/1/uhEk9ktTURBXy9mNDVhYmJmYi04ZmQ3LTQ1ZDAtYWMzMi00MmZlZGY3MjQzNzgucG5nkZMFzQMWzQGugaEwBQ" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="790" height="430" alt="Ministry of Foreign Affairs of Finland" title="Ministry of Foreign Affairs of Finland" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="//ocdn.eu/pulscms-transforms/1/figktktTURBXy9mNDVhYmJmYi04ZmQ3LTQ1ZDAtYWMzMi00MmZlZGY3MjQzNzgucG5nkZMFzQMWzQGu" class="image lazyloaded"></picture> <link rel="preload" as="image" href="//ocdn.eu/pulscms-transforms/1/uhEk9ktTURBXy9mNDVhYmJmYi04ZmQ3LTQ1ZDAtYWMzMi00MmZlZGY3MjQzNzgucG5nkZMFzQMWzQGugaEwBQ">
            </div>

        
            <div class="imgMetaData">
                
                    <span class="caption">Ministry of Foreign Affairs of Finland</span>
                

                
                

                

                

                <div class="clear"></div>
            </div>
        
    </div>

                            
                                
                            
                                
                            
                                




                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The Ministers will discuss the bilateral relations between Finland and Rwanda, regional questions and multilateral cooperation. They will also deepen the economic relations by signing a Memorandum of Understanding on Trade and Investment. Minister Biruta will be accompanied by a business delegation.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                            
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                



    
        <div class="adSlot inText" data-run-module="local/project.inText" id='div-gpt-ad-1618787017312-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/300x250_InReadAd_PliveKE" data-slot-size="[728, 90]" ></div>
    

                            
                                
                            
                                
    

    <div class="recommendedArticles">
        <span class="title">Recommended articles</span>
        <ul>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/XRNk9kuTURBXy9hMzUzNTdmNS04NzNmLTQyNDgtOGM2ZC1iZTI1MGRiMzgyMjAuanBlZ5GTBUZGgaEwBQ" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="70" height="70" alt="Germany star Mueller unsure how to interact with fans amid pandemic" title="Germany star Mueller unsure how to interact with fans amid pandemic" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/KGnktkuTURBXy9hMzUzNTdmNS04NzNmLTQyNDgtOGM2ZC1iZTI1MGRiMzgyMjAuanBlZ5GTBUZG" class="image lazyloaded"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/sports">sports</a>
                        <a class="link"  data-uuid-ui="f4c22998-ee34-4239-a713-2d2df2728ee8" data-ei="7lsiaqnvx6" href="https://www.pulselive.co.ke/sports/football/germany-star-mueller-unsure-how-to-interact-with-fans-amid-pandemic/f2rqd1m">Germany star Mueller unsure how to interact with fans amid pandemic</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/2iwk9kuTURBXy81NDEwMjQ3MC1mMDdhLTRiNDAtYmQwZi0zNDRmYmMwMDc2ODIuanBlZ5GTBUZGgaEwBQ" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="70" height="70" alt="Ferguson says Man Utd must pick 'best players' after Ronaldo benched" title="Ferguson says Man Utd must pick 'best players' after Ronaldo benched" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/rERktkuTURBXy81NDEwMjQ3MC1mMDdhLTRiNDAtYmQwZi0zNDRmYmMwMDc2ODIuanBlZ5GTBUZG" class="image lazyloaded"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/sports">sports</a>
                        <a class="link"  data-uuid-ui="e8b72024-c75b-4fd9-8888-598e455dbc91" data-ei="7lsiaqnvx6" href="https://www.pulselive.co.ke/sports/football/ferguson-says-man-utd-must-pick-best-players-after-ronaldo-benched/yz689pw">Ferguson says Man Utd must pick &#39;best players&#39; after Ronaldo benched</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/-k0k9kpTURBXy8zNWE2MzlmZjA3NmMzOGM0NGVlN2NiZmU4ZGM1YjU4YS5qcGeRkwVGRoGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="70" height="70" alt="Radio Africa unveils Oliver Mathenge's Replacement" title="Radio Africa unveils Oliver Mathenge's Replacement" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/KJvktkpTURBXy8zNWE2MzlmZjA3NmMzOGM0NGVlN2NiZmU4ZGM1YjU4YS5qcGeRkwVGRg" class="image lazyloaded"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/entertainment">entertainment</a>
                        <a class="link"  data-uuid-ui="dfb29429-a27a-46ee-8143-f82eee0204b1" data-ei="7lsiaqnvx6" href="https://www.pulselive.co.ke/entertainment/celebrities/radio-africa-unveils-oliver-mathenges-replacement/gbb1rrs">Radio Africa unveils Oliver Mathenge&#39;s Replacement</a>
                    </div>
                </li>
            
        </ul>
    </div>

                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                            
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        “Rwanda is an important partner for Finland in Africa, for example, in the fight against climate change. Our cooperation in the circular economy is progressing and, on our invitation, Rwanda recently joined the Coalition of Finance Ministers for Climate Action. We want to continue this work together. In the commercial sector, there are plenty of opportunities that serve these goals,” Minister for Foreign Affairs Haavisto said.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Distributed by APO Group on behalf of Ministry of Foreign Affairs of Finland.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                

                            
                                



                            
                                



    

    
        <div class="article-author-wrapper  authorWithImage">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    

                        <span class="author-item">
                            
                                <span class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                    

                                    

                                    
                                </span>

                                
                            
                                <span class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                    

                                    
                                        <span class="author-name">APO Importer</span>
                                    

                                    
                                </span>

                                
                            
                        </span>
                
            </div>
        </div>
    

                            
                                
    <div class="ring-detail-social-share " data-before-text="Tell your friends">
        
        
        

        
            
            
        
        
            
        

        
            
                <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook" data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
            
        
            
            
                <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter" data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
        
            
            
            
                <a href="mailto:?body=https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email" data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
            
            
            
            
            
        
            
            
            
            
                <a href="whatsapp://send?text=https%3A%2F%2Fwww.pulselive.co.ke%2Fapo%2Frwandan-minister-of-foreign-affairs-to-visit-finland%2F8wgbeht?utm_medium%3Dsocial%26utm_source%3Dwhatsapp%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-whatsapp" data-gtm-social="whatsapp" title="WhatsApp" style="width: 30px; height: 30px"></a>
            
            
            
            
        
            
            
            
            
            
                <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht?utm_medium%3Dsocial%26utm_source%3Dlinkedin%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-linkedin" data-gtm-social="linkedin" target="_blank" title="LinkedIn" style="width: 30px; height: 30px"></a>
            
            
            
        
    </div>

                            
                                
                            
                                


    <div class="basicWidget homepageNewsletter">
        <div class="bw-wrapper">
        
            <h3 class="main-section-title">JOIN OUR PULSE COMMUNITY!</h3>
        
            <div class="newsletterWrapper">
                <div class="socialList">
                    
                        <div class="socialIcon facebook lazyLoadBackground" data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/nl/facebook.svg">
                            
                                <a href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank"></a>
                            
                        </div>
                    
                        <div class="socialIcon twitter lazyLoadBackground" data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/nl/twitter.svg">
                            
                                <a href="https://twitter.com/pulselivekenya" title="twitter" target="_blank"></a>
                            
                        </div>
                    
                        <div class="socialIcon instagram lazyLoadBackground" data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/nl/instagram.svg">
                            
                                <a href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank"></a>
                            
                        </div>
                    
                        <div class="socialIcon youtube lazyLoadBackground" data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/nl/youtube.svg">
                            
                                <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank"></a>
                            
                        </div>
                    
                        <div class="socialIcon tiktok lazyLoadBackground" data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/nl/tiktok.svg">
                            
                                <a href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank"></a>
                            
                        </div>
                    
                </div>
                <div class="newsletter dsk">
                    <div class="signUpContainer">
                        <div class="introMessage">
                            Our newsletter gives you access to a curated selection of the most important stories daily.
                        </div>
                        <form id="newsletter-form" method="POST" class="inputForm" action="#" data-run-module="local/project.newsletter_submit">
                            <input type="email" placeholder="Email" name="email" id="email" required>
                            <button id="submitEmail" class="submit">
                                SUBSCRIBE
                            </button>
                        </form>
                    </div>
                    <div id="error" class="error hide"></div>
                    <div id="thanksContainer" class="thanksContainer hide">
                        <div class="row" id="thanksMessage">
                            <p class="subTitle"> Welcome to the Pulse Community! We will now be sending you a daily newsletter on news, entertainment and more.   Also join us across all of our other channels - we love to be connected!</p>
                        </div>
                    </div>
                </div>
                
                <div></div>
                <div id="pushBox" class="pushContainer" data-run-module="local/project.push_notification">
                    <div class='onesignal-customlink-container'></div>
                </div>
                
            </div>
        </div>
    </div>

                            
                                
                            
                                



    
        <div class="adSlot " id='div-gpt-ad-1618841981942-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PulseKE_DT_Article_Below_Article_A" data-slot-size="[728, 90]" ></div>
    

                            
                                
    
        
            <div class="eyewitnessWdg" style="margin-top: 25px;">    <p>Eyewitness? Submit your stories now via social or: </p>    <p>    <b>Email: </b><a href="mailto:news@pulselive.co.ke">news@pulselive.co.ke</a></b></p></div>
        
    

                            
                                



    

    <div class="basicWidget hp-colSize-12 latest bw-v2"
        style=""
        
        
        >

        <div class="bw-wrapper">
             

            
                


    <h2 class="main-section-title">

    
    
        
    

    
        Recommended articles
    

    </h2>

            
                
    <div class="section-elements">
        <div class="items-wrapper columns-3 big-elements-0" >
        

            
            
            

            <div class="layout-wrapper wrap-element-1 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/NCek9kpTURBXy82YjQ0NmI4MDAwMGJhMWM4ZmU2MWI1NzZkYmQ5NmViMS5qcGeSlQMnAM0Cbs0BXpMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Eric Omondi cracks up US celebrities as his viral video hits 8 million views in 24 hrs" title="Eric Omondi cracks up US celebrities as his viral video hits 8 million views in 24 hrs" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/qxDktkpTURBXy82YjQ0NmI4MDAwMGJhMWM4ZmU2MWI1NzZkYmQ5NmViMS5qcGeSlQMnAM0Cbs0BXpMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Eric Omondi cracks up US celebrities as his viral video hits 8 million views in 24 hrs
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/eric-omondi-cracks-up-us-celebrities-as-his-viral-video-hits-8-million-views-in-24/nyy6syw" title="Eric Omondi cracks up US celebrities as his viral video hits 8 million views in 24 hrs"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-2 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/S3qk9kpTURBXy9mMzdjNmEwNzM0ZGU0ZjI5NjhiZGY2YWJlYzkzNWQ1Mi5qcGeSlQMAAM0FAM0C0JMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Inside Eric Omondi's new Sh141  Million Mansion in Karen [Video]" title="Inside Eric Omondi's new Sh141  Million Mansion in Karen [Video]" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/E_vktkpTURBXy9mMzdjNmEwNzM0ZGU0ZjI5NjhiZGY2YWJlYzkzNWQ1Mi5qcGeSlQMAAM0FAM0C0JMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Inside Eric Omondi&#39;s new Sh141  Million Mansion in Karen [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/inside-eric-omondis-new-sh141-million-mansion-in-karen-video/34tkk38" title="Inside Eric Omondi&#39;s new Sh141  Million Mansion in Karen [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-3 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/i88k9kpTURBXy83NTljMTYxNmY3NGVlMDY5MDYwMWUzMjlkNTA0N2JmZi5qcGeSlQPMkDXNAzLNAcyTBczzzIiBoTAF" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Eric Omondi clarifies reports that his new house is an AirBnB" title="Eric Omondi clarifies reports that his new house is an AirBnB" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/S5GktkpTURBXy83NTljMTYxNmY3NGVlMDY5MDYwMWUzMjlkNTA0N2JmZi5qcGeSlQPMkDXNAzLNAcyTBczzzIg" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Eric Omondi clarifies reports that his new house is an AirBnB
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/eric-omondi-clarifies-reports-that-his-new-house-is-an-airbnb/b5dbb9t" title="Eric Omondi clarifies reports that his new house is an AirBnB"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-4 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/-tAk9kpTURBXy82ZWU5ZTk4NTI1YTIyNDA5ZDJiYmQ0NzVlYjM3NGM0NC5qcGeSlQMANc0EOM0CYJMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Lynn Ngugi addresses allegations of blackmailing interview guest [Screenshots]" title="Lynn Ngugi addresses allegations of blackmailing interview guest [Screenshots]" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/QPNktkpTURBXy82ZWU5ZTk4NTI1YTIyNDA5ZDJiYmQ0NzVlYjM3NGM0NC5qcGeSlQMANc0EOM0CYJMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Lynn Ngugi addresses allegations of blackmailing interview guest [Screenshots]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/lynn-ngugi-addresses-allegations-of-blackmailing-interview-guest-screenshots/zk96nzh" title="Lynn Ngugi addresses allegations of blackmailing interview guest [Screenshots]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-5 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/W_ok9kpTURBXy85YmY2NWUxYTgwYzI0NWExZWZkMzYwMDA4YTI2M2ZjMy5qcGeSlQMnAM0Cbs0BXpMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Isaac Mwaura's wife opens up on battle with depression" title="Isaac Mwaura's wife opens up on battle with depression" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/KjKktkpTURBXy85YmY2NWUxYTgwYzI0NWExZWZkMzYwMDA4YTI2M2ZjMy5qcGeSlQMnAM0Cbs0BXpMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Isaac Mwaura&#39;s wife opens up on battle with depression
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/isaac-mwauras-wife-opens-up-on-battle-with-depression/766036y" title="Isaac Mwaura&#39;s wife opens up on battle with depression"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-6 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/0jvk9kpTURBXy82NWM4MWRhYzYyZjQ3ODZkYTY0YzdmMjc2YjYyMjY5MC5wbmeSlQMBAM0H2M0EapMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Uhuru's aide joins first Kenyans to drive on elevated Nairobi Expressway [Video]" title="Uhuru's aide joins first Kenyans to drive on elevated Nairobi Expressway [Video]" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/c2yktkpTURBXy82NWM4MWRhYzYyZjQ3ODZkYTY0YzdmMjc2YjYyMjY5MC5wbmeSlQMBAM0H2M0EapMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Uhuru&#39;s aide joins first Kenyans to drive on elevated Nairobi Expressway [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/uhurus-aide-joins-first-kenyans-to-drive-on-elevated-nairobi-expressway-video/grg7lpw" title="Uhuru&#39;s aide joins first Kenyans to drive on elevated Nairobi Expressway [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-7 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/TVck9kpTURBXy8zMzhlZDhlOTc4MWUyZjViOGVlYzZiZTQ4MzgxNzUxZC5wbmeSlQMAAc0ChM0BapMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Anita Nderu weds Mzungu Bae in Traditional Kikuyu wedding 'Ruracio' [Video]" title="Anita Nderu weds Mzungu Bae in Traditional Kikuyu wedding 'Ruracio' [Video]" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/5A2ktkpTURBXy8zMzhlZDhlOTc4MWUyZjViOGVlYzZiZTQ4MzgxNzUxZC5wbmeSlQMAAc0ChM0BapMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Anita Nderu weds Mzungu Bae in Traditional Kikuyu wedding &#39;Ruracio&#39; [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/anita-nderu-weds-mzungu-bae-in-traditional-kikuyu-wedding-ruracio-video/zqymgsq" title="Anita Nderu weds Mzungu Bae in Traditional Kikuyu wedding &#39;Ruracio&#39; [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-8 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/BO-k9kpTURBXy8yMzI0ODY2Zjg1YmRkNGI5ZGVhMTRiYWRlYzMxOGRkMi5qcGeSlQMAEc0C7s0BpZMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Jalang'o & Churchill explain how their businesses collapsed due to dishonest employees " title="Jalang'o & Churchill explain how their businesses collapsed due to dishonest employees " src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/72DktkpTURBXy8yMzI0ODY2Zjg1YmRkNGI5ZGVhMTRiYWRlYzMxOGRkMi5qcGeSlQMAEc0C7s0BpZMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Jalang&#39;o &amp; Churchill explain how their businesses collapsed due to dishonest employees 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/jalango-and-churchill-explain-how-their-businesses-collapsed-due-to-dishonest/xbe38r7" title="Jalang&#39;o &amp; Churchill explain how their businesses collapsed due to dishonest employees "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-9 ">
                
                
                
                

                <div class="layout-item list-item col-xs-12   ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/M-hk9kpTURBXy9jZWQ4YmZmMmM0MDEwZjAyNzg4ZTNhNDMzM2NhNDRjYS5wbmeSlQMAAc0ChM0BapMFzPPMiIGhMAU" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="243" height="136" alt="Frankie Just GymIt Proposes to Baby Mama Corazon Kwamboka in Zanzibar (Photo)" title="Frankie Just GymIt Proposes to Baby Mama Corazon Kwamboka in Zanzibar (Photo)" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/ce6ktkpTURBXy9jZWQ4YmZmMmM0MDEwZjAyNzg4ZTNhNDMzM2NhNDRjYS5wbmeSlQMAAc0ChM0BapMFzPPMiA" class="image lazyloaded"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Frankie Just GymIt Proposes to Baby Mama Corazon Kwamboka in Zanzibar (Photo)
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/frankie-just-gymit-proposes-to-baby-mama-corazon-kwamboka-in-zanzibar-photo/90sn5wl" title="Frankie Just GymIt Proposes to Baby Mama Corazon Kwamboka in Zanzibar (Photo)"></a>
    </div>

                        
                    
                </div>

                
            </div>
        
        </div>
    </div>

            
        </div>
    </div>

                            
                                


    <div id="taboolaStartHook"></div>
    <div id="taboola-below-article-thumbnails"></div><script type="text/javascript">    window._taboola = window._taboola || [];    _taboola.push(            {mode: 'thumbnails-a', container: 'taboola-below-article-thumbnails', placement: 'Below Article Thumbnails', target_type: 'mix'}    );</script>

                            
                        </div>
                    </div>
                </section>
            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    


                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                            </div>
                        </div>

                        
                    </div>

                    
                        
                            
                                
                                <div class="side-section col-md-3" id="content-side-section">
                                    <div>
                                        
                                            



    
        <div class="adSlot placeholder-250 " id='div-gpt-ad-1617227624691-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_300x250_b1" data-slot-size="[[300, 250], [300, 600], [160, 600], [120, 600]]" ></div>
    

                                        
                                            


    <div class="widget-trending basicWidget">
        
            <h2 class="main-section-title">
                Trending
            </h2>
        

        
        <div class="widget-trending-items">
            
                <div class="layout-wrapper">
                    <div class="layout-item">
                        
                            <div class="bw-title">
                                <h3 class="title">African Union partners with APO Group to Re-brand and Re-position Africa to the world at the Expo 2020 Dubai</h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/v92k9kuTURBXy9kZTE2OTZjNS1kYWZmLTQ2MDEtOWU3YS1hZDJiODRlZjJmZGQuanBlZ5GTBc0BLMysgaEwBQ" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="300" height="172" alt="APO Group" title="APO Group" class="image lazyloaded" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/spIktkuTURBXy9kZTE2OTZjNS1kYWZmLTQ2MDEtOWU3YS1hZDJiODRlZjJmZGQuanBlZ5GTBc0BLMys"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/v92k9kuTURBXy9kZTE2OTZjNS1kYWZmLTQ2MDEtOWU3YS1hZDJiODRlZjJmZGQuanBlZ5GTBc0BLMysgaEwBQ">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/apo/african-union-partners-with-apo-group-to-re-brand-and-re-position-africa-to-the-world/e1yw6jw"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    <div class="layout-item">
                        
                            <div class="bw-title">
                                <h3 class="title">Fox Wallet Bridges the Gap Between DeFi and CeFi with the Launch of an Africa-First, New and Insured Multi-Crypto Wallet</h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/hcEk9ktTURBXy9iMTJjZjQyMC0wMWZiLTQ3MDQtYjY3Zi0zOTBjOGQ2ZGVkNzgucG5nkZMFzQEszKyBoTAF" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="300" height="172" alt="Fox Wallet" title="Fox Wallet" class="image lazyloaded" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/eFIktktTURBXy9iMTJjZjQyMC0wMWZiLTQ3MDQtYjY3Zi0zOTBjOGQ2ZGVkNzgucG5nkZMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/hcEk9ktTURBXy9iMTJjZjQyMC0wMWZiLTQ3MDQtYjY3Zi0zOTBjOGQ2ZGVkNzgucG5nkZMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/apo/fox-wallet-bridges-the-gap-between-defi-and-cefi-with-the-launch-of-an-africa-first/l8slb64"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    <div class="layout-item">
                        
                            <div class="bw-title">
                                <h3 class="title">Coronavirus - Kenya: COVID-19 Update (28 September 2021)</h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/vD3k9kuTURBXy9lYTA1Y2MzMi0zM2I5LTRiODktYmQ4ZC0xZGUxMWU3YzBiNTIuanBlZ5GTBc0BLMysgaEwBQ" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="300" height="172" alt="Ministry of Health, Kenya" title="Ministry of Health, Kenya" class="image lazyloaded" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/VbbktkuTURBXy9lYTA1Y2MzMi0zM2I5LTRiODktYmQ4ZC0xZGUxMWU3YzBiNTIuanBlZ5GTBc0BLMys"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/vD3k9kuTURBXy9lYTA1Y2MzMi0zM2I5LTRiODktYmQ4ZC0xZGUxMWU3YzBiNTIuanBlZ5GTBc0BLMysgaEwBQ">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/apo/coronavirus-kenya-covid-19-update-28-september-2021/srbd1dn"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    <div class="layout-item">
                        
                            <div class="bw-title">
                                <h3 class="title">Media Freedom Coalition Diplomatic Network in Cameroon</h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image"><source data-original="https://ocdn.eu/pulscms-transforms/1/gMBk9kuTURBXy83MTkzZmQxMi1kYjc5LTQ2MDAtODZmNS00NmJhYjkxMjQ0ODEuanBlZ5GTBc0BLMysgaEwBQ" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" type="image/webp"><img width="300" height="172" alt="British High Commission - Yaounde" title="British High Commission - Yaounde" class="image lazyloaded" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-original="https://ocdn.eu/pulscms-transforms/1/AddktkuTURBXy83MTkzZmQxMi1kYjc5LTQ2MDAtODZmNS00NmJhYjkxMjQ0ODEuanBlZ5GTBc0BLMys"></picture> 
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/apo/media-freedom-coalition-diplomatic-network-in-cameroon/gk93gp1"></a>
                        </div>
                    </div>
                </div>
            
        </div>
        
    </div>

                                        
                                            



    
        <div class="stickyWrapper" id="stickyWrapper" data-run-module="local/project.floatSticky" data-slot-name="/53159133/pliveke_dt_article_300x250_b3" data-slot-size="[[300, 600], [300, 250], [160, 600], [120, 600]]">
            <div class="first sticky-slot" id='div-gpt-ad-1617227699389-0'></div>
        </div>
    

                                        
                                    </div>
                                </div>
                            
                        
                    
                </div>
            </div>
        </div>
    </div>

    

    
    
    
    
    
    
    

    
        
        

        

        
            <script type="application/ld+json">
                {
                    "@context": "https://schema.org",
                    "@type": "BreadcrumbList",
                    "itemListElement":[{
                        "@type": "ListItem",
                        "position": 1,
                        "name": "Home",
                        "item": "https://www.pulselive.co.ke"
                    },{
                        "@type": "ListItem",
                        "position": 2,
                        "name": "Apo",
                        "item": "https://www.pulselive.co.ke/apo"
                    },{
                        "@type": "ListItem",
                        "position": 3,
                        "name": "Rwandan Minister Of Foreign Affairs To Visit Finland",
                        "item": "https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht"
                    }]
                }
            </script>
        

        
    
        
        

        

        

        
            <script type="application/ld+json">
                {
                    "@context": "https://schema.org",
                    "@type": "NewsArticle",
                    "@id": "https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht#article",
                    "mainEntityOfPage": {
                        "@type": "WebPage",
                        "@id": "https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht"
                    },
                    "headline": "Rwandan Minister of Foreign Affairs to visit Finland",
                    "primaryImageOfPage": {
                        "@id": "https://www.pulselive.co.ke/apo/rwandan-minister-of-foreign-affairs-to-visit-finland/8wgbeht#mainPhoto"
                    },
                    "image": ["http://ocdn.eu/images/pulscms/MTc7MDA_/f45abbfb-8fd7-45d0-ac32-42fedf724378.png"],
                    "datePublished": "2021-10-05T18:09:22.000+03:00",
                    "dateModified": "2021-10-05T18:09:22.000+03:00",
                    "author": [{
                        "@type": "Person",
                        "name" : "APO Importer"
                    }],
                    "publisher": {
                        "@type": "Organization",
                        "name": "Pulselive Kenya",
                        "logo": {
                            "@type": "ImageObject",
                            "url": "https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"
                        }
                    },
                    "keywords": "",
                    "description": "Minister for Foreign Affairs Haavisto will meet Rwanda’s Minister of Foreign Affairs Vincent Biruta in Helsinki on 6 October",
                    "isAccessibleForFree": true
                }
            </script>
        
    



    



    <div id="customDimensionsCategories" data-categories="kenya/feat/apo"></div>

    <script>
        const categories = document.getElementById('customDimensionsCategories').dataset.categories;

        if (categories && typeof categories === "string" && categories.length > 0) {
            window.dataLayer = window.dataLayer || [];
            window.dataLayer.push({
                'content_categories': categories
            })
        }
    </script>


    



<footer data-run-module="local/common.lazyLoadIS" class="footer-widget-container " >
    

    
        
    <div class="africaFooter">
        <div class="container" >
            
                <div class="advertiseFooterContainer">
                    <div class="advertTitle">
                        Advertise with us
                    </div>
                    <div class="advertBody">
                        Reach out to us at <a style="color: #ff0" href="mailto:salesteam@pulse.co.ke">salesteam@pulse.co.ke</a> or +254113897895 to advertise with us. Find out more about Pulse's products and advertising opportunities at <a href="https://pulse.africa" target="_blank" style="color: #ff0"> pulse.africa</a>   
                    </div>
                </div>
            
            <div class="footer-wrapper">
                
                
                <div class="footer-menu">
                    <ul class="footer-menu-list">
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Home" href="/">
                                Home
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="News" href="/news">
                                News
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Entertainment" href="/entertainment">
                                Entertainment
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Lifestyle" href="/lifestyle">
                                Lifestyle
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Sports" href="/sports">
                                Sports
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Business" href="/business">
                                Business
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Quizzes" href="/quizzes">
                                Quizzes
                            </a>
                            
                        </li>
                        
                    </ul>
                </div>
                

                
                <div class="footer-links-wrapper" id="footer-links-menu">
                    <ul class="links-list">
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/about-us" title="About us">
                                About us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/about-us" title="About us">
                                About us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://pulse.africa" title="Advertise with us">
                                Advertise with us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/terms-of-use/d1z0r3q" title="Terms &amp; Conditions">
                                Terms &amp; Conditions
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/privacy-policy-pulselivecoke/vh9gdmy" title="Privacy Policy">
                                Privacy Policy
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="/influencer-awards/home/n1rbe34" title="Pulse Influencer Awards">
                                Pulse Influencer Awards
                            </a>
                            
                        </li>
                        
                        
                    </ul>
                </div>
                

                
                <div class="socials-wrapper">
                    <ul id="socials" class="socials-wrapper-list">
                        
                        
                        <li class="socials-wrapper-item">
                            <a class="footer-icon 0  " href="" title="" target="_blank"
                               >
                                Social
                            </a>
                        </li>
                        
                        
                        
                        <li class="socials-wrapper-item">
                            <a class="footer-icon 1  lazyLoadBackground" href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank"
                               data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/footer/facebook.svg" style="background: url() 0 100% / contain no-repeat;" >
                                Facebook
                            </a>
                        </li>
                        
                        
                        
                        <li class="socials-wrapper-item">
                            <a class="footer-icon 2  lazyLoadBackground" href="https://twitter.com/pulselivekenya" title="twitter" target="_blank"
                               data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/footer/twitter.svg" style="background: url() 0 100% / contain no-repeat;" >
                                Twitter
                            </a>
                        </li>
                        
                        
                        
                        <li class="socials-wrapper-item">
                            <a class="footer-icon 3  lazyLoadBackground" href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank"
                               data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/footer/instagram.svg" style="background: url() 0 100% / contain no-repeat;" >
                                Instagram
                            </a>
                        </li>
                        
                        
                        
                        <li class="socials-wrapper-item">
                            <a class="footer-icon 4  lazyLoadBackground" href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank"
                               data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/footer/youtube.svg" style="background: url() 0 100% / contain no-repeat;" >
                                Youtube
                            </a>
                        </li>
                        
                        
                        
                        <li class="socials-wrapper-item">
                            <a class="footer-icon 5  lazyLoadBackground" href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank"
                               data-bg="https://ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/img/footer/tiktok.svg" style="background: url() 0 100% / contain no-repeat;" >
                                Tiktok
                            </a>
                        </li>
                        
                        
                    </ul>
                </div>
                

            </div>
            
                
                <div class="disclaimer-text">
                    
                        
                            <p class="footer-description-copyrightsInfo"> &copy; 2021 pulselive.co.ke</p>
                        
                    
                        
                    
                </div>
            
        </div>
    </div>

    
</footer>


<script src="//ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build/js/menu.min.js"></script>

<script type="text/javascript">
    const resourceBuildPath = "//ocdn.eu/ucs/static/UTheme/53a015d1711ef6458d5402d383de2519/build";

    
        const editStoryBookmarklet = "radp-ringier-africa-digital-publishing";
    
</script>

    
        <script type="text/javascript"> window._taboola = window._taboola || []; window._taboola.push( {flush: true} );  </script>
    
<script type='text/javascript' src='https://ssp.mediapal.net/www/delivery/spcjs.php?id=5'></script>

<script type="text/javascript" src="https://radp.ocdn.eu/quantcast_kenya.js" async/></script></body>
</html>

