
    
    
    
    
    <!DOCTYPE html>
    <html lang="en-US">
        <head>
            <meta charset="utf-8" />
            <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><script>/* <![CDATA[ */ ringDataLayer = {"content":{"object":{"type":"story","kind":"article","id":"0de839ee-27fd-4a4d-b4d3-501651d41ddd"},"part":1,"publication":{"point":{"id":"0r3e33w"}},"source":{"system":"ring_content_space","id":"7dd277c7-e647-489d-a0cd-8c305073a877"}},"context":{"publication_structure":{"root":"WWW_PULSELIVE_CO_KE","path":"ENTERTAINMENT/CELEBRITIES/ARTICLE"},"id":{"aureus_offers":["wdmwzkb2e8"]}}}; /* ]]> */</script><script>/* <![CDATA[ */ accConf = {"rum":{"tid":"EA-4719209","boot":"disable","cookieInfo":0,"pageType":"HTML","data":{"RTYPE":"{\"type\":\"story\",\"kind\":\"article\"}"}},"gtm":{"id":["GTM-MGFD5X"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}}; /* ]]> */</script>
        <script type="text/javascript">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</script>
        <script type="text/javascript">
        if(accConf&&accConf.rum&&accConf.rum.data)for(var key in window.dlRumData||(window.dlRumData=[]),accConf.rum.data)window.dlRumData.push({metricName:key,eventValue:accConf.rum.data[key]});
        </script>
        
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<!-- End Google Tag Manager -->

            <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
            <title>Bahati&#39;s Manager Weezdom in Mourning  [ARTICLE] - Pulse  Live Kenya</title>
            
            <meta name="DC.Identifier" content="0de839ee-27fd-4a4d-b4d3-501651d41ddd" />
            
            
                <meta name="description" content="Take Heart Weezdom at this Difficult time" />
            
            <link href="https://ocdn.eu/ucs/static/223e38feb4cdb36efb49d13aa300f8e1/fa5746b6df8fc516acb8be88a8d527d4/build/red/desktop.css" type="text/css" rel="stylesheet">
            
            
            


<script type="text/javascript" data-static-amd-map="{&quot;onettv&quot;:&quot;https://ocdn.eu/paas-static/template-engine/9a45bcb3878bfe2ee5a4f671b8239389/build&quot;,&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/90f2c8adc05ed0952349aade8960bfc9/build&quot;,&quot;pulsembed&quot;:&quot;https://ocdn.eu/paas-static/template-engine/1972b6c75d43a95e148faf3e9d1a8c79/build&quot;,&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;newslivestream&quot;:&quot;https://ocdn.eu/paas-static/template-engine/c521d70663e169ce4f8f4960a2bf333e/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/878f1a114f1d2a25f3a250464145f5f9/build&quot;,&quot;adsinit&quot;:&quot;//ty0lm9uz.onet.pl/e1BrazhrNjd9/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;uss&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4103f0ba4ad9fabb230202e95534e54e/build&quot;,&quot;ustnavigation&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4103f0ba4ad9fabb230202e95534e54e/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/223e38feb4cdb36efb49d13aa300f8e1/fa5746b6df8fc516acb8be88a8d527d4/build&quot;,&quot;localmobile&quot;:&quot;//ocdn.eu/ucs/static/223e38feb4cdb36efb49d13aa300f8e1/fa5746b6df8fc516acb8be88a8d527d4/build&quot;}">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</script>
        <script type="text/javascript" src="https://ocdn.eu/radp/pwa/firebase.js" ></script>
        <!-- disbale ads script from loadinf -->
        <!-- adsConf -->

    

    <script type="text/javascript">/* <![CDATA[ */
        
        
            adsNoBanner = false;
        

        onetAds = {
    "async": 1,
    "sgn_cookie": 0,
    "whitelist": 0,
    "keywords": [
        "detal"
    ],
    "target": "PLIVEKE_URL/CATEGORY",
    "DV": "PLIVEKE_URL/CATEGORY/POZOSTALE",
    "kropka": {
        "DX": "PV,puls,0r3e33w,1,",
        "PU": "0de839ee-27fd-4a4d-b4d3-501651d41ddd"
    },
    "keyvalues": {
        "ci": "0de839ee-27fd-4a4d-b4d3-501651d41ddd"
    },
    "cmd": [],
    "adSlots": [],
    "lazy": 1,
    "lazyPercentage": 200,
    "tid": "EA-4719209",
    "noDfp": 1,
    "mobile": 0,
    "no_gemius": 1,
    "cookieInfo": 1,
    "eventsapi": true
};

        if (typeof identifierEI !== "undefined")
        {
            onetAds.kropka['EI'] = identifierEI;
        }
        
        
        onetAds.cmd.push(function (dlApi){

            var idGenerator = createIdGenerator();
            var htmlblock   = document.querySelectorAll(".htmlblockslot");

            for (var i=0; i<htmlblock.length; i++) {
                configureSlot(htmlblock[i]);
            }

            function configureSlot(adDom) {

                var id      = idGenerator.get();
                var keyword = adDom.getAttribute("data-slot-keyword");

                adDom.setAttribute("id", id);

                var slot = onetAds.defineSlot('flat-autopromo', id);
                slot.setTargeting('kwrd', keyword);
            }

            function createIdGenerator() {

                var counter = 1;

                return {
                    get : get
                };

                function get() {

                    var num = counter;
                    counter++;
                    return "htmlblockslot_id_" + num;
                }
            }
        });


    /* ]]> */</script>





    <script type="text/javascript">
        var pulse2EmbedConfig = {
                OnettvVideo: {
                    'MAIN_ELEMENT': {
                        preset: "mainVideoRADPKe",
                        enableGoogleAnalytics: 2,
                        volume: 0,
                        enableEndScreen: 1,
                        autoplayRelated: 1,
                        enableAds: 1,
                        adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_300x250v&amp;description_url=[placeholder]&amp;tfcd=0&amp;npa=0&amp;sz=300x250%7C300x250&amp;gdfp_req=1&amp;output=vast&amp;unviewed_position_start=1&amp;env=vp&amp;impl=s&amp;correlator=",
                        floatingControls: 1,
                        embedType: 'inTextVideo',
                        showAdvertComment: 1
                    },
                    'INTEXT': {
                        preset: "mainVideoRADPKe",
                        enableGoogleAnalytics: 2,
                        volume: 0,
                        enableEndScreen: 1,
                        autoplayRelated: 1,
                        enableAds: 1,
                        adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_300x250v&amp;description_url=[placeholder]&amp;tfcd=0&amp;npa=0&amp;sz=300x250%7C300x250&amp;gdfp_req=1&amp;output=vast&amp;unviewed_position_start=1&amp;env=vp&amp;impl=s&amp;correlator=",
                        floatingControls: 1,
                        embedType: 'inTextVideo',
                        showAdvertComment: 1
                    }
                }
            };
    </script>

        <script id="adsinit" data-original="//sgqcvfjvr.onet.pl/YnVpbGQvezlza2x0ZTg3fWRsQXBpL2RsLmxpYntOTWFzX0E4N30ubWluLmpz">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</script>
        
            <link rel="canonical" href="https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w" />
        
        <!-- proxyHead -->
        
    

    
        

        

        

        
            <script type="application/ld+json">
                {
                    "@context": "https://schema.org",
                    "@type": "BreadcrumbList",
                    "itemListElement":[{
                        "@type": "ListItem",
                        "position": 1,
                        "name": "Home",
                        "item": "https://www.pulselive.co.ke"
                    },{
                        "@type": "ListItem",
                        "position": 2,
                        "name": "Entertainment",
                        "item": "https://www.pulselive.co.ke/entertainment"
                    },{
                        "@type": "ListItem",
                        "position": 3,
                        "name": "Celebrities",
                        "item": "https://www.pulselive.co.ke/entertainment/celebrities"
                    },{
                        "@type": "ListItem",
                        "position": 4,
                        "name": "Bahatis manager Weezdom In Mourning",
                        "item": "https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w"
                    }]
                }
            </script>
        

        

        
    
        

        

        

        

        
            <script type="application/ld+json">
                {
                    "@type": "NewsArticle",
                    "@id": "https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w#article",
                    "mainEntityOfPage": {
                        "@type": "WebPage",
                        "@id": "https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w"
                    },
                    "headline": "Bahati&#39;s Manager Weezdom in Mourning ",
                    "primaryImageOfPage": {
                        "@id": "https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w#mainPhoto"
                    },
                    "image": ["http://ocdn.eu/images/pulscms/NGM7MDA_/282e3f494cf2039a04964cbf6465ec35.jpg"],
                    "datePublished": "2021-03-24T09:08:27+01:00",
                    "dateModified": "2021-03-24T09:08:18+01:00",
                    "author": [{
                        "@type": "Person",
                        "name" : "Dennis Milimo"
                    }],
                    "publisher": {
                        "@type": "Organization",
                        "name": "Pulse  Live Kenya",
                        "logo": {
                            "@type": "ImageObject",
                            "url": "https://radp.ocdn.eu/logotypes/logo_desktop_kenya_new_v1.svg"
                        }
                    },
                    "description": "Take Heart Weezdom at this Difficult time",
                    "isAccessibleForFree": true
                }
            </script>
        

        
    

        

    

    
        
            <meta property="og:title" content="Bahati&#39;s Manager Weezdom in Mourning " />
        
        
            <meta property="og:description" content="Take Heart Weezdom at this Difficult time" />
        
        
            
                
                    <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/tq5ktkpTURBXy8yODJlM2Y0OTRjZjIwMzlhMDQ5NjRjYmY2NDY1ZWMzNS5qcGeSlQMAFc0EOM0CYJMFzQMUzQG8" />
                
                <meta property="og:image:width" content="788" />
                <meta property="og:image:height" content="444" />
            
            
            
                <meta property="og:image:alt" content="Weezdom"/>
            
        
        
            <meta property="og:url" content="https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w" />
        
        
            <meta property="og:type" content="article" />
        
        
            <meta property="og:site_name" content="Pulse  Live Kenya"/>
        
        
            <meta property="article:publisher" content="https://www.facebook.com/pulselivekenya"/>
        
        
            <meta property="og:locale" content="en_KE" />
        
        
            <meta property="article:published_time" content="2021-03-24 09:08:18+0100" />
        
        
            <meta property="article:modified_time" content="2021-03-24 09:08:18+0100" />
        
        
            <meta property="article:section" content="Celebrities" />
        
        
            <meta property="og:updated_time" content="2021-03-24 09:08:18+0100" />
        
        
            <meta property="fb:app_id" content="715603858641973" />
        
        
            
    <meta property="fb:pages" content="252006125219593" />    

        
    



<meta name="facebook-utm_source" content="facebook"/>
<meta name="facebook-utm_medium" content="social"/>
<meta name="facebook-utm_campaign" content="share-button"/><!-- socialShare -->
        
    



    <script type="text/javascript">
        window.dataLayer = window.dataLayer || [];
        window.dataLayer.push({"DV":"TARGET/Part2","author1_name":"Dennis Milimo","author1_uuid":"72db854f-1b63-5abf-8522-93d44a689716","datePublished":"2021-03-24","uuid":"0de839ee-27fd-4a4d-b4d3-501651d41ddd","type":"Article","license":"Pulse Live Kenya"});
        
        if(window.addEventListener) {
            window.addEventListener("load", pageSpeedForDataLayer);
        } else if (window.attachEvent) {
            window.attachEvent("onload", pageSpeedForDataLayer);
        }
        
        function pageSpeedForDataLayer() {
            setTimeout(function () {
                var te = 0,    ti = 0, teDescription = 'slow';
                if (window.performance) {
                    var g = window.performance.timing;
                    te = g.loadEventEnd - g.navigationStart;
                    ti = g.domInteractive - g.navigationStart;
                }
                if(te > 0 && te < 6e4 && ti > 0 && ti < 6e4) {                  
                    if(te < 3000) {
                        teDescription = 'fast';
                    } else if (te >= 3000 && te <= 7000) {
                        teDescription = 'medium';
                    }
                        
                    window.dataLayer.push({
                        'event': 'speed',
                        'params': {
                            'ti': ti,
                            'te': te,
                            'teDescription': teDescription
                        }
                    });
                }
            }, 3000);  
        }
    </script>
<!-- dataLayer -->
        
    <link rel="amphtml" href="https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w.amp" />
<!-- ampUrl -->
        <!-- onetNewsUrl -->
        
    <script>
        
        
        

        
    </script>

        
            
    
    

        

        
<script type="text/javascript">
  var isMobile = false;
</script>
<link rel="manifest" href="/manifest.json">

        
            <link rel="icon" type="image/png" href="https://ocdn.eu/radp/favicon.ico" />
        

<link rel="apple-touch-icon" href="/icon.png">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">

<script type="text/javascript">
  if (navigator.serviceWorker) {
    navigator.serviceWorker.register('/pwa-sw2.js', {
      scope: '/'
    });
    navigator.serviceWorker.getRegistration()
    .then(function(registration) {
        if(registration && registration.active) {
            document.cookie ="pwaMode=pwa;path=/";
            document.cookie ="WebsiteType=desktop;path=/";
        } else {
            document.cookie = "pwaMode=website;path=/";
            document.cookie ="WebsiteType=desktop;path=/";
        }
    });
  }else {
      document.cookie = "pwaMode=website;path=/";
      document.cookie ="WebsiteType=desktop;path=/";
  }


  window.addEventListener('beforeinstallprompt', function (e) {
    // Sending PWAHomeIconPrompt event when the prompt is launched.
    dataLayer.push({
      'pwaEventAction': 'PWAHomeIconPrompt',
      'pwaEventLabel': 'PWA Home Icon Prompt',
      'event': 'PWAHomeIconPrompt'
    });
    e.userChoice.then(function (res) {
      if (res.outcome === 'dismissed') {
        dataLayer.push({
          'pwaEventAction': 'PWAHomeIconCancelled',
          'pwaEventLabel': 'PWA Home Icon Cancelled',
          'event': 'PWAHomeIconCancelled'
        });
      } else if (res.outcome === 'default') {
            dataLayer.push({
                'pwaEventAction': 'PWAHomeIconDismissed',
                'pwaEventLabel': 'PWA Home Icon Dismissed',
                'event': 'PWAHomeIconDismissed'
            });
      } else {
            dataLayer.push({
                'pwaEventAction': 'PWAHomeIconAdded',
                'pwaEventLabel': 'PWA Home Icon Added',
                'event': 'PWAHomeIconAdded'
            });
      }
    });
  });
  if (document.cookie.indexOf("sessionStartMode=") === -1) {
    if (window.location.href.indexOf('pwa=1') > -1) {
        dataLayer.push({
            'pwaEventAction': 'PWAHomeSesionsStarted',
            'pwaEventLabel': 'PWA Home Sesions Started',
            'event': 'PWAHomeSesionsStarted'
        });

        document.cookie = "sessionStartMode=homeScreen;path=/"
    } else {
        document.cookie = "sessionStartMode=browser"
    }
  }
</script>
<meta name="theme-color" content="#000000">
<link rel="dns-prefetch" href="https://ocdn.eu" />
<link rel="dns-prefetch" href="https://fonts.gstatic.com" />
<link rel="dns-prefetch" href="https://google-analytics.com" />
<link rel="dns-prefetch" href="https://sgqcvfjvr.onet.pl" />
<link rel="dns-prefetch" href="https://onet.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://ls.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://csr.onet.pl" />
<link rel="dns-prefetch" href="https://kropka.onet.pl" />
<link rel="dns-prefetch" href="https://cmp.dreamlab.pl" />
<link rel="dns-prefetch" href="https://authorisation.grupaonet.pl" />
<link rel="dns-prefetch" href="https://pulsembed.eu" />
<link rel="dns-prefetch" href="https://etoto-platform.onet.pl" />
<link rel="dns-prefetch" href="https://mvp.onet.pl" />
<link rel="dns-prefetch" href="https://gapl.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://player-api.dreamlab.pl" />
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net" />
<link rel="dns-prefetch" href="https://csi.gstatic.com" />

<link rel="preconnect" href="https://ocdn.eu" />
<link rel="preconnect" href="https://fonts.gstatic.com" />
<link rel="preconnect" href="https://google-analytics.com" />
<link rel="preconnect" href="https://sgqcvfjvr.onet.pl" />
<link rel="preconnect" href="https://onet.hit.gemius.pl" />
<link rel="preconnect" href="https://ls.hit.gemius.pl" />
<link rel="preconnect" href="https://csr.onet.pl" />
<link rel="preconnect" href="https://kropka.onet.pl" />
<link rel="preconnect" href="https://cmp.dreamlab.pl" />
<link rel="preconnect" href="https://authorisation.grupaonet.pl" />
<link rel="preconnect" href="https://pulsembed.eu" />
<link rel="preconnect" href="https://etoto-platform.onet.pl" />
<link rel="preconnect" href="https://mvp.onet.pl" />
<link rel="preconnect" href="https://gapl.hit.gemius.pl" />
<link rel="preconnect" href="https://player-api.dreamlab.pl" />
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" />
<link rel="preconnect" href="https://csi.gstatic.com" />
<script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[],function(){var t=document.createElement("script");t.async=!0,t.type="text/javascript";var e="https:"==document.location.protocol;t.src=(e?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(t,o)}();</script>      <script>googletag.cmd.push(function () { var o = window.location.pathname.split("/"); switch (o[1]) { case "": o[1] = "home" }void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1)); var e = token.length; if (document.location.hostname == 'www.pulse.ng') { googletag.pubads().setTargeting('PulseNG_URL', [token]); } if (document.location.hostname == 'www.pulse.sn') { googletag.pubads().setTargeting('PulseSN_URL', [token]); } if (document.location.hostname == 'www.pulse.com.gh') { googletag.pubads().setTargeting('PulseGH_URL', [token]); } if (document.location.hostname == 'www.pulselive.co.ke') { googletag.pubads().setTargeting('PliveKE_URL', [token]); } if (document.location.hostname == 'africa.businessinsider.com') { googletag.pubads().setTargeting('PulseBI_URL', [token]); } console.log(token, e), googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices() });</script>
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "4.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d3lcz8vpax4lo2.cloudfront.net/ads-code/99b38bf6-07eb-44ab-a741-e822695d6401.js');/*]]>*/</script>
<script type='text/javascript'>             var googletag = googletag || {};             googletag.cmd = googletag.cmd || [];             (function () {                 var gads = document.createElement('script');             gads.async = true;             gads.type = 'text/javascript';             var useSSL = 'https:' == document.location.protocol;             gads.src = (useSSL ? 'https:' : 'http:') +                 '//www.googletagservices.com/tag/js/gpt.js';             var node = document.getElementsByTagName('script')[0];             node.parentNode.insertBefore(gads, node);         })();         </script>
<script type="text/javascript" src="//ocdn.eu/ucs/static/223e38feb4cdb36efb49d13aa300f8e1/fa5746b6df8fc516acb8be88a8d527d4/build/scripts.js" async defer></script>
        <!-- special ads disbale check -->

        <script>
            var liveblog_talos_lizard_cfg={'urls':["https://liveblog-push.dreamlab.pl/ws"],oob_url:false};
        </script>
    <script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
    <script> Sailthru.init({ "customerId": "e3bb91358ab42ece773022042c6cfd66", "iscustom": true, "autoTrackPageview": false, "useStoredTags": false });
        Sailthru.track('pageview', {
            url: "https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w",
            tags: "celebrities",
            onSuccess : function () { console.log('trackPageView success note'); },
            onError : function () { console.log('trackPageView failure note'); }
        }); </script>
        <script type="text/javascript" src="//ocdn.eu/ucs/static/223e38feb4cdb36efb49d13aa300f8e1/fa5746b6df8fc516acb8be88a8d527d4/build/push.js"></script>
    </head>
        <div>
            <!-- IO script tracking div  -->
    <body id="newDetail" class="desktop scheme_red content-type-Article">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->

        


        <div class="onet-ad" id="onet-ad-flat-belkagorna"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
        
<header id="pageHeader" class="pageWrapper">
    <div class="container customSize">
        <div class="pageHeaderLogo">
            <h1><a href="//www.pulselive.co.ke"> <img class="serviceLogo switch" alt="Pulse Live Kenya" src="https://radp.ocdn.eu/logotypes/logo_desktop_kenya_new_v1.svg"> </a></h1>
        </div> 
        <nav class="siteNavigation">
            <div id="tabMenu" class="transition">
                <div id="siteNavigation" class="siteNavigation"  >
                    <div class="row">
                        <div  class="firstLevel row " data-run-module="local/main.menu">
                            <ul class="mainMenu col-xs-12 verticals">
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/news">News</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Local"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/news/local">
                                                Local
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-World"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/news/world">
                                                World
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/entertainment">Entertainment</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Celebs"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/entertainment/celebrities">
                                                Celebs
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Music"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/entertainment/music">
                                                Music
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Games"
                                            data-dropdown-uuid=""  data-dropdown-index="3" href="/entertainment/games">
                                                Games
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/lifestyle">Lifestyle</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Fashion"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/lifestyle/fashion">
                                                Fashion
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Beauty-&amp;-Health"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/lifestyle/beauty-health">
                                                Beauty &amp; Health
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Relationships-&amp;-Weddings"
                                            data-dropdown-uuid=""  data-dropdown-index="3" href="/lifestyle/relationships-and-weddings">
                                                Relationships &amp; Weddings
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Food,-Travel,-Arts-&amp;-Culture"
                                            data-dropdown-uuid=""  data-dropdown-index="4" href="/lifestyle/food-travel">
                                                Food, Travel, Arts &amp; Culture
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/sports">Sports</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Football"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/sports/football">
                                                Football
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/business">Business </a>
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/quizzes">Quizzes</a>
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/classifieds">Classifieds</a>
                                    
                                </li>
                                
                                
                                
                                
                            </ul>       
                        </div>
                    </div>
                </div>
            </div>
            
        </nav>
        <div class="searchBar switch">
                <ul class="profileList">
                    
                    <li class="facebook">
                        <a href="https://www.facebook.com/pulselivekenya" title="Follow us on Facebook" target="_blank">Facebook</a>
                    </li>  
                    
                    
                    <li class="twitter">
                        <a href="https://twitter.com/pulselivekenya" title="Follow us on Twitterze" target="_blank">Twitter</a>
                    </li>  
                    
                    
                    <li class="instagram">
                        <a href="https://www.instagram.com/pulselivekenya/" title="Follow us on Instagram" target="_blank">Instagram</a>
                    </li>  
                    
                    
                    <li class="youtube">
                        <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="Watch us on YouTube" target="_blank">YouTube</a>
                    </li>  
                    
                    
                </ul>
                <div class="search-container menu-button search" data-search-container="">
                    <div class="svg icon-search"></div>
                </div>
        </div>
        
    </div>
    <div class="searchDiv">
        <form id="searchForm" class="searchForm closed" method="get" action="/search">
            <input id="searchInput" type="text" class="searchQueryInput switch" placeholder="Search" x-webkit-speech="" autocomplete="off" id="searchQuery" name="q">
        </form>  
    </div>
    <div class="menuBg"></div>
</header><!-- header -->
        


        


        <div class="onet-ad" id="onet-ad-top"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
        
        <section class="pageAligment">
            <div id="doc" data-run-module="local/main.LazyLoadIS"  data-preload="true">
                 <!-- channelConfig -->
                


<!-- specialBanner -->

                <div class="pageContent pageWrapper container customSize" >
                    
                    <div class="row">
                        
                        <div class="col-xs containerCustom">
                            <div class="leftColWrapper">
                                
                                    
                                        
  <div class="onet-ad" id="onet-ad-flat-boxday5" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("flat-boxday5");
            onetAds.show("flat-boxday5");
        </script>
    </div>
<!-- widgetAboveArticle0 -->
                                    
                                        
  <div class="onet-ad" id="onet-ad-top" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("top");
            onetAds.show("top");
        </script>
    </div>
<!-- widgetAboveArticle1 -->
                                    
                                        <!-- widgetAboveArticle2 -->
                                    
                                        <!-- widgetAboveArticle3 -->
                                    
                                        <!-- widgetAboveArticle4 -->
                                    
                                        <!-- widgetAboveArticle5 -->
                                    
                                        <!-- widgetAboveArticle6 -->
                                    
                                
                                <article class="articleDetail">
                                    

    <ol class="breadcrumbs">
        
            
        
            
                <li><a class="breadcrumbItem mainCategory" href="https://www.pulselive.co.ke/entertainment">Entertainment</a></li>
            
        
            
                <li><a class="breadcrumbItem subCategory" href="https://www.pulselive.co.ke/entertainment/celebrities">Celebrities</a></li>
            
        
    </ol>
 <!--breadcrumbs-->
                                    <!-- reportHeader -->

                                    
                                        <header class="atricleTop">
                                            <h1 class="mainTitle">
    
        Bahati&#39;s Manager Weezdom in Mourning 
    
</h1> <!-- title -->
                                            


    <div class="articleHeading">

        
        
        
        
        
        
        
        
            
                
                <div class="authDesc authDesc1">
                    
                        <a href="https://www.pulselive.co.ke/author/dennis-milimo" >
                    
                        <span class="name" itemprop="name">Dennis Milimo</span>
                    
                        </a>
                    
                </div>
            
        

        <time class="datePublished">
            
            
            
            
                
                    Today at 11:08 AM
                
            
        </time>
        
        

        <div class="sourceCopytight">
            
            
        </div>
        
    </div>
    
 <!-- sourc -->
                                             
    <div class="socialShare socialShareTop">
        <span class="shareTop">Tell your friends</span>
        <a data-run-module="local/main.socialShare_facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook" data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button"></a>
        <a data-run-module="local/main.socialShare_twitter" href="javascript:void(0);" data-gtm-social="twitter" class="shareIcon ring-icon-twitter" title="Twitter" data-socialname="pulselivekenya" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button"></a>
        <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" data-gtm-social="email" class="shareIcon ring-icon-email" title="Email"></a>
    </div>

                                        </header>
                                    

                                    <!-- teaserVideo -->

                                    
                                        
                                            <div id="teadsTv" data-run-module="local/main.scriptsLazyLoad" data-type="teadsTv" data-href="//a.teads.tv/page/87018/tag"></div>
                                        
                                    
                                    <div data-io-article-url="https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w" class="whitelistPremium">
                                        
                                            


    
        <strong id="lead" class="hyphenate lead">
            Take Heart Weezdom at this Difficult time<br/>
        </strong>
    
<!-- lead -->
                                            
 
    
    
    

    
        
            
            <figure class="mainPhoto" id="mainPhoto">

                
                    
                    

                     
                        <picture class="loaderBlock" >
                            <div class="preLoader">
                                <div class="loadBlock"></div>
                            </div>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/ZeTk9kpTURBXy8yODJlM2Y0OTRjZjIwMzlhMDQ5NjRjYmY2NDY1ZWMzNS5qcGeRkwXNAxTNAbyBoTAF" type="image/webp">
                            <img itemprop="url" data-original="//ocdn.eu/pulscms-transforms/1/wSgk9kpTURBXy8yODJlM2Y0OTRjZjIwMzlhMDQ5NjRjYmY2NDY1ZWMzNS5qcGeRkwXNAxTNAbyBoTAB"  alt="Weezdom"  />
                        </picture>
                    
                  

                
                    
                    
                        <figcaption class="caption hide">
                            <span class="imageDescription">Weezdom</span>
                            
                            
                            

                        </figcaption>
                    
                

                


                    
                
            </figure>
        
    
<!-- teaser -->
                                            <div class="detailContentWrapper">
                                        


                                            <div class="detailContent">
                                                 
                                                

<div class="recommendedArticles" id="recommendedArticle">
    <strong class="hyphenate lead">RECOMMENDED ARTICLES</strong>
    <ul class="recUl">
        
        
        

        <li>
            <picture class="photo">
                <source data-original="//ocdn.eu/pulscms-transforms/1/YHHk9kuTURBXy81OTA3NmUxMi0xZmVkLTRmYzctYWI3OC1mMDNiNDhjNGM3NTQuanBlZ5OVA8y2zOvNDNHNDNeVAgBkw8OTBWRkgaEwBQ"
                        type="image/webp">
                <img data-original="//ocdn.eu/pulscms-transforms/1/cnjktkuTURBXy81OTA3NmUxMi0xZmVkLTRmYzctYWI3OC1mMDNiNDhjNGM3NTQuanBlZ5OVA8y2zOvNDNHNDNeVAgBkw8OTBWRk"
                     src="data:image/jpeg;base64,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"
                     alt="Familiar look to Deschamps&#39; France for start of World Cup defence"/>
            </picture>
                <a href="//www.pulselive.co.ke/sports">
                    <p class="recCategory">sports  </p>
                </a>

            <p><a class="link"  data-uuid-ui="d7558444-005f-4f32-b2f4-db246cafda3d" data-ei="wdmwzkb2e8" href="https://www.pulselive.co.ke/sports/football/familiar-look-to-deschamps-france-for-start-of-world-cup-defence/f8ct571">Familiar look to Deschamps&#39; France for start of World Cup defence</a></p>
        </li>
        
        
        

        <li>
            <picture class="photo">
                <source data-original="//ocdn.eu/pulscms-transforms/1/0bJk9kpTURBXy81MWVhOTk3ODQ4Y2ZmOTNmMDVjYWVkNWEwOTNiNTYyOS5qcGeTlQPMtszrzQzRzQzXlQIAZMPDkwVkZIGhMAU"
                        type="image/webp">
                <img data-original="//ocdn.eu/pulscms-transforms/1/s-YktkpTURBXy81MWVhOTk3ODQ4Y2ZmOTNmMDVjYWVkNWEwOTNiNTYyOS5qcGeTlQPMtszrzQzRzQzXlQIAZMPDkwVkZA"
                     src="data:image/jpeg;base64,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"
                     alt="Details of Senator Malala&#39;s planned ouster as Deputy Minority leader"/>
            </picture>
                <a href="//www.pulselive.co.ke/news">
                    <p class="recCategory">news  </p>
                </a>

            <p><a class="link"  data-uuid-ui="cd522375-e958-4b9c-ab5c-e36fc4c1cc15" data-ei="wdmwzkb2e8" href="https://www.pulselive.co.ke/news/local/details-of-senator-cleophas-malalas-planned-removal-as-deputy-minority-leader/26tfmw7">Details of Senator Malala&#39;s planned ouster as Deputy Minority leader</a></p>
        </li>
        
        
        

        <li>
            <picture class="photo">
                <source data-original="//ocdn.eu/pulscms-transforms/1/dV4k9kqTURBXy84NWQ3N2Y3NjBkZWRhMzI0NDMxM2E1YTVmMWRhYzlhMS5qcGVnk5UDzLbM680M0c0M15UCAGTDw5MFZGSBoTAF"
                        type="image/webp">
                <img data-original="//ocdn.eu/pulscms-transforms/1/rQHktkqTURBXy84NWQ3N2Y3NjBkZWRhMzI0NDMxM2E1YTVmMWRhYzlhMS5qcGVnk5UDzLbM680M0c0M15UCAGTDw5MFZGQ"
                     src="data:image/jpeg;base64,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"
                     alt="2 dead, several injured as Mandera bound bus hits IED (Photos)"/>
            </picture>
                <a href="//www.pulselive.co.ke/news">
                    <p class="recCategory">news  </p>
                </a>

            <p><a class="link"  data-uuid-ui="c320de0e-72e6-4fce-bfe1-6012f0367f51" data-ei="wdmwzkb2e8" href="https://www.pulselive.co.ke/news/local/2-dead-several-injured-as-mandera-bound-bus-hits-ied-photos/h9dbbs5">2 dead, several injured as Mandera bound bus hits IED (Photos)</a></p>
        </li>
        
    </ul>
</div>
<!-- inRead -->
                                                
                                                





    



    






    <script type="text/javascript">/* <![CDATA[ */

      if (!adsNoBanner)
        onetAds.adSlots.push('flat-intext');
    /* ]]> */</script>




<div id="detail" class="detail intext articleBody" itemprop="articleBody" data-run-module="local/main.slotBetweenParagraphs">



     
        

        
        

        
            
                

                

                    

                    
                    

                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">Former EMB Signee and <a href="https://www.pulselive.co.ke/entertainment/weezdom-appointed-bahatis-music-manager-months-after-quitting-music/jlefbmv" id="cc26647b-6cd6-420b-87d2-ece412bfee84">Bahati’s Manager</a> Weezdom is mourning the sudden death of his Aunt identified as Grace Kanyali.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">A heartbroken Weezdom shared the sad news via his Instagram page, with a “Rest In Peace” message to his departed Auntie.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><em>“RIP Auntie Grace Kanyali🙏😭💔💔” </em>reads Weezdom’s announcement.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <div class="embeddedApp">
    <div
        data-run-module="embeddedapp/main.app"
        data-type="desktop"
        data-params="{&quot;caption&quot;:&quot;www.instagram.com&quot;,&quot;publicationId&quot;:{&quot;type&quot;:&quot;pulsembed&quot;,&quot;pulsembed&quot;:{&quot;id&quot;:&quot;5Z2Zlae5A&quot;,&quot;client&quot;:&quot;78d48ba2-1292-4bd1-8ee8-270575d5c1d8&quot;}},&quot;parameters&quot;:{&quot;url&quot;:&quot;https://www.instagram.com/p/CMyecM2pHjT/&quot;,&quot;provider&quot;:&quot;Instagram&quot;,&quot;thumb_url&quot;:&quot;https://www.instagram.com/p/CMyecM2pHjT/media?size=t&quot;,&quot;embedCode&quot;:&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/5Z2Zlae5A/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;weezdom254\&quot; data-embed-id=\&quot;5Z2Zlae5A\&quot; data-provider-name=\&quot;Instagram\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://www.instagram.com/p/CMyecM2pHjT/\&quot; target=\&quot;_blank\&quot;&gt;www.instagram.com&lt;/a&gt;&lt;/div&gt;\n&quot;},&quot;platform&quot;:{&quot;code&quot;:&quot;pulsembed&quot;},&quot;alignment&quot;:&quot;center&quot;}"
        style="display:inline-block"
        ></div>
    </div>
    


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



        
      


            <div class="onet-ad"  data-opt-pos="5"    id="left5" data-slot="left"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #left5::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
    
    
    


 

    
        
    <p class="hyphenate "><strong>Condolence Messages</strong></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">Fans and other celebrities joined the conversation, sending in their condolence messages.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/infinity_clix/" id="f186deb8-2eff-4b1e-980e-3b4fbe0915bb"> infinity_clix</a> <em>“Pole sana for the loss 🙏 9”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/designawen/" id="e608bc58-0935-4f87-adfa-43cdb1569b73"> designawen</a> <em>“My condolences dear🙏🙏🙏”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/sylvester_snr1/" id="9815f2be-e798-42ed-a23d-ff59470b2dfb">sylvester_snr1</a> <em>“😢😢😢”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/wanjiku9747/" id="15e194cd-a166-4a00-aea5-8b0d1ecab1d1"> wanjiku9747</a> <em>“Poleni sana😢”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/kimlittoz/" id="aad2c01d-f26a-4df6-ae4b-faefac061b0c">kimlittoz</a> <em>“pole sana bro RIP”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/blessingnyiva/" id="a0e34fd3-8af1-4ef6-aa1b-86c998065776"> blessingnyiva</a> <em>“Pole bro”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/a.f.r.i.c.a.n._tycoon/" id="454aba63-267d-4491-8ebd-9b4805e958dd">a.f.r.i.c.a.n._tycoon</a> <em>“Take heart💔💔😢😢”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/carl_ke254/" id="8b5b6d5e-2cac-4d80-a06f-50014f42c516"> carl_ke254</a> <em>“So sorry bro, it shall be well😢😢”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/kadzo._/" id="a0f94f76-c02c-40ea-80eb-2f73edb96eb0">kadzo._</a> <em>“I'm sorry bro😢😢😢 my condolences”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    
      


            <div class="onet-ad"  data-opt-pos="16"    id="left16" data-slot="left"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #left16::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/orlandomaneger/" id="68c0ccc2-6d71-43bd-9138-75a6b5ff6eaa">orlandomaneger</a><em> “Rest in peace😢😢😢”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/marion_essy/" id="c894abd0-9f8c-47b0-8905-e5dba833ba14">marion_essy</a> <em>“😢😢😢😢 💔💔💔💔”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/fridadarshla1245/" id="07aebd71-a1f5-40d6-8fe1-854ff0c7c53a"> fridadarshla1245</a> “<em>Condolences to the family en may God be with you at this difficult moment,,may her soul RIP 🙏🙏🙏🙏”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/rispahwairimu/" id="476ccbfd-e6da-46e1-90f7-56114414892d">rispahwairimu</a> <em>“My condolences 😢”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/dj_joeflex/" id="2a0be3bf-9002-4a22-ab59-912cf01a66a4">dj_joeflex</a> “<em>My Condolences. All is well”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><strong>Another Death </strong></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">In August 2020, Weezdom again lost his mother-figure <a href="https://www.pulselive.co.ke/entertainment/former-emb-signee-weezdom-in-mourning/9wf3j0d" id="fb0efe86-0307-4162-9cff-1a33bad2af90">in the gospel industry identified as Faith Peterz.</a></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><em>“I must say that the gift of lie is the most important thing in the world, Nimeptata tu Habari saa hizi. I have just lost someone who was very important in my life and someone who I wished would stay just to see my success but I have lost her today. A close friend who became family with time and at my hardest moment she held my hand as a mother figure. Rest in Peace, Faiz Peterz.</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    
      


            <div class="onet-ad"  data-opt-pos="24"    id="left24" data-slot="left"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #left24::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
    


 

    
        
    <p class="hyphenate "><em>Friend who Became Family🙏🙏🙏 I Can't Believe it!! RiP Mamaaa💔💔💔 You'll Live in My Heart Forever🙏”</em> reads Weezdom’s message.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <div class="embeddedApp">
    <div
        data-run-module="embeddedapp/main.app"
        data-type="desktop"
        data-params="{&quot;caption&quot;:&quot;www.instagram.com&quot;,&quot;publicationId&quot;:{&quot;type&quot;:&quot;pulsembed&quot;,&quot;pulsembed&quot;:{&quot;id&quot;:&quot;GqpEqSc4T&quot;,&quot;client&quot;:&quot;78d48ba2-1292-4bd1-8ee8-270575d5c1d8&quot;}},&quot;parameters&quot;:{&quot;url&quot;:&quot;https://www.instagram.com/p/CEhYj_zpSHT/?utm_source=ig_embed&quot;,&quot;provider&quot;:&quot;Instagram&quot;,&quot;thumb_url&quot;:&quot;https://www.instagram.com/p/CEhYj_zpSHT/media?size=t&quot;,&quot;embedCode&quot;:&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/GqpEqSc4T/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;weezdom254\&quot; data-embed-id=\&quot;GqpEqSc4T\&quot; data-provider-name=\&quot;Instagram\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://www.instagram.com/p/CEhYj_zpSHT/?utm_source=ig_embed\&quot; target=\&quot;_blank\&quot;&gt;www.instagram.com&lt;/a&gt;&lt;/div&gt;\n&quot;},&quot;platform&quot;:{&quot;code&quot;:&quot;pulsembed&quot;},&quot;alignment&quot;:&quot;center&quot;}"
        style="display:inline-block"
        ></div>
    </div>
    


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">In September 2019, <a href="https://www.pulselive.co.ke/entertainment/bahatis-new-signee-weezdom-in-mourning-the-death-of-his-stepmother/ccc8qst" id="04d5b2b1-80d8-47b9-9630-7f2d00db8164">Weezdom also lost his stepmother who succumbed to cervical cancer.</a></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><em>“1 Year Ago my Step Mom was diagnosed with Cervical Cancer already at Stage 3. Since then, she's been in a lot of pain and Hospitalized at Texas Cancer Centre Until Jana When She Left Us, Rest In Peace MOM I love You” </em>shared Weezdom.</p>


    



<!-- block end -->
                        
                    
                    

                

                

            
        

    

    <!-- sonda -->
    
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
    

</div><!-- detail -->
                                                <!-- detail -->
                                                <!-- liveblog -->

                                                <div class="afterDetailModules">
                                                    
                                                </div>

                                                <!-- detail -->
                                                 <!-- added moxTv id diff for desktop -->
                                                
                                                










<div id="articleFooterAuthorSource" class="articleFooter">

        <div class="authorsSources">
            
            
                                
            

            
                
                                
                    
                            <span class="sourcesLabel">
                                
                                    Source:
                                
                            </span>

                        <span>
                            <span>
                                
                                    
                                        <span itemprop="name">Pulse Live Kenya</span>
                                    
                                
                            </span>
                        </span>

                    

                
            

            
            <span class="authorsClear"></span>
        </div>
	
</div>

    
<!-- detailFooter -->

                                                
<!-- tags -->
                                                
    
    
    

    
       
        
        
        
            <div class="authorSourceProfile authorProfile">
                

                    

                        

                        
                            <div class="photoWrapper">
                                <picture class="photo">
                                    <source data-original="//ocdn.eu/pulscms-transforms/1/sKHk9kpTURBXy83ZDFmYzAyNWZlNjRiNTk4N2FjNzU1NzMxMzQ3NWQ1Yi5qcGeTlQPMyc0CvM0OHs0L-JUCAGTDw5MFZGSBoTAF" type="image/webp">
                                    <img data-original="//ocdn.eu/pulscms-transforms/1/8MQktkpTURBXy83ZDFmYzAyNWZlNjRiNTk4N2FjNzU1NzMxMzQ3NWQ1Yi5qcGeTlQPMyc0CvM0OHs0L-JUCAGTDw5MFZGQ" src="data:image/jpeg;base64,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" alt="Dennis Milimo"/>
                                </picture>
                            </div>
                        
                    
                

                <header>
                    
                            <a data-gtm="author-profile" href="https://www.pulselive.co.ke/author/dennis-milimo" >
                                <span class="name" itemprop="name">Dennis Milimo</span>
                    </a>
                    
                            <a class="moreAbout" data-gtm="author-profile" href="https://www.pulselive.co.ke/author/dennis-milimo" >More from the author <span>»</span></a>
                </header>

                
                
                <div class="clear"></div>
            </div>

        
        
        
    
<!-- authorProfile-->
                                                <style amp-custom>
    #link-ad::before {
    content: "AD";
    font-size: .6em;
    text-align: center;
    display: block;
    color: #bfbbbb7d;
}
</style>
<br>
    <div id="link-ad">
        <div style="background: #eee;">
            <a href="https://bit.ly/2T7UGMY"
                style="margin: 10px; display: inline-block; font-weight: bold; color:#000; " target="_blank">
                &gt;&gt; Make some extra cash, sell on Pigiame for free
            </a>
        </div>
    </div>

                                                
                                                    <div class="socialShare socialShareBottom">
    <span class="shareTop">Tell your friends</span>
    <a data-run-module="local/main.socialShare_facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook" data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button"></a>
    <a data-run-module="local/main.socialShare_twitter" href="javascript:void(0);" data-gtm-social="twitter" class="shareIcon ring-icon-twitter" title="Twitter" data-socialname="pulselivekenya" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button"></a>
    <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" data-gtm-social="email" class="shareIcon ring-icon-email"></a>
    <a href="whatsapp://send?text=https%3A%2F%2Fwww.pulselive.co.ke%2Fentertainment%2Fcelebrities%2Fbahatis-manager-weezdom-in-mourning%2F0r3e33w?utm_medium%3Dsocial%26utm_source%3Dwhatsapp%26utm_campaign%3Dshare-button" data-action="share/whatsapp/share" data-gtm-social="whatsapp" class="shareIcon ring-icon-whatsapp"></a>
    <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.pulselive.co.ke/entertainment/celebrities/bahatis-manager-weezdom-in-mourning/0r3e33w?utm_medium%3Dsocial%26utm_source%3Dlinkedin%26utm_campaign%3Dshare-button" target="_blank" data-gtm-social="linkedin" class="shareIcon ring-icon-linkedin" title="LinkedIn"></a>
</div><!-- contentShareBottom -->
                                                
                                            </div>

                                            <div id="widgetStop"></div>
                                        </div>
                                    </div>

                                    
    
    
        
    
<!-- relatedMaterials -->
                                    <!-- sherlock -->

                                    <!-- seeAlsoLinks -->

                                    
<!-- filesAttachments -->

                                    <!-- tableofcontent -->
                                    <!-- pagination -->

                                    

                                        


            <div class="onet-ad"    id="leadbanner-bottom" data-slot="flat-leadbanner"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #leadbanner-bottom::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>

                                        <div id="googleAdsCont">
                                            


        <div class="onet-ad" id="onet-ad-rectangle1"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                            


        <div class="onet-ad" id="onet-ad-rectangle3"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                        </div>
                                        <div class="onet-ad" id="onet-ad-flat-nin"></div>

                                        


        <div class="onet-ad" id="onet-ad-flat-plista"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                    

                                    <!-- editorsList -->
                                    <!-- stream -->
                                    
                                        <div id="taboolaStartHook" data-run-module="local/main.scriptsLazyLoad" data-type="taboola" data-href="//cdn.taboola.com/libtrc/ringierkenya-network/loader.js"></div>
                                    
                                    
                                        
                                    

                                    


        <div class="onet-ad" id="onet-ad-flat-widget"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>

                                      <!-- disbale block column  -->
                                        
                                         <!-- Load the newsletter here only under article -->
                                            <div id="newsletterLoader" data-run-module="local/main.subscribeNewsletter"  data-source="newsletterWidget" data-config="{&quot;keyField&quot;:&quot;pulselive.co.ke&quot;,&quot;listIdField&quot;:&quot;4&quot;,&quot;publicationNameField&quot;:&quot;pulselive.co.ke&quot;,&quot;slangField&quot;:&quot;Kua rada&quot;,&quot;nlTitleField&quot;:&quot;Join the&quot;,&quot;nlDescField&quot;:&quot;clique&quot;,&quot;nlDescEndField&quot;:&quot;Don&#39;t miss a thing, get the latest updates to fuel your conversation daily&quot;,&quot;nlSuccessField&quot;:&quot;Thank you for subscribing to our newsletter!&quot;,&quot;nlSuccessEndField&quot;:&quot;&quot;,&quot;nlPrivacyText1&quot;:&quot;By clicking again, you agree to our &quot;,&quot;nlPrivacyText2&quot;:&quot;privacy policy&quot;,&quot;nlPrivacyText3&quot;:&quot;and European users agree to our data transfer policy.&quot;,&quot;apiUrlField&quot;:&quot;https://nl.pulse.com.gh/&quot;,&quot;privacyUrlField&quot;:&quot;https://www.pulselive.co.ke/info/terms-and-conditions-pulselivecoke/d1z0r3q&quot;,&quot;classField&quot;:&quot;&quot;}">
                                            </div>
                                            
                                                
  <div class="onet-ad" id="onet-ad-rectangle3" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("rectangle3");
            onetAds.show("rectangle3");
        </script>
    </div>
<!-- widgetRight0 -->
                                            
                                                
<section class="newsletterSignup_wdg">
    <div class="topMain LazyLoadBG red" data-bg="">
        <div class="row" id="signUpContainer">
            <div class="col-sm-6" style="margin-top: auto;margin-bottom: auto;">
                <div id="intro">
                   
                    
                    <p class="topSlang">Join the  <span class="quote">
                            " Pulse Community" </span>&nbsp; </p>
                    <span id="subTitle"> Don&#39;t miss a thing, get the latest updates to fuel your conversation daily </span>
                    
                </div>
                <div id="termsConditions" class="hide">
                    <br><br>
                    <p>By clicking again you agree to our  <a class="color" target="_blank"
                            href="https://www.pulse.com.gh/info/privacy-policy-how-we-respect-your-privacy-or-pulsecomgh/3qxd7kj">
                            privacy policy </a>  and European users agree to data transfer policy
                    </p>
                </div>
            </div>
            <div class="col-sm-6" style="margin-top: auto;margin-bottom: auto;">

                <form method="POST" class="inputForm" action="/newsletter">
                    
                    <button name="sendUpdates" id="sendUpdates"
                        class="">
                        SEND ME UPDATES
                    </button>
                </form>

            </div>
        </div>

        <div class="row hide" id="thanksContainer">
            Thank you! You have successfully subscribed to receive the Pulselive  newsletter pulselive.co.ke
            
        </div>
    </div>
    <br>
    <script type="text/javascript">
        function getEmail() {
            // Selecting the input element and get its value 
            var inputVal = document.getElementById("email").value;

            Sailthru.integration("userSignUp", {
                "email": '"' + inputVal + '"',
                "lists": {},
                "vars": {},
            });
        }

    </script>

    <script type="text/javascript">
        function sendMeUpdates(event) {
            return false;
        }


        function sendPrivacyEmail(event) {
            return false;
        }
    </script>

</section>
<!-- widgetRight1 -->
                                            
                                                <div class="socialButtonsWdg">

<a href="https://www.facebook.com/pulselivekenya/?ref=br_rs" rel="nofollow" target="_blank" class="facebook">LIKE PULSE KENYA</a>


<a href="https://www.instagram.com/pulselivekenya/" rel="nofollow" target="_blank" class="instagram">FOLLOW PULSE KENYA</a>

</div><!-- widgetRight2 -->
                                            
                                                
    <div class="eyewitnessWdg">    <p>Eyewitness? Submit your stories now via social or: </p>    <p><a href="news@pulselive.co.ke">news@pulselive.co.ke</a></b></p></div>
<!-- widgetRight3 -->
                                            
                                                


<section id="recommended-articles">
<div class="col-xs-12 wdgWrapper">
<div
    class="wdg threeColumn wdgStandard"
     >

    
    <div class="widgetsHeader">
        
            
        
        <h1 class="title">
            
            <span class="titleTxt">Recommended Articles</span>
            <span class="titleUnderlined">&nbsp;</span>
        </h1>
    </div>
    
    
    
    <div class="wdgItems">
        <div class="row">
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/10-things-meghan-and-harry-told-oprah/d4jfswz">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/AOXk9kpTURBXy80NzIwNDc2ZDAwMzJlMjZmOGI1YzM2ZGZmZWE3OWU0ZC5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="10 things Meghan and Harry told Oprah"  data-original="//ocdn.eu/pulscms-transforms/1/ej_k9kpTURBXy80NzIwNDc2ZDAwMzJlMjZmOGI1YzM2ZGZmZWE3OWU0ZC5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        10 things Meghan and Harry told Oprah
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/08/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/jahmby-koikai-makes-radio-comeback-after-6-years/l67kyyd">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/D1Ek9kpTURBXy81YTU5ZDVjOTRlZGNmZGI2NWY1OTIyNmEyY2RmM2MwOS5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Jahmby Koikai lands new radio job 6 years after leaving QFM"  data-original="//ocdn.eu/pulscms-transforms/1/hXIk9kpTURBXy81YTU5ZDVjOTRlZGNmZGI2NWY1OTIyNmEyY2RmM2MwOS5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Jahmby Koikai lands new radio job 6 years after leaving QFM
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/team-mafisi-mrelax-pale-dm-karen-nyamu-to-men-asking-if-she-is-single-after-the/7r97svv">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/quSk9kpTURBXy80YmFhMDY0MWFkNzExNzUyZDI4MzBkYjYxYWI2NjQ0Zi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Team Mafisi Mrelax pale DM- Karen Nyamu to men asking if she is single (Screenshot)"  data-original="//ocdn.eu/pulscms-transforms/1/u_nk9kpTURBXy80YmFhMDY0MWFkNzExNzUyZDI4MzBkYjYxYWI2NjQ0Zi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Team Mafisi Mrelax pale DM- Karen Nyamu to men asking if she is single (Screenshot)
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/vera-sidika-speaks-out-over-allegations-that-she-fell-on-stage-while-entraining/mcp3gcn">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/b9Wk9kpTURBXy83MDhhMmEwNzIyMjQyNzhhZThlNzk1N2I1MjlkZTlkMi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Vera Sidika speaks out over allegations that she fell on stage while entraining guests"  data-original="//ocdn.eu/pulscms-transforms/1/g3ck9kpTURBXy83MDhhMmEwNzIyMjQyNzhhZThlNzk1N2I1MjlkZTlkMi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Vera Sidika speaks out over allegations that she fell on stage while entraining guests
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/ktns-jamal-gaddafi-tests-positive-for-covid-19/y30v6sv">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/IuHk9kpTURBXy9iNzlmYmQ2ODIxZWYzYmE5YTdmODgwMDEwYzkwNzgwNC5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="KTN’s Jamal Gaddafi tests positive for Covid-19 "  data-original="//ocdn.eu/pulscms-transforms/1/JWfk9kpTURBXy9iNzlmYmQ2ODIxZWYzYmE5YTdmODgwMDEwYzkwNzgwNC5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        KTN’s Jamal Gaddafi tests positive for Covid-19 
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/raila-odinga-leads-kenyans-in-mourning-legendary-reggae-artiste-bunny-wailer/vrshfv2">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/mrOk9kqTURBXy8zM2U2OTc4NjhjMGFkOGFkM2M0YmI2NDY4YWIxODBlOS5qZmlmkZMFzQGGzOCBoTAF" type="image/webp">
                            <img alt="Raila Odinga leads Kenyans in Mourning Legendary Reggae Artiste Bunny Wailer"  data-original="//ocdn.eu/pulscms-transforms/1/LR5k9kqTURBXy8zM2U2OTc4NjhjMGFkOGFkM2M0YmI2NDY4YWIxODBlOS5qZmlmkZMFzQGGzOCBoTAB" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Raila Odinga leads Kenyans in Mourning Legendary Reggae Artiste Bunny Wailer
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/just-lost-my-brother-bashir-milele-fms-captain-otoyo-in-mourning/9hztff4">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/EbOk9kpTURBXy9jNDBlOTUzNDZmZGEzNWE1Y2Q5ZTQ3OGRkZTk5NTlkOS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Milele FM&#39;s Captain Otoyo in Mourning"  data-original="//ocdn.eu/pulscms-transforms/1/g5ak9kpTURBXy9jNDBlOTUzNDZmZGEzNWE1Y2Q5ZTQ3OGRkZTk5NTlkOS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Milele FM&#39;s Captain Otoyo in Mourning
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/cate-rira-ventures-into-business-months-after-partying-ways-with-nation-fm-photos/27n3jp3">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/IM7k9kpTURBXy9jOTVlMDNhZjVlOThkZTM1OWE3NDEyYTkzMzIyNjdkNC5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Cate Rira unveils new venture months after quitting Nation FM (Photos)"  data-original="//ocdn.eu/pulscms-transforms/1/4XSk9kpTURBXy9jOTVlMDNhZjVlOThkZTM1OWE3NDEyYTkzMzIyNjdkNC5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Cate Rira unveils new venture months after quitting Nation FM (Photos)
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/betty-kyallo-to-launch-own-clothing-line-bk-closet/bsvq0s8">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/Hr5k9kpTURBXy81NWU3ODNhZWZhYmZhMGJhMTFlZjE3MGMxNjBkMzMxOC5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Betty Kyallo to launch own Clothing line"  data-original="//ocdn.eu/pulscms-transforms/1/P1yk9kpTURBXy81NWU3ODNhZWZhYmZhMGJhMTFlZjE3MGMxNjBkMzMxOC5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Betty Kyallo to launch own Clothing line
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/03/2021</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
        
            
        
            
        
            
        
        </div>
    </div>
    
</div>
</div>
</section>
<!-- widgetRight4 -->
                                            
                                                
    <div id="taboola-below-article-thumbnails"></div><script type="text/javascript">    window._taboola = window._taboola || [];    _taboola.push(            {mode: 'thumbnails-a', container: 'taboola-below-article-thumbnails', placement: 'Below Article Thumbnails', target_type: 'mix'}    );</script>
<!-- widgetRight5 -->
                                            
                                                <!-- widgetRight6 -->
                                            
                                        
                                    


                                    
                                     <!-- no ads bannner -->
                                        
                                        
                                    
                                    </article>
                            </div>
                            <!--check if its a featured article -->
                             <!-- disbale right column  -->
                                    
                                    <div class="rightColWrapper">
                                        <aside class="extraList">
                                                
                                                    
                                                        
  <div class="onet-ad" id="onet-ad-right" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("right");
            onetAds.show("right");
        </script>
    </div>
<!-- widgetRight0 -->
                                                    
                                                        


<section id="trending">
<div class="col-xs-12 wdgWrapper">
<div
    class="wdg wdgStandardRightColumn "
     >
    
    
    <div class="widgetsHeader">
        <h1 class="title">
            
            <span class="titleTxt">Trending</span>
        </h1>
    </div>
    
    
    <div class="wdgItems">
        <div class="row">
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/kaka-empires-femi-one-appointed-monster-energy-drink-brand-ambassador/d38kdcb">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/dC-k9kpTURBXy9mZDE2MDVkN2EyMTMzN2Y4YzUwMWMzMmE0MjhkMDcxYS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Kaka Empire’s Femi One lands new Ambassadorial Deal (Photos)"  data-original="//ocdn.eu/pulscms-transforms/1/teGk9kpTURBXy9mZDE2MDVkN2EyMTMzN2Y4YzUwMWMzMmE0MjhkMDcxYS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Kaka Empire’s Femi One lands new Ambassadorial Deal (Photos)
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/10-facts-about-late-e-sir-as-the-world-marks-18-years-since-his-death/21me3ep">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/XkPk9kpTURBXy9hNWU0ZjQ3ZDQwYWIxM2U0YTM0ODExYzYzMGM5MWQ1Mi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt=" 10 Facts about late E-sir as the world marks 18 years since his death"  data-original="//ocdn.eu/pulscms-transforms/1/4DRk9kpTURBXy9hNWU0ZjQ3ZDQwYWIxM2U0YTM0ODExYzYzMGM5MWQ1Mi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                         10 Facts about late E-sir as the world marks 18 years since his death
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/kenyans-react-as-lupita-nyongo-shares-photos-while-holidaying-in-lamu-kenya/fvfh0kx">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/-LWk9kpTURBXy8zNWU0ODdjOGI1NGE3ODkzZDAxZjg3OTI0MTNhMmY4Mi5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Actress Lupita Nyong’o spotted in Lamu and Kenyans can’t keep calm (Photos)"  data-original="//ocdn.eu/pulscms-transforms/1/3Tdk9kpTURBXy8zNWU0ODdjOGI1NGE3ODkzZDAxZjg3OTI0MTNhMmY4Mi5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Actress Lupita Nyong’o spotted in Lamu and Kenyans can’t keep calm (Photos)
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/uhurus-look-alike-michael-gitonga-checks-into-rehab-months-after-stories-about-him/v5dwb7x">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/Dsxk9kpTURBXy81M2IxNjM5YjlmZjE4MjY5Yzg1MzlhMmFhZTlhMDE5OS5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Uhuru’s look-alike Michael Gitonga goes into Rehab days after saying he was used by Brands that offered him help"  data-original="//ocdn.eu/pulscms-transforms/1/8r4k9kpTURBXy81M2IxNjM5YjlmZjE4MjY5Yzg1MzlhMmFhZTlhMDE5OS5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Uhuru’s look-alike Michael Gitonga goes into Rehab days after saying he was used by Brands that offered him help
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
            
                
            
                
            
                
            
        </div>
    </div>
    
</div>
</div>
</section>
<!-- widgetRight1 -->
                                                    
                                                        
  <div class="onet-ad" id="onet-ad-right3" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("right3");
            onetAds.show("right3");
        </script>
    </div>
<!-- widgetRight2 -->
                                                    
                                                        
    <div class="extraList"  data-content-container="stream">
        <div id="floatingGroup" data-run-module="local/main.asideContainerDel_float">
            <div id="stickyRight" class="asideAds asideBlock">
                <div class="stickyWrapper" data-pos="1">
                    <div id='onet-ad-right2' class='onet-ad sticky-slot'></div>
                </div>
            </div>
        </div>
    </div>
<!-- widgetRight3 -->
                                                    
                                                
                                        </aside>
                                    </div>
                                    
                            
                        </div>
                    </div>
                </div>
                <!-- gallery -->
            </div>
        </section>
         <!-- insertion of Aureus start -->
                        <!-- insertion of Aureus end -->
        <footer class='footer'>
    <div class="topFooter">
        <div class="footer pageWrapper container customSize">
            <div class="serviceFooterContainer">
                
                <div class="advertTitle">
                    Advertise with us:
                </div>
                <div class="advertBody">
                    <div>Reach out to us at <a href="mailto:salesteam@pulse.co.ke">salesteam@pulse.co.ke</a> or 0714928113 to advertise with us. Find out more about Pulse's products and advertising opportunities at <a href="https://pulse.africa" target="_blank" style="color: #ff0"> pulse.africa</a> </div>
                </div>
                
            </div>
            <div class="serviceFooterContainer">
                <div class="logoContainer">
                    
                        <a class="portalLogo" href="//www.pulselive.co.ke">
                            <img src="https://ocdn.eu/radp/logotypes/pulselive-kenya.svg">
                        </a>
                    
                    
                        <p class="fnote">We inform &amp; engage - 24/7</p>
                    
                </div>
                
                <ul class="footNav">
                    
                        
                            <li>
                                <a href="/" title="Home" class="fHeader">Home</a>
                                
                                <ul class="footNavSecond">
                                    
                                        
                                        <li>
                                            <a href="/news" title="News">News</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/entertainment" title="Entertainment">Entertainment</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/lifestyle" title="Lifestyle">Lifestyle</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/sports" title="Sports">Sports</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/business" title="Business">Business</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/quizzes" title="Quizzes">Quizzes</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/classifieds" title="Classifieds">Classifieds</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="https://africa.businessinsider.com/" title="Businessinsider">Businessinsider</a>
                                        </li>
                                        
                                    
                                </ul>
                                
                            </li>
                        
                    
                    
                    <li>
                        <span class="fHeader">About us</span>
                        <ul class="footNavSecond">
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/about-us" title="About Us">About Us</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="https://pulse.africa" title="Advertise">Advertise</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/privacy-policy-pulselivecoke/vh9gdmy	" title="Privacy Policy">Privacy Policy</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/terms-and-conditions-pulselivecoke/d1z0r3q" title="Terms &amp; Conditions">Terms &amp; Conditions</a>
                            </li>
                            
                            
                        </ul>
                    </li>
                    
                    
                    <li>
                        <span class="fHeader">Social</span>
                        
<div id="socialLinks" class="socialLinks serviceFooterContainer">
    <ul class="profileList">
        
        <li class="facebook icon-fb">
            <a href="https://www.facebook.com/pulselivekenya/" title="Follow us on Facebook">Facebook</a>
        </li>  
        
        
        <li class="twitter icon-twitter">
            <a href="https://twitter.com/pulselivekenya" title="Follow us on Twitterze">Twitter</a>
        </li>  
        
        
        
        <li class="instagram icon-instagram">
            <a href="https://www.instagram.com/pulselivekenya/" title="Follow us on Instagram">Instagram</a>
        </li>  
        
        
        
        <li class="youtube icon-youtube">
            <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="Watch us on YouTube">YouTube</a>
        </li>  
        
        
        
        <li class="newsletter icon-newsletter">
            <a href="https://www.pulselive.co.ke/newsletter" title="Registration and newsletter subscription">Newsletter</a>
        </li>
        
    </ul>
</div>

                    </li>
                    
                </ul>
                
                <div class="slideToTop" data-run-module="uss/main.slideToTop" style="opacity: 0;">
                    <a href="javascript:void(0)">
                        <span></span>
                    </a>
                </div>
            </div>
        </div>
    </div>
    <div class="bottomFooter">
        <div id="copyrights" class="container">
            &copy; 2021  Pulselive.co.ke
        </div>
    </div>

</footer>

             
            <script>
                var parentDiv =document.getElementById('detail');
                var d = document.getElementById("recommendedArticle");
                d.style.display = 'block';
                var child = parentDiv.children[2];
                 parentDiv.insertBefore(d, child)
            </script>
        
        
        <!-- Use footer script -->
        
        
        <script type="text/javascript">    var adsDiv =document.getElementById('bNhjLmVPUXEW');     if(!adsDiv){     window.dataLayer = window.dataLayer || [];          window.dataLayer.push({ 'event' : 'adblock-detected'}); }  </script> <script src="https://radp.ocdn.eu/js/adblocker.js" type="text/javascript">
         
        <script type="text/javascript"> window._taboola = window._taboola || []; _taboola.push( {flush: true} );  </script>
        <script type="text/javascript" src="https://ocdn.eu/radp/quantcast_ live kenya.js" async/></script>
    <script type='text/javascript' src='https://ssp.mediapal.net/www/delivery/spcjs.php?id=5'></script>
<script>
var eadt=eadt||{};eadt.cmd=eadt.cmd||[];
(function(){var s=document.createElement('script');s.async=true;s.type='text/javascript';var useSSL='https:'==document.location.protocol;s.src=(useSSL?'https:':'http:')+'//eas-fe.eskimi.com/js/adt.js';var n=document.getElementsByTagName('script')[0];n.parentNode.insertBefore(s,n)})();
</script>

<div id="ead-1565081532088-0">
<script>
eadt.cmd.push(function(){
    eadt.setMacros('%%CLICK_URL_UNESC%%');
    eadt.setDomain(0); // skip domain ID
    eadt.setNetwork(0); // next network ID
    eadt.render('427', 'ead-1565081532088-0');
});
</script>
</div></body>
    </div>
    </html>
