 
     
    
    
    
    <!DOCTYPE html>
    <html lang="en-US">
        <head>
            <meta charset="utf-8" />
            <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><script>/* <![CDATA[ */ ringDataLayer = {"content":{"object":{"type":"story","kind":"article","id":"1c5e99e5-359b-4682-ba5c-e6a32411dff0"},"part":1,"publication":{"point":{"id":"fqvnwm6"}},"source":{"system":"ring_content_space","id":"7dd277c7-e647-489d-a0cd-8c305073a877"}},"context":{"publication_structure":{"root":"WWW_PULSELIVE_CO_KE","path":"ENTERTAINMENT/CELEBRITIES/ARTICLE"},"id":{"aureus_offers":["59poypesnd"]}}}; /* ]]> */</script><script>/* <![CDATA[ */ accConf = {"rum":{"tid":"EA-4719209","boot":"disable","cookieInfo":0,"pageType":"HTML","data":{"RTYPE":"{\"type\":\"story\",\"kind\":\"article\"}"}},"gtm":{"id":["GTM-MGFD5X"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}}; /* ]]> */</script>
        <script type="text/javascript">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</script>
        <script type="text/javascript">
        if(accConf&&accConf.rum&&accConf.rum.data)for(var key in window.dlRumData||(window.dlRumData=[]),accConf.rum.data)window.dlRumData.push({metricName:key,eventValue:accConf.rum.data[key]});
        </script>
        
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<!-- End Google Tag Manager -->

            <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
            <title>Death never prepares you- Kate Actress and her family in mourning  [ARTICLE] - Pulse  Live Kenya</title>
            
            <meta name="DC.Identifier" content="1c5e99e5-359b-4682-ba5c-e6a32411dff0" />
            
            
            <meta name="description" content="Still trying to comprehend that you are not here anymore- Kate Actress" />
            
            <link href="https://ocdn.eu/ucs/static/3a5ed13e35b52b66219d0dd4d1ebbde3/d112b4190e43ff6ba92fc6a5d2c199d2/build/red/desktop.css" type="text/css" rel="stylesheet">
            
            
            


<script type="text/javascript" data-static-amd-map="{&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/305a3e930539ff2e72e94acb885c4cb2/build&quot;,&quot;newslivestream&quot;:&quot;https://ocdn.eu/paas-static/template-engine/c521d70663e169ce4f8f4960a2bf333e/build&quot;,&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;onettv&quot;:&quot;https://ocdn.eu/paas-static/template-engine/9a45bcb3878bfe2ee5a4f671b8239389/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/90f2c8adc05ed0952349aade8960bfc9/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;pulsembed&quot;:&quot;https://ocdn.eu/paas-static/template-engine/1972b6c75d43a95e148faf3e9d1a8c79/build&quot;,&quot;adsinit&quot;:&quot;//ty0lm9uz.onet.pl/e1BrazhrNDB9/build&quot;,&quot;uss&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4103f0ba4ad9fabb230202e95534e54e/build&quot;,&quot;ustnavigation&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4103f0ba4ad9fabb230202e95534e54e/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/3a5ed13e35b52b66219d0dd4d1ebbde3/d112b4190e43ff6ba92fc6a5d2c199d2/build&quot;,&quot;localmobile&quot;:&quot;//ocdn.eu/ucs/static/3a5ed13e35b52b66219d0dd4d1ebbde3/d112b4190e43ff6ba92fc6a5d2c199d2/build&quot;}">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</script>
        <script type="text/javascript" src="https://ocdn.eu/radp/pwa/firebase.js" ></script>
        <!-- disbale ads script from loadinf -->
        <!-- adsConf -->

    

    <script type="text/javascript">/* <![CDATA[ */
        
        
            adsNoBanner = false;
        

        onetAds = {
    "async": 1,
    "sgn_cookie": 0,
    "whitelist": 0,
    "keywords": [
        "detal",
        "brian-safari",
        "kate-actress",
        "catherine-kamau"
    ],
    "target": "PLIVEKE_URL/CATEGORY",
    "DV": "PLIVEKE_URL/CATEGORY/brian-safari/POZOSTALE",
    "kropka": {
        "DX": "PV,puls,fqvnwm6,1,",
        "PU": "1c5e99e5-359b-4682-ba5c-e6a32411dff0"
    },
    "keyvalues": {
        "ci": "1c5e99e5-359b-4682-ba5c-e6a32411dff0"
    },
    "cmd": [],
    "adSlots": [],
    "lazy": 1,
    "lazyPercentage": 200,
    "tid": "EA-4719209",
    "noDfp": 1,
    "mobile": 0,
    "autoslot": 1,
    "no_gemius": 1,
    "cookieInfo": 1,
    "eventsapi": true
};

        if (typeof identifierEI !== "undefined")
        {
            onetAds.kropka['EI'] = identifierEI;
        }
        
        
        onetAds.cmd.push(function (dlApi){

            var idGenerator = createIdGenerator();
            var htmlblock   = document.querySelectorAll(".htmlblockslot");

            for (var i=0; i<htmlblock.length; i++) {
                configureSlot(htmlblock[i]);
            }

            function configureSlot(adDom) {

                var id      = idGenerator.get();
                var keyword = adDom.getAttribute("data-slot-keyword");

                adDom.setAttribute("id", id);

                var slot = onetAds.defineSlot('flat-autopromo', id);
                slot.setTargeting('kwrd', keyword);
            }

            function createIdGenerator() {

                var counter = 1;

                return {
                    get : get
                };

                function get() {

                    var num = counter;
                    counter++;
                    return "htmlblockslot_id_" + num;
                }
            }
        });


    /* ]]> */</script>





    <script type="text/javascript">
        var pulse2EmbedConfig = {
                OnettvVideo: {
                    'MAIN_ELEMENT': {
                        preset: "mainVideoRADPKe",
                        enableGoogleAnalytics: 2,
                        volume: 0,
                        enableEndScreen: 1,
                        autoplayRelated: 1,
                        enableAds: 1,
                        adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_300x250v&amp;description_url=[placeholder]&amp;tfcd=0&amp;npa=0&amp;sz=300x250%7C300x250&amp;gdfp_req=1&amp;output=vast&amp;unviewed_position_start=1&amp;env=vp&amp;impl=s&amp;correlator=",
                        floatingControls: 1,
                        embedType: 'inTextVideo',
                        showAdvertComment: 1
                    },
                    'INTEXT': {
                        preset: "mainVideoRADPKe",
                        enableGoogleAnalytics: 2,
                        volume: 0,
                        enableEndScreen: 1,
                        autoplayRelated: 1,
                        enableAds: 1,
                        adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_300x250v&amp;description_url=[placeholder]&amp;tfcd=0&amp;npa=0&amp;sz=300x250%7C300x250&amp;gdfp_req=1&amp;output=vast&amp;unviewed_position_start=1&amp;env=vp&amp;impl=s&amp;correlator=",
                        floatingControls: 1,
                        embedType: 'inTextVideo',
                        showAdvertComment: 1
                    }
                }
            };
    </script>

        <script id="adsinit" data-original="//sgqcvfjvr.onet.pl/YnVpbGQvezlza2x0ZTYwfWRsQXBpL2RsLmxpYntOTWFzX0E2MH0ubWluLmpz">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</script>
        
            <link rel="canonical" href="https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6" />
        
        <!-- proxyHead -->
        
    

    
        

        

        

        
            <script type="application/ld+json">
                {
                    "@context": "https://schema.org",
                    "@type": "BreadcrumbList",
                    "itemListElement":[{
                        "@type": "ListItem",
                        "position": 1,
                        "name": "Home",
                        "item": "https://www.pulselive.co.ke"
                    },{
                        "@type": "ListItem",
                        "position": 2,
                        "name": "Entertainment",
                        "item": "https://www.pulselive.co.ke/entertainment"
                    },{
                        "@type": "ListItem",
                        "position": 3,
                        "name": "Celebrities",
                        "item": "https://www.pulselive.co.ke/entertainment/celebrities"
                    },{
                        "@type": "ListItem",
                        "position": 4,
                        "name": "Death never Prepares You Kate Actress And Her Family In Mourning",
                        "item": "https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6"
                    }]
                }
            </script>
        

        

        
    
        

        

        

        

        
            <script type="application/ld+json">
                {
                    "@type": "NewsArticle",
                    "@id": "https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6#article",
                    "mainEntityOfPage": {
                        "@type": "WebPage",
                        "@id": "https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6"
                    },
                    "headline": "Death never prepares you- Kate Actress as she mourns Brother-in-law",
                    "primaryImageOfPage": {
                        "@id": "https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6#mainPhoto"
                    },
                    "image": ["http://ocdn.eu/images/pulscms/NTE7MDA_/abee04aafe0c6135b66f0617ed7c6bf8.jpg"],
                    "datePublished": "2021-01-13T06:31:49+01:00",
                    "dateModified": "2021-01-13T06:31:44+01:00",
                    "author": [{
                        "@type": "Person",
                        "name" : "Dennis Milimo"
                    }],
                    "publisher": {
                        "@type": "Organization",
                        "name": "Pulse  Live Kenya",
                        "logo": {
                            "@type": "ImageObject",
                            "url": "https://radp.ocdn.eu/logotypes/logo_desktop_kenya_new_v1.svg"
                        }
                    },
                    "description": "Still trying to comprehend that you are not here anymore- Kate Actress",
                    "isAccessibleForFree": true
                }
            </script>
        

        
    

        

    

    
        
            <meta property="og:title" content="Death never prepares you- Kate Actress as she mourns Brother-in-law" />
        
        
            <meta property="og:description" content="Still trying to comprehend that you are not here anymore- Kate Actress" />
        
        
            
                
                    <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/HmvktkpTURBXy9hYmVlMDRhYWZlMGM2MTM1YjY2ZjA2MTdlZDdjNmJmOC5qcGeSlQMBMc0EOM0CYJMFzQMUzQG8" />
                
                <meta property="og:image:width" content="788" />
                <meta property="og:image:height" content="444" />
            
            
            
                <meta property="og:image:alt" content="Actress Catherine Kamau aka Kate Actress "/>
            
        
        
            <meta property="og:url" content="https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6" />
        
        
            <meta property="og:type" content="article" />
        
        
            <meta property="og:site_name" content="Pulse  Live Kenya"/>
        
        
            <meta property="article:publisher" content="https://www.facebook.com/pulselivekenya"/>
        
        
            <meta property="og:locale" content="en_KE" />
        
        
            <meta property="article:published_time" content="2021-01-13 06:31:44+0100" />
        
        
            <meta property="article:modified_time" content="2021-01-13 06:31:44+0100" />
        
        
            <meta property="article:section" content="Celebrities" />
        
        
            <meta property="og:updated_time" content="2021-01-13 06:31:44+0100" />
        
        
            <meta property="fb:app_id" content="715603858641973" />
        
        
            
    <meta property="fb:pages" content="252006125219593" />    

        
    



<meta name="facebook-utm_source" content="facebook"/>
<meta name="facebook-utm_medium" content="social"/>
<meta name="facebook-utm_campaign" content="share-button"/><!-- socialShare -->
        
    



    <script type="text/javascript">
        window.dataLayer = window.dataLayer || [];
        window.dataLayer.push({"DV":"TARGET/Part2","author1_name":"Dennis Milimo","author1_uuid":"72db854f-1b63-5abf-8522-93d44a689716","datePublished":"2021-01-13","uuid":"1c5e99e5-359b-4682-ba5c-e6a32411dff0","type":"Article","license":"Pulse Live Kenya"});
        
        if(window.addEventListener) {
            window.addEventListener("load", pageSpeedForDataLayer);
        } else if (window.attachEvent) {
            window.attachEvent("onload", pageSpeedForDataLayer);
        }
        
        function pageSpeedForDataLayer() {
            setTimeout(function () {
                var te = 0,    ti = 0, teDescription = 'slow';
                if (window.performance) {
                    var g = window.performance.timing;
                    te = g.loadEventEnd - g.navigationStart;
                    ti = g.domInteractive - g.navigationStart;
                }
                if(te > 0 && te < 6e4 && ti > 0 && ti < 6e4) {                  
                    if(te < 3000) {
                        teDescription = 'fast';
                    } else if (te >= 3000 && te <= 7000) {
                        teDescription = 'medium';
                    }
                        
                    window.dataLayer.push({
                        'event': 'speed',
                        'params': {
                            'ti': ti,
                            'te': te,
                            'teDescription': teDescription
                        }
                    });
                }
            }, 3000);  
        }
    </script>
<!-- dataLayer -->
        
    <link rel="amphtml" href="https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6.amp" />
<!-- ampUrl -->
        <!-- onetNewsUrl -->
        
    <script>
        
        
        

        
    </script>

        
            
    
    

        
            
        
<script type="text/javascript">
  var isMobile = false;
</script>
<link rel="manifest" href="/manifest.json">

        
            <link rel="icon" type="image/png" href="https://ocdn.eu/radp/favicon.ico" />
        

<link rel="apple-touch-icon" href="/icon.png">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">

<script type="text/javascript">
  if (navigator.serviceWorker) {
    navigator.serviceWorker.register('/pwa-sw2.js', {
      scope: '/'
    });
    navigator.serviceWorker.getRegistration()
    .then(function(registration) {
        if(registration && registration.active) {
            document.cookie ="pwaMode=pwa;path=/";
            document.cookie ="WebsiteType=desktop;path=/";
        } else {
            document.cookie = "pwaMode=website;path=/";
            document.cookie ="WebsiteType=desktop;path=/";
        }
    });
  }else {
      document.cookie = "pwaMode=website;path=/";
      document.cookie ="WebsiteType=desktop;path=/";
  }


  window.addEventListener('beforeinstallprompt', function (e) {
    // Sending PWAHomeIconPrompt event when the prompt is launched.
    dataLayer.push({
      'pwaEventAction': 'PWAHomeIconPrompt',
      'pwaEventLabel': 'PWA Home Icon Prompt',
      'event': 'PWAHomeIconPrompt'
    });
    e.userChoice.then(function (res) {
      if (res.outcome === 'dismissed') {
        dataLayer.push({
          'pwaEventAction': 'PWAHomeIconCancelled',
          'pwaEventLabel': 'PWA Home Icon Cancelled',
          'event': 'PWAHomeIconCancelled'
        });
      } else if (res.outcome === 'default') {
            dataLayer.push({
                'pwaEventAction': 'PWAHomeIconDismissed',
                'pwaEventLabel': 'PWA Home Icon Dismissed',
                'event': 'PWAHomeIconDismissed'
            });
      } else {
            dataLayer.push({
                'pwaEventAction': 'PWAHomeIconAdded',
                'pwaEventLabel': 'PWA Home Icon Added',
                'event': 'PWAHomeIconAdded'
            });
      }
    });
  });
  if (document.cookie.indexOf("sessionStartMode=") === -1) {
    if (window.location.href.indexOf('pwa=1') > -1) {
        dataLayer.push({
            'pwaEventAction': 'PWAHomeSesionsStarted',
            'pwaEventLabel': 'PWA Home Sesions Started',
            'event': 'PWAHomeSesionsStarted'
        });

        document.cookie = "sessionStartMode=homeScreen;path=/"
    } else {
        document.cookie = "sessionStartMode=browser"
    }
  }
</script>
<meta name="theme-color" content="#000000">
<link rel="dns-prefetch" href="https://ocdn.eu" />
<link rel="dns-prefetch" href="https://fonts.gstatic.com" />
<link rel="dns-prefetch" href="https://google-analytics.com" />
<link rel="dns-prefetch" href="https://sgqcvfjvr.onet.pl" />
<link rel="dns-prefetch" href="https://onet.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://ls.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://csr.onet.pl" />
<link rel="dns-prefetch" href="https://kropka.onet.pl" />
<link rel="dns-prefetch" href="https://cmp.dreamlab.pl" />
<link rel="dns-prefetch" href="https://authorisation.grupaonet.pl" />
<link rel="dns-prefetch" href="https://pulsembed.eu" />
<link rel="dns-prefetch" href="https://etoto-platform.onet.pl" />
<link rel="dns-prefetch" href="https://mvp.onet.pl" />
<link rel="dns-prefetch" href="https://gapl.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://player-api.dreamlab.pl" />
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net" />
<link rel="dns-prefetch" href="https://csi.gstatic.com" />

<link rel="preconnect" href="https://ocdn.eu" />
<link rel="preconnect" href="https://fonts.gstatic.com" />
<link rel="preconnect" href="https://google-analytics.com" />
<link rel="preconnect" href="https://sgqcvfjvr.onet.pl" />
<link rel="preconnect" href="https://onet.hit.gemius.pl" />
<link rel="preconnect" href="https://ls.hit.gemius.pl" />
<link rel="preconnect" href="https://csr.onet.pl" />
<link rel="preconnect" href="https://kropka.onet.pl" />
<link rel="preconnect" href="https://cmp.dreamlab.pl" />
<link rel="preconnect" href="https://authorisation.grupaonet.pl" />
<link rel="preconnect" href="https://pulsembed.eu" />
<link rel="preconnect" href="https://etoto-platform.onet.pl" />
<link rel="preconnect" href="https://mvp.onet.pl" />
<link rel="preconnect" href="https://gapl.hit.gemius.pl" />
<link rel="preconnect" href="https://player-api.dreamlab.pl" />
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" />
<link rel="preconnect" href="https://csi.gstatic.com" />
<script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[],function(){var t=document.createElement("script");t.async=!0,t.type="text/javascript";var e="https:"==document.location.protocol;t.src=(e?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(t,o)}();</script>      <script>googletag.cmd.push(function () { var o = window.location.pathname.split("/"); switch (o[1]) { case "": o[1] = "home" }void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1)); var e = token.length; if (document.location.hostname == 'www.pulse.ng') { googletag.pubads().setTargeting('PulseNG_URL', [token]); } if (document.location.hostname == 'www.pulse.sn') { googletag.pubads().setTargeting('PulseSN_URL', [token]); } if (document.location.hostname == 'www.pulse.com.gh') { googletag.pubads().setTargeting('PulseGH_URL', [token]); } if (document.location.hostname == 'www.pulselive.co.ke') { googletag.pubads().setTargeting('PliveKE_URL', [token]); } if (document.location.hostname == 'africa.businessinsider.com') { googletag.pubads().setTargeting('PulseBI_URL', [token]); } console.log(token, e), googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices() });</script>
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "4.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d3lcz8vpax4lo2.cloudfront.net/ads-code/99b38bf6-07eb-44ab-a741-e822695d6401.js');/*]]>*/</script>
<script type='text/javascript'>             var googletag = googletag || {};             googletag.cmd = googletag.cmd || [];             (function () {                 var gads = document.createElement('script');             gads.async = true;             gads.type = 'text/javascript';             var useSSL = 'https:' == document.location.protocol;             gads.src = (useSSL ? 'https:' : 'http:') +                 '//www.googletagservices.com/tag/js/gpt.js';             var node = document.getElementsByTagName('script')[0];             node.parentNode.insertBefore(gads, node);         })();         </script>
<script type="text/javascript" src="//ocdn.eu/ucs/static/3a5ed13e35b52b66219d0dd4d1ebbde3/d112b4190e43ff6ba92fc6a5d2c199d2/build/scripts.js" async defer></script>
        <!-- special ads disbale check -->     
        
        <script>
            var liveblog_talos_lizard_cfg={'urls':["https://liveblog-push.dreamlab.pl/ws"],oob_url:false};
        </script>
    <script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
    <script> Sailthru.init({ "customerId": "e3bb91358ab42ece773022042c6cfd66", "iscustom": true, "autoTrackPageview": false, "useStoredTags": false });
        Sailthru.track('pageview', {
            url: "https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6",
            tags: "celebrities",
            onSuccess : function () { console.log('trackPageView success note'); },
            onError : function () { console.log('trackPageView failure note'); }
        }); </script>
        <script type="text/javascript" src="//ocdn.eu/ucs/static/3a5ed13e35b52b66219d0dd4d1ebbde3/d112b4190e43ff6ba92fc6a5d2c199d2/build/push.js"></script>
    </head>
        <div> 
            <!-- IO script tracking div  -->
    <body id="newDetail" class="desktop scheme_red content-type-Article">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->

        


        <div class="onet-ad" id="onet-ad-flat-belkagorna"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
        
<header id="pageHeader" class="pageWrapper">
    <div class="container customSize">
        <div class="pageHeaderLogo">
            <h1><a href="//www.pulselive.co.ke"> <img class="serviceLogo switch" alt="Pulse Live Kenya" src="https://radp.ocdn.eu/logotypes/logo_desktop_kenya_new_v1.svg"> </a></h1>
        </div> 
        <nav class="siteNavigation">
            <div id="tabMenu" class="transition">
                <div id="siteNavigation" class="siteNavigation"  >
                    <div class="row">
                        <div  class="firstLevel row " data-run-module="local/main.menu">
                            <ul class="mainMenu col-xs-12 verticals">
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/news">News</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Local"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/news/local">
                                                Local
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-World"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/news/world">
                                                World
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/entertainment">Entertainment</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Celebs"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/entertainment/celebrities">
                                                Celebs
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Music"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/entertainment/music">
                                                Music
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Games"
                                            data-dropdown-uuid=""  data-dropdown-index="3" href="/entertainment/games">
                                                Games
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/lifestyle">Lifestyle</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Fashion"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/lifestyle/fashion">
                                                Fashion
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Beauty-&amp;-Health"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/lifestyle/beauty-health">
                                                Beauty &amp; Health
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Relationships-&amp;-Weddings"
                                            data-dropdown-uuid=""  data-dropdown-index="3" href="/lifestyle/relationships-and-weddings">
                                                Relationships &amp; Weddings
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Food,-Travel,-Arts-&amp;-Culture"
                                            data-dropdown-uuid=""  data-dropdown-index="4" href="/lifestyle/food-travel">
                                                Food, Travel, Arts &amp; Culture
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/sports">Sports</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li >
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Football"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/sports/football">
                                                Football
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/business">Business </a>
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/quizzes">Quizzes</a>
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/classifieds">Classifieds</a>
                                    
                                </li>
                                
                                
                                
                                
                            </ul>       
                        </div>
                    </div>
                </div>
            </div>
            
        </nav>
        <div class="searchBar switch">
                <ul class="profileList">
                    
                    <li class="facebook">
                        <a href="https://www.facebook.com/pulselivekenya" title="Follow us on Facebook" target="_blank">Facebook</a>
                    </li>  
                    
                    
                    <li class="twitter">
                        <a href="https://twitter.com/pulselivekenya" title="Follow us on Twitterze" target="_blank">Twitter</a>
                    </li>  
                    
                    
                    <li class="instagram">
                        <a href="https://www.instagram.com/pulselivekenya/" title="Follow us on Instagram" target="_blank">Instagram</a>
                    </li>  
                    
                    
                    <li class="youtube">
                        <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="Watch us on YouTube" target="_blank">YouTube</a>
                    </li>  
                    
                    
                </ul>
                <div class="search-container menu-button search" data-search-container="">
                    <div class="svg icon-search"></div>
                </div>
        </div>
        
    </div>
    <div class="searchDiv">
        <form id="searchForm" class="searchForm closed" method="get" action="/search">
            <input id="searchInput" type="text" class="searchQueryInput switch" placeholder="Search" x-webkit-speech="" autocomplete="off" id="searchQuery" name="q">
        </form>  
    </div>
    <div class="menuBg"></div>
</header><!-- header -->
        


        


        <div class="onet-ad" id="onet-ad-top"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
        
        <section class="pageAligment">
            <div id="doc" data-run-module="local/main.LazyLoadIS"  data-preload="true">
                 <!-- channelConfig -->
                


<!-- specialBanner -->
                
                <div class="pageContent pageWrapper container customSize" >
                    
                    <div class="row">
                        
                        <div class="col-xs containerCustom">
                            <div class="leftColWrapper">                              
                                
                                    
                                        
  <div class="onet-ad" id="onet-ad-flat-boxday5" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("flat-boxday5");
            onetAds.show("flat-boxday5");
        </script>
    </div>
<!-- widgetAboveArticle0 -->
                                    
                                        
  <div class="onet-ad" id="onet-ad-top" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("top");
            onetAds.show("top");
        </script>
    </div>
<!-- widgetAboveArticle1 -->
                                    
                                        <!-- widgetAboveArticle2 -->
                                    
                                        <!-- widgetAboveArticle3 -->
                                    
                                        <!-- widgetAboveArticle4 -->
                                    
                                        <!-- widgetAboveArticle5 -->
                                    
                                        <!-- widgetAboveArticle6 -->
                                    
                                        <!-- widgetAboveArticle7 -->
                                    
                                        <!-- widgetAboveArticle8 -->
                                    
                                
                                <article class="articleDetail">
                                    

    <ol class="breadcrumbs">
        
            
        
            
                <li><a class="breadcrumbItem mainCategory" href="https://www.pulselive.co.ke/entertainment">Entertainment</a></li>
            
        
            
                <li><a class="breadcrumbItem subCategory" href="https://www.pulselive.co.ke/entertainment/celebrities">Celebrities</a></li>
            
        
    </ol>
 <!--breadcrumbs-->
                                    <!-- reportHeader -->
                                    
                                    
                                        <header class="atricleTop">
                                            <h1 class="mainTitle">
    
        Death never prepares you- Kate Actress as she mourns Brother-in-law
    
</h1> <!-- title -->
                                            


    <div class="articleHeading">

        
        
        
        
        
        
        
        
            
                
                <div class="authDesc authDesc1">
                    
                        <a href="https://www.pulselive.co.ke/author/dennis-milimo" >
                    
                        <span class="name" itemprop="name">Dennis Milimo</span>
                    
                        </a>
                    
                </div>
            
        

        <time class="datePublished">
            
            
            
            
                
                    Today at 8:31 AM
                
            
        </time>
        
        

        <div class="sourceCopytight">
            
            
        </div>
        
    </div>
    
 <!-- sourc -->
                                             
    <div class="socialShare socialShareTop">
        <span class="shareTop">Tell your friends</span>
        <a data-run-module="local/main.socialShare_facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook" data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button"></a>
        <a data-run-module="local/main.socialShare_twitter" href="javascript:void(0);" data-gtm-social="twitter" class="shareIcon ring-icon-twitter" title="Twitter" data-socialname="pulselivekenya" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button"></a>
        <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" data-gtm-social="email" class="shareIcon ring-icon-email" title="Email"></a>
    </div>

                                        </header>
                                    
                                    
                                    <!-- teaserVideo -->

                                    
                                        
                                            <div id="teadsTv" data-run-module="local/main.scriptsLazyLoad" data-type="teadsTv" data-href="//a.teads.tv/page/87018/tag"></div>
                                        
                                    
                                    <div data-io-article-url="https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6" class="whitelistPremium">
                                        
                                            



    
        <strong id="lead" class="hyphenate lead">
            
                Still trying to comprehend that you are not here anymore- Kate Actress <br/>
            
        </strong>
    
<!-- lead -->
                                            
 
    
    
    

    
        
            
            <figure class="mainPhoto" id="mainPhoto">

                
                    
                    

                     
                        <picture class="loaderBlock" >
                            <div class="preLoader">
                                <div class="loadBlock"></div>
                            </div>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/uM8k9kpTURBXy9hYmVlMDRhYWZlMGM2MTM1YjY2ZjA2MTdlZDdjNmJmOC5qcGeRkwXNAxTNAbyBoTAF" type="image/webp">
                            <img itemprop="url" data-original="//ocdn.eu/pulscms-transforms/1/O5sk9kpTURBXy9hYmVlMDRhYWZlMGM2MTM1YjY2ZjA2MTdlZDdjNmJmOC5qcGeRkwXNAxTNAbyBoTAB"  alt="Actress Catherine Kamau aka Kate Actress "  />
                        </picture>
                    
                  

                
                    
                    
                        <figcaption class="caption hide">
                            <span class="imageDescription">Actress Catherine Kamau aka Kate Actress </span>
                            
                            
                            

                        </figcaption>
                    
                

                


                    
                
            </figure>
        
    
<!-- teaser -->
                                            <div class="detailContentWrapper">
                                        
                                        
                                                
                                            <div class="detailContent">
                                                 
                                                

<div class="recommendedArticles" id="recommendedArticle">
    <strong class="hyphenate lead">RECOMMENDED ARTICLES</strong>
    <ul class="recUl">
        
        
        

        <li>
            <picture class="photo">
                <source data-original="//ocdn.eu/pulscms-transforms/1/6Mbk9kpTURBXy9iYzg3YzFmMGRlNjEyNTM4MTEwNjZjYjdjYWI4MjQxOC5wbmeTlQMAAM0JmM0MkJUCAGTDw5MFZGSBoTAF"
                        type="image/webp">
                <img data-original="//ocdn.eu/pulscms-transforms/1/M02ktkpTURBXy9iYzg3YzFmMGRlNjEyNTM4MTEwNjZjYjdjYWI4MjQxOC5wbmeTlQMAAM0JmM0MkJUCAGTDw5MFZGQ"
                     src="data:image/jpeg;base64,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"
                     alt="Another high school student arrested after attempting to hack deputy principal with a panga"/>
            </picture>
                <a href="//www.pulselive.co.ke/news">
                    <p class="recCategory">news  </p>
                </a>

            <p><a class="link"  data-uuid-ui="c9bc9a9e-3063-4a10-bf06-73c7cbfd1924" data-ei="59poypesnd" href="https://www.pulselive.co.ke/news/local/form-2-student-at-mokwerero-secondary-school-arrested-after-attempting-to-hack/t0fj43r">Another high school student arrested after attempting to hack deputy principal with a panga</a></p>
        </li>
        
        
        

        <li>
            <picture class="photo">
                <source data-original="//ocdn.eu/pulscms-transforms/1/1u7k9kuTURBXy82ZjEyMDA1Mi0zMTRjLTRjYzQtYTBmZi00MzFjYTZjM2JlODcuanBlZ5OVAwAAzQmYzQyQlQIAZMPDkwVkZIGhMAU"
                        type="image/webp">
                <img data-original="//ocdn.eu/pulscms-transforms/1/sauktkuTURBXy82ZjEyMDA1Mi0zMTRjLTRjYzQtYTBmZi00MzFjYTZjM2JlODcuanBlZ5OVAwAAzQmYzQyQlQIAZMPDkwVkZA"
                     src="data:image/jpeg;base64,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"
                     alt="Bitcoin: The Cryptocurrency That&#39;s Changing the World"/>
            </picture>
                <a href="//www.pulselive.co.ke/news">
                    <p class="recCategory">news  </p>
                </a>

            <p><a class="link"  data-uuid-ui="ba9547d5-6536-4913-bb58-e519dd01e1aa" data-ei="59poypesnd" href="https://www.pulselive.co.ke/business/bitcoin-the-cryptocurrency-thats-changing-the-world/15vs6dp">Bitcoin: The Cryptocurrency That&#39;s Changing the World</a></p>
        </li>
        
        
        

        <li>
            <picture class="photo">
                <source data-original="//ocdn.eu/pulscms-transforms/1/QYhk9kuTURBXy85Yzc2YTlhZi05MzFmLTRkZmItOTMxOS04NWJhZTVmYmFlN2IuanBlZ5OVAwAAzQmYzQyQlQIAZMPDkwVkZIGhMAU"
                        type="image/webp">
                <img data-original="//ocdn.eu/pulscms-transforms/1/uE3ktkuTURBXy85Yzc2YTlhZi05MzFmLTRkZmItOTMxOS04NWJhZTVmYmFlN2IuanBlZ5OVAwAAzQmYzQyQlQIAZMPDkwVkZA"
                     src="data:image/jpeg;base64,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"
                     alt="Premier League clubs warned by EPL chief over Covid protocols"/>
            </picture>
                <a href="//www.pulselive.co.ke/sports">
                    <p class="recCategory">sports  </p>
                </a>

            <p><a class="link"  data-uuid-ui="8f26f3cd-dff5-4444-a742-dec1597b05e9" data-ei="59poypesnd" href="https://www.pulselive.co.ke/sports/football/premier-league-clubs-warned-by-epl-chief-over-covid-protocols/xv1d945">Premier League clubs warned by EPL chief over Covid protocols</a></p>
        </li>
        
    </ul>
</div>
<!-- inRead -->
                                                
                                                





    



    






    <script type="text/javascript">/* <![CDATA[ */

      if (!adsNoBanner)
        onetAds.adSlots.push('flat-intext');
    /* ]]> */</script>




<div id="detail" class="detail intext articleBody" itemprop="articleBody" data-run-module="local/main.slotBetweenParagraphs">



     
        

        
        

        
            
                

                

                    

                    
                    

                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">Actress <a href="https://www.pulselive.co.ke/entertainment/celebrities/kate-actress-wins-the-prestigious-youtube-award-sliver-plaque-photo/9jjqmd5" id="2b0edd68-466f-40b5-8a92-a71f8305d5b8">Catherine Kamau aka Kate Actress </a>is mourning the sudden demise of her brother-in-law identified as Brian Safari.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">A heartbroken Kate, shared the sad news via her Instagram, stating that her sister had lost her best friend, noting that indeed death never prepares anyone. She went ahead to ask her over 1.6 million followers to pray for her family.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><em> "My niece lost her daddy 💔..my sister her bestest friend .Damn!! Death never prepares you .Brian ,I have so much respect for you , you loved your daughter so much , she was your world , my sister, nyambu is lost. </em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><em>Still trying to comprehend that you are not here anymore, mum has lost her son , your family is devastated brian , you left so soon . This hurts 💔💔💔, WE LOVED YOU BABA BUNBUN (SAMARA).REST IN PEACE BRIAN SAFARI. Remember us in your prayers fam 🙏” </em>reads Kate Actress Announcement.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



        
      


            <div class="onet-ad"  data-opt-pos="5"    id="left5" data-slot="left"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #left5::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
    
    
    


 

    
        
    
        <a name="image_2dfcfd63-fa67-4f5e-87f8-5c563e1e4f9b" style="position:relative; top:-100px; display: block"></a>
    
    
    <div class="image" data-item-uuid="4f41844d-1b74-4851-8925-25f253ec7321">
    	<div class="imageCaptionWrapper">
        <div class="imageWrapper"
             
             
                data-uuid-photo="2dfcfd63-fa67-4f5e-87f8-5c563e1e4f9b"
             
             
             >
            
            
            
                
            
                
                

                 
                    <picture class="loaderBlock" >
                        <div class="preLoader">
                            <div class="loadBlock"></div>
                        </div>
                        <source data-original="//ocdn.eu/pulscms-transforms/1/vcQk9kpTURBXy83NTYyZjgwMDg4NzYwNjhmZWFhZmIyZDlkYzE1ZGFhNi5qcGeSlQLNAxQAwsOVAgDNAvjCw4GhMAU" type="image/webp">
                        <img data-original="//ocdn.eu/pulscms-transforms/1/8F6k9kpTURBXy83NTYyZjgwMDg4NzYwNjhmZWFhZmIyZDlkYzE1ZGFhNi5qcGeSlQLNAxQAwsOVAgDNAvjCw4GhMAE" src="" alt="Kate Actress&#39;s  Brother in-law and family "  />
                    </picture>
                
              
                
                    <figcaption itemprop="caption" class="caption  hide " style="max-width: 788px;">
                        <span>
                            Kate Actress&#39;s  Brother in-law and family  
                        </span>
                    </figcaption>
				
                
                
                	
                	
                                   
                
                
                
	            
                                  
				


			
        </div>			
        </div>
    </div>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate ">Following the revelation, fans and celebrities took to the comment section to condole with the actress and her family.</p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><strong>Also Read: </strong><a href="https://www.pulselive.co.ke/entertainment/celebrities/kate-actress-wins-the-prestigious-youtube-award-sliver-plaque-photo/9jjqmd5" id="d827dbc5-4b54-4bdc-8dda-9ebb243b8dbb"><strong>Kate Actress wins the Prestigious YouTube Award (Photo)</strong></a></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><strong>Condolences messages</strong></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/millychebby/" id="75605b08-c20f-40c1-9fa6-e474cb88245f">millychebby</a> <em>“I am soooo sorry for your loss hun may God give your family peace that surpuses human understanding?”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/jmatubia/" id="fe84267f-1f9d-4e2c-9d15-bce8b7449390"> jmatubia</a> <em>“Pole sana to you and your family 🙏🙏🙏”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/abelmutua/" id="66c8a24f-ea2b-4e44-b3b9-938e4f9694eb"> abelmutua</a> <em>“So sad Yaani. Devastating. May you find solace”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    
        <a name="image_8c7ee7a8-84f7-4e69-9af1-fcc245c8a05c" style="position:relative; top:-100px; display: block"></a>
    
    
    <div class="image" data-item-uuid="6b45a978-7a4e-48a7-b4a1-e32ef0284f06">
    	<div class="imageCaptionWrapper">
        <div class="imageWrapper"
             
             
                data-uuid-photo="8c7ee7a8-84f7-4e69-9af1-fcc245c8a05c"
             
             
             >
            
            
            
                
            
                
                

                 
                    <picture class="loaderBlock" >
                        <div class="preLoader">
                            <div class="loadBlock"></div>
                        </div>
                        <source data-original="//ocdn.eu/pulscms-transforms/1/UzSk9kpTURBXy9mZjRiZjg3M2RkY2UwMTAxMTY2MWFkMzNkNDYxYjkzYi5qcGeSlQLNAxQAwsOVAgDNAvjCw4GhMAU" type="image/webp">
                        <img data-original="//ocdn.eu/pulscms-transforms/1/0FXk9kpTURBXy9mZjRiZjg3M2RkY2UwMTAxMTY2MWFkMzNkNDYxYjkzYi5qcGeSlQLNAxQAwsOVAgDNAvjCw4GhMAE" src="" alt="The late Brian Safari "  />
                    </picture>
                
              
                
                    <figcaption itemprop="caption" class="caption  hide " style="max-width: 788px;">
                        <span>
                            The late Brian Safari  
                        </span>
                    </figcaption>
				
                
                
                	
                	
                                   
                
                
                
	            
                                  
				


			
        </div>			
        </div>
    </div>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/alicekamande/" id="ef1d2fd3-b335-40a1-96ec-b510bda2e9db"> alicekamande</a> “<em>Pole sana as a family. May the Lord comfort you🙏”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/millywajesus/" id="487d9158-f170-4dfd-b6f6-c1655b11725b"> millywajesus</a> <em>“So sorry for your loss.😭”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/phoinahaircollection/" id="254b084c-3c92-4506-9f3b-6438a13b9d05">phoinahaircollection</a> <em>“Poleni sana babe”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    
      


            <div class="onet-ad"  data-opt-pos="16"    id="left16" data-slot="left"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #left16::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/terryannechebet/" id="3b692e98-945f-454c-8aaf-7cd721887858"> terryannechebet</a> <em>“Poleni sana to your sister and family. 🙏🏽🙏🏽🙏🏽🙏🏽”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <div class="embeddedApp">
    <div
        data-run-module="embeddedapp/main.app"
        data-type="desktop"
        data-params="{&quot;caption&quot;:&quot;www.instagram.com&quot;,&quot;publicationId&quot;:{&quot;type&quot;:&quot;pulsembed&quot;,&quot;pulsembed&quot;:{&quot;id&quot;:&quot;aSCQ3p-2_&quot;,&quot;client&quot;:&quot;78d48ba2-1292-4bd1-8ee8-270575d5c1d8&quot;}},&quot;parameters&quot;:{&quot;url&quot;:&quot;https://www.instagram.com/p/CJ6T1Uarhjn/&quot;,&quot;provider&quot;:&quot;Instagram&quot;,&quot;thumb_url&quot;:&quot;https://www.instagram.com/p/CJ6T1Uarhjn/media?size=t&quot;,&quot;embedCode&quot;:&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/aSCQ3p-2_/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;kate_actress\&quot; data-embed-id=\&quot;aSCQ3p-2_\&quot; data-provider-name=\&quot;Instagram\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://www.instagram.com/p/CJ6T1Uarhjn/\&quot; target=\&quot;_blank\&quot;&gt;www.instagram.com&lt;/a&gt;&lt;/div&gt;\n&quot;},&quot;platform&quot;:{&quot;code&quot;:&quot;pulsembed&quot;},&quot;alignment&quot;:&quot;center&quot;}"
        style="display:inline-block"
        ></div>
    </div>
    


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/muthonidrummerqueen/" id="1dcbe629-fd0a-421e-a759-16381d55c3be"> muthonidrummerqueen</a> <em>“Sending you and your whole family comfort”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/christinewawira/" id="3ca76d13-fd33-4acb-8f57-229cdd014af6">christinewawira</a> <em>“So sorry for this loss ♥️🙏🏾 keeping you all in prayer”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/nanaowiti/" id="ba2a4900-de5b-4a7e-9cee-61f222f5bbe4"> nanaowiti</a> <em>“I’m so sorry for your loss </em><a href="https://www.instagram.com/kate_actress/" id="4a5d252a-393e-4331-acc3-685631bba64b"><em>@kate_actress</em></a><em> . May God comfort you and the whole family”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/nickmutuma/" id="6fe6bb44-8780-48db-a47d-38583dfaacf9"> nickmutuma</a> “<em>Sincerest condolences to you and your family mama k ❤️”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/officialjanetmbugua/" id="8a3c15a4-8c98-44fc-9677-b849cd068f18">officialjanetmbugua</a> <em>“So sorry 💔🙏🏾”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/sheilamwanyigha/" id="990e632e-cdc3-461d-9c0b-fbf0e73b7246">sheilamwanyigha</a> <em>“Pole sana for this terrible loss. 🙏🏽🙏🏽🙏🏽”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    
      


            <div class="onet-ad"  data-opt-pos="24"    id="left24" data-slot="left"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #left24::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/wanjiru_mbugua/" id="893fa8dd-b632-4a72-b72c-143b49167dd4"> wanjiru_mbugua</a><em> “So sorry for your loss dear. Blessed are those who mourn. For they shall be comforted. Have Peace Sis🙏”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/captainotoyo/" id="666b5880-f8a2-46df-b151-40cd7d7d6b62"> captainotoyo</a> “<em>My sincere Condolences </em><a href="https://www.instagram.com/kate_actress/" id="550ad1cf-00a2-41ea-b959-d60d2186c831"><em>@kate_actress</em></a><em> Mwenyezi Mungu awape nguvu na uwezo  him we shall all return to)”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/celestinegachuhi/" id="32dd24b6-c676-4f9d-8400-c973252f07cc"> celestinegachuhi</a> <em>“😰, my sincere condolences to you and your family 🙏🙏🙏 it is well”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/lizzntonjira/" id="72806279-210c-4d3c-83a6-8ab4a67c6d68">lizzntonjira</a> <em>“Sending you hugs ....poleni sana ❤️❤️”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/wa_thaish/" id="8f6c4ae0-3a19-4c49-8639-8f380732c8f8"> wa_thaish</a> “<em>😥😥😥..Praying for strength upon the whole family”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "> <a href="https://www.instagram.com/mi.s.s_hurricane/" id="5a8592d1-8717-4f61-8fd9-e37b82221bcf">mi.s.s_hurricane</a> “<em>RIP take heart ♥️♥️ may he rest with the angels”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <p class="hyphenate "><a href="https://www.instagram.com/judykilonzo/" id="f32e69d7-e427-4716-b815-1ec86af45be0"> judykilonzo</a> <em>“🙏🏾May the Lord comfort and strengthen the family in Jesus name”</em></p>


    



<!-- block end -->
                        
                    
                    

                

                    

                    
                    

                      
                        
                            <!-- block open -->



    
    
    


 

    
        
    <div class="embeddedApp">
    <div
        data-run-module="embeddedapp/main.app"
        data-type="desktop"
        data-params="{&quot;caption&quot;:&quot;www.instagram.com&quot;,&quot;publicationId&quot;:{&quot;type&quot;:&quot;pulsembed&quot;,&quot;pulsembed&quot;:{&quot;id&quot;:&quot;XU1lE9DtK&quot;,&quot;client&quot;:&quot;78d48ba2-1292-4bd1-8ee8-270575d5c1d8&quot;}},&quot;parameters&quot;:{&quot;url&quot;:&quot;https://www.instagram.com/p/CJ6Vx2prkWG/&quot;,&quot;provider&quot;:&quot;Instagram&quot;,&quot;thumb_url&quot;:&quot;https://www.instagram.com/p/CJ6Vx2prkWG/media?size=t&quot;,&quot;embedCode&quot;:&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/XU1lE9DtK/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;kate_actress\&quot; data-embed-id=\&quot;XU1lE9DtK\&quot; data-provider-name=\&quot;Instagram\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://www.instagram.com/p/CJ6Vx2prkWG/\&quot; target=\&quot;_blank\&quot;&gt;www.instagram.com&lt;/a&gt;&lt;/div&gt;\n&quot;},&quot;platform&quot;:{&quot;code&quot;:&quot;pulsembed&quot;},&quot;alignment&quot;:&quot;center&quot;}"
        style="display:inline-block"
        ></div>
    </div>
    


    



<!-- block end -->
                        
                    
                    

                

                

            
        

    

    <!-- sonda -->
    
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
    

</div><!-- detail -->
                                                <!-- detail -->
                                                <!-- liveblog -->
                                                
                                                <div class="afterDetailModules">
                                                    
                                                </div>
        
                                                <!-- detail -->
                                                 <!-- added moxTv id diff for desktop -->
                                                
                                                










<div id="articleFooterAuthorSource" class="articleFooter">

        <div class="authorsSources">
            
            
                                
            

            
                
                                
                    
                            <span class="sourcesLabel">
                                
                                    Source:
                                
                            </span>

                        <span>
                            <span>
                                
                                    
                                        <span itemprop="name">Pulse Live Kenya</span>
                                    
                                
                            </span>
                        </span>

                    

                
            

            
            <span class="authorsClear"></span>
        </div>
	
</div>

    
<!-- detailFooter -->

                                                
<div id="relatedTopics" class="relatedTopics tagList">
    
        <span class="relatedTopic tags">
            <a href="/brian-safari" title="Brian Safari">
                #BRIAN SAFARI                 
            </a>
        </span>
    
        <span class="relatedTopic tags">
            <a href="/kate-actress" title="Kate Actress">
                #KATE ACTRESS                 
            </a>
        </span>
    
        <span class="relatedTopic tags">
            <a href="/catherine-kamau" title="Catherine Kamau">
                #CATHERINE KAMAU             
            </a>
        </span>
    
</div>

<!-- tags -->
                                                
    
    
    

    
       
        
        
        
            <div class="authorSourceProfile authorProfile">
                

                    

                        

                        
                            <div class="photoWrapper">
                                <picture class="photo">
                                    <source data-original="//ocdn.eu/pulscms-transforms/1/sKHk9kpTURBXy83ZDFmYzAyNWZlNjRiNTk4N2FjNzU1NzMxMzQ3NWQ1Yi5qcGeTlQPMyc0CvM0OHs0L-JUCAGTDw5MFZGSBoTAF" type="image/webp">
                                    <img data-original="//ocdn.eu/pulscms-transforms/1/8MQktkpTURBXy83ZDFmYzAyNWZlNjRiNTk4N2FjNzU1NzMxMzQ3NWQ1Yi5qcGeTlQPMyc0CvM0OHs0L-JUCAGTDw5MFZGQ" src="data:image/jpeg;base64,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" alt="Dennis Milimo"/>
                                </picture>
                            </div>
                        
                    
                

                <header>
                    
                            <a data-gtm="author-profile" href="https://www.pulselive.co.ke/author/dennis-milimo" >
                                <span class="name" itemprop="name">Dennis Milimo</span>
                    </a>
                    
                            <a class="moreAbout" data-gtm="author-profile" href="https://www.pulselive.co.ke/author/dennis-milimo" >More from the author <span>»</span></a>
                </header>

                
                
                <div class="clear"></div>
            </div>

        
        
        
    
<!-- authorProfile-->
                                                <style amp-custom>
    #link-ad::before {
    content: "AD";
    font-size: .6em;
    text-align: center;
    display: block;
    color: #bfbbbb7d;
}
</style>
<br>
    <div id="link-ad">
        <div style="background: #eee;">
            <a href="https://bit.ly/2T7UGMY"
                style="margin: 10px; display: inline-block; font-weight: bold; color:#000; " target="_blank">
                &gt;&gt; Make some extra cash, sell on Pigiame for free
            </a>
        </div>
    </div>

                                                
                                                    <div class="socialShare socialShareBottom">
    <span class="shareTop">Tell your friends</span>
    <a data-run-module="local/main.socialShare_facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook" data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button"></a>
    <a data-run-module="local/main.socialShare_twitter" href="javascript:void(0);" data-gtm-social="twitter" class="shareIcon ring-icon-twitter" title="Twitter" data-socialname="pulselivekenya" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button"></a>
    <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" data-gtm-social="email" class="shareIcon ring-icon-email"></a>
    <a href="whatsapp://send?text=https%3A%2F%2Fwww.pulselive.co.ke%2Fentertainment%2Fcelebrities%2Fdeath-never-prepares-you-kate-actress-and-her-family-in-mourning%2Ffqvnwm6?utm_medium%3Dsocial%26utm_source%3Dwhatsapp%26utm_campaign%3Dshare-button" data-action="share/whatsapp/share" data-gtm-social="whatsapp" class="shareIcon ring-icon-whatsapp"></a>
    <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.pulselive.co.ke/entertainment/celebrities/death-never-prepares-you-kate-actress-and-her-family-in-mourning/fqvnwm6?utm_medium%3Dsocial%26utm_source%3Dlinkedin%26utm_campaign%3Dshare-button" target="_blank" data-gtm-social="linkedin" class="shareIcon ring-icon-linkedin" title="LinkedIn"></a>
</div><!-- contentShareBottom -->
                                                
                                            </div>
                                            
                                            <div id="widgetStop"></div>
                                        </div>
                                    </div>
                                        
                                    
    
    
        
    
<!-- relatedMaterials -->
                                    <!-- sherlock -->

                                    <!-- seeAlsoLinks -->

                                    
<!-- filesAttachments -->

                                    <!-- tableofcontent -->
                                    <!-- pagination -->

                                    

                                        


            <div class="onet-ad"    id="leadbanner-bottom" data-slot="flat-leadbanner"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #leadbanner-bottom::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>

                                        <div id="googleAdsCont">
                                            


        <div class="onet-ad" id="onet-ad-rectangle1"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                            


        <div class="onet-ad" id="onet-ad-rectangle3"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                        </div>
                                        <div class="onet-ad" id="onet-ad-flat-nin"></div>

                                        


        <div class="onet-ad" id="onet-ad-flat-plista"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                    

                                    <!-- editorsList -->
                                    <!-- stream -->
                                    
                                        <div id="taboolaStartHook" data-run-module="local/main.scriptsLazyLoad" data-type="taboola" data-href="//cdn.taboola.com/libtrc/ringierkenya-network/loader.js"></div>
                                    
                                    
                                        
                                    
                                    
                                    


        <div class="onet-ad" id="onet-ad-flat-widget"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>

                                      <!-- disbale block column  -->
                                        
                                         <!-- Load the newsletter here only under article -->
                                            <div id="newsletterLoader" data-run-module="local/main.subscribeNewsletter"  data-source="newsletterWidget" data-config="{&quot;keyField&quot;:&quot;pulselive.co.ke&quot;,&quot;listIdField&quot;:&quot;4&quot;,&quot;publicationNameField&quot;:&quot;pulselive.co.ke&quot;,&quot;slangField&quot;:&quot;Kua rada&quot;,&quot;nlTitleField&quot;:&quot;Join the&quot;,&quot;nlDescField&quot;:&quot;clique&quot;,&quot;nlDescEndField&quot;:&quot;Don&#39;t miss a thing, get the latest updates to fuel your conversation daily&quot;,&quot;nlSuccessField&quot;:&quot;Thank you for subscribing to our newsletter!&quot;,&quot;nlSuccessEndField&quot;:&quot;&quot;,&quot;nlPrivacyText1&quot;:&quot;By clicking again, you agree to our &quot;,&quot;nlPrivacyText2&quot;:&quot;privacy policy&quot;,&quot;nlPrivacyText3&quot;:&quot;and European users agree to our data transfer policy.&quot;,&quot;apiUrlField&quot;:&quot;https://nl.pulse.com.gh/&quot;,&quot;privacyUrlField&quot;:&quot;https://www.pulselive.co.ke/info/terms-and-conditions-pulselivecoke/d1z0r3q&quot;,&quot;classField&quot;:&quot;&quot;}">
                                            </div>
                                            
                                                
  <div class="onet-ad" id="onet-ad-rectangle3" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("rectangle3");
            onetAds.show("rectangle3");
        </script>
    </div>
<!-- widgetRight0 -->
                                            
                                                
<section class="newsletterSignup_wdg">
    <div class="topMain LazyLoadBG red" data-bg="">
        <div class="row" id="signUpContainer">
            <div class="col-sm-6" style="margin-top: auto;margin-bottom: auto;">
                <div id="intro">
                   
                    
                    <p class="topSlang">Join the  <span class="quote">
                            "kua rada" </span>&nbsp; clique</p>
                    <span id="subTitle"> Don&#39;t miss a thing, get the latest updates to fuel your conversation daily </span>
                    
                </div>
                <div id="termsConditions" class="hide">
                    <br><br>
                    <p>By clicking again you agree to our  <a class="color" target="_blank"
                            href="https://www.pulse.com.gh/info/privacy-policy-how-we-respect-your-privacy-or-pulsecomgh/3qxd7kj">
                            privacy policy </a>  and European users agree to data transfer policy
                    </p>
                </div>
            </div>
            <div class="col-sm-6" style="margin-top: auto;margin-bottom: auto;">

                <form method="POST" class="inputForm" action="/newsletter">
                    
                    <button name="sendUpdates" id="sendUpdates"
                        class="">
                        SEND ME UPDATES
                    </button>
                </form>

            </div>
        </div>

        <div class="row hide" id="thanksContainer">
            Thank you! You have successfully subscribed to receive the Pulselive  newsletter pulselive.co.ke
            
        </div>
    </div>
    <br>
    <script type="text/javascript">
        function getEmail() {
            // Selecting the input element and get its value 
            var inputVal = document.getElementById("email").value;

            Sailthru.integration("userSignUp", {
                "email": '"' + inputVal + '"',
                "lists": {},
                "vars": {},
            });
        }

    </script>

    <script type="text/javascript">
        function sendMeUpdates(event) {
            return false;
        }


        function sendPrivacyEmail(event) {
            return false;
        }
    </script>

</section>
<!-- widgetRight1 -->
                                            
                                                <div class="socialButtonsWdg">

<a href="https://www.facebook.com/pulselivekenya/?ref=br_rs" rel="nofollow" target="_blank" class="facebook">LIKE PULSE KENYA</a>


<a href="https://www.instagram.com/pulselivekenya/" rel="nofollow" target="_blank" class="instagram">FOLLOW PULSE KENYA</a>

</div><!-- widgetRight2 -->
                                            
                                                
    <div class="eyewitnessWdg">    <p>Eyewitness? Submit your stories now via social or: </p>    <p><a href="news@pulselive.co.ke">news@pulselive.co.ke</a></b></p></div>
<!-- widgetRight3 -->
                                            
                                                


<section id="recommended-articles">
<div class="col-xs-12 wdgWrapper">
<div
    class="wdg threeColumn wdgStandard"
     >

    
    <div class="widgetsHeader">
        
            
        
        <h1 class="title">
            
            <span class="titleTxt">Recommended Articles</span>
            <span class="titleUnderlined">&nbsp;</span>
        </h1>
    </div>
    
    
    
    <div class="wdgItems">
        <div class="row">
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/former-ntv-presenter-faith-muturi-and-hubby-george-ngugi-welcome-a-bouncing-baby-boy/2d0e19f">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/hk3k9kpTURBXy8xZjc5OWVlNjY3YjgxYWZhYTg2NjZhNDIzNzc4MjQ3NS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Former NTV Presenter Faith Muturi &amp; hubby welcome a bouncing Baby Boy"  data-original="//ocdn.eu/pulscms-transforms/1/Qv4k9kpTURBXy8xZjc5OWVlNjY3YjgxYWZhYTg2NjZhNDIzNzc4MjQ3NS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Former NTV Presenter Faith Muturi &amp; hubby welcome a bouncing Baby Boy
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/23/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/theres-no-me-without-you-diana-marua-as-she-pours-out-her-heart-to-bahati/h4hlkrh">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/puYk9kpTURBXy82ZjAxYjgwYjY4ZmE1NTJmYmY3NmIwMTE3NTg1MTU5Yy5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Diana Marua’s confession to hubby Bahati as he turns 28"  data-original="//ocdn.eu/pulscms-transforms/1/6ORk9kpTURBXy82ZjAxYjgwYjY4ZmE1NTJmYmY3NmIwMTE3NTg1MTU5Yy5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Diana Marua’s confession to hubby Bahati as he turns 28
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/23/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/kenyans-not-happy-with-sauti-sol-as-new-details-emerge-on-why-they-cancelled-their/cy4jhd3">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/1xmk9kpTURBXy9iYzlkMTI3ZTM4YTI0ZTNkOGJiYjkxZWI0YTE3N2RmYi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Kenyans turn the heat on Sauti Sol as new details emerge on why they cancelled their show (Video)"  data-original="//ocdn.eu/pulscms-transforms/1/gcEk9kpTURBXy9iYzlkMTI3ZTM4YTI0ZTNkOGJiYjkxZWI0YTE3N2RmYi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Kenyans turn the heat on Sauti Sol as new details emerge on why they cancelled their show (Video)
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/23/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/band-becas-carol-wins-the-eric-omondis-wife-material-show/w55lnbr">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/E_Gk9kpTURBXy82Zjk0NzVmMTlhNmM3OTBhNmU5YWZkNTZlZTg2ZTkyNC5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Kenyans Choose a wife for Eric Omondi as his Wife Material show comes to an End"  data-original="//ocdn.eu/pulscms-transforms/1/LBvk9kpTURBXy82Zjk0NzVmMTlhNmM3OTBhNmU5YWZkNTZlZTg2ZTkyNC5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Kenyans Choose a wife for Eric Omondi as his Wife Material show comes to an End
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/23/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/kfcbs-ezekiel-mutua-calls-for-the-arrest-of-eric-omondi-over-his-wife-material-show/76v0b48">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/XYGk9kpTURBXy9jZTM1MWRiMjBhNWE5ODlkNjQ5ZGYwZmJjNDM4Yzk4NC5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="KFCB’s Ezekiel Mutua calls for the arrest of Eric Omondi over his ‘Wife Material Show’"  data-original="//ocdn.eu/pulscms-transforms/1/gR2k9kpTURBXy9jZTM1MWRiMjBhNWE5ODlkNjQ5ZGYwZmJjNDM4Yzk4NC5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        KFCB’s Ezekiel Mutua calls for the arrest of Eric Omondi over his ‘Wife Material Show’
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/23/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/comedian-flaqo-lands-in-trouble-with-kot-after-trying-to-defend-sauti-sol/vx2cx2h">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/jhBk9kpTURBXy8zZmU5ZDg2ZjQzZTEyYmZiNjY4ZTczODI5N2U4NDU2Yy5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="KOT hurl Unprintable insults at Flaqo after trying to defend Sauti Sol"  data-original="//ocdn.eu/pulscms-transforms/1/cUWk9kpTURBXy8zZmU5ZDg2ZjQzZTEyYmZiNjY4ZTczODI5N2U4NDU2Yy5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        KOT hurl Unprintable insults at Flaqo after trying to defend Sauti Sol
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/24/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/band-becas-carol-speaks-out-after-winning-eric-omondis-wife-material-competition/djdnvgs">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/vLrk9kpTURBXy9iODAzMzk5MDUwOWVhNGE1Mzg1YmJiZWI5OTBlNGU4Ni5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Band Beca’s Carol speaks out after winning Eric Omondi’s Wife Material Competition"  data-original="//ocdn.eu/pulscms-transforms/1/mVrk9kpTURBXy9iODAzMzk5MDUwOWVhNGE1Mzg1YmJiZWI5OTBlNGU4Ni5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Band Beca’s Carol speaks out after winning Eric Omondi’s Wife Material Competition
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/24/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/ntv-john-otanga-journalist-appeals-for-financial-help-to-seek-cancer-treatment-in/7vtn2wh">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/SY_k9kpTURBXy81NTQ2ZWQ3YjAxOWE5NGM5OTdmOGYwNzNkYWY4ZjcxMy5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Rashid Abdalla appeals to Kenyans to help NTV Journalist get cancer treatment in India"  data-original="//ocdn.eu/pulscms-transforms/1/D_Wk9kpTURBXy81NTQ2ZWQ3YjAxOWE5NGM5OTdmOGYwNzNkYWY4ZjcxMy5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Rashid Abdalla appeals to Kenyans to help NTV Journalist get cancer treatment in India
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/24/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/i-always-questioned-why-she-didnt-raise-me-ntvs-mark-masai-speaks-on-his-biological/plll145">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/WXNk9kpTURBXy9hNzJjN2RlN2U2ZTM0MjZlN2JlYmNhMGZiOThkMWM3My5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="I always questioned why she didn&#39;t raise me – NTV’s Mark Masai speaks on his Biological Mother"  data-original="//ocdn.eu/pulscms-transforms/1/q_nk9kpTURBXy9hNzJjN2RlN2U2ZTM0MjZlN2JlYmNhMGZiOThkMWM3My5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        I always questioned why she didn&#39;t raise me – NTV’s Mark Masai speaks on his Biological Mother
                    </h3>
                    
                    
                        <span class="itemDate">Published 12/24/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
        
            
        
            
        
            
        
        </div>
    </div>
    
</div>
</div>
</section>
<!-- widgetRight4 -->
                                            
                                                
     <script>                              (function(window, document, undefined) {                            var script_tag = document.createElement('script');                            script_tag.src = 'https://ad.mox.tv/mox/mwayss_invocation.min.js?pzoneid=5163&height=405&width=720&tld=pulselive.co.ke&ctype=iframe';                            var container = document.querySelectorAll('[data-id=_mwayss-978f50cc641698ad9dc63615cc2410f9]')[0];                                container.setAttribute('id', (container.getAttribute('data-id')+(new Date()).getTime()));                            container.removeAttribute('data-id');                            container.parentNode.insertBefore(script_tag, container);                        })(window, document);                    </script>
<!-- widgetRight5 -->
                                            
                                                
    <div id="taboola-below-article-thumbnails"></div><script type="text/javascript">    window._taboola = window._taboola || [];    _taboola.push(            {mode: 'thumbnails-a', container: 'taboola-below-article-thumbnails', placement: 'Below Article Thumbnails', target_type: 'mix'}    );</script>
<!-- widgetRight6 -->
                                            
                                                <!-- widgetRight7 -->
                                            
                                                <!-- widgetRight8 -->
                                            
                                        
                                    
                                                                    

                                    
                                     <!-- no ads bannner -->
                                                                       
                                        
                                    
                                    </article>                
                            </div>
                            <!--check if its a featured article -->   
                             <!-- disbale right column  -->
                                    
                                    <div class="rightColWrapper">
                                        <aside class="extraList">
                                                
                                                    
                                                        
  <div class="onet-ad" id="onet-ad-right" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("right");
            onetAds.show("right");
        </script>
    </div>
<!-- widgetRight0 -->
                                                    
                                                        


<section id="trending">
<div class="col-xs-12 wdgWrapper">
<div
    class="wdg wdgStandardRightColumn "
     >
    
    
    <div class="widgetsHeader">
        <h1 class="title">
            
            <span class="titleTxt">Trending</span>
        </h1>
    </div>
    
    
    <div class="wdgItems">
        <div class="row">
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/tanasha-donnas-message-to-diamond-as-she-gets-featured-on-list-of-10-most-viewed/tbxtv3y">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/LTKk9kpTURBXy84ZmM2NWEyZmU2OTAwODM5MWJiOWE5ODc2ODQ4NTY5Yi5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Tanasha Donna’s message to Diamond as she features on list of 10 most viewed songs in Africa"  data-original="//ocdn.eu/pulscms-transforms/1/w57k9kpTURBXy84ZmM2NWEyZmU2OTAwODM5MWJiOWE5ODc2ODQ4NTY5Yi5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Tanasha Donna’s message to Diamond as she features on list of 10 most viewed songs in Africa
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/diamonds-wasafi-tv-banned-for-6-months-over-airing-indecent-content/zpyyng1">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/4Epk9kpTURBXy83OWYzYmI4MzVmNTNjMGFjY2QxOTY0YWM2NmQ4NDQyOS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Diamond’s Wasafi TV banned for 6 Months over airing indecent content"  data-original="//ocdn.eu/pulscms-transforms/1/YKQk9kpTURBXy83OWYzYmI4MzVmNTNjMGFjY2QxOTY0YWM2NmQ4NDQyOS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Diamond’s Wasafi TV banned for 6 Months over airing indecent content
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/kate-actress-wins-the-prestigious-youtube-award-sliver-plaque-photo/9jjqmd5">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/v-lk9kpTURBXy8wYzllNGM0M2VmNWM4ZWQyN2EwOTYyZTc3MTUwNWRiZS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Kate Actress wins the Prestigious YouTube Award (Photo)"  data-original="//ocdn.eu/pulscms-transforms/1/07_k9kpTURBXy8wYzllNGM0M2VmNWM4ZWQyN2EwOTYyZTc3MTUwNWRiZS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Kate Actress wins the Prestigious YouTube Award (Photo)
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities/i-lost-my-car-was-homeless-for-a-minute-andrew-kibe-talks-struggles-after-exiting/fdx5stk">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/yGJk9kpTURBXy85N2UxMzI2NjZjZTdhNWE4ZDY1MmY5M2ZlZGY0YTc2Mi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="I lost my Car, was homeless for a Minute- Andrew Kibe talks struggles after exiting Kiss 100"  data-original="//ocdn.eu/pulscms-transforms/1/n-uk9kpTURBXy85N2UxMzI2NjZjZTdhNWE4ZDY1MmY5M2ZlZGY0YTc2Mi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        I lost my Car, was homeless for a Minute- Andrew Kibe talks struggles after exiting Kiss 100
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
            
                
            
                
            
                
            
        </div>
    </div>
    
</div>
</div>
</section>
<!-- widgetRight1 -->
                                                    
                                                        
  <div class="onet-ad" id="onet-ad-right3" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("right3");
            onetAds.show("right3");
        </script>
    </div>
<!-- widgetRight2 -->
                                                    
                                                        
    <div class="extraList"  data-content-container="stream">
        <div id="floatingGroup" data-run-module="local/main.asideContainerDel_float">
            <div id="stickyRight" class="asideAds asideBlock">
                <div class="stickyWrapper" data-pos="1">
                    <div id='onet-ad-right2' class='onet-ad sticky-slot'></div>
                </div>
            </div>
        </div>
    </div>
<!-- widgetRight3 -->
                                                    
                                                
                                        </aside>
                                    </div>
                                    
                            
                        </div>
                    </div>
                </div>
                <!-- gallery -->
            </div>
        </section>
         <!-- insertion of Aureus start -->
                        <!-- insertion of Aureus end -->
        <footer class='footer'>
    <div class="topFooter">
        <div class="footer pageWrapper container customSize">
            <div class="serviceFooterContainer">
                
                <div class="advertTitle">
                    Advertise with us:
                </div>
                <div class="advertBody">
                    <div>Reach out to us at <a href="mailto:salesteam@pulse.co.ke">salesteam@pulse.co.ke</a> or 0714928113 to advertise with us. Find out more about Pulse's products and advertising opportunities at <a href="https://pulse.africa" target="_blank" style="color: #ff0"> pulse.africa</a> </div>
                </div>
                
            </div>
            <div class="serviceFooterContainer">
                <div class="logoContainer">
                    
                        <a class="portalLogo" href="//www.pulselive.co.ke">
                            <img src="https://ocdn.eu/radp/logotypes/pulselive-kenya.svg">
                        </a>
                    
                    
                        <p class="fnote">We inform &amp; engage - 24/7</p>
                    
                </div>
                
                <ul class="footNav">
                    
                        
                            <li>
                                <a href="/" title="Home" class="fHeader">Home</a>
                                
                                <ul class="footNavSecond">
                                    
                                        
                                        <li>
                                            <a href="/news" title="News">News</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/entertainment" title="Entertainment">Entertainment</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/lifestyle" title="Lifestyle">Lifestyle</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/sports" title="Sports">Sports</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/business" title="Business">Business</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/quizzes" title="Quizzes">Quizzes</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/classifieds" title="Classifieds">Classifieds</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="https://africa.businessinsider.com/" title="Businessinsider">Businessinsider</a>
                                        </li>
                                        
                                    
                                </ul>
                                
                            </li>
                        
                    
                    
                    <li>
                        <span class="fHeader">About us</span>
                        <ul class="footNavSecond">
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/about-us" title="About Us">About Us</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="https://pulse.africa" title="Advertise">Advertise</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/privacy-policy-pulselivecoke/vh9gdmy	" title="Privacy Policy">Privacy Policy</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/terms-and-conditions-pulselivecoke/d1z0r3q" title="Terms &amp; Conditions">Terms &amp; Conditions</a>
                            </li>
                            
                            
                        </ul>
                    </li>
                    
                    
                    <li>
                        <span class="fHeader">Social</span>
                        
<div id="socialLinks" class="socialLinks serviceFooterContainer">
    <ul class="profileList">
        
        <li class="facebook icon-fb">
            <a href="https://www.facebook.com/pulselivekenya/" title="Follow us on Facebook">Facebook</a>
        </li>  
        
        
        <li class="twitter icon-twitter">
            <a href="https://twitter.com/pulselivekenya" title="Follow us on Twitterze">Twitter</a>
        </li>  
        
        
        
        <li class="instagram icon-instagram">
            <a href="https://www.instagram.com/pulselivekenya/" title="Follow us on Instagram">Instagram</a>
        </li>  
        
        
        
        <li class="youtube icon-youtube">
            <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="Watch us on YouTube">YouTube</a>
        </li>  
        
        
        
        <li class="newsletter icon-newsletter">
            <a href="https://www.pulselive.co.ke/newsletter" title="Registration and newsletter subscription">Newsletter</a>
        </li>
        
    </ul>
</div>

                    </li>
                    
                </ul>
                
                <div class="slideToTop" data-run-module="uss/main.slideToTop" style="opacity: 0;">
                    <a href="javascript:void(0)">
                        <span></span>
                    </a>
                </div>
            </div>
        </div>
    </div>
    <div class="bottomFooter">
        <div id="copyrights" class="container">
            &copy; 2021  Pulselive.co.ke
        </div>
    </div>

</footer>

             
            <script>
                var parentDiv =document.getElementById('detail');
                var d = document.getElementById("recommendedArticle");
                d.style.display = 'block';
                var child = parentDiv.children[2];
                 parentDiv.insertBefore(d, child)
            </script>
        
            
        <!-- Use footer script -->
        
        
        <script type="text/javascript">    var adsDiv =document.getElementById('bNhjLmVPUXEW');     if(!adsDiv){     window.dataLayer = window.dataLayer || [];          window.dataLayer.push({ 'event' : 'adblock-detected'}); }  </script> <script src="https://radp.ocdn.eu/js/adblocker.js" type="text/javascript">
         
        <script type="text/javascript"> window._taboola = window._taboola || []; _taboola.push( {flush: true} );  </script>
        <script type="text/javascript" src="https://ocdn.eu/radp/quantcast_ live kenya.js" async/></script>
    <script type='text/javascript' src='https://ssp.mediapal.net/www/delivery/spcjs.php?id=5'></script>
<script>
var eadt=eadt||{};eadt.cmd=eadt.cmd||[];
(function(){var s=document.createElement('script');s.async=true;s.type='text/javascript';var useSSL='https:'==document.location.protocol;s.src=(useSSL?'https:':'http:')+'//eas-fe.eskimi.com/js/adt.js';var n=document.getElementsByTagName('script')[0];n.parentNode.insertBefore(s,n)})();
</script>

<div id="ead-1565081532088-0">
<script>
eadt.cmd.push(function(){
    eadt.setMacros('%%CLICK_URL_UNESC%%');
    eadt.setDomain(0); // skip domain ID
    eadt.setNetwork(0); // next network ID
    eadt.render('427', 'ead-1565081532088-0');
});
</script>
</div></body>
    </div>
    </html>
