




<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8"/><script>/* <![CDATA[ */ ringDataLayer = {"context":{"variant":{"accelerator":"d3d3LnB1bHNlbGl2ZS5jby5rZTo6UFJPRF9WMg=="},"publication_structure":{"root":"WWW_PULSELIVE_CO_KE","path":"ENTERTAINMENT/CELEBRITIES/ARTICLE"},"id":{"aureus_offers":["wxnd7a0gvf"]}},"content":{"object":{"type":"story","kind":"article","id":"da0e680f-b075-41e3-adca-361bb1302d23"},"part":1,"publication":{"point":{"id":"3bemqsl"}},"source":{"system":"ring_content_space","id":"7dd277c7-e647-489d-a0cd-8c305073a877"}}}; /* ]]> */</script><script>/* <![CDATA[ */ accConf = {"rum":{"tid":"EA-4719209","cookieInfo":0,"pageType":"HTML"},"gtm":{"id":["GTM-MGFD5X"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}}; /* ]]> */</script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<!-- End Google Tag Manager -->

    <meta name="viewport" content="width=device-width, initial-scale=1">
    












<link rel="preconnect" href="https://ocdn.eu">
<link rel="dns-prefetch" href="https://ocdn.eu">


    <title>Diana Marua Bahati clears air on beef with Mr Seed's wife Nimo Gachuiri | Pulselive Kenya</title>





    <meta name="description" content="Diana said she was in good terms with Nimo although they had not met in a long time | Pulselive Kenya">



    
        
            <meta name="robots" content="index,follow">
        
    



    <link rel="canonical" href="https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl" />
     
        <link rel="amphtml" href="https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl.amp" />
    



    <meta name="ring-local-canonical" content="https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl" data-isExternal="false">



    <meta name="ring-global-lazyload-behavior" content="auto detect">



    <meta name="DC.Identifier" content="da0e680f-b075-41e3-adca-361bb1302d23">





    <meta name="theme-color" content="#AC2723"/>



    <link rel="apple-touch-icon" href="https://ocdn.eu/radp/pwa/512x512.png">



    <link rel="manifest" href="/manifest.json"  crossorigin="use-credentials" >



    


    

    
        
        
        
        
        
        

        
            <meta property="og:title" content="Diana Marua clears air on beef with Mr Seed&#39;s wife Nimo" />
        

        
            <meta property="og:description" content="Diana said she was in good terms with Nimo although they had not met in a long time" />
        

        
            <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/sNMktkpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQSwzQJ2" />
        

        
            <meta property="og:image:width" content="1200" />
        

        
            <meta property="og:image:height" content="630" />
        

        
            <meta property="og:image:type" content="png"/>
        

        
            <meta property="og:image:alt" content="YouTube influencer Diana Marua and model Nimo Gachuiri"/>
        

        
            <meta property="og:url" content="https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl" />
        

        
            <meta property="og:type" content="Article" />
        

        
            <meta property="og:site_name" content="Pulselive Kenya"/>
        

        
            <meta property="article:publisher" content="https://www.facebook.com/pulselivekenya"/>
        

        
            <meta property="og:locale" content="en_EN" />
        

        
            <meta property="og:updated_time" content="2022-04-24 16:01:26+0200" />

            
                <meta property="article:modified_time" content="2022-04-24 16:01:26+0200" />
            
        

        
            <meta property="article:published_time" content="2022-04-24 16:01:26+0200" />
        

        
            <meta property="article:section" content="celebrities" />
        

        
            
                
                    <meta property="article:author" content="Amos Robi" />
                
            

            
                
                    <meta property="article:tag" content="DianaMarua" />
                
            
                
                    <meta property="article:tag" content="BahatiKenya" />
                
            
                
                    <meta property="article:tag" content="NimoGachuiri" />
                
            
                
                    <meta property="article:tag" content="2022ElectionsKE" />
                
            
                
                    <meta property="article:tag" content="Mathare" />
                
            
        

        
            <meta name="twitter:card" content="summary_large_image">
            <meta name="twitter:image" content="https://ocdn.eu/pulscms-transforms/1/sNMktkpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQSwzQJ2">
        

        
            <meta property="twitter:title" content="Diana Marua clears air on beef with Mr Seed&#39;s wife Nimo" />
        

        
            <meta property="twitter:description" content="Diana said she was in good terms with Nimo although they had not met in a long time" />
        

        
            <meta property="fb:app_id" content="715603858641973" />
        

        
            <meta property="fb:pages" content="252006125219593" />
        

        
            <meta name="keywords" content="DianaMarua, BahatiKenya, NimoGachuiri, 2022ElectionsKE, Mathare" />
        
    


<meta name="facebook-utm_source" content="facebook"/>
<meta name="facebook-utm_medium" content="social"/>
<meta name="facebook-utm_campaign" content="share-button"/>
    









    <link id="variables-styles" data-theme="light" href="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/styles/project-variables-light.css" type="text/css" rel="stylesheet"/>


<link id="init-styles" href="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/styles/project-init.css" type="text/css" rel="stylesheet"/>


    
        
            
            
            
            
            

            
                
                    

                    <link href="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/styles/project-Common.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          id="page-partial-style-project-Common"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
                
                    

                    <link href="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/styles/project-Detail.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          id="page-partial-style-project-Detail"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
                
            
        
    

    
    <script>
    if ('serviceWorker' in navigator) {
        window.addEventListener('load', function () {
            navigator.serviceWorker.register('pwa-service-worker.js')
                .then(function (registration) {
                    
                }, function (err) {
                    
                });
        });
    }
</script>
    


<script data-static-amd-map="{&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/fbc3bd59219c65f9c312840c9743c691/build&quot;,&quot;adsinit&quot;:&quot;https://ty0lm9uz.onet.pl/e1BrazgxMzJ9/build&quot;,&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/162d5140a65ebc0fa2e96da195a4eb9b/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;pulsembed&quot;:&quot;https://pulsembed.eu/amd/1.0.6/build&quot;,&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/js&quot;}">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</script>
    


<script>
    const schemaOrgItemList = {
        "@type": "ItemList",
        "itemListElement": []
    };
</script>

<noscript>
    <style>
        
        .image-wrapper{position:relative;display:inline-flex}.image-wrapper::after,.image-wrapper::before{background-image:var(--noscript-src);content:'';position:absolute;left:0;top:0;bottom:0;right:0;background-size:cover;background-repeat:no-repeat;background-position:center}
    </style>
</noscript>
    
        
    
















    <script>
        if (typeof dlApi === 'undefined') {
            dlApi = {
                async: 1,
                cookieInfo: '',
                no_gemius: 1,
                adsNoBanner: 1,
                noDfp: 1,
                mobile: 'false',
                target: '',
                tid: 'EA-4719209',
                DV: "pulselive_co_ke/main"
            }
        }
    </script>

    
        <script>
                dlApi = Object.assign(dlApi, {
                    kropka: {
                        DX: "PV,puls,3bemqsl,7,a",
                        PU: "da0e680f-b075-41e3-adca-361bb1302d23"
                    }
                });
        </script>
    


    


    
    
    
    
    
    
    

    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>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</script>


    
    
    
    

    <script defer src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
    <script>
        window.addEventListener('DOMContentLoaded', function() {
            Sailthru.init({ "customerId": "e3bb91358ab42ece773022042c6cfd66", "iscustom": true, "autoTrackPageview": false, "useStoredTags": false });
            Sailthru.track('pageview', {
                url: "https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl",
                tags: "celebrities",
                onSuccess: function () {
                    
                },
                onError: function () {
                    
                }
            });
        });
    </script>


    
    
        
            <script type="text/javascript">var pulse2EmbedConfig = { pulsevideo: { player: "flowplayer", params: { autoplayNext: !0, enableAds: !1 }, plugins: [{ script: "https://imasdk.googleapis.com/js/sdkloader/ima3.js" }, { script: "https://embed.videos.ringpublishing.com/flowplayer/plugins/ads.min.js", config: { ima: { ads: [{ adTag: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", time: 0 }] } } }] }, OnettvVideo: { 'MAIN_ELEMENT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 }, 'INTEXT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 } } }</script>
        
    


    

    
    
        
            <script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[],function(){var t=document.createElement("script");t.async=!0,t.type="text/javascript";var e="https:"==document.location.protocol;t.src=(e?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(t,o)}();</script><script type='text/javascript'>googletag.cmd.push(function () { var o = window.location.pathname.split("/"); switch (o[1]) { case "": o[1] = "home" }void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1)); var e = token.length; if (document.location.hostname == 'www.pulse.ng') { googletag.pubads().setTargeting('PulseNG_URL', [token]); } if (document.location.hostname == 'www.pulse.sn') { googletag.pubads().setTargeting('PulseSN_URL', [token]); } if (document.location.hostname == 'www.pulse.com.gh') { googletag.pubads().setTargeting('PulseGH_URL', [token]); } if (document.location.hostname == 'www.pulselive.co.ke') { googletag.pubads().setTargeting('PliveKE_URL', [token]); } if (document.location.hostname == 'africa.businessinsider.com') { googletag.pubads().setTargeting('PulseBI_URL', [token]); } googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices() });</script><script type='text/javascript'>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];(function () {var gads = document.createElement('script');gads.async = true;gads.type = 'text/javascript';var useSSL = 'https:' == document.location.protocol;gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';var node = document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads, node);})();</script>
        
    


    

<script>if ("undefined" === typeof dlApi) { dlApi = {"target":"unknown/unknown","cookieInfo":"","no_gemius":1,"adsNoBanner":1,"noDfp":1,"tid":"EA-4719209"}; }</script>
<script src="https://lib.onet.pl/s.csr/build/dlApi/dl.boot.min.js" async></script>
</head>
<body class="articleDetail story-type-article css-project withRightColumn desktop  ">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->


    
    


    





<header id="main-page-header"  class="main-page-header " >
    <div class="header-lazy-wrapper" data-run-module="local/lazyLoad.run">
        
            <div class="header-widget-box header-above-wrapper">
                <div class="main-page-nav container">
                    
    















    <div class="menu-hamburger  hide-on-big-screens">
        
        
        
            <div class="menuToggle">
                <span></span>
                <span></span>
                <span></span>
            </div>
        
        
        
    </div>

    <div class="menu-mobile-container menu-hamburger
        
        
        " >
        <a class="main-page-logo"
           
           title="Pulselive Kenya"
           href="https://www.pulselive.co.ke/"
        >
            <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
        </a>


        
        
        
            <div class="menuToggleInside">
                <span></span>
                <span></span>
                <span></span>
            </div>
        
        
        
        <ul class="hamburger-list-items">
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="News" href="/news" >
                            News
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Politics" href="/news/politics">
                                            Politics
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/news/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Metro" href="/news/metro">
                                            Metro
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="World" href="/news/world">
                                            World
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Entertainment" href="/entertainment" >
                            Entertainment
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                            Celebrities
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Music" href="/entertainment/music">
                                            Music
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                            Movies
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Lifestyle" href="/lifestyle" >
                            Lifestyle
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                            Fashion
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                            Beauty &amp; Health
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-weddings">
                                            Relationships &amp; Weddings
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                            Food, Travel, Arts &amp; Culture
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Sports" href="/sports" >
                            Sports
                        </a>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Business" href="/business" >
                            Business
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/business/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="International" href="/business/international">
                                            International
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Quizzes" href="/quizzes" >
                            Quizzes
                        </a>
                        
                    </li>
                
                
            
        </ul>
    </div>


    

    






<div class="page-logo-wrapper ">
    <a class="main-page-logo"
       id="main-page-logo"
       title="Pulselive Kenya"
       href="https://www.pulselive.co.ke/"
    >
        <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
    </a>
</div>

    










    <ul class="main-page-nav menu-desktop menu-justify-center   hide-on-small-screens"
        
    >
        
            
                <li id="listMenuItem-0" class="menu-item  has-subMenu">
                    <a class="menu-title" title="News" href="/news" >
                        News
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Politics" href="/news/politics">
                                        Politics
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Local" href="/news/local">
                                        Local
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Metro" href="/news/metro">
                                        Metro
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-3" class="submenu-item ">
                                    <a class="submenu-title" title="World" href="/news/world">
                                        World
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-1" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Entertainment" href="/entertainment" >
                        Entertainment
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                        Celebrities
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Music" href="/entertainment/music">
                                        Music
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                        Movies
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-2" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Lifestyle" href="/lifestyle" >
                        Lifestyle
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                        Fashion
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                        Beauty &amp; Health
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-weddings">
                                        Relationships &amp; Weddings
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-3" class="submenu-item ">
                                    <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                        Food, Travel, Arts &amp; Culture
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-3" class="menu-item  ">
                    <a class="menu-title" title="Sports" href="/sports" >
                        Sports
                    </a>
                    
                </li>
            
        
            
                <li id="listMenuItem-4" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Business" href="/business" >
                        Business
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Local" href="/business/local">
                                        Local
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="International" href="/business/international">
                                        International
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-5" class="menu-item  ">
                    <a class="menu-title" title="Quizzes" href="/quizzes" >
                        Quizzes
                    </a>
                    
                </li>
            
        
        
    </ul>


    
    <div class="headerSocials">
        <ul class="profileList">
            
                <li class="facebook">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.facebook.com/pulsenigeria247"
                        title="Follow us on Facebook"
                        target="_blank"
                    >
                        instagram
                    </a>
                </li>
            
                <li class="twitter">
                    <a
                        rel="noopener noreferrer"
                        href="https://twitter.com/pulsenigeria247"
                        title="Follow us on Twitter"
                        target="_blank"
                    >
                        twitter
                    </a>
                </li>
            
                <li class="instagram">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.instagram.com/PulseNigeria247/"
                        title="Follow us on Instagram"
                        target="_blank"
                    >
                        instagram
                    </a>
                </li>
            
                <li class="youtube">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.youtube.com/user/PulseNigeria247"
                        title="Watch us on YouTube"
                        target="_blank"
                    >
                        youtube
                    </a>
                </li>
            
                <li class="tiktok">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.tiktok.com/@pulsenigeria247"
                        title="Tiktok with us"
                        target="_blank"
                    >
                        tiktok
                    </a>
                </li>
            
        </ul>
    </div>


    

    

    

    

    

    

    

    

    

    

    






<div class="search-container-wrapper ">
    <div class="search-container" data-run-module="local/project.menu_search">
        <div id="search-button">
            <div class="svg icon-search" style="background-image:url(https://ocdn.eu/radp/icons/header/search.svg)"></div>
        </div>
        <form action="/search">
            <input type="search" placeholder="I’m looking for..." name="q" required data-placeholder-source="I’m looking for..." data-required-message="Please type your query and press search">
            <button type="submit">O</button>
        </form>
    </div>
</div>

                </div>
            </div>
        
        
        
            <div class="header-widget-box header-below-wrapper">
                <div class="main-page-nav container">
                    
    





                </div>
            </div>
        
    </div>
</header>

    
    <div class="page-container " data-run-module="local/lazyLoad.run">
        
            
            <div class="header-banner container-full">
                
                    


    
        <div class="adSlot " id='div-gpt-ad-1623221635248-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_970x90_a1" data-slot-size="[[728, 90], [970, 250], [970, 90]]" ></div>
    

                
            </div>
        
        <div class="container-full right-column-300">
            <div class="container">
                <div class="page-wrapper row">
                    <div id="article" class="main-section col-md-9">
                        <div class="articleBox ">
                            <div data-article-id="3bemqsl">
                                
                                    


    

    
        <div class="container-wrapper ">
            

            
                <!-- LEFT content columns -->
                <section class="ring-grid-box-container ring-grid-container container ">
                    
                    <div class="row">
                        <div class="ring-grid-left-box col-sm-12 col-md-12 col-lg-12">
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1621854609633-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PliveKE_DT_Sticky_Footer" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1617224545705-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/plive_dt_floater" data-slot-size="[1, 1]" ></div>
    

                            
                                


    
        <div class="adSlot placeholder-90 " id='div-gpt-ad-1623221635248-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_970x90_a1" data-slot-size="[[728, 90], [970, 250], [970, 90]]" ></div>
    

                            
                                
                            
                                


    <div class="breadcrumbs-widget ">
        
            



    
        
            <a href="https://www.pulselive.co.ke/" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    <strong>
                        RADP / Pulse Kenya
                    </strong>
                </span>
            </a>

            

            
                <span class="breadcrumbs-item-sep">&nbsp;&gt;&nbsp;</span>
            
        
    
        
            <a href="https://www.pulselive.co.ke/entertainment" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    
                        Entertainment
                    
                </span>
            </a>

            

            
                <span class="breadcrumbs-item-sep">&nbsp;&gt;&nbsp;</span>
            
        
    
        
            <a href="https://www.pulselive.co.ke/entertainment/celebrities" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    
                        Celebrities
                    
                </span>
            </a>

            

            
        
    

        
    </div>

                            
                                






    
        
            <h1 class="article-headline ">
                <span>
                    
                        Diana Marua clears air on beef with Mr Seed&#39;s wife Nimo
                    
                </span>
            </h1>
        
    

                            
                                



    

    
        <div class="article-author-wrapper ">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/amos-robi" title="Amos Robi"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    

                                    
                                        <span class="author-name">Amos Robi</span>
                                    

                                    

                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                


    

    <div class="ring-detail-article-date ">
        
            <time class="detail-article-date date-type-publicationDate" datetime="2022-04-24T17:01:26.000+03:00">
                
                    April 24, 2022 5:01 PM
                
            </time>
        
    </div>

                            
                                
    
    
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                
                   <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
                
            
                
                
                   <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
            
                
                
                
                   <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
                
                
                
                
                
            
        
    </div>

                            
                                









     <div id="lead" class="article-perex ">
          <p>Diana said she was in good terms with Nimo although they had not met in a long time</p>
     </div>

                            
                                
                            
                                












    <div class="article-gallery " >
            <div  class="image-container" id="article-main-image">
                
                <picture data-image-source="article_photo" data-caption="YouTube influencer Diana Marua and model Nimo Gachuiri" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/xCTktkpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQMWzQGu); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/NTak9kpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQMWzQGugaEwBQ" srcset="https://ocdn.eu/pulscms-transforms/1/NTak9kpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQMWzQGugaEwBQ" type="image/webp"><img width="790" height="430" alt="YouTube influencer Diana Marua and model Nimo Gachuiri" title="YouTube influencer Diana Marua and model Nimo Gachuiri" src="https://ocdn.eu/pulscms-transforms/1/xCTktkpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQMWzQGu" data-original="https://ocdn.eu/pulscms-transforms/1/xCTktkpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQMWzQGu" class="image "></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/NTak9kpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzQMWzQGugaEwBQ">
            </div>

        
            <div class="imgMetaData">
                
                    <span class="caption">YouTube influencer Diana Marua and model Nimo Gachuiri</span>
                

                
                

                

                

                <div class="clear"></div>
            </div>
        
    </div>

                            
                                
                            
                                
                            
                                




                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        YouTuber turned rapper Diana Marua has come out to clear the air on her having beef with Mr Seed’s wife Nimo.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 inText" data-run-module="local/project.inText" id='div-gpt-ad-1618787017312-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/300x250_InReadAd_PliveKE" data-slot-size="[728, 90]" ></div>
    

                            
                                
                            
                                
    

    <div class="recommendedArticles">
        <span class="title">Recommended articles</span>
        <ul>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/s84ktkpTURBXy81MWNkNGI0ZjRkOTk4NmU1NGJhZjQzYjUxNTA3ZGM0Ny5qcGeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/DR9k9kpTURBXy81MWNkNGI0ZjRkOTk4NmU1NGJhZjQzYjUxNTA3ZGM0Ny5qcGeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Surrender or face same fate as Katombi Gang - DCI warns Mombasa gangs" title="Surrender or face same fate as Katombi Gang - DCI warns Mombasa gangs" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/s84ktkpTURBXy81MWNkNGI0ZjRkOTk4NmU1NGJhZjQzYjUxNTA3ZGM0Ny5qcGeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/news">news</a>
                        <a class="link"  data-uuid-ui="ef88b992-127c-4e9a-b038-c4d59f17f6bb" data-ei="wxnd7a0gvf" href="https://www.pulselive.co.ke/news/local/surrender-or-face-same-fate-as-katombi-gang-dci-warns-mombasa-gangs/m4y6gnn">Surrender or face same fate as Katombi Gang - DCI warns Mombasa gangs</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/Hj2ktkuTURBXy9jMTYwODk5My1mN2U0LTQxNzEtODA1MS01YzJkZTYzNTYzMmEuanBlZ5GTBUZG); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/RH9k9kuTURBXy9jMTYwODk5My1mN2U0LTQxNzEtODA1MS01YzJkZTYzNTYzMmEuanBlZ5GTBUZGgaEwBQ" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="'We are in the fight for the win'- Leclerc vows to bounce back in Emilia Romagna Grand Prix" title="'We are in the fight for the win'- Leclerc vows to bounce back in Emilia Romagna Grand Prix" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/Hj2ktkuTURBXy9jMTYwODk5My1mN2U0LTQxNzEtODA1MS01YzJkZTYzNTYzMmEuanBlZ5GTBUZG" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/1">1</a>
                        <a class="link"  data-uuid-ui="e24a8e9d-b30a-464c-9f87-b97774d4c8de" data-ei="wxnd7a0gvf" href="https://www.pulselive.co.ke/sports/other-sports/formula1/ferrari-driver-charles-leclerc-vows-to-bounce-back-in-emilia-romagna-grand-prix/mr2lq7m">&#39;We are in the fight for the win&#39;- Leclerc vows to bounce back in Emilia Romagna Grand Prix</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/zCzktkpTURBXy8xMmEwNDk0OWE4ZGY5YTJiM2ZmNjc0OTlmMTU0NzcwNi5wbmeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/37Ck9kpTURBXy8xMmEwNDk0OWE4ZGY5YTJiM2ZmNjc0OTlmMTU0NzcwNi5wbmeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Honour 'Utumishi Kwa Wote' ahead of the 2022 elections [Pulse Contributor's Opinion]" title="Honour 'Utumishi Kwa Wote' ahead of the 2022 elections [Pulse Contributor's Opinion]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/zCzktkpTURBXy8xMmEwNDk0OWE4ZGY5YTJiM2ZmNjc0OTlmMTU0NzcwNi5wbmeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/news">news</a>
                        <a class="link"  data-uuid-ui="dbaf690f-b283-4be3-b87c-917543a707b1" data-ei="wxnd7a0gvf" href="https://www.pulselive.co.ke/news/politics/opinion-honour-utumishi-kwa-wote-ahead-of-the-2022-elections/8embcwq">Honour &#39;Utumishi Kwa Wote&#39; ahead of the 2022 elections [Pulse Contributor&#39;s Opinion]</a>
                    </div>
                </li>
            
        </ul>
    </div>

                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                            
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Diana Marua acknowledged past differences between her and Nimo but argued she was not mature enough to handle issues appropriately back then.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        She was speaking during a function at a city hospital where she partners as a brand ambassador. She added that she and Nimo had not gotten together in a long time but they are in good terms.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>"The differences were there but you know people make mistakes in their former years and you sometimes realize probably you were not mature enough to handle issues in a better way buy life teaches us lessons differently,” she</em> stated.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Diana and Nimo crossed paths in 2018 during a New Year's party where Diana allegedly mistreated Nimo despite her being pregnant at the time.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Diana, whose husband Bahati will be running for Mathare Member of Parliament, said she was going to support her husband as he tries to enter the August house in the upcoming polls.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>“You know once you marry your best friend his life becomes your life, everything he touches you flow with it, everything you touch he flows with it,”</em> Diana explained.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-image ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- image: supported -->
    
    


    
    
    
    

    <div class="imageBlock aligment-center">
		<div>
			
                <span class="image-holder" data-fancybox="images-2a587af9-6f2f-4985-a310-204098c02f7a" data-caption="Kevin Bahati"  >
                    <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/_AKktkpTURBXy84MzA0ZWU0Njk4NTkyYjhmZjA3YTMxOTZhMmQwMDc1NS5qcGeRlQLNAobNA13Cww); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/QlWk9kpTURBXy84MzA0ZWU0Njk4NTkyYjhmZjA3YTMxOTZhMmQwMDc1NS5qcGeRlQLNAobNA13Cw4GhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'646'%20height%3D'861'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="646" height="861" alt="Kevin Bahati" title="Kevin Bahati" class="image lazyloaded imgWithMetaData" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'646'%20height%3D'861'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/_AKktkpTURBXy84MzA0ZWU0Njk4NTkyYjhmZjA3YTMxOTZhMmQwMDc1NS5qcGeRlQLNAobNA13Cww" loading="lazy"></picture> 
                </span>
			
			<div class="imgMetaData">
				
                    <span class="caption">Kevin Bahati</span>
                

                
                    <span class="description">Kevin Bahati</span>
                

				
					<span class="copyright"> Pulse Live Kenya</span>
				
				<div class="clear"></div>
			</div>
		</div>
	</div>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-heading ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- heading: supported -->
    
    


    
    

    

    <h3 class="heading-h3 replaced-h1" id="nav-ring-9">
        Mr Seed's open letter to Bahati 
    </h3>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Mr Seed <a href="https://www.pulselive.co.ke/entertainment/celebrities/mr-seeds-open-letter-to-bahati-as-he-goes-for-mathare-mp-seat/tcb88pq" id="aed04a48-b9ce-456c-8e36-eac9afc0a2cb">recently sent out his wishes to Bahati</a> praising the <em>Adhiambo</em> hitmaker whom he said was a leader and not a politician adding that the people of Mathare deserved a leader such as Bahati.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>“You are not a politician, but a leader. I pray the people of Mathare get to know how your intentions for them are pure. I support you my brother,” </em>said the singer.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>He added: “'Nilizaliwa Huruma' isn't just a line to a song to make a good hook but a testament of how we loved our home Huruma in Mathare. It was all we had, a place to call home. I remember us sleeping down (literally) you shared with me your vision for the people and how when you get blessed you will like to bless other.”</em>
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                
                            
                                

                            
                                
                            
                                



    <div class="taxonomies article-taxonomies ">
        
        <ul>
            
                <li>
                    
                        <a href="/topic/diana-marua-diana-b" title="DianaMarua">
                    
                        DianaMarua
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/kevin-bahati" title="BahatiKenya">
                    
                        BahatiKenya
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/nimo-gachuiri" title="NimoGachuiri">
                    
                        NimoGachuiri
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/2022-elections-kenya" title="2022ElectionsKE">
                    
                        2022ElectionsKE
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/mathare-valley" title="Mathare">
                    
                        Mathare
                    
                        </a>
                    
                </li>
            
        </ul>
    </div>

                            
                                



    

    
        <div class="article-author-wrapper  authorWithImage">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/amos-robi" title="Amos Robi"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    
                                        <span class="author-photo">
                                            

                                            

                                            <picture data-image-source="article-author" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/Bd_ktkpTURBXy83YTM4ZGZkYTZlNTIwMTMyMTEyYjQyODViMmJhZjdmYy5qcGeSlQMAAM0Bp80BqJMFRkY); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/AEyk9kpTURBXy83YTM4ZGZkYTZlNTIwMTMyMTEyYjQyODViMmJhZjdmYy5qcGeSlQMAAM0Bp80BqJMFRkaBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Amos Robi" title="Amos Robi" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/Bd_ktkpTURBXy83YTM4ZGZkYTZlNTIwMTMyMTEyYjQyODViMmJhZjdmYy5qcGeSlQMAAM0Bp80BqJMFRkY" class="image lazyloaded" loading="lazy"></picture> 
                                        </span>
                                    

                                    

                                    

                                    
                                
                                    

                                    
                                        <span class="author-name">Amos Robi</span>
                                    

                                    

                                    
                                
                                    

                                    

                                    

                                    
                                        <span class="author-description">Amos Robi is an opinionated, open minded communications practitioner looking to change the world from the digital front.</span>
                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                
    
    
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                
                   <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
                
            
                
                
                   <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
            
                
                
                
                   <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
                
                
                
                
                
            
                
                
                
                
                   <a href="whatsapp://send?text=https%3A%2F%2Fwww.pulselive.co.ke%2Fentertainment%2Fcelebrities%2Fdiana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri%2F3bemqsl?utm_medium%3Dsocial%26utm_source%3Dwhatsapp%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-whatsapp " data-gtm-social="whatsapp" title="WhatsApp" style="width: 30px; height: 30px"></a>
                
                
                
                
            
                
                
                
                
                
                   <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl?utm_medium%3Dsocial%26utm_source%3Dlinkedin%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-linkedin " data-gtm-social="linkedin" target="_blank" title="LinkedIn" style="width: 30px; height: 30px"></a>
                
                
                
            
        
    </div>

                            
                                


    <div class="basicWidget homepageNewsletter">
        <div class="bw-wrapper">
        
            <h3 class="main-section-title">JOIN OUR PULSE COMMUNITY!</h3>
        
            <div class="newsletterWrapper">
                <div class="socialList">
                    
                        <div class="socialIcon facebook">
                            
                                <a href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon twitter">
                            
                                <a href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon instagram">
                            
                                <a href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon youtube">
                            
                                <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon tiktok">
                            
                                <a href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/nl/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                </div>
                <div id="nlbox" class="newsletter dsk">
                    <div class="signUpContainer">
                        <div class="introMessage">
                            Our newsletter gives you access to a curated selection of the most important stories daily.
                        </div>
                        <form id="newsletter-form" method="POST" class="inputForm" action="#" data-run-module="local/project.newsletter_submit">
                            <input type="email" placeholder="Email" name="email" id="email" required>
                            <button id="submitEmail" class="submit">
                                SUBSCRIBE
                            </button>
                        </form>
                    </div>
                    <div id="error" class="error hide"></div>
                    <div id="thanksContainer" class="thanksContainer hide">
                        <div class="row" id="thanksMessage">
                            <p class="subTitle"> Welcome to the Pulse Community! We will now be sending you a daily newsletter on news, entertainment and more.   Also join us across all of our other channels - we love to be connected!</p>
                        </div>
                    </div>
                </div>
                
                    <div></div>
                    <div id="pushBox" class="pushContainer" data-run-module="local/project.push_notification">
                        <div class='onesignal-customlink-container'></div>
                        <div class="blockedText" id="pushBlocked"></div>
                    </div>
                
            </div>
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 " id='div-gpt-ad-1618841981942-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PulseKE_DT_Article_Below_Article_A" data-slot-size="[728, 90]" ></div>
    

                            
                                
    
        
            <div class="eyewitnessWdg" style="margin-top: 25px;">    <p>Eyewitness? Submit your stories now via social or: </p>    <p>    <b>Email: </b><a href="mailto:news@pulselive.co.ke">news@pulselive.co.ke</a></b></p></div>
        
    

                            
                                



    
    

    <div class="basicWidget hp-colSize-12 latest bw-v2"
        style=""
        
        
        >

        <div class="bw-wrapper">
             

            
                


    <h2 class="main-section-title">

    
    
        
    

    
        Recommended articles
    

    </h2>

            
                
    <div class="section-elements">
        <div class="items-wrapper columns-3 big-elements-0" >
        

            
            
            

            <div class="layout-wrapper wrap-element-1 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/wTbktkpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/1rZk9kpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Diana Marua clears air on beef with Mr Seed's wife Nimo" title="Diana Marua clears air on beef with Mr Seed's wife Nimo" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/wTbktkpTURBXy9iYzUxNDE3MmE0MzM0ZDRlZWI5OGYwYWJmOGFjMWMzNy5wbmeSlQMADM0CWM0BUpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Diana Marua clears air on beef with Mr Seed&#39;s wife Nimo
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl" title="Diana Marua clears air on beef with Mr Seed&#39;s wife Nimo"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-2 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/-qBktkpTURBXy8yODY4NzBhNWE1MmUyMzQzOTc2MDU3ODhlYzlhNDExNC5wbmeSlQMAMc0Eic0CjpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/j86k9kpTURBXy8yODY4NzBhNWE1MmUyMzQzOTc2MDU3ODhlYzlhNDExNC5wbmeSlQMAMc0Eic0CjpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Milly Chebby reveals she quit job at DP Ruto's office" title="Milly Chebby reveals she quit job at DP Ruto's office" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/-qBktkpTURBXy8yODY4NzBhNWE1MmUyMzQzOTc2MDU3ODhlYzlhNDExNC5wbmeSlQMAMc0Eic0CjpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Milly Chebby reveals she quit job at DP Ruto&#39;s office
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/milly-chebby-reveals-she-quit-job-at-dp-rutos-office/zxe447f" title="Milly Chebby reveals she quit job at DP Ruto&#39;s office"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-3 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/IvkktkpTURBXy9lODg3YTJhYzVlODY1NTIzM2U5ZjUyN2RkOTY1NjZkOS5qcGeSlQPMsM0BKc0Ctc0BhpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/1idk9kpTURBXy9lODg3YTJhYzVlODY1NTIzM2U5ZjUyN2RkOTY1NjZkOS5qcGeSlQPMsM0BKc0Ctc0BhpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Advice Kate Actress received after asking if she should join politics" title="Advice Kate Actress received after asking if she should join politics" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/IvkktkpTURBXy9lODg3YTJhYzVlODY1NTIzM2U5ZjUyN2RkOTY1NjZkOS5qcGeSlQPMsM0BKc0Ctc0BhpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Advice Kate Actress received after asking if she should join politics
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/advice-kate-actress-received-after-asking-if-she-should-join-politics/dc3pkn8" title="Advice Kate Actress received after asking if she should join politics"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-4 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/lihktkpTURBXy9lZGYyMzc5ZjhlZWU0Mjc0YTc5ZGMyOGNlMGM4YTAzNC5wbmeSlQMASc0Csc0Bg5MFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/Ch4k9kpTURBXy9lZGYyMzc5ZjhlZWU0Mjc0YTc5ZGMyOGNlMGM4YTAzNC5wbmeSlQMASc0Csc0Bg5MFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Some old baba - Noti Flow reveals reason for breakup with King Alami [SCREENSHOT]" title="Some old baba - Noti Flow reveals reason for breakup with King Alami [SCREENSHOT]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/lihktkpTURBXy9lZGYyMzc5ZjhlZWU0Mjc0YTc5ZGMyOGNlMGM4YTAzNC5wbmeSlQMASc0Csc0Bg5MFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Some old baba - Noti Flow reveals reason for breakup with King Alami [SCREENSHOT]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/some-old-baba-noti-flow-reveals-reason-for-breakup-with-king-alami/4wfgcjy" title="Some old baba - Noti Flow reveals reason for breakup with King Alami [SCREENSHOT]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-5 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/5luktkpTURBXy82ODJmNTcyOWUyMDUwYzVlZWJhYzFjOTI2YTEwMjAyNy5wbmeSlQMACs0D6c0CM5MFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/jbUk9kpTURBXy82ODJmNTcyOWUyMDUwYzVlZWJhYzFjOTI2YTEwMjAyNy5wbmeSlQMACs0D6c0CM5MFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Big Ted's post at State House following appointment as Consul-General" title="Big Ted's post at State House following appointment as Consul-General" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/5luktkpTURBXy82ODJmNTcyOWUyMDUwYzVlZWJhYzFjOTI2YTEwMjAyNy5wbmeSlQMACs0D6c0CM5MFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Big Ted&#39;s post at State House following appointment as Consul-General
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/tomas-kwaka-big-teds-post-at-state-house-following-appointment-as-consul-general/x0sm0xl" title="Big Ted&#39;s post at State House following appointment as Consul-General"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-6 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/qEJktkpTURBXy8zOTBjODI2ZDEyMjUzMWZiNGZiMGE1NzhmNWVmMTRlMy5wbmeSlQMAAc0ChM0BapMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/goxk9kpTURBXy8zOTBjODI2ZDEyMjUzMWZiNGZiMGE1NzhmNWVmMTRlMy5wbmeSlQMAAc0ChM0BapMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Joyce Omondi mourns Waihiga's sister; Diamond yearns for collabo with Rihanna & other stories on #PulseUhondoMtaani " title="Joyce Omondi mourns Waihiga's sister; Diamond yearns for collabo with Rihanna & other stories on #PulseUhondoMtaani " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/qEJktkpTURBXy8zOTBjODI2ZDEyMjUzMWZiNGZiMGE1NzhmNWVmMTRlMy5wbmeSlQMAAc0ChM0BapMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Joyce Omondi mourns Waihiga&#39;s sister; Diamond yearns for collabo with Rihanna &amp; other stories on #PulseUhondoMtaani 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/joyce-omondi-mourns-waihigas-sister-i-want-a-collabo-with-rihanna-diamond-and-other/z8vsxsb" title="Joyce Omondi mourns Waihiga&#39;s sister; Diamond yearns for collabo with Rihanna &amp; other stories on #PulseUhondoMtaani "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-7 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/zKiktkpTURBXy8wMmMyM2MwNDk5NTMzZDlhMzJhMWFmMzkxZjk4NjM3NC5qcGeSlQMAzQeWzRe3zQ1WkwXM88yI); "><source data-original="https://ocdn.eu/pulscms-transforms/1/3Kdk9kpTURBXy8wMmMyM2MwNDk5NTMzZDlhMzJhMWFmMzkxZjk4NjM3NC5qcGeSlQMAzQeWzRe3zQ1WkwXM88yIgaEwBQ" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Grammy award-nominated star Terri unveils highly anticipated EP 'In Transit' " title="Grammy award-nominated star Terri unveils highly anticipated EP 'In Transit' " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/zKiktkpTURBXy8wMmMyM2MwNDk5NTMzZDlhMzJhMWFmMzkxZjk4NjM3NC5qcGeSlQMAzQeWzRe3zQ1WkwXM88yI" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Grammy award-nominated star Terri unveils highly anticipated EP &#39;In Transit&#39; 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/music/grammy-award-nominated-star-terri-unveils-highly-anticipated-ep-in-transit/c2n3g66" title="Grammy award-nominated star Terri unveils highly anticipated EP &#39;In Transit&#39; "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-8 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/SUYktkpTURBXy8yMDA2M2I0YjM1ZTEwNDhkM2ZkMTExOTc0MjVkNjZkMC5qcGeSlQMAzIfNBDjNAmCTBczzzIg); "><source data-original="https://ocdn.eu/pulscms-transforms/1/JZQk9kpTURBXy8yMDA2M2I0YjM1ZTEwNDhkM2ZkMTExOTc0MjVkNjZkMC5qcGeSlQMAzIfNBDjNAmCTBczzzIiBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Kwani hamjui jokes - Akothee laughs off breakup reports with Nelly Oaks " title="Kwani hamjui jokes - Akothee laughs off breakup reports with Nelly Oaks " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/SUYktkpTURBXy8yMDA2M2I0YjM1ZTEwNDhkM2ZkMTExOTc0MjVkNjZkMC5qcGeSlQMAzIfNBDjNAmCTBczzzIg" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Kwani hamjui jokes - Akothee laughs off breakup reports with Nelly Oaks 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/kwani-hamjui-jokes-akothee-laughs-off-breakup-reports-with-nelly-oaks/7x56tdr" title="Kwani hamjui jokes - Akothee laughs off breakup reports with Nelly Oaks "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-9 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/t3kktkpTURBXy9iNzZjNmFkZDYyOWU5YTFhNjIyYjUwM2ZkMWIzMzc3MS5qcGeSlQMAzN7NBDjNAl-TBczzzIg); "><source data-original="https://ocdn.eu/pulscms-transforms/1/YwKk9kpTURBXy9iNzZjNmFkZDYyOWU5YTFhNjIyYjUwM2ZkMWIzMzc3MS5qcGeSlQMAzN7NBDjNAl-TBczzzIiBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Davido reveals he is in a relationship" title="Davido reveals he is in a relationship" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/t3kktkpTURBXy9iNzZjNmFkZDYyOWU5YTFhNjIyYjUwM2ZkMWIzMzc3MS5qcGeSlQMAzN7NBDjNAl-TBczzzIg" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Davido reveals he is in a relationship
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/entertainment/celebrities/davido-reveals-he-is-in-a-relationship/04sr62s" title="Davido reveals he is in a relationship"></a>
    </div>

                        
                    
                </div>

                
            </div>
        
        </div>
    </div>

            
        </div>
    </div>

                            
                                
                            
                        </div>
                    </div>
                </section>
            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

                                
                            </div>
                        </div>

                        
                    </div>

                    
                        
                            
                                
                                <div class="side-section col-md-3" id="content-side-section">
                                    <div>
                                        
                                            


    
        <div class="adSlot placeholder-600 mt-4 " id='div-gpt-ad-1617227624691-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_300x250_b1" data-slot-size="[[300, 250], [300, 600], [160, 600], [120, 600]]" ></div>
    

                                        
                                            


    <div class="widget-trending basicWidget ">
        
            <h2 class="main-section-title">
                Trending
            </h2>
        

        
        <div class="widget-trending-items">
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Wizkid replies Banky W over wedding absence remarks
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/_JBktkpTURBXy82Mjc1NDBhYTdjNDBlZWY1OTZhNzBmMTNmYTQ2ZmM5YS5wbmeSlQMAAM0C4M0BnpMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/e9ck9kpTURBXy82Mjc1NDBhYTdjNDBlZWY1OTZhNzBmMTNmYTQ2ZmM5YS5wbmeSlQMAAM0C4M0BnpMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/e9ck9kpTURBXy82Mjc1NDBhYTdjNDBlZWY1OTZhNzBmMTNmYTQ2ZmM5YS5wbmeSlQMAAM0C4M0BnpMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Banky W and Wizkid" title="Banky W and Wizkid" class="image " src="https://ocdn.eu/pulscms-transforms/1/_JBktkpTURBXy82Mjc1NDBhYTdjNDBlZWY1OTZhNzBmMTNmYTQ2ZmM5YS5wbmeSlQMAAM0C4M0BnpMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/_JBktkpTURBXy82Mjc1NDBhYTdjNDBlZWY1OTZhNzBmMTNmYTQ2ZmM5YS5wbmeSlQMAAM0C4M0BnpMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/e9ck9kpTURBXy82Mjc1NDBhYTdjNDBlZWY1OTZhNzBmMTNmYTQ2ZmM5YS5wbmeSlQMAAM0C4M0BnpMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/entertainment/celebrities/wizkid-replies-banky-w-over-wedding-absence-remarks/8ttj0ny"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Jalang&#39;o &amp; wife Amina launch their own restaurant in Nairobi CBD [Video]
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/M5qktkpTURBXy9kZjJkNmIyZDliZGY5OWFhYzhkMjFjYTk0ZjM2Mzc2NS5wbmeSlQMAAc0ChM0BapMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/l9Wk9kpTURBXy9kZjJkNmIyZDliZGY5OWFhYzhkMjFjYTk0ZjM2Mzc2NS5wbmeSlQMAAc0ChM0BapMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/l9Wk9kpTURBXy9kZjJkNmIyZDliZGY5OWFhYzhkMjFjYTk0ZjM2Mzc2NS5wbmeSlQMAAc0ChM0BapMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Jalang’o & wife Amina launch their own restaurant in Nairobi CBD [Video]" title="Jalang’o & wife Amina launch their own restaurant in Nairobi CBD [Video]" class="image " src="https://ocdn.eu/pulscms-transforms/1/M5qktkpTURBXy9kZjJkNmIyZDliZGY5OWFhYzhkMjFjYTk0ZjM2Mzc2NS5wbmeSlQMAAc0ChM0BapMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/M5qktkpTURBXy9kZjJkNmIyZDliZGY5OWFhYzhkMjFjYTk0ZjM2Mzc2NS5wbmeSlQMAAc0ChM0BapMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/l9Wk9kpTURBXy9kZjJkNmIyZDliZGY5OWFhYzhkMjFjYTk0ZjM2Mzc2NS5wbmeSlQMAAc0ChM0BapMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/entertainment/celebrities/jalango-and-wife-amina-launch-their-own-restaurant-in-nairobi-cbd-video/enhbrtt"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Citizen TV&#39;s Joyce Omondi mourns Waihiga&#39;s younger sister
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/F1hktkpTURBXy9kNjAzNzRlZjNiZGI4OGFkZGU0Y2NkZGY4ZTI4NGYxNy5qcGeSlQMAOM0DJc0BxJMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/4fOk9kpTURBXy9kNjAzNzRlZjNiZGI4OGFkZGU0Y2NkZGY4ZTI4NGYxNy5qcGeSlQMAOM0DJc0BxJMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/4fOk9kpTURBXy9kNjAzNzRlZjNiZGI4OGFkZGU0Y2NkZGY4ZTI4NGYxNy5qcGeSlQMAOM0DJc0BxJMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Waihiga and Joyce (Instagram)" title="Waihiga and Joyce (Instagram)" class="image " src="https://ocdn.eu/pulscms-transforms/1/F1hktkpTURBXy9kNjAzNzRlZjNiZGI4OGFkZGU0Y2NkZGY4ZTI4NGYxNy5qcGeSlQMAOM0DJc0BxJMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/F1hktkpTURBXy9kNjAzNzRlZjNiZGI4OGFkZGU0Y2NkZGY4ZTI4NGYxNy5qcGeSlQMAOM0DJc0BxJMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/4fOk9kpTURBXy9kNjAzNzRlZjNiZGI4OGFkZGU0Y2NkZGY4ZTI4NGYxNy5qcGeSlQMAOM0DJc0BxJMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/entertainment/celebrities/citizen-tvs-joyce-omondi-mourns-waihigas-younger-sister/95wlmnw"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Joke Silva, Ini Edo, Uche Jombo, others attend Rita Dominic&#39;s wedding
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/L2qktkpTURBXy9hMmQ2NDI2N2VkNGY2M2QzYjE1NDMwODY1NDcxYTY5OC5qcGeSlQMAPs0EOM0CYJMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/v3ak9kpTURBXy9hMmQ2NDI2N2VkNGY2M2QzYjE1NDMwODY1NDcxYTY5OC5qcGeSlQMAPs0EOM0CYJMFzQEszKyBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="300" height="172" alt="A cross section of Nigerian celebrities present at Rita Dominic's wedding in Owerri [SamuelSmith]" title="A cross section of Nigerian celebrities present at Rita Dominic's wedding in Owerri [SamuelSmith]" class="image lazyloaded" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/L2qktkpTURBXy9hMmQ2NDI2N2VkNGY2M2QzYjE1NDMwODY1NDcxYTY5OC5qcGeSlQMAPs0EOM0CYJMFzQEszKw" loading="lazy"></picture> 
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/entertainment/celebrities/joke-silva-ini-edo-uche-jombo-others-attend-rita-dominics-wedding/6pbh187"></a>
                        </div>
                    </div>
                </div>
            
        </div>
        
    </div>

                                        
                                            


    
        <div class="stickyWrapper" id="stickyWrapper" data-run-module="local/project.floatSticky" data-slot-name="/53159133/pliveke_dt_article_300x250_b3" data-slot-size="[[300, 600], [300, 250], [160, 600], [120, 600]]">
            <div class="first sticky-slot" id='div-gpt-ad-1617227699389-0'></div>
        </div>
    

                                        
                                    </div>
                                </div>
                            
                        
                    
                </div>
            </div>
        </div>
    </div>

    

    
    
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.pulselive.co.ke"},{"@type":"ListItem","position":2,"name":"Entertainment","item":"https://www.pulselive.co.ke/entertainment"},{"@type":"ListItem","position":3,"name":"Celebrities","item":"https://www.pulselive.co.ke/entertainment/celebrities"},{"@type":"ListItem","position":4,"name":"Diana Marua Bahati Clears Air On Beef With Mr Seeds Wife Nimo Gachuiri","item":"https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl"}]}
            </script>
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"NewsArticle","@id":"https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl#article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl"},"headline":"Diana Marua clears air on beef with Mr Seed's wife Nimo","primaryImageOfPage":{"@id":"https://www.pulselive.co.ke/entertainment/celebrities/diana-marua-bahati-clears-air-on-beef-with-mr-seeds-wife-nimo-gachuiri/3bemqsl#mainPhoto"},"image":["https://ocdn.eu/images/pulscms/Zjg7MDA_/bc514172a4334d4eeb98f0abf8ac1c37.png"],"datePublished":"2022-04-24T17:01:26.000+03:00","dateModified":"2022-04-24T17:01:26.000+03:00","author":[{"@type":"Person","name":"Amos Robi","url":"https://www.pulselive.co.ke/author/amos-robi","image":{"@type":"ImageObject","url":"https://ocdn.eu/images/pulscms/NTU7MDA_/7a38dfda6e520132112b4285b2baf7fc.jpg","height":424,"width":423}}],"publisher":{"@type":"Organization","name":"Pulselive Kenya","logo":{"@type":"ImageObject","url":"https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"}},"keywords":["Diana Marua, Diana B","Kevin Bahati","Nimo Gachuiri","2022 Elections Kenya","Mathare Valley"],"description":"Diana said she was in good terms with Nimo although they had not met in a long time","isAccessibleForFree":true}
            </script>
        
    



    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
            <div class="footer-widget-box footer-below-wrapper container">
                <div class="footer-widget-wrapper">
                    
    





    
        
    

    <script>
        window.dataLayer = window.dataLayer || [];

        const eventData = {
            event: 'pageload',
            articleAuthor: 'Amos Robi',
            articleCategory: 'entertainment',
        }

        window.addEventListener('load', function () {
            window.dataLayer.push(eventData);
        });
    </script>


    











<div class="africaFooter">
    <div class="container">
        
            <div class="advertiseFooterContainer">
                <div class="advertTitle">
                    Advertise with us
                </div>
                <div class="advertBody">
                    Reach out to us at <a style="color: #ff0" href="mailto:salesteam@pulse.co.ke" rel="noopener noreferrer">salesteam@pulse.co.ke</a> or +254113897895 to advertise with us. Find out more about Pulse's products and advertising opportunities at <a href="https://pulse.africa" target="_blank" style="color: #ff0" rel="noopener noreferrer"> pulse.africa</a>   
                </div>
            </div>
        

        <div class="footer-wrapper">
            

            
                <div class="footer-menu">
                    <ul class="footer-menu-list">
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Home" href="/">
                                            Home
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Entertainment" href="/entertainment">
                                            Entertainment
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Lifestyle" href="/lifestyle">
                                            Lifestyle
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Sports" href="/sports">
                                            Sports
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Business" href="/business">
                                            Business
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Quizzes" href="/quizzes">
                                            Quizzes
                                        </a>
                                    
                                </li>
                            
                        
                    </ul>
                </div>
            

            
                <div class="footer-links-wrapper" id="footer-links-menu">
                    <ul class="links-list">
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/about-us" title="About Us">
                                            About Us
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/about-us" title="About Us">
                                            About Us
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="https://pulse.africa" title="Advertise with us">
                                            Advertise with us
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/terms-of-use" title="Terms &amp; Conditions">
                                            Terms &amp; Conditions
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/privacy-policy" title="Privacy Policy">
                                            Privacy Policy
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/influencer-awards/get-ready-for-the-pulse-influencer-awards-2022/n1rbe34" title="Pulse Influencer Awards">
                                            Pulse Influencer Awards
                                        </a>
                                    
                                </li>
                            
                        
                    </ul>
                </div>
            

            
                <div class="socials-wrapper">
                    <ul id="socials" class="socials-wrapper-list">
                        
                            
                                <li class="socials-wrapper-item">
                                    <span class="footer-icon 0 " >
                                        
                                        Social
                                    </span>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 1 "  href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Facebook
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 2 "  href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Twitter
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 3 "  href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Instagram
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 4 "  href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Youtube
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 5 "  href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Tiktok
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 6 "  href="https://www.pulse.com.gh/newsletter" title="newsletter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/newsletter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/newsletter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="newsletter" title="newsletter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/img/footer/newsletter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Newsletter
                                    </a>
                                </li>
                            
                        
                    </ul>
                </div>
            
        </div>

        

        
    </div>
</div>

                </div>
            </div>
        
    </div>
</footer>



    



    <div id="customDimensionsCategories" data-categories="kenya/entertainment/celebrities"></div>

    <script>
        const categories = document.getElementById('customDimensionsCategories').dataset.categories;

        if (categories && typeof categories === "string" && categories.length > 0) {
            window.dataLayer = window.dataLayer || [];
            window.dataLayer.push({
                'content_categories': categories
            })
        }
    </script>


    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
    </div>
</footer>




<script src="//ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/js/menu.min.js"></script>


<script src="//ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build/js/css-variables-polyfill.umd.js"></script>


<script>
    const resourceBuildPath = "//ocdn.eu/ucs/static/UTheme/cefd3dbaefc4a978e3d72c7ad5fab445/build";

    
        const editStoryBookmarklet = "radp-ringier-africa-digital-publishing";
    
</script>

    
        <script type="text/javascript"> window._taboola = window._taboola || []; window._taboola.push( {flush: true} );  </script>
    
<script type='text/javascript' src='https://ssp.mediapal.net/www/delivery/spcjs.php?id=5'></script></body>
</html>

