




<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8"/><script>/* <![CDATA[ */ ringDataLayer = {"context":{"variant":{"accelerator":"d3d3LnB1bHNlbGl2ZS5jby5rZTo6UFJPRF9WMg=="},"publication_structure":{"root":"WWW_PULSELIVE_CO_KE","path":"NEWS/ARTICLE"},"id":{"aureus_offers":["n19e67avwg"]}},"content":{"object":{"type":"story","kind":"article","id":"752c1ec2-9ccb-45b5-925c-4f29853587cf"},"part":1,"publication":{"point":{"id":"k2bhgtt"}},"source":{"system":"ring_content_space","id":"7dd277c7-e647-489d-a0cd-8c305073a877"}}}; /* ]]> */</script><script>/* <![CDATA[ */ accConf = {"rum":{"tid":"EA-4719209","cookieInfo":0,"pageType":"HTML"},"gtm":{"id":["GTM-MGFD5X"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}}; /* ]]> */</script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<!-- End Google Tag Manager -->

    <meta name="viewport" content="width=device-width, initial-scale=1">
    













    <title>Insights from heated Senetor Ledama Olekina Enoch Wambua debate on News Night | Pulselive Kenya</title>





    <meta name="description" content="Ledama-Wambua clash on national TV provides insights into boardroom negotiations around Kenyas 2022 presidential election | Pulselive Kenya">



    
        
            <meta name="robots" content="index,follow">
        
    



    <link rel="canonical" href="https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt" />
     
        <link rel="amphtml" href="https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt.amp" />
    



    <meta name="ring-local-canonical" content="https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt" data-isExternal="false">



    <meta name="ring-global-lazyload-behavior" content="auto detect">



    <meta name="DC.Identifier" content="752c1ec2-9ccb-45b5-925c-4f29853587cf">





    <meta name="theme-color" content="#AC2723"/>



    <link rel="apple-touch-icon" href="https://ocdn.eu/radp/pwa/512x512.png">



    <link rel="manifest" href="/manifest.json"  crossorigin="use-credentials" >




    


    

    
        
        
        
        
        
        

        
            <meta property="og:title" content="Senators&#39; heated TV debate reveals unknown details of Kalonzo-Raila standoff" />
        

        
            <meta property="og:description" content="Ledama-Wambua clash on national TV provides insights into boardroom negotiations around Kenyas 2022 presidential election" />
        

        
            <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/ilZktkpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQSwzQJ2" />
        

        
            <meta property="og:image:width" content="1200" />
        

        
            <meta property="og:image:height" content="630" />
        

        
            <meta property="og:image:type" content="png"/>
        

        
            <meta property="og:image:alt" content="Narok Senator Ledama Olekina and Kitui Senator Enoch Wambua reveal unknown details of Kalonzo Musyoka-Raila Odinga stand-off in TV debate."/>
        

        
            <meta property="og:url" content="https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt" />
        

        
            <meta property="og:type" content="Article" />
        

        
            <meta property="og:site_name" content="Pulselive Kenya"/>
        

        
            <meta property="article:publisher" content="https://www.facebook.com/pulselivekenya"/>
        

        
            <meta property="og:locale" content="en_EN" />
        

        
            <meta property="og:updated_time" content="2022-03-02 14:29:46+0100" />

            
                <meta property="article:modified_time" content="2022-03-02 14:29:46+0100" />
            
        

        
            <meta property="article:published_time" content="2022-03-02 14:29:46+0100" />
        

        
            <meta property="article:section" content="news" />
        

        
            
                
                    <meta property="article:author" content="Miriam Mwende" />
                
            

            
                
                    <meta property="article:tag" content="LedamaOlekina" />
                
            
                
                    <meta property="article:tag" content="EnochWambua" />
                
            
                
                    <meta property="article:tag" content="MutulaKilonzoJr" />
                
            
                
                    <meta property="article:tag" content="WiperParty" />
                
            
                
                    <meta property="article:tag" content="ODM" />
                
            
        

        
            <meta name="twitter:card" content="summary_large_image">
            <meta name="twitter:image" content="https://ocdn.eu/pulscms-transforms/1/ilZktkpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQSwzQJ2">
        

        
            <meta property="twitter:title" content="Senators&#39; heated TV debate reveals unknown details of Kalonzo-Raila standoff" />
        

        
            <meta property="twitter:description" content="Ledama-Wambua clash on national TV provides insights into boardroom negotiations around Kenyas 2022 presidential election" />
        

        
            <meta property="fb:app_id" content="715603858641973" />
        

        
            <meta property="fb:pages" content="252006125219593" />
        

        
            <meta name="keywords" content="LedamaOlekina, EnochWambua, MutulaKilonzoJr, WiperParty, ODM" />
        
    


<meta name="facebook-utm_source" content="facebook"/>
<meta name="facebook-utm_medium" content="social"/>
<meta name="facebook-utm_campaign" content="share-button"/>
    







<link id="init-styles" href="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/styles/project-init/light.css" type="text/css" rel="stylesheet"/>


    
        
            
            
            
            
            

            
                
                    <link class="cssSwitcher" href="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/styles/project-Common/light.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          data-style-type="partial-style-project-Common"
                          data-theme-variant="true"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
                
                    <link class="cssSwitcher" href="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/styles/project-Detail/light.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          data-style-type="partial-style-project-Detail"
                          data-theme-variant="true"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
    

    
    <script>
    if ('serviceWorker' in navigator) {
        window.addEventListener('load', function () {
            navigator.serviceWorker.register('pwa-service-worker.js')
                .then(function (registration) {
                    
                }, function (err) {
                    
                });
        });
    }
</script>
    


<script data-static-amd-map="{&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/162d5140a65ebc0fa2e96da195a4eb9b/build&quot;,&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/fbc3bd59219c65f9c312840c9743c691/build&quot;,&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;adsinit&quot;:&quot;https://ty0lm9uz.onet.pl/e1BrazgxMTV9/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;pulsembed&quot;:&quot;https://pulsembed.eu/amd/1.0.6/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/js&quot;}">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</script>
    


<script>
    const schemaOrgItemList = {
        "@type": "ItemList",
        "itemListElement": []
    };
</script>

<noscript>
    <style>
        
        .image-wrapper{position:relative;display:inline-flex}.image-wrapper::after,.image-wrapper::before{background-image:var(--noscript-src);content:'';position:absolute;left:0;top:0;bottom:0;right:0;background-size:cover;background-repeat:no-repeat;background-position:center}
    </style>
</noscript>
    
        
    
















    <script>
        if (typeof dlApi === 'undefined') {
            dlApi = {
                async: 1,
                cookieInfo: '',
                no_gemius: 1,
                adsNoBanner: 1,
                noDfp: 1,
                mobile: 'false',
                target: '',
                tid: 'EA-4719209',
                DV: "pulselive_co_ke/main"
            }
        }
    </script>

    
        <script>
                dlApi = Object.assign(dlApi, {
                    kropka: {
                        DX: "PV,puls,k2bhgtt,7,a",
                        PU: "752c1ec2-9ccb-45b5-925c-4f29853587cf"
                    }
                });
        </script>
    


    


    
    
    
    
    
    
    

    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>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</script>


    
    
    
    

    <script defer src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
    <script>
        window.addEventListener('DOMContentLoaded', function() {
            Sailthru.init({ "customerId": "e3bb91358ab42ece773022042c6cfd66", "iscustom": true, "autoTrackPageview": false, "useStoredTags": false });
            Sailthru.track('pageview', {
                url: "https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt",
                tags: "news",
                onSuccess: function () {
                    
                },
                onError: function () {
                    
                }
            });
        });
    </script>


    
    
        
            <script type="text/javascript">var pulse2EmbedConfig = { pulsevideo: { player: "flowplayer", params: { autoplayNext: !0, enableAds: !1 }, plugins: [{ script: "https://imasdk.googleapis.com/js/sdkloader/ima3.js" }, { script: "https://embed.videos.ringpublishing.com/flowplayer/plugins/ads.min.js", config: { ima: { ads: [{ adTag: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", time: 0 }] } } }] }, OnettvVideo: { 'MAIN_ELEMENT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 }, 'INTEXT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 } } }</script>
        
    


    

    
    
        
            <script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[],function(){var t=document.createElement("script");t.async=!0,t.type="text/javascript";var e="https:"==document.location.protocol;t.src=(e?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(t,o)}();</script><script type='text/javascript'>googletag.cmd.push(function () { var o = window.location.pathname.split("/"); switch (o[1]) { case "": o[1] = "home" }void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1)); var e = token.length; if (document.location.hostname == 'www.pulse.ng') { googletag.pubads().setTargeting('PulseNG_URL', [token]); } if (document.location.hostname == 'www.pulse.sn') { googletag.pubads().setTargeting('PulseSN_URL', [token]); } if (document.location.hostname == 'www.pulse.com.gh') { googletag.pubads().setTargeting('PulseGH_URL', [token]); } if (document.location.hostname == 'www.pulselive.co.ke') { googletag.pubads().setTargeting('PliveKE_URL', [token]); } if (document.location.hostname == 'africa.businessinsider.com') { googletag.pubads().setTargeting('PulseBI_URL', [token]); } googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices() });</script><script type='text/javascript'>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];(function () {var gads = document.createElement('script');gads.async = true;gads.type = 'text/javascript';var useSSL = 'https:' == document.location.protocol;gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';var node = document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads, node);})();</script>
        
    


    

<script>if ("undefined" === typeof dlApi) { dlApi = {"target":"unknown/unknown","cookieInfo":"","no_gemius":1,"adsNoBanner":1,"noDfp":1,"tid":"EA-4719209"}; }</script>
<script src="https://lib.onet.pl/s.csr/build/dlApi/dl.boot.min.js" async></script>
</head>
<body class="articleDetail story-type-article css-project withRightColumn desktop  ">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->


    
    


    





<header id="main-page-header"  class="main-page-header " >
    <div class="header-lazy-wrapper" data-run-module="local/lazyLoad.run">
        
            <div class="header-widget-box header-above-wrapper">
                <div class="main-page-nav container">
                    
    










    <div class="menu-hamburger  hide-on-big-screens">
        <div class="menuToggle">
            <span></span>
            <span></span>
            <span></span>
        </div>
    </div>

    <div class="menu-mobile-container menu-hamburger" >
        <a class="main-page-logo"
           
           title="Pulselive Kenya"
           href="https://www.pulselive.co.ke/"
        >
            <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
        </a>
        <div class="menuToggleInside">
            <span></span>
            <span></span>
            <span></span>
        </div>
        <ul class="hamburger-list-items">
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="News" href="/news" >
                            News
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Politics" href="/news/politics">
                                            Politics
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/news/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="World" href="/news/world">
                                            World
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Entertainment" href="/entertainment" >
                            Entertainment
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                            Celebrities
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Music" href="/entertainment/music">
                                            Music
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                            Movies
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Lifestyle" href="/lifestyle" >
                            Lifestyle
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                            Fashion
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                            Beauty &amp; Health
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-and-weddings">
                                            Relationships &amp; Weddings
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                            Food, Travel, Arts &amp; Culture
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Sports" href="/sports" >
                            Sports
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Football" href="/sports/football">
                                            Football
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Football Stats" href="/sports/football/statistics">
                                            Football Stats
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="More" href="/sports/more">
                                            More
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Business" href="/business" >
                            Business
                        </a>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Quizzes" href="/quizzes" >
                            Quizzes
                        </a>
                        
                    </li>
                
                
            
        </ul>
    </div>


    

    






<div class="page-logo-wrapper ">
    <a class="main-page-logo"
       id="main-page-logo"
       title="Pulselive Kenya"
       href="https://www.pulselive.co.ke/"
    >
        <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
    </a>
</div>

    










    <ul class="main-page-nav menu-desktop menu-justify-center   hide-on-small-screens"
        
    >
        
            
                <li id="listMenuItem-0" class="menu-item  has-subMenu">
                    <a class="menu-title" title="News" href="/news" >
                        News
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Politics" href="/news/politics">
                                        Politics
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Local" href="/news/local">
                                        Local
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="World" href="/news/world">
                                        World
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-1" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Entertainment" href="/entertainment" >
                        Entertainment
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                        Celebrities
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Music" href="/entertainment/music">
                                        Music
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                        Movies
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-2" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Lifestyle" href="/lifestyle" >
                        Lifestyle
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                        Fashion
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                        Beauty &amp; Health
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-and-weddings">
                                        Relationships &amp; Weddings
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-3" class="submenu-item ">
                                    <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                        Food, Travel, Arts &amp; Culture
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-3" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Sports" href="/sports" >
                        Sports
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Football" href="/sports/football">
                                        Football
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Football Stats" href="/sports/football/statistics">
                                        Football Stats
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="More" href="/sports/more">
                                        More
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-4" class="menu-item  ">
                    <a class="menu-title" title="Business" href="/business" >
                        Business
                    </a>
                    
                </li>
            
        
            
                <li id="listMenuItem-5" class="menu-item  ">
                    <a class="menu-title" title="Quizzes" href="/quizzes" >
                        Quizzes
                    </a>
                    
                </li>
            
        
        
    </ul>


    
    <div class="headerSocials">
        <ul class="profileList">
            
                <li class="facebook">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.facebook.com/pulselivekenya"
                        title="Follow us on Facebook"
                        target="_blank"
                    >
                        facebook
                    </a>
                </li>
            
                <li class="twitter">
                    <a
                        rel="noopener noreferrer"
                        href="https://twitter.com/pulselivekenya"
                        title="Follow us on Twitter"
                        target="_blank"
                    >
                        twitter
                    </a>
                </li>
            
                <li class="instagram">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.instagram.com/pulselivekenya/"
                        title="Follow us on Instagram"
                        target="_blank"
                    >
                        instagram
                    </a>
                </li>
            
                <li class="youtube">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw"
                        title="Watch us on YouTube"
                        target="_blank"
                    >
                        youtube
                    </a>
                </li>
            
                <li class="tiktok">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.tiktok.com/@pulselivekenya"
                        title="Tiktok with us"
                        target="_blank"
                    >
                        tiktok
                    </a>
                </li>
            
        </ul>
    </div>


    

    

    

    

    

    






<div class="search-container-wrapper ">
    <div class="search-container" data-run-module="local/project.menu_search">
        <div id="search-button">
            <div class="svg icon-search" style="background-image:url(https://ocdn.eu/radp/icons/header/search.svg)"></div>
        </div>
        <form action="/search">
            <input type="search" placeholder="I’m looking for..." name="q" required data-placeholder-source="I’m looking for..." data-required-message="Please type your query and press search">
            <button type="submit">O</button>
        </form>
    </div>
</div>

                </div>
            </div>
        
        
        
            <div class="header-widget-box header-below-wrapper">
                <div class="main-page-nav container">
                    
    





                </div>
            </div>
        
    </div>
</header>

    

    <!-- AFRICA PROJECT - paid article flag test - START -->
    
    <!-- AFRICA PROJECT - paid article flag test - END -->

    <div class="page-container " data-run-module="local/lazyLoad.run">
        
            
            <div class="header-banner container-full">
                
                    


    
        <div class="adSlot " id='div-gpt-ad-1623221635248-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_970x90_a1" data-slot-size="[[728, 90], [970, 250], [970, 90]]" ></div>
    

                
            </div>
        
        <div class="container-full right-column-300">
            <div class="container">
                <div class="page-wrapper row">
                    <div id="article" class="main-section col-md-9">
                        <div class="articleBox ">
                            <div data-article-id="k2bhgtt">

                                
    

    
        <div class="container-wrapper ">
            

            
                <!-- LEFT content columns -->
                <section class="ring-grid-box-container ring-grid-container container ">
                    
                    <div class="row">
                        <div class="ring-grid-left-box col-sm-12 col-md-12 col-lg-12">
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1621854609633-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PliveKE_DT_Sticky_Footer" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1617224545705-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/plive_dt_floater" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                


    <div class="breadcrumbs-widget ">
        
            


    
        
            <a href="https://www.pulselive.co.ke/" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    <strong>
                        RADP / Pulse Kenya
                    </strong>
                </span>
            </a>

            
                <span class="breadcrumbs-item-sep">&nbsp;&gt;&nbsp;</span>
            
        
    
        
            <a href="https://www.pulselive.co.ke/news" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    
                        News
                    
                </span>
            </a>

            
        
    

        
    </div>

                            
                                






    
        
            <h1 class="article-headline ">
                <span>
                    
                        Senators&#39; heated TV debate reveals unknown details of Kalonzo-Raila standoff
                    
                </span>
            </h1>
        
    

                            
                                



    

    
        <div class="article-author-wrapper ">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/miriam-mwende" title="Miriam Mwende"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    

                                    
                                        <span class="author-name">Miriam Mwende</span>
                                    

                                    

                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                


    

    <div class="ring-detail-article-date ">
        
            <time class="detail-article-date date-type-publicationDate" datetime="2022-03-02T16:29:46.000+03:00">
                
                    March 2, 2022 4:29 PM
                
            </time>
        
    </div>

                            
                                
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
            
        
            
            
                <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
        
            
            
            
                <a href="mailto:?body=https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
            
            
            
            
            
        
    </div>

                            
                                







     <div id="lead" class="article-perex ">
          <p>Ledama-Wambua clash on national TV provides insights into boardroom negotiations around Kenya's 2022 presidential election</p>
     </div>

                            
                                
                            
                                












    <div class="article-gallery " >
            <div  class="image-container" id="article-main-image">
                
                <picture data-image-source="article_photo" data-caption="Narok Senator Ledama Olekina and Kitui Senator Enoch Wambua reveal unknown details of Kalonzo Musyoka-Raila Odinga stand-off in TV debate." style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/hibktkpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQMWzQGu); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/n0xk9kpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQMWzQGugaEwBQ" srcset="https://ocdn.eu/pulscms-transforms/1/n0xk9kpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQMWzQGugaEwBQ" type="image/webp"><img width="790" height="430" alt="Narok Senator Ledama Olekina and Kitui Senator Enoch Wambua reveal unknown details of Kalonzo Musyoka-Raila Odinga stand-off in TV debate." title="Narok Senator Ledama Olekina and Kitui Senator Enoch Wambua reveal unknown details of Kalonzo Musyoka-Raila Odinga stand-off in TV debate." src="https://ocdn.eu/pulscms-transforms/1/hibktkpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQMWzQGu" data-original="https://ocdn.eu/pulscms-transforms/1/hibktkpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQMWzQGu" class="image "></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/n0xk9kpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzQMWzQGugaEwBQ">
            </div>

        
            <div class="imgMetaData">
                
                    <span class="caption">Narok Senator Ledama Olekina and Kitui Senator Enoch Wambua reveal unknown details of Kalonzo Musyoka-Raila Odinga stand-off in TV debate.</span>
                

                
                

                

                

                <div class="clear"></div>
            </div>
        
    </div>

                            
                                
                            
                                
                            
                                




                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        A heated TV debate between Narok Senator Ledama Olekina and his Kitui counterpart Enoch Kiio Wambua on Tuesday night has introduced new details to the ongoing stand-off between Wiper leader Kalonzo Musyoka and the Azimio La Umoja presidential campaign, spearheaded by former Prime Minister Raila Odinga.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 inText" data-run-module="local/project.inText" id='div-gpt-ad-1618787017312-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/300x250_InReadAd_PliveKE" data-slot-size="[728, 90]" ></div>
    

                            
                                
                            
                                
    

    <div class="recommendedArticles">
        <span class="title">Recommended articles</span>
        <ul>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/63SktkpTURBXy84YzI1ZDdlYWQzY2Q4ZDYwNWNhYmI1MzYwOGY2MjAwYS5wbmeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/eahk9kpTURBXy84YzI1ZDdlYWQzY2Q4ZDYwNWNhYmI1MzYwOGY2MjAwYS5wbmeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="My dad was jailed for stealing Sh3 million from employer - Mwafreeka" title="My dad was jailed for stealing Sh3 million from employer - Mwafreeka" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/63SktkpTURBXy84YzI1ZDdlYWQzY2Q4ZDYwNWNhYmI1MzYwOGY2MjAwYS5wbmeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/entertainment">entertainment</a>
                        <a class="link"  data-uuid-ui="c0cb5906-fd38-49ff-9f23-40b92cdcd61b" data-ei="n19e67avwg" href="https://www.pulselive.co.ke/entertainment/celebrities/mwafreeka-narrates-how-his-father-was-jailed-for-stealing-sh3-million-from-employer/tz0mbdy">My dad was jailed for stealing Sh3 million from employer - Mwafreeka</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/qNdktkqTURBXy81ZDA2MmE3NTdmOGMyZmM3Y2IxNjU4NTFkMTc5OWRlZS5qcGVnkZMFRkY); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/W77k9kqTURBXy81ZDA2MmE3NTdmOGMyZmM3Y2IxNjU4NTFkMTc5OWRlZS5qcGVnkZMFRkaBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="South Africa's richest man Johann Rupert has lost over $1 billion due to Ukraine, Russia conflict" title="South Africa's richest man Johann Rupert has lost over $1 billion due to Ukraine, Russia conflict" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/qNdktkqTURBXy81ZDA2MmE3NTdmOGMyZmM3Y2IxNjU4NTFkMTc5OWRlZS5qcGVnkZMFRkY" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/international">international</a>
                        <a class="link"  data-uuid-ui="b31c5c32-7685-499b-a471-40b4f845bdca" data-ei="n19e67avwg" href="https://www.pulselive.co.ke/business/international/south-africas-richest-man-johann-rupert-has-lost-over-dollar1-billion-due-to-ukraine/250xy14">South Africa&#39;s richest man Johann Rupert has lost over $1 billion due to Ukraine, Russia conflict</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/HSxktkpTURBXy8zNjEyOWVkNDk1NmVhNWZlYzg5N2Q3YmUyZDA5OGJlOS5wbmeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/4Zck9kpTURBXy8zNjEyOWVkNDk1NmVhNWZlYzg5N2Q3YmUyZDA5OGJlOS5wbmeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="DP Ruto arrives in style at Karson Institute in the US [Video]" title="DP Ruto arrives in style at Karson Institute in the US [Video]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/HSxktkpTURBXy8zNjEyOWVkNDk1NmVhNWZlYzg5N2Q3YmUyZDA5OGJlOS5wbmeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/news">news</a>
                        <a class="link"  data-uuid-ui="9d0b830f-d1e8-4689-988a-8478cd7a5282" data-ei="n19e67avwg" href="https://www.pulselive.co.ke/news/dr-william-ruto-arrives-in-style-at-us-karson-institute-for-race-peace-and-social/p075xq0">DP Ruto arrives in style at Karson Institute in the US [Video]</a>
                    </div>
                </li>
            
        </ul>
    </div>

                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                            
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The debate hosted on <em>Citizen TV</em>'s <em>News Night</em> political talk show, centred on a confidential document signed by the Orange Democratic Movement (ODM) party leader where Mr Odinga admitted that the defunct National Super Alliance (NASA) coalition owed the Wiper Party, Sh87 million.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Citing it as the reason why <a href="https://www.pulselive.co.ke/news/odm-was-not-supposed-to-have-a-presidential-candidate-in-2022-kalonzo-musyoka/v6qjb1v" id="b146f7c9-b1ad-4154-bf5c-07f6291ccd8d">Mr Kalonzo took a hard stance</a> on joining forces with Mr Odinga in <a href="https://www.pulselive.co.ke/news/kenyan-2022-presidential-and-deputy-presidential-debates-showrunners-unveiled/yxfkc9v" id="d051e0aa-818b-4178-8231-5ce38c2d4b41">the 2022 presidential election</a>, Wiper party Vice-Chairperson Senator Mutula Kilonzo Jr conveyed that the Wiper party had only received Sh25 million of the amount stipulated.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-heading ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- heading: supported -->
    
    


    
    

    

    <h3 class="heading-h3 replaced-h1" id="nav-ring-4">
        Prof. Makau Mutua's hesitation in leaking memo
    </h3>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Asked why the Wiper party leader choose to make public the sensitive document, Senator Wambua stated that Professor Makau Mutua had been given two chances to disclose the information and hesitated.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-image ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- image: supported -->
    
    


    
    
    
    

    <div class="imageBlock aligment-center">
		<div>
			
                <span class="image-holder" data-fancybox="images-a1167cba-af7c-495f-9b06-f38d23f5b2cc" data-caption="Senator Enoch Wambua"  >
                    <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/8NqktkpTURBXy8wNzBjZmM1MjExNzRiNDJmYTczNGU0MjE4OTk3NGYwMS5qcGeRlQLNAxbNAlHCww); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/K4dk9kpTURBXy8wNzBjZmM1MjExNzRiNDJmYTczNGU0MjE4OTk3NGYwMS5qcGeRlQLNAxbNAlHCw4GhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'593'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="790" height="593" alt="Senator Enoch Wambua" title="Senator Enoch Wambua" class="image lazyloaded imgWithMetaData" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'593'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/8NqktkpTURBXy8wNzBjZmM1MjExNzRiNDJmYTczNGU0MjE4OTk3NGYwMS5qcGeRlQLNAxbNAlHCww" loading="lazy"></picture> 
                </span>
			
			<div class="imgMetaData">
				
                    <span class="caption">Senator Enoch Wambua</span>
                

                
                    <span class="description">Senator Enoch Wambua</span>
                

				
					<span class="copyright"> Pulse Live Kenya</span>
				
				<div class="clear"></div>
			</div>
		</div>
	</div>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>"An opportunity had been presented to the person who was supposed to reveal the details of that argument, twice. One time in my presence, and that did not happen. Both the principals who signed the document with my party leader and the depository of the agreement are in breach of the contents of the document and so my party leader was forced to make the document public,"</em> Wambua outlined.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-heading ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- heading: supported -->
    
    


    
    

    

    <h3 class="heading-h3 replaced-h1" id="nav-ring-8">
        ODM senator woos Kalonzo Musyoka
    </h3>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The Narok Senator's position on the matter seemed to irk those who followed the interview with a majority suggesting that Olekina may have underestimated Senator Wambua's wherewithal in political rhetoric.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        An online commentator identified as Collins Kibet remarked:<em> "Ledama had to even insult leaders who support Kalonzo. Anyway, yesterday's [March 1] discussion was less of facts and full of emotions."</em>
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-image ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- image: supported -->
    
    


    
    
    
    

    <div class="imageBlock aligment-center">
		<div>
			
                <span class="image-holder" data-fancybox="images-a88a7d32-84f7-42c5-8872-8e5a9c68e3d2" data-caption="Narok Senator Ledama Olekina"  >
                    <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/6MOktkpTURBXy9jOGE1ODJiNDZjNTUyYjJjMzQxYTlhZmM2NDQ0ZTc2Ny5qcGeRlQLNAu7NAfTCww); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/FBAk9kpTURBXy9jOGE1ODJiNDZjNTUyYjJjMzQxYTlhZmM2NDQ0ZTc2Ny5qcGeRlQLNAu7NAfTCw4GhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'750'%20height%3D'500'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="750" height="500" alt="Narok Senator Ledama Olekina" title="Narok Senator Ledama Olekina" class="image lazyloaded imgWithMetaData" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'750'%20height%3D'500'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/6MOktkpTURBXy9jOGE1ODJiNDZjNTUyYjJjMzQxYTlhZmM2NDQ0ZTc2Ny5qcGeRlQLNAu7NAfTCww" loading="lazy"></picture> 
                </span>
			
			<div class="imgMetaData">
				
                    <span class="caption">Narok Senator Ledama Olekina</span>
                

                
                    <span class="description">No matter what we do, Koitalel arap Samoei is winning - Ledama Ole Kina explains comment on new formula</span>
                

				
					<span class="copyright"> Pulse Live Kenya</span>
				
				<div class="clear"></div>
			</div>
		</div>
	</div>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Speaking as a member of <a href="https://www.pulselive.co.ke/news/video-of-edwin-sifuna-angry-exchange-with-police-during-odm-event-at-kasarani-stadium/j39vkv1" id="c5b54cf8-0fef-42b8-922d-dbf7b9380408">the Orange party</a>, Mr Ledama termed Kalonzo's political strategists as 'extremists'. He urged the former Vice President to discard their advice on the matter and to follow his conviction.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>"The honourable Kalonzo Musyoka is surrounded by a group of extremists... As I know him, he is a gentleman and he cares about this country... I think Enoch and his group are holding Kalonzo - a fine gentleman - hostage and the only ransom there is their re-election... So it's not about Kalonzo, it's about their aim," </em>Senator Olekina insisted.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-heading ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- heading: supported -->
    
    


    
    

    

    <h3 class="heading-h3 replaced-h1" id="nav-ring-14">
        Kalonzo Musyoka's Sh62 million decision
    </h3>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The details of the leaked document come at the height of ongoing renegotiations ahead of the 2022 presidential election, with Kalonzo being fronted as <a href="https://www.pulselive.co.ke/news/moses-kuria-officially-invited-to-join-one-kenya-alliance-gives-one-condition/8m6bz4l" id="18d213a9-ee07-46de-a4ff-6ac5faa9127f">a possible third-time running-mate for former PM</a> Odinga.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-image ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- image: supported -->
    
    


    
    
    
    

    <div class="imageBlock aligment-center">
		<div>
			
                <span class="image-holder" data-fancybox="images-072cbe99-67af-40c7-89ce-9a5d393c680c" data-caption="Wiper party leader Kalonzo Musyoka with President Uhuru Kenyatta during the Jubilee party NDC at KICC on February 26, 2022"  >
                    <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/J9jktkpTURBXy9lNzg3Y2Q2M2VjNjkyN2QwOTA3YTBlOGUwMjIyYWUzNy5wbmeRlQLNAxbNAxvCww); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/E6Qk9kpTURBXy9lNzg3Y2Q2M2VjNjkyN2QwOTA3YTBlOGUwMjIyYWUzNy5wbmeRlQLNAxbNAxvCw4GhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'795'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="790" height="795" alt="Wiper party leader Kalonzo Musyoka with President Uhuru Kenyatta during the Jubilee party NDC at KICC on February 26, 2022" title="Wiper party leader Kalonzo Musyoka with President Uhuru Kenyatta during the Jubilee party NDC at KICC on February 26, 2022" class="image lazyloaded imgWithMetaData" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'795'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/J9jktkpTURBXy9lNzg3Y2Q2M2VjNjkyN2QwOTA3YTBlOGUwMjIyYWUzNy5wbmeRlQLNAxbNAxvCww" loading="lazy"></picture> 
                </span>
			
			<div class="imgMetaData">
				
                    <span class="caption">Wiper party leader Kalonzo Musyoka with President Uhuru Kenyatta during the Jubilee party NDC at KICC on February 26, 2022</span>
                

                

				
					<span class="copyright"> Pulse Live Kenya</span>
				
				<div class="clear"></div>
			</div>
		</div>
	</div>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        A resolution to the stand-off is now hinged on the Sh62 million deficit, Wiper claims is rightfully owed to them, as per the details of the signed document.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>"Raila remains a brother with whom I've labored with in absolute good faith to bring true democratic change to our country. I am ready to work with him again, I urge that as we engage in fresh negotiations, this document forms the basis of such negotiations," </em>Kalonzo stated in a March 1 press address.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        With Azimio La Umoja and ODM luminaries taking the charm-offensive route with Kalonzo, the former VP's pending Sh62 million decision remains one of the closely watched developments around Kenya's 2022 presidential election.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <strong>Here are more reactions to the heated, and telling debate:-</strong>
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-embedded_application ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- embedded_application: supported -->
    
    


    
    
        <div class="embeddedApp"
            data-run-module="local/common.lazyEmbeds"
            data-embed="&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/re5Otmaf4/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;Frank%20Mtetezi%20(%CA%99%E1%B4%80%EA%9C%B0)%F0%9F%97%A8%EF%B8%8F%F0%9F%87%B0%F0%9F%87%AA\&quot; data-embed-id=\&quot;re5Otmaf4\&quot; data-provider-name=\&quot;Twitter\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://twitter.com/FrankMtetezi/status/1498745143146557440\&quot; target=\&quot;_blank\&quot;&gt;twitter.com&lt;/a&gt;&lt;/div&gt;\n&quot;">
                <div class="ringLoader">
                    <div class="topWrapper"></div>
                    <div class="bottomWrapper"></div>
                </div>
            
        </div>
    


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-embedded_application ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- embedded_application: supported -->
    
    


    
    
        <div class="embeddedApp"
            data-run-module="local/common.lazyEmbeds"
            data-embed="&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/HdCCu2s0v/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;Denis%20Kimutai\&quot; data-embed-id=\&quot;HdCCu2s0v\&quot; data-provider-name=\&quot;Twitter\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://twitter.com/DKN2030/status/1498914953096482817\&quot; target=\&quot;_blank\&quot;&gt;twitter.com&lt;/a&gt;&lt;/div&gt;\n&quot;">
                <div class="ringLoader">
                    <div class="topWrapper"></div>
                    <div class="bottomWrapper"></div>
                </div>
            
        </div>
    


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-embedded_application ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- embedded_application: supported -->
    
    


    
    
        <div class="embeddedApp"
            data-run-module="local/common.lazyEmbeds"
            data-embed="&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/JJcR_k2HR/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;Stephen%20Mutoro\&quot; data-embed-id=\&quot;JJcR_k2HR\&quot; data-provider-name=\&quot;Twitter\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://twitter.com/smutoro/status/1498758467519139846\&quot; target=\&quot;_blank\&quot;&gt;twitter.com&lt;/a&gt;&lt;/div&gt;\n&quot;">
                <div class="ringLoader">
                    <div class="topWrapper"></div>
                    <div class="bottomWrapper"></div>
                </div>
            
        </div>
    


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-embedded_application ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- embedded_application: supported -->
    
    


    
    
        <div class="embeddedApp"
            data-run-module="local/common.lazyEmbeds"
            data-embed="&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/iLCeK7fKE/\&quot; data-height-hint=\&quot;\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;King%20Luther%20%F0%9F%91%91\&quot; data-embed-id=\&quot;iLCeK7fKE\&quot; data-provider-name=\&quot;Twitter\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://twitter.com/naya_biggie/status/1498902128970055685\&quot; target=\&quot;_blank\&quot;&gt;twitter.com&lt;/a&gt;&lt;/div&gt;\n&quot;">
                <div class="ringLoader">
                    <div class="topWrapper"></div>
                    <div class="bottomWrapper"></div>
                </div>
            
        </div>
    


                                                
                                            
                                        </div>
                                    
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                

                            
                                
                            
                                



    <div class="taxonomies article-taxonomies ">
        
        <ul>
            
                <li>
                    
                        <a href="/topic/ledama-olekina" title="LedamaOlekina">
                    
                        LedamaOlekina
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/enochwambua" title="EnochWambua">
                    
                        EnochWambua
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/mutula-kilonzo-jr" title="MutulaKilonzoJr">
                    
                        MutulaKilonzoJr
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/wiper-party" title="WiperParty">
                    
                        WiperParty
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/odm" title="ODM">
                    
                        ODM
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/railaodinga" title="RailaOdinga">
                    
                        RailaOdinga
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/azimiolaumoja" title="AzimioLaUmoja">
                    
                        AzimioLaUmoja
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/kalonzo-musyoka" title="KalonzoMusyoka">
                    
                        KalonzoMusyoka
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/citizen-tv" title="CitizenTV">
                    
                        CitizenTV
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/professor-makau-mutua" title="MakauMutua">
                    
                        MakauMutua
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/2022-elections-kenya" title="2022ElectionsKE">
                    
                        2022ElectionsKE
                    
                        </a>
                    
                </li>
            
        </ul>
    </div>

                            
                                



    

    
        <div class="article-author-wrapper  authorWithImage">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/miriam-mwende" title="Miriam Mwende"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    
                                        <span class="author-photo">
                                            

                                            

                                            <picture data-image-source="article-author" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/3DnktkqTURBXy82MTg5NTQ2MzMyZjg4Njc2MmQxYjhhMDRhMjBjMGRjNi5qcGVnkpUDAADNAlnNAyCTBUZG); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/Zksk9kqTURBXy82MTg5NTQ2MzMyZjg4Njc2MmQxYjhhMDRhMjBjMGRjNi5qcGVnkpUDAADNAlnNAyCTBUZGgaEwBQ" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Miriam Mwende" title="Miriam Mwende" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/3DnktkqTURBXy82MTg5NTQ2MzMyZjg4Njc2MmQxYjhhMDRhMjBjMGRjNi5qcGVnkpUDAADNAlnNAyCTBUZG" class="image lazyloaded" loading="lazy"></picture> 
                                        </span>
                                    

                                    

                                    

                                    
                                
                                    

                                    
                                        <span class="author-name">Miriam Mwende</span>
                                    

                                    

                                    
                                
                                    

                                    

                                    

                                    
                                        <span class="author-description">Aspiring thought leader. Politics, media, and culture enthusiast. Believer in the power of journalism as an instrument for change. #IAmForJournalists</span>
                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
            
        
            
            
                <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
        
            
            
            
                <a href="mailto:?body=https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
            
            
            
            
            
        
            
            
            
            
                <a href="whatsapp://send?text=https%3A%2F%2Fwww.pulselive.co.ke%2Fnews%2Finsights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night%2Fk2bhgtt?utm_medium%3Dsocial%26utm_source%3Dwhatsapp%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-whatsapp " data-gtm-social="whatsapp" title="WhatsApp" style="width: 30px; height: 30px"></a>
            
            
            
            
        
            
            
            
            
            
                <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt?utm_medium%3Dsocial%26utm_source%3Dlinkedin%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-linkedin " data-gtm-social="linkedin" target="_blank" title="LinkedIn" style="width: 30px; height: 30px"></a>
            
            
            
        
    </div>

                            
                                


    <div class="basicWidget homepageNewsletter">
        <div class="bw-wrapper">
        
            <h3 class="main-section-title">JOIN OUR PULSE COMMUNITY!</h3>
        
            <div class="newsletterWrapper">
                <div class="socialList">
                    
                        <div class="socialIcon facebook">
                            
                                <a href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon twitter">
                            
                                <a href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon instagram">
                            
                                <a href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon youtube">
                            
                                <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon tiktok">
                            
                                <a href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                </div>
                <div id="nlbox" class="newsletter dsk ">
                    <div class="signUpContainer">
                        <div class="introMessage">
                            Our newsletter gives you access to a curated selection of the most important stories daily.
                        </div>
                        <form id="newsletter-form" method="POST" class="inputForm" action="#" data-run-module="local/project.newsletter_submit">
                            <input type="email" placeholder="Email" name="email" id="email" required>
                            <button id="submitEmail" class="submit ">
                                SUBSCRIBE
                            </button>
                        </form>
                    </div>
                    <div id="error" class="error hide"></div>
                    <div id="thanksContainer" class="thanksContainer hide">
                        <div class="row" id="thanksMessage">
                            <p class="subTitle"> Welcome to the Pulse Community! We will now be sending you a daily newsletter on news, entertainment and more.   Also join us across all of our other channels - we love to be connected!</p>
                        </div>
                    </div>
                </div>
                
                    <div></div>
                    <div id="pushBox" class="pushContainer " data-run-module="local/project.push_notification">
                        <div class='onesignal-customlink-container'></div>
                        <div class="blockedText" id="pushBlocked">Unblock notifications in browser settings.</div>
                    </div>
                
            </div>
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 " id='div-gpt-ad-1618841981942-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PulseKE_DT_Article_Below_Article_A" data-slot-size="[728, 90]" ></div>
    

                            
                                
    
        
            <div class="eyewitnessWdg" style="margin-top: 25px;">    <p>Eyewitness? Submit your stories now via social or: </p>    <p>    <b>Email: </b><a href="mailto:news@pulselive.co.ke">news@pulselive.co.ke</a></b></p></div>
        
    

                            
                                



    

    <div class="basicWidget hp-colSize-12 latest bw-v2"
        style=""
        
        
        >

        <div class="bw-wrapper">
             

            
                


    <h2 class="main-section-title">

    
    
        
    

    
        Recommended articles
    

    </h2>

            
                
    <div class="section-elements">
        <div class="items-wrapper columns-3 big-elements-0" >
        

            
            
            

            <div class="layout-wrapper wrap-element-1 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/bfDktkpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/afBk9kpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Senators' heated TV debate reveals unknown details of Kalonzo-Raila standoff" title="Senators' heated TV debate reveals unknown details of Kalonzo-Raila standoff" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/bfDktkpTURBXy8wYTk5OWY1ODkxZjMyNDZiNzQxODQ2NmZhMmI1YzVkYS5wbmeSlQMAEs0CWM0BUZMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Senators&#39; heated TV debate reveals unknown details of Kalonzo-Raila standoff
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt" title="Senators&#39; heated TV debate reveals unknown details of Kalonzo-Raila standoff"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-2 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/5yIktkpTURBXy9mMWFjMTYxY2Q0MjQyNDAyODljMTdlZDg2ZDUxOWUxOC5qcGeSlQMAOM0CDs0BKJMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/niXk9kpTURBXy9mMWFjMTYxY2Q0MjQyNDAyODljMTdlZDg2ZDUxOWUxOC5qcGeSlQMAOM0CDs0BKJMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Police launch manhunt for woman after husband's murder in Molo" title="Police launch manhunt for woman after husband's murder in Molo" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/5yIktkpTURBXy9mMWFjMTYxY2Q0MjQyNDAyODljMTdlZDg2ZDUxOWUxOC5qcGeSlQMAOM0CDs0BKJMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Police launch manhunt for woman after husband&#39;s murder in Molo
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/police-launch-manhunt-of-woman-who-killed-her-husband-in-molo/72v20d0" title="Police launch manhunt for woman after husband&#39;s murder in Molo"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-3 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/2AvktkpTURBXy8zMWM0YjhkMDAyMGRmN2YxY2IwOWQ5YzcwYWQ2NmJiMy5qcGeSlQMAK80C2M0BmZMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/ptJk9kpTURBXy8zMWM0YjhkMDAyMGRmN2YxY2IwOWQ5YzcwYWQ2NmJiMy5qcGeSlQMAK80C2M0BmZMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Sonko calls for justice after house-help was accused of child's death" title="Sonko calls for justice after house-help was accused of child's death" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/2AvktkpTURBXy8zMWM0YjhkMDAyMGRmN2YxY2IwOWQ5YzcwYWQ2NmJiMy5qcGeSlQMAK80C2M0BmZMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Sonko calls for justice after house-help was accused of child&#39;s death
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/house-help-maureen-nyaboke-accused-of-baby-andy-death-mike-sonko-calls-for-justice/4xdvl24" title="Sonko calls for justice after house-help was accused of child&#39;s death"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-4 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/HBHktkpTURBXy8zNjEyOWVkNDk1NmVhNWZlYzg5N2Q3YmUyZDA5OGJlOS5wbmeSlQMAEs0Bq8zwkwXM88yI); "><source data-original="https://ocdn.eu/pulscms-transforms/1/wvyk9kpTURBXy8zNjEyOWVkNDk1NmVhNWZlYzg5N2Q3YmUyZDA5OGJlOS5wbmeSlQMAEs0Bq8zwkwXM88yIgaEwBQ" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="DP Ruto arrives in style at Karson Institute in the US [Video]" title="DP Ruto arrives in style at Karson Institute in the US [Video]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/HBHktkpTURBXy8zNjEyOWVkNDk1NmVhNWZlYzg5N2Q3YmUyZDA5OGJlOS5wbmeSlQMAEs0Bq8zwkwXM88yI" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            DP Ruto arrives in style at Karson Institute in the US [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/dr-william-ruto-arrives-in-style-at-us-karson-institute-for-race-peace-and-social/p075xq0" title="DP Ruto arrives in style at Karson Institute in the US [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-5 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/NdDktkpTURBXy9jYjgzNGE0YzRhYWNkYzA5ZDIyNWUyMTRkMzUzNzc5OC5qcGeSlQN6Vs0CX80BVpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/h35k9kpTURBXy9jYjgzNGE0YzRhYWNkYzA5ZDIyNWUyMTRkMzUzNzc5OC5qcGeSlQN6Vs0CX80BVpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="2022 Presidential Debates showrunners unveiled " title="2022 Presidential Debates showrunners unveiled " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/NdDktkpTURBXy9jYjgzNGE0YzRhYWNkYzA5ZDIyNWUyMTRkMzUzNzc5OC5qcGeSlQN6Vs0CX80BVpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            2022 Presidential Debates showrunners unveiled 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/kenyan-2022-presidential-and-deputy-presidential-debates-showrunners-unveiled/yxfkc9v" title="2022 Presidential Debates showrunners unveiled "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-6 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/HaVktkpTURBXy8xMTE2N2Y3NDgxNWJjNDYyNTI5MWI3YWZjNTM4ZGE1Mi5wbmeSlQMAAM0DTc0B25MFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/Uyhk9kpTURBXy8xMTE2N2Y3NDgxNWJjNDYyNTI5MWI3YWZjNTM4ZGE1Mi5wbmeSlQMAAM0DTc0B25MFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="GSU graduates behind viral video sent on leave after 3-month retraining" title="GSU graduates behind viral video sent on leave after 3-month retraining" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/HaVktkpTURBXy8xMTE2N2Y3NDgxNWJjNDYyNTI5MWI3YWZjNTM4ZGE1Mi5wbmeSlQMAAM0DTc0B25MFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            GSU graduates behind viral video sent on leave after 3-month retraining
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/gsu-graduates-behind-viral-threats-video-sent-on-leave-after-three-month-retraining/07n258j" title="GSU graduates behind viral video sent on leave after 3-month retraining"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-7 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/uirktkpTURBXy9hY2YxMTEyMWMyNDk4NTVkYjkzYjM4ZGQwY2FjOTUzZS5qcGeSlQMAEM0CDM0BJpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/ANIk9kpTURBXy9hY2YxMTEyMWMyNDk4NTVkYjkzYjM4ZGQwY2FjOTUzZS5qcGeSlQMAEM0CDM0BJpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Ruto appoints former CS as new Chief of Staff" title="Ruto appoints former CS as new Chief of Staff" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/uirktkpTURBXy9hY2YxMTEyMWMyNDk4NTVkYjkzYjM4ZGQwY2FjOTUzZS5qcGeSlQMAEM0CDM0BJpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Ruto appoints former CS as new Chief of Staff
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/dp-ruto-appoints-former-cs-davis-chichir-as-new-chief-of-staff/pg8z2wt" title="Ruto appoints former CS as new Chief of Staff"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-8 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/OPNktkpTURBXy83YTg0ZDg4NDgxNDEwMTM2M2ZjZDE3MWFkNDIwMGIyYS5qcGeSlQPMiADNBJPNApOTBczzzIg); "><source data-original="https://ocdn.eu/pulscms-transforms/1/i6vk9kpTURBXy83YTg0ZDg4NDgxNDEwMTM2M2ZjZDE3MWFkNDIwMGIyYS5qcGeSlQPMiADNBJPNApOTBczzzIiBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Mixed reactions as court orders 50-year jail term for transporting marijuana" title="Mixed reactions as court orders 50-year jail term for transporting marijuana" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/OPNktkpTURBXy83YTg0ZDg4NDgxNDEwMTM2M2ZjZDE3MWFkNDIwMGIyYS5qcGeSlQPMiADNBJPNApOTBczzzIg" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Mixed reactions as court orders 50-year jail term for transporting marijuana
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/wajir-court-hands-mohammed-oloo-and-abraham-hassan-50-years-in-jail-over-bhang/hg00whp" title="Mixed reactions as court orders 50-year jail term for transporting marijuana"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-9 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/qVfktkpTURBXy8yNWRlMzUzNmI5NGMwYTMxZGZkMTQxNzJlMjg3ZDJlMS5qcGeSlQMADc0DhM0B-pMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/JYOk9kpTURBXy8yNWRlMzUzNmI5NGMwYTMxZGZkMTQxNzJlMjg3ZDJlMS5qcGeSlQMADc0DhM0B-pMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Woman who survived knife attack by ex-lover stabbed to death by new husband " title="Woman who survived knife attack by ex-lover stabbed to death by new husband " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/qVfktkpTURBXy8yNWRlMzUzNmI5NGMwYTMxZGZkMTQxNzJlMjg3ZDJlMS5qcGeSlQMADc0DhM0B-pMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Woman who survived knife attack by ex-lover stabbed to death by new husband 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/damackline-bonareri-survived-knife-attack-only-to-be-stabbed-to-death-in-2nd-marriage/z3sbkmz" title="Woman who survived knife attack by ex-lover stabbed to death by new husband "></a>
    </div>

                        
                    
                </div>

                
            </div>
        
        </div>
    </div>

            
        </div>
    </div>

                            
                                
                            
                        </div>
                    </div>
                </section>
            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    


                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                            </div>
                        </div>

                        
                    </div>

                    
                        
                            
                                
                                <div class="side-section col-md-3" id="content-side-section">
                                    <div>
                                        
                                            


    
        <div class="adSlot placeholder-600 mt-4 " id='div-gpt-ad-1617227624691-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_300x250_b1" data-slot-size="[[300, 250], [300, 600], [160, 600], [120, 600]]" ></div>
    

                                        
                                            


    <div class="widget-trending basicWidget ">
        
            <h2 class="main-section-title">
                Trending
            </h2>
        

        
        <div class="widget-trending-items">
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    NTSA announces crackdown on all motorists countrywide
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/1j3ktkpTURBXy9hMThlODFiN2IxZTU5Mjg4YzQ5ZDlhZjVkYzY2YzMxZS5qcGeSlQMAH80D6M0CMpMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/t7qk9kpTURBXy9hMThlODFiN2IxZTU5Mjg4YzQ5ZDlhZjVkYzY2YzMxZS5qcGeSlQMAH80D6M0CMpMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/t7qk9kpTURBXy9hMThlODFiN2IxZTU5Mjg4YzQ5ZDlhZjVkYzY2YzMxZS5qcGeSlQMAH80D6M0CMpMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="NTSA officers in a car" title="NTSA officers in a car" class="image " src="https://ocdn.eu/pulscms-transforms/1/1j3ktkpTURBXy9hMThlODFiN2IxZTU5Mjg4YzQ5ZDlhZjVkYzY2YzMxZS5qcGeSlQMAH80D6M0CMpMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/1j3ktkpTURBXy9hMThlODFiN2IxZTU5Mjg4YzQ5ZDlhZjVkYzY2YzMxZS5qcGeSlQMAH80D6M0CMpMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/t7qk9kpTURBXy9hMThlODFiN2IxZTU5Mjg4YzQ5ZDlhZjVkYzY2YzMxZS5qcGeSlQMAH80D6M0CMpMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/ntsa-announces-crackdown-on-all-motorists-countrywide-for-all-traffic-offences/bl25q3d"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Uhuru says he&#39;ll support DP Ruto under one condition
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/TxSktkpTURBXy8wZjMzM2NmYTI2MzZmYzUwNDc5ZTk4Y2E4Zjc0MDljZC5qcGeSlQMAMs0DVc0B35MFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/Wflk9kpTURBXy8wZjMzM2NmYTI2MzZmYzUwNDc5ZTk4Y2E4Zjc0MDljZC5qcGeSlQMAMs0DVc0B35MFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/Wflk9kpTURBXy8wZjMzM2NmYTI2MzZmYzUwNDc5ZTk4Y2E4Zjc0MDljZC5qcGeSlQMAMs0DVc0B35MFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="President Uhuru Kenyatta speakign at Sagana State Lodge" title="President Uhuru Kenyatta speakign at Sagana State Lodge" class="image " src="https://ocdn.eu/pulscms-transforms/1/TxSktkpTURBXy8wZjMzM2NmYTI2MzZmYzUwNDc5ZTk4Y2E4Zjc0MDljZC5qcGeSlQMAMs0DVc0B35MFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/TxSktkpTURBXy8wZjMzM2NmYTI2MzZmYzUwNDc5ZTk4Y2E4Zjc0MDljZC5qcGeSlQMAMs0DVc0B35MFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/Wflk9kpTURBXy8wZjMzM2NmYTI2MzZmYzUwNDc5ZTk4Y2E4Zjc0MDljZC5qcGeSlQMAMs0DVc0B35MFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/key-highlights-in-president-uhuru-kenyatta-speech-at-sagana-state-lodge-february-23/tjeqt00"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Al-Shabaab can hit planes at low altitudes, US warns Kenyans
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/IMHktkpTURBXy8wMGYwYTMzYjU2OGNkYWY4MjY5NjcxNzliMTBjNjk4MS5qcGeSlQMAH80EAM0CQJMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/P0Ck9kpTURBXy8wMGYwYTMzYjU2OGNkYWY4MjY5NjcxNzliMTBjNjk4MS5qcGeSlQMAH80EAM0CQJMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/P0Ck9kpTURBXy8wMGYwYTMzYjU2OGNkYWY4MjY5NjcxNzliMTBjNjk4MS5qcGeSlQMAH80EAM0CQJMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="TOPSHOT - A Somali soldier holds a machine gun at Sanguuni military base, where an American special operations soldier was killed by a mortar attack on June 8, about 450 km south of Mogadishu, Somalia, on June 13, 2018. (MOHAMED ABDIWAHAB/AFP via Getty Images)" title="TOPSHOT - A Somali soldier holds a machine gun at Sanguuni military base, where an American special operations soldier was killed by a mortar attack on June 8, about 450 km south of Mogadishu, Somalia, on June 13, 2018. (MOHAMED ABDIWAHAB/AFP via Getty Images)" class="image " src="https://ocdn.eu/pulscms-transforms/1/IMHktkpTURBXy8wMGYwYTMzYjU2OGNkYWY4MjY5NjcxNzliMTBjNjk4MS5qcGeSlQMAH80EAM0CQJMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/IMHktkpTURBXy8wMGYwYTMzYjU2OGNkYWY4MjY5NjcxNzliMTBjNjk4MS5qcGeSlQMAH80EAM0CQJMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/P0Ck9kpTURBXy8wMGYwYTMzYjU2OGNkYWY4MjY5NjcxNzliMTBjNjk4MS5qcGeSlQMAH80EAM0CQJMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/us-warns-al-shabaab-is-targeting-kenyan-airspace/jfg4mty"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Milly Nafula gets furnished house, Sh3.5M university scholarship
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/c4jktkpTURBXy9hN2U2OTAzOGIxMTU2MWFmMmIwODcyYWYyNzMyNmRmMy5qcGeSlQMpAM0Dg80B-pMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/Tb6k9kpTURBXy9hN2U2OTAzOGIxMTU2MWFmMmIwODcyYWYyNzMyNmRmMy5qcGeSlQMpAM0Dg80B-pMFzQEszKyBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="300" height="172" alt="Prof. Gicharu handing house to Milly Nafula Photo/Jared Nyataya NMG" title="Prof. Gicharu handing house to Milly Nafula Photo/Jared Nyataya NMG" class="image lazyloaded" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/c4jktkpTURBXy9hN2U2OTAzOGIxMTU2MWFmMmIwODcyYWYyNzMyNmRmMy5qcGeSlQMpAM0Dg80B-pMFzQEszKw" loading="lazy"></picture> 
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/milly-nafula-gets-sh3-million-scholarship-to-study-medicine-at-mount-kenya-university/ffmnrjb"></a>
                        </div>
                    </div>
                </div>
            
        </div>
        
    </div>

                                        
                                            


    
        <div class="stickyWrapper" id="stickyWrapper" data-run-module="local/project.floatSticky" data-slot-name="/53159133/pliveke_dt_article_300x250_b3" data-slot-size="[[300, 600], [300, 250], [160, 600], [120, 600]]">
            <div class="first sticky-slot" id='div-gpt-ad-1617227699389-0'></div>
        </div>
    

                                        
                                    </div>
                                </div>
                            
                        
                    
                </div>
            </div>
        </div>
    </div>

    

    
    
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.pulselive.co.ke"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.pulselive.co.ke/news"},{"@type":"ListItem","position":3,"name":"Insights From Heated Senetor Ledama Olekina Enoch Wambua Debate On News Night","item":"https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt"}]}
            </script>
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"NewsArticle","@id":"https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt#article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt"},"headline":"Senators' heated TV debate reveals unknown details of Kalonzo-Raila standoff","primaryImageOfPage":{"@id":"https://www.pulselive.co.ke/news/insights-from-heated-senetor-ledama-olekina-enoch-wambua-debate-on-news-night/k2bhgtt#mainPhoto"},"image":["http://ocdn.eu/images/pulscms/NTI7MDA_/0a999f5891f3246b7418466fa2b5c5da.png"],"datePublished":"2022-03-02T16:29:46.000+03:00","dateModified":"2022-03-02T16:29:46.000+03:00","author":[{"@type":"Person","name":"Miriam Mwende","url":"https://www.pulselive.co.ke/author/miriam-mwende"}],"publisher":{"@type":"Organization","name":"Pulselive Kenya","logo":{"@type":"ImageObject","url":"https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"}},"keywords":["Ledama Olekina","EnochWambua","Mutula Kilonzo Jr","Wiper Party","ODM","RailaOdinga","AzimioLaUmoja","Kalonzo Musyoka","Citizen TV","Professor Makau Mutua","2022 Elections Kenya"],"description":"Ledama-Wambua clash on national TV provides insights into boardroom negotiations around Kenyas 2022 presidential election","isAccessibleForFree":true}
            </script>
        
    



    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
            <div class="footer-widget-box footer-below-wrapper container">
                <div class="footer-widget-wrapper">
                    
    
    <div class="africaFooter">
        <div class="container" >
            
                <div class="advertiseFooterContainer">
                    <div class="advertTitle">
                        Advertise with us
                    </div>
                    <div class="advertBody">
                        Reach out to us at <a style="color: #ff0" href="mailto:salesteam@pulse.co.ke" rel="noopener noreferrer">salesteam@pulse.co.ke</a> or +254113897895 to advertise with us. Find out more about Pulse's products and advertising opportunities at <a href="https://pulse.africa" target="_blank" style="color: #ff0" rel="noopener noreferrer"> pulse.africa</a>   
                    </div>
                </div>
            
            <div class="footer-wrapper">
                
                
                <div class="footer-menu">
                    <ul class="footer-menu-list">
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Home" href="/">
                                Home
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="News" href="/news">
                                News
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Entertainment" href="/entertainment">
                                Entertainment
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Lifestyle" href="/lifestyle">
                                Lifestyle
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Sports" href="/sports">
                                Sports
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Business" href="/business">
                                Business
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Quizzes" href="/quizzes">
                                Quizzes
                            </a>
                            
                        </li>
                        
                    </ul>
                </div>
                

                
                <div class="footer-links-wrapper" id="footer-links-menu">
                    <ul class="links-list">
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/about-us" title="About us">
                                About us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/about-us" title="About us">
                                About us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://pulse.africa" title="Advertise with us">
                                Advertise with us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/terms-of-use/d1z0r3q" title="Terms &amp; Conditions">
                                Terms &amp; Conditions
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/privacy-policy-pulselivecoke/vh9gdmy" title="Privacy Policy">
                                Privacy Policy
                            </a>
                            
                        </li>
                        
                        
                    </ul>
                </div>
                

                
                <div class="socials-wrapper">
                    <ul id="socials" class="socials-wrapper-list">
                        
                            
                                <li class="socials-wrapper-item">
                                    <span class="footer-icon 0 " >
                                        
                                        Social
                                    </span>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 1 "  href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Facebook
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 2 "  href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Twitter
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 3 "  href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Instagram
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 4 "  href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Youtube
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 5 "  href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Tiktok
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 6 "  href="https://www.pulse.com.gh/newsletter" title="newsletter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/newsletter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/newsletter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="newsletter" title="newsletter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/newsletter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Newsletter
                                    </a>
                                </li>
                            
                        
                    </ul>
                </div>
                
            </div>

            

            
                
                <div class="disclaimer-text">
                    
                        
                            <p class="footer-description-copyrightsInfo"> &copy; 2022 pulselive.co.ke</p>
                        
                    
                </div>
            
        </div>
    </div>


                </div>
            </div>
        
    </div>
</footer>



    



    <div id="customDimensionsCategories" data-categories="kenya/news"></div>

    <script>
        const categories = document.getElementById('customDimensionsCategories').dataset.categories;

        if (categories && typeof categories === "string" && categories.length > 0) {
            window.dataLayer = window.dataLayer || [];
            window.dataLayer.push({
                'content_categories': categories
            })
        }
    </script>


    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
    </div>
</footer>




<script src="//ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/js/menu.min.js"></script>

<script>
    const resourceBuildPath = "//ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build";

    
        const editStoryBookmarklet = "radp-ringier-africa-digital-publishing";
    
</script>

    
        <script type="text/javascript"> window._taboola = window._taboola || []; window._taboola.push( {flush: true} );  </script>
    
<script type='text/javascript' src='https://ssp.mediapal.net/www/delivery/spcjs.php?id=5'></script></body>
</html>

