




<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8"/><script>/* <![CDATA[ */ ringDataLayer = {"context":{"variant":{"accelerator":"d3d3LnB1bHNlbGl2ZS5jby5rZTo6UFJPRF9WMl9C"},"publication_structure":{"root":"WWW_PULSELIVE_CO_KE","path":"NEWS/ARTICLE"},"id":{"aureus_offers":["j9rjjzdhvw"]}},"content":{"object":{"type":"story","kind":"article","id":"d272758c-7ed3-49c3-befc-a2fbaae40d0b"},"part":1,"publication":{"point":{"id":"6cwekd5"}},"source":{"system":"ring_content_space","id":"7dd277c7-e647-489d-a0cd-8c305073a877"}}}; /* ]]> */</script><script>/* <![CDATA[ */ accConf = {"rum":{"tid":"EA-4719209","cookieInfo":0,"pageType":"HTML"},"gtm":{"id":["GTM-MGFD5X"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}}; /* ]]> */</script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<!-- End Google Tag Manager -->

    <meta name="viewport" content="width=device-width, initial-scale=1">
    













    <title>Jimi Wanjigi responds to DCI's order to surrender firearms | Pulselive Kenya</title>





    <meta name="description" content="Wanjigi maintained that he would not be cowed to drop his presidential bid.  | Pulselive Kenya">



    
        
            <meta name="robots" content="index,follow">
        
    



    <link rel="canonical" href="https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5" />
     
        <link rel="amphtml" href="https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5.amp" />
    



    <meta name="ring-local-canonical" content="https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5" data-isExternal="false">



    <meta name="ring-global-lazyload-behavior" content="auto detect">



    <meta name="DC.Identifier" content="d272758c-7ed3-49c3-befc-a2fbaae40d0b">





    <meta name="theme-color" content="#AC2723"/>



    <link rel="apple-touch-icon" href="https://ocdn.eu/radp/pwa/512x512.png">



    <link rel="manifest" href="/manifest.json"  crossorigin="use-credentials" >




    


    

    
        
        
        
        
        
        

        
            <meta property="og:title" content="Wanjigi responds to DCI&#39;s order to surrender firearms" />
        

        
            <meta property="og:description" content="Wanjigi maintained that he would not be cowed to drop his presidential bid" />
        

        
            <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/Pf_ktkpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQSwzQJ2" />
        

        
            <meta property="og:image:width" content="1200" />
        

        
            <meta property="og:image:height" content="630" />
        

        
            <meta property="og:image:type" content="jpg"/>
        

        
            <meta property="og:image:alt" content="Jimi Wanjigi responds to DCI&#39;s order to surrender firearms"/>
        

        
            <meta property="og:url" content="https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5" />
        

        
            <meta property="og:type" content="Article" />
        

        
            <meta property="og:site_name" content="Pulselive Kenya"/>
        

        
            <meta property="article:publisher" content="https://www.facebook.com/pulselivekenya"/>
        

        
            <meta property="og:locale" content="en_EN" />
        

        
            <meta property="og:updated_time" content="2022-02-22 12:06:15+0100" />

            
                <meta property="article:modified_time" content="2022-02-22 12:06:15+0100" />
            
        

        
            <meta property="article:published_time" content="2022-02-22 12:06:15+0100" />
        

        
            <meta property="article:section" content="news" />
        

        
            
                
                    <meta property="article:author" content="Denis Mwangi" />
                
            

            
        

        
            <meta name="twitter:card" content="summary_large_image">
            <meta name="twitter:image" content="https://ocdn.eu/pulscms-transforms/1/Pf_ktkpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQSwzQJ2">
        

        
            <meta property="twitter:title" content="Wanjigi responds to DCI&#39;s order to surrender firearms" />
        

        
            <meta property="twitter:description" content="Wanjigi maintained that he would not be cowed to drop his presidential bid" />
        

        
            <meta property="fb:app_id" content="715603858641973" />
        

        
            <meta property="fb:pages" content="252006125219593" />
        

        
    


<meta name="facebook-utm_source" content="facebook"/>
<meta name="facebook-utm_medium" content="social"/>
<meta name="facebook-utm_campaign" content="share-button"/>
    







<link id="init-styles" href="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/styles/project-init/light.css" type="text/css" rel="stylesheet"/>


    
        
            
            
            
            
            

            
                
                    <link class="cssSwitcher" href="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/styles/project-Common/light.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          data-style-type="partial-style-project-Common"
                          data-theme-variant="true"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
                
                    <link class="cssSwitcher" href="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/styles/project-Detail/light.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          data-style-type="partial-style-project-Detail"
                          data-theme-variant="true"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
    

    
    <script>
    if ('serviceWorker' in navigator) {
        window.addEventListener('load', function () {
            navigator.serviceWorker.register('pwa-service-worker.js')
                .then(function (registration) {
                    
                }, function (err) {
                    
                });
        });
    }
</script>
    


<script data-static-amd-map="{&quot;adsinit&quot;:&quot;https://ty0lm9uz.onet.pl/e1BrazgxMTN9/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/162d5140a65ebc0fa2e96da195a4eb9b/build&quot;,&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;pulsembed&quot;:&quot;https://pulsembed.eu/amd/1.0.6/build&quot;,&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/fbc3bd59219c65f9c312840c9743c691/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/js&quot;}">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</script>
    


<script>
    const schemaOrgItemList = {
        "@type": "ItemList",
        "itemListElement": []
    };
</script>

<noscript>
    <style>
        
        .image-wrapper{position:relative;display:inline-flex}.image-wrapper::after,.image-wrapper::before{background-image:var(--noscript-src);content:'';position:absolute;left:0;top:0;bottom:0;right:0;background-size:cover;background-repeat:no-repeat;background-position:center}
    </style>
</noscript>
    
        
    
















    <script>
        if (typeof dlApi === 'undefined') {
            dlApi = {
                async: 1,
                cookieInfo: '',
                no_gemius: 1,
                adsNoBanner: 1,
                noDfp: 1,
                mobile: 'false',
                target: '',
                tid: 'EA-4719209',
                DV: "pulselive_co_ke/main"
            }
        }
    </script>

    
        <script>
                dlApi = Object.assign(dlApi, {
                    kropka: {
                        DX: "PV,puls,6cwekd5,7,a",
                        PU: "d272758c-7ed3-49c3-befc-a2fbaae40d0b"
                    }
                });
        </script>
    


    


    
    
    
    
    
    
    

    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>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</script>


    
    
    
    

    <script defer src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
    <script>
        window.addEventListener('DOMContentLoaded', function() {
            Sailthru.init({ "customerId": "e3bb91358ab42ece773022042c6cfd66", "iscustom": true, "autoTrackPageview": false, "useStoredTags": false });
            Sailthru.track('pageview', {
                url: "https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5",
                tags: "news",
                onSuccess: function () {
                    
                },
                onError: function () {
                    
                }
            });
        });
    </script>


    
    
        
            <script type="text/javascript">var pulse2EmbedConfig = { pulsevideo: { player: "flowplayer", params: { autoplayNext: !0, enableAds: !1 }, plugins: [{ script: "https://imasdk.googleapis.com/js/sdkloader/ima3.js" }, { script: "https://embed.videos.ringpublishing.com/flowplayer/plugins/ads.min.js", config: { ima: { ads: [{ adTag: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", time: 0 }] } } }] }, OnettvVideo: { 'MAIN_ELEMENT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 }, 'INTEXT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 } } }</script>
        
    


    

    
    
        
            <script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[],function(){var t=document.createElement("script");t.async=!0,t.type="text/javascript";var e="https:"==document.location.protocol;t.src=(e?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(t,o)}();</script><script type='text/javascript'>googletag.cmd.push(function () { var o = window.location.pathname.split("/"); switch (o[1]) { case "": o[1] = "home" }void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1)); var e = token.length; if (document.location.hostname == 'www.pulse.ng') { googletag.pubads().setTargeting('PulseNG_URL', [token]); } if (document.location.hostname == 'www.pulse.sn') { googletag.pubads().setTargeting('PulseSN_URL', [token]); } if (document.location.hostname == 'www.pulse.com.gh') { googletag.pubads().setTargeting('PulseGH_URL', [token]); } if (document.location.hostname == 'www.pulselive.co.ke') { googletag.pubads().setTargeting('PliveKE_URL', [token]); } if (document.location.hostname == 'africa.businessinsider.com') { googletag.pubads().setTargeting('PulseBI_URL', [token]); } googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices() });</script><script type='text/javascript'>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];(function () {var gads = document.createElement('script');gads.async = true;gads.type = 'text/javascript';var useSSL = 'https:' == document.location.protocol;gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';var node = document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads, node);})();</script>
        
    


    

<script>if ("undefined" === typeof dlApi) { dlApi = {"target":"unknown/unknown","cookieInfo":"","no_gemius":1,"adsNoBanner":1,"noDfp":1,"tid":"EA-4719209"}; }</script>
<script src="https://lib.onet.pl/s.csr/build/dlApi/dl.boot.min.js" async></script>
</head>
<body class="articleDetail story-type-article css-project withRightColumn desktop  ">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->


    
    


    





<header id="main-page-header"  class="main-page-header " >
    <div class="header-lazy-wrapper" data-run-module="local/lazyLoad.run">
        
            <div class="header-widget-box header-above-wrapper">
                <div class="main-page-nav container">
                    
    










    <div class="menu-hamburger  hide-on-big-screens">
        <div class="menuToggle">
            <span></span>
            <span></span>
            <span></span>
        </div>
    </div>

    <div class="menu-mobile-container menu-hamburger" >
        <a class="main-page-logo"
           
           title="Pulselive Kenya"
           href="https://www.pulselive.co.ke/"
        >
            <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
        </a>
        <div class="menuToggleInside">
            <span></span>
            <span></span>
            <span></span>
        </div>
        <ul class="hamburger-list-items">
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="News" href="/news" >
                            News
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Politics" href="/news/politics">
                                            Politics
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/news/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="World" href="/news/world">
                                            World
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Entertainment" href="/entertainment" >
                            Entertainment
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                            Celebrities
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Music" href="/entertainment/music">
                                            Music
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                            Movies
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Lifestyle" href="/lifestyle" >
                            Lifestyle
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                            Fashion
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                            Beauty &amp; Health
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-and-weddings">
                                            Relationships &amp; Weddings
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                            Food, Travel, Arts &amp; Culture
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Sports" href="/sports" >
                            Sports
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Football" href="/sports/football">
                                            Football
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Football Stats" href="/sports/football/statistics">
                                            Football Stats
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="More" href="/sports/more">
                                            More
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Business" href="/business" >
                            Business
                        </a>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Quizzes" href="/quizzes" >
                            Quizzes
                        </a>
                        
                    </li>
                
                
            
        </ul>
    </div>


    

    






<div class="page-logo-wrapper ">
    <a class="main-page-logo"
       id="main-page-logo"
       title="Pulselive Kenya"
       href="https://www.pulselive.co.ke/"
    >
        <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
    </a>
</div>

    










    <ul class="main-page-nav menu-desktop menu-justify-center   hide-on-small-screens"
        
    >
        
            
                <li id="listMenuItem-0" class="menu-item  has-subMenu">
                    <a class="menu-title" title="News" href="/news" >
                        News
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Politics" href="/news/politics">
                                        Politics
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Local" href="/news/local">
                                        Local
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="World" href="/news/world">
                                        World
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-1" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Entertainment" href="/entertainment" >
                        Entertainment
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                        Celebrities
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Music" href="/entertainment/music">
                                        Music
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                        Movies
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-2" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Lifestyle" href="/lifestyle" >
                        Lifestyle
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                        Fashion
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                        Beauty &amp; Health
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-and-weddings">
                                        Relationships &amp; Weddings
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-3" class="submenu-item ">
                                    <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                        Food, Travel, Arts &amp; Culture
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-3" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Sports" href="/sports" >
                        Sports
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Football" href="/sports/football">
                                        Football
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Football Stats" href="/sports/football/statistics">
                                        Football Stats
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="More" href="/sports/more">
                                        More
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-4" class="menu-item  ">
                    <a class="menu-title" title="Business" href="/business" >
                        Business
                    </a>
                    
                </li>
            
        
            
                <li id="listMenuItem-5" class="menu-item  ">
                    <a class="menu-title" title="Quizzes" href="/quizzes" >
                        Quizzes
                    </a>
                    
                </li>
            
        
        
    </ul>


    
    <div class="headerSocials">
        <ul class="profileList">
            
                <li class="facebook">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.facebook.com/pulselivekenya"
                        title="Follow us on Facebook"
                        target="_blank"
                    >
                        facebook
                    </a>
                </li>
            
                <li class="twitter">
                    <a
                        rel="noopener noreferrer"
                        href="https://twitter.com/pulselivekenya"
                        title="Follow us on Twitter"
                        target="_blank"
                    >
                        twitter
                    </a>
                </li>
            
                <li class="instagram">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.instagram.com/pulselivekenya/"
                        title="Follow us on Instagram"
                        target="_blank"
                    >
                        instagram
                    </a>
                </li>
            
                <li class="youtube">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw"
                        title="Watch us on YouTube"
                        target="_blank"
                    >
                        youtube
                    </a>
                </li>
            
                <li class="tiktok">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.tiktok.com/@pulselivekenya"
                        title="Tiktok with us"
                        target="_blank"
                    >
                        tiktok
                    </a>
                </li>
            
        </ul>
    </div>


    

    

    

    

    

    






<div class="search-container-wrapper ">
    <div class="search-container" data-run-module="local/project.menu_search">
        <div id="search-button">
            <div class="svg icon-search" style="background-image:url(https://ocdn.eu/radp/icons/header/search.svg)"></div>
        </div>
        <form action="/search">
            <input type="search" placeholder="I’m looking for..." name="q" required data-placeholder-source="I’m looking for..." data-required-message="Please type your query and press search">
            <button type="submit">O</button>
        </form>
    </div>
</div>

                </div>
            </div>
        
        
        
            <div class="header-widget-box header-below-wrapper">
                <div class="main-page-nav container">
                    
    





                </div>
            </div>
        
    </div>
</header>

    

    <!-- AFRICA PROJECT - paid article flag test - START -->
    
    <!-- AFRICA PROJECT - paid article flag test - END -->

    <div class="page-container " data-run-module="local/lazyLoad.run">
        
            
            <div class="header-banner container-full">
                
                    


    
        <div class="adSlot " id='div-gpt-ad-1623221635248-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_970x90_a1" data-slot-size="[[728, 90], [970, 250], [970, 90]]" ></div>
    

                
            </div>
        
        <div class="container-full right-column-300">
            <div class="container">
                <div class="page-wrapper row">
                    <div id="article" class="main-section col-md-9">
                        <div class="articleBox ">
                            <div data-article-id="6cwekd5">

                                
    

    
        <div class="container-wrapper ">
            

            
                <!-- LEFT content columns -->
                <section class="ring-grid-box-container ring-grid-container container ">
                    
                    <div class="row">
                        <div class="ring-grid-left-box col-sm-12 col-md-12 col-lg-12">
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1621854609633-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PliveKE_DT_Sticky_Footer" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1617224545705-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/plive_dt_floater" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                


    <div class="breadcrumbs-widget ">
        
            


    
        
            <a href="https://www.pulselive.co.ke/" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    <strong>
                        RADP / Pulse Kenya
                    </strong>
                </span>
            </a>

            
                <span class="breadcrumbs-item-sep">&nbsp;&gt;&nbsp;</span>
            
        
    
        
            <a href="https://www.pulselive.co.ke/news" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    
                        News
                    
                </span>
            </a>

            
        
    

        
    </div>

                            
                                






    
        
            <h1 class="article-headline ">
                <span>
                    
                        Wanjigi responds to DCI&#39;s order to surrender firearms
                    
                </span>
            </h1>
        
    

                            
                                



    

    
        <div class="article-author-wrapper ">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/denis-mwangi" title="Denis Mwangi"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    

                                    
                                        <span class="author-name">Denis Mwangi</span>
                                    

                                    

                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                


    

    <div class="ring-detail-article-date ">
        
            <time class="detail-article-date date-type-publicationDate" datetime="2022-02-22T14:06:15.000+03:00">
                
                    February 22, 2022 2:06 PM
                
            </time>
        
    </div>

                            
                                
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
            
        
            
            
                <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
        
            
            
            
                <a href="mailto:?body=https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
            
            
            
            
            
        
    </div>

                            
                                







     <div id="lead" class="article-perex ">
          <p>Wanjigi maintained that he would not be cowed to drop his presidential bid. </p>
     </div>

                            
                                
                            
                                












    <div class="article-gallery " >
            <div  class="image-container" id="article-main-image">
                
                <picture data-image-source="article_photo" data-caption="Jimi Wanjigi responds to DCI's order to surrender firearms" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/Hm-ktkpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQMWzQGu); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/QIbk9kpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQMWzQGugaEwBQ" srcset="https://ocdn.eu/pulscms-transforms/1/QIbk9kpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQMWzQGugaEwBQ" type="image/webp"><img width="790" height="430" alt="Jimi Wanjigi responds to DCI's order to surrender firearms" title="Jimi Wanjigi responds to DCI's order to surrender firearms" src="https://ocdn.eu/pulscms-transforms/1/Hm-ktkpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQMWzQGu" data-original="https://ocdn.eu/pulscms-transforms/1/Hm-ktkpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQMWzQGu" class="image "></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/QIbk9kpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzQMWzQGugaEwBQ">
            </div>

        
            <div class="imgMetaData">
                
                    <span class="caption">Jimi Wanjigi responds to DCI&#39;s order to surrender firearms</span>
                

                
                

                

                

                <div class="clear"></div>
            </div>
        
    </div>

                            
                                
                            
                                
                            
                                




                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        ODM presidential aspirant Jimi Wanjigi has responded to summons by the Directorate of Criminal Investigations to <a href="https://www.pulselive.co.ke/news/wanjigi-given-72-hours-to-surrender-10-guns-to-dci/3dcpfgb" id="c5fb8d80-258f-41d3-b484-5f27eacd0178">surrender 10 guns or risk arrest.</a> 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 inText" data-run-module="local/project.inText" id='div-gpt-ad-1618787017312-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/300x250_InReadAd_PliveKE" data-slot-size="[728, 90]" ></div>
    

                            
                                
                            
                                
    

    <div class="recommendedArticles">
        <span class="title">Recommended articles</span>
        <ul>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/7rJktkpTURBXy83MmIyOGZhZjlhYmUxY2M5M2ZjY2Y4MjZkMTgzZjlmOS5qcGeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/iDSk9kpTURBXy83MmIyOGZhZjlhYmUxY2M5M2ZjY2Y4MjZkMTgzZjlmOS5qcGeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="President Kenyatta flags off relief food to drought striken counties" title="President Kenyatta flags off relief food to drought striken counties" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/7rJktkpTURBXy83MmIyOGZhZjlhYmUxY2M5M2ZjY2Y4MjZkMTgzZjlmOS5qcGeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/news">news</a>
                        <a class="link"  data-uuid-ui="fb0f4d3d-f7a6-4bb6-aee6-93688ba68665" data-ei="j9rjjzdhvw" href="https://www.pulselive.co.ke/news/the-president-flagged-off-the-consignment-of-food-to-23-affected-counties/ld722kv">President Kenyatta flags off relief food to drought striken counties</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/e9aktkpTURBXy85MTRhMmQ3ZmIxMTA3YWQyZGE4NGM4N2UwNDVjNmQwOS5qcGeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/5uQk9kpTURBXy85MTRhMmQ3ZmIxMTA3YWQyZGE4NGM4N2UwNDVjNmQwOS5qcGeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Rashid Abdalla and Lulu Hassan mourn Pete actress Bi Salama" title="Rashid Abdalla and Lulu Hassan mourn Pete actress Bi Salama" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/e9aktkpTURBXy85MTRhMmQ3ZmIxMTA3YWQyZGE4NGM4N2UwNDVjNmQwOS5qcGeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/entertainment">entertainment</a>
                        <a class="link"  data-uuid-ui="d989201e-f151-4491-b7d3-17c9465af508" data-ei="j9rjjzdhvw" href="https://www.pulselive.co.ke/entertainment/celebrities/rashid-abdalla-and-lulu-hassan-mourn-pete-actress-bi-salama/vdv9m71">Rashid Abdalla and Lulu Hassan mourn Pete actress Bi Salama</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/8ixktkpTURBXy81MDA3NWRmMzQ5YjhlZjQ2ZDQ0NGYwZjhhNGM3OGYxOS5qcGeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/FxVk9kpTURBXy81MDA3NWRmMzQ5YjhlZjQ2ZDQ0NGYwZjhhNGM3OGYxOS5qcGeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Kenya steals show at emergency UN Security Council meeting [Video]" title="Kenya steals show at emergency UN Security Council meeting [Video]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/8ixktkpTURBXy81MDA3NWRmMzQ5YjhlZjQ2ZDQ0NGYwZjhhNGM3OGYxOS5qcGeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/news">news</a>
                        <a class="link"  data-uuid-ui="d8b73b2f-7240-41f4-84ff-1c561ee144ba" data-ei="j9rjjzdhvw" href="https://www.pulselive.co.ke/news/kenya-wades-in-on-the-russia-ukraine-tensions-at-un-security-council-meeting-video/0wf34sz">Kenya steals show at emergency UN Security Council meeting [Video]</a>
                    </div>
                </li>
            
        </ul>
    </div>

                            
                                













    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                            
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Speaking to the media on Tuesday, February 22, Wanjigi said the threats were politically instigated. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        “<em>What they are doing to me now is what Raila and I went through when they raided my home at Muthaiga in 2017.</em>
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        “<em>It is strange that Raila and his cohorts are now partially in government and applying the employing the same tactics,</em>” he said. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-image ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- image: supported -->
    
    


    
    
    
    

    <div class="imageBlock aligment-center">
		<div>
			
                <span class="image-holder" data-fancybox="images-bb32443e-fe0a-4f71-91e4-26b3eadc4f54" data-caption="Jimi Wanjigi responds to DCI's order to surrender firearms"  >
                    <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/ipnktkpTURBXy8xYTVlNzgxZjg2MzNhZjU4ODdlYzEyNjk4MjliN2M5Yi5qcGeRlQLNAxbNAbTCww); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/7vbk9kpTURBXy8xYTVlNzgxZjg2MzNhZjU4ODdlYzEyNjk4MjliN2M5Yi5qcGeRlQLNAxbNAbTCw4GhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'436'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="790" height="436" alt="Jimi Wanjigi responds to DCI's order to surrender firearms" title="Jimi Wanjigi responds to DCI's order to surrender firearms" class="image lazyloaded imgWithMetaData" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'436'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/ipnktkpTURBXy8xYTVlNzgxZjg2MzNhZjU4ODdlYzEyNjk4MjliN2M5Yi5qcGeRlQLNAxbNAbTCww" loading="lazy"></picture> 
                </span>
			
			<div class="imgMetaData">
				
                    <span class="caption">Jimi Wanjigi responds to DCI&#39;s order to surrender firearms</span>
                

                

				
					<span class="copyright"> Pulse Live Kenya</span>
				
				<div class="clear"></div>
			</div>
		</div>
	</div>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The businessman asked the ODM party to allow for democracy within the party, accusing Odinga of dictatorial tendencies. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Wanjigi maintained that he would not be cowed to drop his presidential bid. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The ODM presidential aspirant has been in trouble with the DCI following a land case in which <a href="https://www.pulselive.co.ke/news/businessman-jimi-wanjigi-arrested-in-dramatic-raid-video/xs0geck" id="b5e8b4a9-7e0b-4ba2-9f4b-3bb799e1d2ec">he has been accused of grabbing</a>. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        During the raid on his Kwacha House offices in Westlands, DCI officers established that one of Wanjigi’s bodyguards was armed. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        "<em>The said person disclosed that you had armed him as your bodyguard. It was later established that the said person is one Josephat Onyiego Mogendi, an Ex - GSU Officer previously attached to the elite RECCE Company.</em>
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        "<em>The establishment of the fact that the officer is an ex-GSU is an indication of a high- level scheme that you have congregated highly trained persons in the use of firearms for ulterior motives,</em>" the DCI accused Wanjigi.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-image ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- image: supported -->
    
    


    
    
    
    

    <div class="imageBlock aligment-center">
		<div>
			
                <span class="image-holder" data-fancybox="images-ff9c3765-5ede-46a9-b34f-6a20337aebf4" data-caption="Jimi Wanjigi in court on Wednesday, January 19, 2022"  >
                    <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/-vektkpTURBXy84MDU1NjhjMWRjYjQ4OTMxM2E1ZjdmYWJjM2U3ZDYwNC5qcGeRlQLNAxbNAfvCww); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/AHyk9kpTURBXy84MDU1NjhjMWRjYjQ4OTMxM2E1ZjdmYWJjM2U3ZDYwNC5qcGeRlQLNAxbNAfvCw4GhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'507'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="790" height="507" alt="Jimi Wanjigi in court on Wednesday, January 19, 2022" title="Jimi Wanjigi in court on Wednesday, January 19, 2022" class="image lazyloaded imgWithMetaData" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'507'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/-vektkpTURBXy84MDU1NjhjMWRjYjQ4OTMxM2E1ZjdmYWJjM2U3ZDYwNC5qcGeRlQLNAxbNAfvCww" loading="lazy"></picture> 
                </span>
			
			<div class="imgMetaData">
				
                    <span class="caption">Jimi Wanjigi in court on Wednesday, January 19, 2022</span>
                

                

				
					<span class="copyright"> Pulse Live Kenya</span>
				
				<div class="clear"></div>
			</div>
		</div>
	</div>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The directorate also said that the whereabouts of the firearms in Wanjigi's possession were unknown, further serving as a risk that they could be used in criminal activities.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        "<em>The illegal holding of firearms and such massive amount of ammunition particularly at this time of heightened political activity could be used to commit a myriad of offences including but not limited to maiming and or killing of innocent persons or opponents,</em>" the DCI stated.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Some of the guns in Wanjigi's possession are primarily used by military teams which raises suspicion on how he was able to obtain them.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The list of guns includes Glock pistols, ceska pistols, CQ rifle, one Gilboa rifle, one shotgun, one pistol, and a long-barrelled rifle.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                

                            
                                
                            
                                



                            
                                



    

    
        <div class="article-author-wrapper  authorWithImage">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/denis-mwangi" title="Denis Mwangi"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    
                                        <span class="author-photo">
                                            

                                            

                                            <picture data-image-source="article-author" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/E26ktkpTURBXy9jNjhjMzNmMGEzZmRkNTAyYWMyZDM3N2NjNTFmMzJlNi5qcGeSlQMAAM0EAM0FAJMFRkY); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/4wvk9kpTURBXy9jNjhjMzNmMGEzZmRkNTAyYWMyZDM3N2NjNTFmMzJlNi5qcGeSlQMAAM0EAM0FAJMFRkaBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Denis Mwangi" title="Denis Mwangi" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/E26ktkpTURBXy9jNjhjMzNmMGEzZmRkNTAyYWMyZDM3N2NjNTFmMzJlNi5qcGeSlQMAAM0EAM0FAJMFRkY" class="image lazyloaded" loading="lazy"></picture> 
                                        </span>
                                    

                                    

                                    

                                    
                                
                                    

                                    
                                        <span class="author-name">Denis Mwangi</span>
                                    

                                    

                                    
                                
                                    

                                    

                                    

                                    
                                        <span class="author-description">Denis is a highly professional and talented multimedia journalist with a solid experience in creating compelling news as well as distributing or delivering it using multiple digital platforms to engage readers.</span>
                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
            
        
            
            
                <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
            
            
            
            
            
            
        
            
            
            
                <a href="mailto:?body=https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
            
            
            
            
            
        
            
            
            
            
                <a href="whatsapp://send?text=https%3A%2F%2Fwww.pulselive.co.ke%2Fnews%2Fjimi-wanjigi-responds-to-dcis-order-to-surrender-firearms%2F6cwekd5?utm_medium%3Dsocial%26utm_source%3Dwhatsapp%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-whatsapp " data-gtm-social="whatsapp" title="WhatsApp" style="width: 30px; height: 30px"></a>
            
            
            
            
        
            
            
            
            
            
                <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5?utm_medium%3Dsocial%26utm_source%3Dlinkedin%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-linkedin " data-gtm-social="linkedin" target="_blank" title="LinkedIn" style="width: 30px; height: 30px"></a>
            
            
            
        
    </div>

                            
                                


    <div class="basicWidget homepageNewsletter">
        <div class="bw-wrapper">
        
            <h3 class="main-section-title">JOIN OUR PULSE COMMUNITY!</h3>
        
            <div class="newsletterWrapper">
                <div class="socialList">
                    
                        <div class="socialIcon facebook">
                            
                                <a href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon twitter">
                            
                                <a href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon instagram">
                            
                                <a href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon youtube">
                            
                                <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon tiktok">
                            
                                <a href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/nl/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                </div>
                <div id="nlbox" class="newsletter dsk nlred">
                    <div class="signUpContainer">
                        <div class="introMessage">
                            Our newsletter gives you access to a curated selection of the most important stories daily.
                        </div>
                        <form id="newsletter-form" method="POST" class="inputForm" action="#" data-run-module="local/project.newsletter_submit">
                            <input type="email" placeholder="Email" name="email" id="email" required>
                            <button id="submitEmail" class="submit darkred">
                                SUBSCRIBE
                            </button>
                        </form>
                    </div>
                    <div id="error" class="error hide"></div>
                    <div id="thanksContainer" class="thanksContainer hide">
                        <div class="row" id="thanksMessage">
                            <p class="subTitle"> Welcome to the Pulse Community! We will now be sending you a daily newsletter on news, entertainment and more.   Also join us across all of our other channels - we love to be connected!</p>
                        </div>
                    </div>
                </div>
                
                    <div></div>
                    <div id="pushBox" class="pushContainer dark" data-run-module="local/project.push_notification">
                        <div class='onesignal-customlink-container'></div>
                        <div class="blockedText" id="pushBlocked">Unblock notifications in browser settings.</div>
                    </div>
                
            </div>
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 " id='div-gpt-ad-1618841981942-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PulseKE_DT_Article_Below_Article_A" data-slot-size="[728, 90]" ></div>
    

                            
                                
    
        
            <div class="eyewitnessWdg" style="margin-top: 25px;">    <p>Eyewitness? Submit your stories now via social or: </p>    <p>    <b>Email: </b><a href="mailto:news@pulselive.co.ke">news@pulselive.co.ke</a></b></p></div>
        
    

                            
                                



    

    <div class="basicWidget hp-colSize-12 latest bw-v2"
        style=""
        
        
        >

        <div class="bw-wrapper">
             

            
                


    <h2 class="main-section-title">

    
    
        
    

    
        Recommended articles
    

    </h2>

            
                
    <div class="section-elements">
        <div class="items-wrapper columns-3 big-elements-0" >
        

            
            
            

            <div class="layout-wrapper wrap-element-1 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/FxtktkpTURBXy83MmIyOGZhZjlhYmUxY2M5M2ZjY2Y4MjZkMTgzZjlmOS5qcGeSlQMALM0EVs0CcJMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/bVnk9kpTURBXy83MmIyOGZhZjlhYmUxY2M5M2ZjY2Y4MjZkMTgzZjlmOS5qcGeSlQMALM0EVs0CcJMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="President Kenyatta flags off relief food to drought striken counties" title="President Kenyatta flags off relief food to drought striken counties" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/FxtktkpTURBXy83MmIyOGZhZjlhYmUxY2M5M2ZjY2Y4MjZkMTgzZjlmOS5qcGeSlQMALM0EVs0CcJMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            President Kenyatta flags off relief food to drought striken counties
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/the-president-flagged-off-the-consignment-of-food-to-23-affected-counties/ld722kv" title="President Kenyatta flags off relief food to drought striken counties"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-2 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/p_nktkpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/H8vk9kpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Wanjigi responds to DCI's order to surrender firearms" title="Wanjigi responds to DCI's order to surrender firearms" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/p_nktkpTURBXy84MzBlM2ExYTY5MGVlMDVjMWNlODI0N2ZhZWE4Y2M2My5qcGeSlQMAL80FAM0C0JMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Wanjigi responds to DCI&#39;s order to surrender firearms
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5" title="Wanjigi responds to DCI&#39;s order to surrender firearms"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-3 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/CuUktkpTURBXy84ZGI0MTY2MTVmMjhkMTgzN2ZkOGU0ZmVjYTJhYjY3Zi5qcGeSlQMAcs0KFs0FrJMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/8YAk9kpTURBXy84ZGI0MTY2MTVmMjhkMTgzN2ZkOGU0ZmVjYTJhYjY3Zi5qcGeSlQMAcs0KFs0FrJMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="CS Monica Juma drops out of race for top Commonwealth job" title="CS Monica Juma drops out of race for top Commonwealth job" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/CuUktkpTURBXy84ZGI0MTY2MTVmMjhkMTgzN2ZkOGU0ZmVjYTJhYjY3Zi5qcGeSlQMAcs0KFs0FrJMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            CS Monica Juma drops out of race for top Commonwealth job
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/energy-cs-monica-juma-drops-out-of-race-for-commonwealth-secretary-general/byj3rey" title="CS Monica Juma drops out of race for top Commonwealth job"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-4 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/DMVktkpTURBXy82MTFkMTVhNjgzMmIxNWUzYWU1NjI0ZDc5YjUwODkzMS5qcGeSlQMAE80DwM0CHJMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/0Vok9kpTURBXy82MTFkMTVhNjgzMmIxNWUzYWU1NjI0ZDc5YjUwODkzMS5qcGeSlQMAE80DwM0CHJMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Sabina Chege admitted at the Nairobi Hospital " title="Sabina Chege admitted at the Nairobi Hospital " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/DMVktkpTURBXy82MTFkMTVhNjgzMmIxNWUzYWU1NjI0ZDc5YjUwODkzMS5qcGeSlQMAE80DwM0CHJMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Sabina Chege admitted at the Nairobi Hospital 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/muranga-woman-representative-sabina-chege-admitted-at-nairobi-hospital/cjgc4h9" title="Sabina Chege admitted at the Nairobi Hospital "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-5 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/6TTktkpTURBXy81MDA3NWRmMzQ5YjhlZjQ2ZDQ0NGYwZjhhNGM3OGYxOS5qcGeSlQMTAM0D0M0CJZMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/FeGk9kpTURBXy81MDA3NWRmMzQ5YjhlZjQ2ZDQ0NGYwZjhhNGM3OGYxOS5qcGeSlQMTAM0D0M0CJZMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Kenya steals show at emergency UN Security Council meeting [Video]" title="Kenya steals show at emergency UN Security Council meeting [Video]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/6TTktkpTURBXy81MDA3NWRmMzQ5YjhlZjQ2ZDQ0NGYwZjhhNGM3OGYxOS5qcGeSlQMTAM0D0M0CJZMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Kenya steals show at emergency UN Security Council meeting [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/kenya-wades-in-on-the-russia-ukraine-tensions-at-un-security-council-meeting-video/0wf34sz" title="Kenya steals show at emergency UN Security Council meeting [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-6 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/S7zktkpTURBXy85NDBlODMyZDYxZDBlYTlmNTFjZTAyNWQ1MmMwYjExNC5wbmeSlQMBAM0C7c0BppMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/iLBk9kpTURBXy85NDBlODMyZDYxZDBlYTlmNTFjZTAyNWQ1MmMwYjExNC5wbmeSlQMBAM0C7c0BppMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="UDA Party set to unveil its Presidential candidate at Kasarani " title="UDA Party set to unveil its Presidential candidate at Kasarani " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/S7zktkpTURBXy85NDBlODMyZDYxZDBlYTlmNTFjZTAyNWQ1MmMwYjExNC5wbmeSlQMBAM0C7c0BppMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            UDA Party set to unveil its Presidential candidate at Kasarani 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/uda-party-set-to-unveil-its-presidential-candidate-at-kasarani-on-march-15/ncyq6f7" title="UDA Party set to unveil its Presidential candidate at Kasarani "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-7 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/PWpktkpTURBXy9iYzdiMGYwZWQ2MTZiN2RjYzNjZDJkODdkZjliNjI0MS5qcGeSlQMAAc0Ej80CkJMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/yO3k9kpTURBXy9iYzdiMGYwZWQ2MTZiN2RjYzNjZDJkODdkZjliNjI0MS5qcGeSlQMAAc0Ej80CkJMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Jubilee party, Uhuru on the spot over billboards splashed all over Nairobi" title="Jubilee party, Uhuru on the spot over billboards splashed all over Nairobi" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/PWpktkpTURBXy9iYzdiMGYwZWQ2MTZiN2RjYzNjZDJkODdkZjliNjI0MS5qcGeSlQMAAc0Ej80CkJMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Jubilee party, Uhuru on the spot over billboards splashed all over Nairobi
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/jubilee-party-uhuru-kenyatta-is-on-the-spot-over-billboards-erected-in-nairobi/3218x1s" title="Jubilee party, Uhuru on the spot over billboards splashed all over Nairobi"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-8 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/idXktkpTURBXy85ZDMxZDY2YmE0MThiMzczMDQ4NjllNmYwNThjYWFiOC5qcGeSlQMnAM0Cbs0BXpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/uimk9kpTURBXy85ZDMxZDY2YmE0MThiMzczMDQ4NjllNmYwNThjYWFiOC5qcGeSlQMnAM0Cbs0BXpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Wanjigi given 72 hours to surrender 10 guns to DCI" title="Wanjigi given 72 hours to surrender 10 guns to DCI" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/idXktkpTURBXy85ZDMxZDY2YmE0MThiMzczMDQ4NjllNmYwNThjYWFiOC5qcGeSlQMnAM0Cbs0BXpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Wanjigi given 72 hours to surrender 10 guns to DCI
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/wanjigi-given-72-hours-to-surrender-10-guns-to-dci/3dcpfgb" title="Wanjigi given 72 hours to surrender 10 guns to DCI"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-9 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/r1YktkpTURBXy84MDFiNTk5MzA2MWYzNjIxY2Y1MDUwMWNjMmE1ZjM5ZC5qcGeSlQNIAM0EIM0CUpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/bu_k9kpTURBXy84MDFiNTk5MzA2MWYzNjIxY2Y1MDUwMWNjMmE1ZjM5ZC5qcGeSlQNIAM0EIM0CUpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Livondo summoned by DCI over Uhuru assassination statement" title="Livondo summoned by DCI over Uhuru assassination statement" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/r1YktkpTURBXy84MDFiNTk5MzA2MWYzNjIxY2Y1MDUwMWNjMmE1ZjM5ZC5qcGeSlQNIAM0EIM0CUpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Livondo summoned by DCI over Uhuru assassination statement
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/stanley-livondo-is-expected-to-appear-before-dci-over-remarks-made-in-thika/1vv1m33" title="Livondo summoned by DCI over Uhuru assassination statement"></a>
    </div>

                        
                    
                </div>

                
            </div>
        
        </div>
    </div>

            
        </div>
    </div>

                            
                                
                            
                        </div>
                    </div>
                </section>
            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    


                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                                
                            </div>
                        </div>

                        
                    </div>

                    
                        
                            
                                
                                <div class="side-section col-md-3" id="content-side-section">
                                    <div>
                                        
                                            


    
        <div class="adSlot placeholder-600 mt-4 " id='div-gpt-ad-1617227624691-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_300x250_b1" data-slot-size="[[300, 250], [300, 600], [160, 600], [120, 600]]" ></div>
    

                                        
                                            


    <div class="widget-trending basicWidget ">
        
            <h2 class="main-section-title">
                Trending
            </h2>
        

        
        <div class="widget-trending-items">
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Joho personally grants wife&#39;s request for a divorce
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/eQPktkpTURBXy9lNzQ2MzVhNjkzZGE3YjQzNDhhNTM4M2UxNzg5ZjIzYS5qcGeSlQMAAM0EOM0CYJMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/dzHk9kpTURBXy9lNzQ2MzVhNjkzZGE3YjQzNDhhNTM4M2UxNzg5ZjIzYS5qcGeSlQMAAM0EOM0CYJMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/dzHk9kpTURBXy9lNzQ2MzVhNjkzZGE3YjQzNDhhNTM4M2UxNzg5ZjIzYS5qcGeSlQMAAM0EOM0CYJMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Mombasa Governor Ali Hassan Joho divorces forst wife, Italian Madina Giovanni Fazzini" title="Mombasa Governor Ali Hassan Joho divorces forst wife, Italian Madina Giovanni Fazzini" class="image " src="https://ocdn.eu/pulscms-transforms/1/eQPktkpTURBXy9lNzQ2MzVhNjkzZGE3YjQzNDhhNTM4M2UxNzg5ZjIzYS5qcGeSlQMAAM0EOM0CYJMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/eQPktkpTURBXy9lNzQ2MzVhNjkzZGE3YjQzNDhhNTM4M2UxNzg5ZjIzYS5qcGeSlQMAAM0EOM0CYJMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/dzHk9kpTURBXy9lNzQ2MzVhNjkzZGE3YjQzNDhhNTM4M2UxNzg5ZjIzYS5qcGeSlQMAAM0EOM0CYJMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/mombasa-governor-hassan-joho-agrees-to-divorce-first-wife-madina-giovanni-fazzini/kbx5lyd"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    #LowerFoodPrices: Origin of top trending hashtag that has united Kenyans
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/lEzktkpTURBXy9lMDU0OWFkYjcwNmYzMTAyYmUyZmViN2Q3NTBlOGRiYy5wbmeSlQMADM0Ebs0CfZMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/bA0k9kpTURBXy9lMDU0OWFkYjcwNmYzMTAyYmUyZmViN2Q3NTBlOGRiYy5wbmeSlQMADM0Ebs0CfZMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/bA0k9kpTURBXy9lMDU0OWFkYjcwNmYzMTAyYmUyZmViN2Q3NTBlOGRiYy5wbmeSlQMADM0Ebs0CfZMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="President Uhuru Kenyatta" title="President Uhuru Kenyatta" class="image " src="https://ocdn.eu/pulscms-transforms/1/lEzktkpTURBXy9lMDU0OWFkYjcwNmYzMTAyYmUyZmViN2Q3NTBlOGRiYy5wbmeSlQMADM0Ebs0CfZMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/lEzktkpTURBXy9lMDU0OWFkYjcwNmYzMTAyYmUyZmViN2Q3NTBlOGRiYy5wbmeSlQMADM0Ebs0CfZMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/bA0k9kpTURBXy9lMDU0OWFkYjcwNmYzMTAyYmUyZmViN2Q3NTBlOGRiYy5wbmeSlQMADM0Ebs0CfZMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/lowerfoodprices-trending-online-campaign-ahead-of-uhuru-kenyatta-sagana-3-meeting/cbjm3r3"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Pundits break down Stanley Livondo&#39;s alarming claim of attempts to eliminate Uhuru
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/49-ktkpTURBXy9mODBhMGVjOWYyNjBmZTEwYzRmOTA2NGUwY2IyNGMyMC5qcGeSlQMAb80CFs0BLJMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/OMTk9kpTURBXy9mODBhMGVjOWYyNjBmZTEwYzRmOTA2NGUwY2IyNGMyMC5qcGeSlQMAb80CFs0BLJMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/OMTk9kpTURBXy9mODBhMGVjOWYyNjBmZTEwYzRmOTA2NGUwY2IyNGMyMC5qcGeSlQMAb80CFs0BLJMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Kakamega politician Stanley Livondo" title="Kakamega politician Stanley Livondo" class="image " src="https://ocdn.eu/pulscms-transforms/1/49-ktkpTURBXy9mODBhMGVjOWYyNjBmZTEwYzRmOTA2NGUwY2IyNGMyMC5qcGeSlQMAb80CFs0BLJMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/49-ktkpTURBXy9mODBhMGVjOWYyNjBmZTEwYzRmOTA2NGUwY2IyNGMyMC5qcGeSlQMAb80CFs0BLJMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/OMTk9kpTURBXy9mODBhMGVjOWYyNjBmZTEwYzRmOTA2NGUwY2IyNGMyMC5qcGeSlQMAb80CFs0BLJMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/political-pundits-breakdown-stanley-livondo-alarming-claim-on-attempts-to-eliminate/4f2qmmw"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    What changed on my support for DP Ruto&#39;s presidential bid - Moses Kuria tells all
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/qt3ktkqTURBXy85MjE1NjE5NzQ0OWMzYTYxZTdjMGNjZjgzN2NmOGU2Zi5qcGVnkpUDAADNBDjNAl-TBc0BLMys); "><source data-original="https://ocdn.eu/pulscms-transforms/1/wz5k9kqTURBXy85MjE1NjE5NzQ0OWMzYTYxZTdjMGNjZjgzN2NmOGU2Zi5qcGVnkpUDAADNBDjNAl-TBc0BLMysgaEwBQ" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="300" height="172" alt="Gatundu South MP Moses Kuria" title="Gatundu South MP Moses Kuria" class="image lazyloaded" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/qt3ktkqTURBXy85MjE1NjE5NzQ0OWMzYTYxZTdjMGNjZjgzN2NmOGU2Zi5qcGVnkpUDAADNBDjNAl-TBc0BLMys" loading="lazy"></picture> 
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/what-changed-on-my-support-for-dp-rutos-presidential-bid-moses-kuria-opens-up/4k96qq5"></a>
                        </div>
                    </div>
                </div>
            
        </div>
        
    </div>

                                        
                                            


    
        <div class="stickyWrapper" id="stickyWrapper" data-run-module="local/project.floatSticky" data-slot-name="/53159133/pliveke_dt_article_300x250_b3" data-slot-size="[[300, 600], [300, 250], [160, 600], [120, 600]]">
            <div class="first sticky-slot" id='div-gpt-ad-1617227699389-0'></div>
        </div>
    

                                        
                                    </div>
                                </div>
                            
                        
                    
                </div>
            </div>
        </div>
    </div>

    

    
    
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.pulselive.co.ke"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.pulselive.co.ke/news"},{"@type":"ListItem","position":3,"name":"Jimi Wanjigi Responds To Dcis Order To Surrender Firearms","item":"https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5"}]}
            </script>
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"NewsArticle","@id":"https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5#article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5"},"headline":"Wanjigi responds to DCI's order to surrender firearms","primaryImageOfPage":{"@id":"https://www.pulselive.co.ke/news/jimi-wanjigi-responds-to-dcis-order-to-surrender-firearms/6cwekd5#mainPhoto"},"image":["http://ocdn.eu/images/pulscms/Mzk7MDA_/830e3a1a690ee05c1ce8247faea8cc63.jpg"],"datePublished":"2022-02-22T14:06:15.000+03:00","dateModified":"2022-02-22T14:06:15.000+03:00","author":[{"@type":"Person","name":"Denis Mwangi","url":"https://www.pulselive.co.ke/author/denis-mwangi"}],"publisher":{"@type":"Organization","name":"Pulselive Kenya","logo":{"@type":"ImageObject","url":"https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"}},"keywords":[],"description":"Wanjigi maintained that he would not be cowed to drop his presidential bid. ","isAccessibleForFree":true}
            </script>
        
    



    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
            <div class="footer-widget-box footer-below-wrapper container">
                <div class="footer-widget-wrapper">
                    
    
    <div class="africaFooter">
        <div class="container" >
            
                <div class="advertiseFooterContainer">
                    <div class="advertTitle">
                        Advertise with us
                    </div>
                    <div class="advertBody">
                        Reach out to us at <a style="color: #ff0" href="mailto:salesteam@pulse.co.ke" rel="noopener noreferrer">salesteam@pulse.co.ke</a> or +254113897895 to advertise with us. Find out more about Pulse's products and advertising opportunities at <a href="https://pulse.africa" target="_blank" style="color: #ff0" rel="noopener noreferrer"> pulse.africa</a>   
                    </div>
                </div>
            
            <div class="footer-wrapper">
                
                
                <div class="footer-menu">
                    <ul class="footer-menu-list">
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Home" href="/">
                                Home
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="News" href="/news">
                                News
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Entertainment" href="/entertainment">
                                Entertainment
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Lifestyle" href="/lifestyle">
                                Lifestyle
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Sports" href="/sports">
                                Sports
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Business" href="/business">
                                Business
                            </a>
                            
                        </li>
                        
                        <li class="footer-menu-item">
                            <a class="footer-menu-title" title="Quizzes" href="/quizzes">
                                Quizzes
                            </a>
                            
                        </li>
                        
                    </ul>
                </div>
                

                
                <div class="footer-links-wrapper" id="footer-links-menu">
                    <ul class="links-list">
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/about-us" title="About us">
                                About us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/about-us" title="About us">
                                About us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://pulse.africa" title="Advertise with us">
                                Advertise with us
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/terms-of-use/d1z0r3q" title="Terms &amp; Conditions">
                                Terms &amp; Conditions
                            </a>
                            
                        </li>
                        
                        
                        
                        <li class="link-item">
                            
                            <a class="link-title menu-title" target="_blank"
                                href="https://www.pulselive.co.ke/info/privacy-policy-pulselivecoke/vh9gdmy" title="Privacy Policy">
                                Privacy Policy
                            </a>
                            
                        </li>
                        
                        
                    </ul>
                </div>
                

                
                <div class="socials-wrapper">
                    <ul id="socials" class="socials-wrapper-list">
                        
                            
                                <li class="socials-wrapper-item">
                                    <span class="footer-icon 0 " >
                                        
                                        Social
                                    </span>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 1 "  href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Facebook
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 2 "  href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Twitter
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 3 "  href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Instagram
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 4 "  href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Youtube
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 5 "  href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Tiktok
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 6 "  href="https://www.pulse.com.gh/newsletter" title="newsletter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/newsletter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/newsletter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="newsletter" title="newsletter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/img/footer/newsletter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Newsletter
                                    </a>
                                </li>
                            
                        
                    </ul>
                </div>
                
            </div>

            

            
                
                <div class="disclaimer-text">
                    
                        
                            <p class="footer-description-copyrightsInfo"> &copy; 2022 pulselive.co.ke</p>
                        
                    
                </div>
            
        </div>
    </div>


                </div>
            </div>
        
    </div>
</footer>



    



    <div id="customDimensionsCategories" data-categories="kenya/news"></div>

    <script>
        const categories = document.getElementById('customDimensionsCategories').dataset.categories;

        if (categories && typeof categories === "string" && categories.length > 0) {
            window.dataLayer = window.dataLayer || [];
            window.dataLayer.push({
                'content_categories': categories
            })
        }
    </script>


    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
    </div>
</footer>




<script src="//ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build/js/menu.min.js"></script>

<script>
    const resourceBuildPath = "//ocdn.eu/ucs/static/UTheme/de8359f10b225817a12bf384c658110e/build";

    
        const editStoryBookmarklet = "radp-ringier-africa-digital-publishing";
    
</script>

    
        <script type="text/javascript"> window._taboola = window._taboola || []; window._taboola.push( {flush: true} );  </script>
    
<script type='text/javascript' src='https://ssp.mediapal.net/www/delivery/spcjs.php?id=5'></script></body>
</html>

