




<!DOCTYPE html>
<html lang="en">





<head>
    <meta charset="utf-8"/><script>/* <![CDATA[ */ ringDataLayer = {"context":{"variant":{"accelerator":"d3d3LnB1bHNlbGl2ZS5jby5rZTo6UFJPRF9WMQ=="},"publication_structure":{"root":"WWW_PULSELIVE_CO_KE","path":"NEWS/LOCAL/ARTICLE"},"id":{"aureus_offers":["4ldrttnbdb"]}},"content":{"object":{"type":"story","kind":"article","id":"573e25bc-810f-4571-80fc-0fb3b07c80b9"},"part":1,"publication":{"point":{"id":"9zff2m0"}},"source":{"system":"ring_content_space","id":"7dd277c7-e647-489d-a0cd-8c305073a877"}}}; /* ]]> */</script><script>/* <![CDATA[ */ accConf = {"rum":{"tid":"EA-4719209","cookieInfo":0,"pageType":"HTML"},"gtm":{"id":["GTM-MGFD5X"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}}; /* ]]> */</script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<!-- End Google Tag Manager -->

    <meta name="viewport" content="width=device-width, initial-scale=1">
    












<link rel="preconnect" href="https://ocdn.eu">
<link rel="dns-prefetch" href="https://ocdn.eu">


    <title>Villager interrupts burial of Rigathi Gachagua's brother to ask for money [Video] | Pulselive Kenya</title>





    <meta name="description" content="The villager marched straight towards Rigathi Gachagua who was addressing the mourners and asked the MP to fulfil his promise | Pulselive Kenya">



    
        
            <meta name="robots" content="index,follow">
        
    



    <link rel="canonical" href="https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0" />
     
        <link rel="amphtml" href="https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0.amp" />
    



    <meta name="ring-local-canonical" content="https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0" data-isExternal="false">



    <meta name="ring-global-lazyload-behavior" content="auto detect">



    <meta name="DC.Identifier" content="573e25bc-810f-4571-80fc-0fb3b07c80b9">





    <meta name="theme-color" content="#AC2723"/>



    <link rel="apple-touch-icon" href="https://ocdn.eu/radp/pwa/512x512.png">



    <link rel="manifest" href="/manifest.json"  crossorigin="use-credentials" >



    


    

    
        
        
        
        
        
        

        
            <meta property="og:title" content="Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money [Video]" />
        

        
            <meta property="og:description" content="The villager marched straight towards Rigathi Gachagua who was addressing the mourners and asked the MP to fulfil his promise" />
        

        
            <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/PHdktkpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQSwzQJ2" />
        

        
            <meta property="og:image:width" content="1200" />
        

        
            <meta property="og:image:height" content="630" />
        

        
            <meta property="og:image:type" content="png"/>
        

        
            <meta property="og:image:alt" content="Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money"/>
        

        
            <meta property="og:url" content="https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0" />
        

        
            <meta property="og:type" content="Article" />
        

        
            <meta property="og:site_name" content="Pulselive Kenya"/>
        

        
            <meta property="article:publisher" content="https://www.facebook.com/pulselivekenya"/>
        

        
            <meta property="og:locale" content="en_EN" />
        

        
            <meta property="og:updated_time" content="2022-05-17 16:44:16+0200" />

            
                <meta property="article:modified_time" content="2022-05-17 16:44:16+0200" />
            
        

        
            <meta property="article:published_time" content="2022-05-17 16:44:16+0200" />
        

        
            <meta property="article:section" content="local" />
        

        
            
                
                    <meta property="article:author" content="Denis Mwangi" />
                
            

            
                
                    <meta property="article:tag" content="RigathiGachagua" />
                
            
                
                    <meta property="article:tag" content="NyeriNews" />
                
            
                
                    <meta property="article:tag" content="KenyaKwanza" />
                
            
                
                    <meta property="article:tag" content="2022ElectionsKE" />
                
            
        

        
            <meta name="twitter:card" content="summary_large_image">
            <meta name="twitter:image" content="https://ocdn.eu/pulscms-transforms/1/PHdktkpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQSwzQJ2">
        

        
            <meta property="twitter:title" content="Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money [Video]" />
        

        
            <meta property="twitter:description" content="The villager marched straight towards Rigathi Gachagua who was addressing the mourners and asked the MP to fulfil his promise" />
        

        
            <meta property="fb:app_id" content="715603858641973" />
        

        
            <meta property="fb:pages" content="252006125219593" />
        

        
            <meta name="keywords" content="RigathiGachagua, NyeriNews, KenyaKwanza, 2022ElectionsKE" />
        
    


<meta name="facebook-utm_source" content="facebook"/>
<meta name="facebook-utm_medium" content="social"/>
<meta name="facebook-utm_campaign" content="share-button"/>
    









    <link id="variables-styles" data-theme="light" href="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/styles/project-variables-light.css" type="text/css" rel="stylesheet"/>


<link id="init-styles" href="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/styles/project-init.css" type="text/css" rel="stylesheet"/>


    
        
            
            
            
            
            

            
                
                    

                    <link href="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/styles/project-Common.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          id="page-partial-style-project-Common"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
                
                    

                    <link href="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/styles/project-Detail.css"
                          type="text/css"
                           rel="preload stylesheet" as="style" onload="this.onload=null; this.rel='stylesheet'" 
                          id="page-partial-style-project-Detail"
                    />
                
            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
        
            
            
            
            
            

            
                
            
        
    

    
    <script>
    if ('serviceWorker' in navigator) {
        window.addEventListener('load', function () {
            navigator.serviceWorker.register('pwa-service-worker.js')
                .then(function (registration) {
                    
                }, function (err) {
                    
                });
        });
    }
</script>
    


<script data-static-amd-map="{&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/162d5140a65ebc0fa2e96da195a4eb9b/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/fbc3bd59219c65f9c312840c9743c691/build&quot;,&quot;adsinit&quot;:&quot;https://ty0lm9uz.onet.pl/e1BrazgxMzh9/build&quot;,&quot;pulsembed&quot;:&quot;https://pulsembed.eu/amd/1.0.7/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/js&quot;}">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</script>
    


<script>
    const schemaOrgItemList = {
        "@type": "ItemList",
        "itemListElement": []
    };
</script>

<noscript>
    <style>
        
        .image-wrapper{position:relative;display:inline-flex}.image-wrapper::after,.image-wrapper::before{background-image:var(--noscript-src);content:'';position:absolute;left:0;top:0;bottom:0;right:0;background-size:cover;background-repeat:no-repeat;background-position:center}
    </style>
</noscript>
    
        
    
















    <script>
        if (typeof dlApi === 'undefined') {
            dlApi = {
                async: 1,
                cookieInfo: '',
                no_gemius: 1,
                adsNoBanner: 1,
                noDfp: 1,
                mobile: 'false',
                target: '',
                tid: 'EA-4719209',
                DV: "pulselive_co_ke/main"
            }
        }
    </script>

    
        <script>
                dlApi = Object.assign(dlApi, {
                    kropka: {
                        DX: "PV,puls,9zff2m0,7,a",
                        PU: "573e25bc-810f-4571-80fc-0fb3b07c80b9"
                    }
                });
        </script>
    


    



    
    
    
    
    
    
    

    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>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</script>


    


    
    
    

    <script defer src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
    <script>
        window.addEventListener('DOMContentLoaded', function() {
            Sailthru.init({ "customerId": "e3bb91358ab42ece773022042c6cfd66", "iscustom": true, "autoTrackPageview": false, "useStoredTags": false });
            Sailthru.track('pageview', {
                url: "https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0",
                tags: "local-news",
                onSuccess: function () {
                    
                },
                onError: function () {
                    
                }
            });
        });
    </script>


    
    
        
            <script type="text/javascript">var pulse2EmbedConfig = { pulsevideo: { player: "flowplayer", params: { autoplayNext: !0, enableAds: !1 }, plugins: [{ script: "https://imasdk.googleapis.com/js/sdkloader/ima3.js" }, { script: "https://embed.videos.ringpublishing.com/flowplayer/plugins/ads.min.js", config: { ima: { ads: [{ adTag: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", time: 0 }] } } }] }, OnettvVideo: { 'MAIN_ELEMENT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 }, 'INTEXT': { preset: "mainVideoRADPGh", enableGoogleAnalytics: 2, volume: 0, enableEndScreen: 1, autoplayRelated: 1, enableAds: 1, adserverUrl: "https://pubads.g.doubleclick.net/gampad/ads?iu=/53159133/PliveKE_video_new_640x360&description_url=[placeholder]&tfcd=0&npa=0&sz=640x360&gdfp_req=1&output=vast&unviewed_position_start=1&env=vp&impl=s&correlator=", floatingControls: 1, embedType: 'inTextVideo', showAdvertComment: 1 } } }</script>
        
    


    

    <script>"use strict";document.addEventListener("DOMContentLoaded",function(e){var t=document.querySelector("#taboolaStartHook");if(t){var n=function(){var e,t,n;window._taboola=window._taboola||[],window._taboola.push({article:"auto"}),e=document.createElement("script"),t=document.getElementsByTagName("script")[0],n="tb_loader_script",document.getElementById(n)||(e.async=1,e.src="//cdn.taboola.com/libtrc/ringierkenya-network/loader.js",e.id=n,t.parentNode.insertBefore(e,t)),window.performance&&"function"==typeof window.performance.mark&&window.performance.mark("tbl_ic")};if("IntersectionObserver"in window)new IntersectionObserver(function(e,t){e[0].isIntersecting&&(n(),t.disconnect())},{threshold:1}).observe(t);else n()}});</script>


    


    <script type='text/javascript'>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [], function () {
            var t = document.createElement("script");
            t.async = !0, t.type = "text/javascript";
            var e = "https:" == document.location.protocol;
            t.src = (e ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
            var o = document.getElementsByTagName("script")[0];
            o.parentNode.insertBefore(t, o)
        }();
    </script>
    <script type='text/javascript'>
        googletag.cmd.push(function () {
            var o = window.location.pathname.split("/");
            switch (o[1]) {
                case "":
                    o[1] = "home"
            }
            void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1));
            var e = token.length;
            if (document.location.hostname == 'www.pulse.ng') {
                googletag.pubads().setTargeting('PulseNG_URL', [token]);
            }
            if (document.location.hostname == 'www.pulse.sn') {
                googletag.pubads().setTargeting('PulseSN_URL', [token]);
            }
            if (document.location.hostname == 'www.pulse.com.gh') {
                googletag.pubads().setTargeting('PulseGH_URL', [token]);
            }
            if (document.location.hostname == 'www.pulselive.co.ke') {
                googletag.pubads().setTargeting('PliveKE_URL', [token]);
            }
            if (document.location.hostname == 'africa.businessinsider.com') {
                googletag.pubads().setTargeting('PulseBI_URL', [token]);
            }
            if (document.location.hostname == 'www.pulse.ci') {
                googletag.pubads().setTargeting('PulseCI_URL', [token]);
            }
            if (document.location.hostname == 'www.pulse.ug') {
                googletag.pubads().setTargeting('PulseUG_URL', [token]);
            }
            googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices()
        });
    </script>
    <script type='text/javascript'>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function () {
            var gads = document.createElement('script');
            gads.async = true;
            gads.type = 'text/javascript';
            var useSSL = 'https:' == document.location.protocol;
            gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
            var node = document.getElementsByTagName('script')[0];
            node.parentNode.insertBefore(gads, node);
        })();
    </script>


    

<script>if ("undefined" === typeof dlApi) { dlApi = {"target":"unknown/unknown","cookieInfo":"","no_gemius":1,"adsNoBanner":1,"noDfp":1,"tid":"EA-4719209"}; }</script>
<script src="https://lib.onet.pl/s.csr/build/dlApi/dl.boot.min.js" async></script>
</head>
<body class="articleDetail story-type-article css-project withRightColumn desktop  ">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->


    
    


    





<header id="main-page-header"  class="main-page-header " >
    <div class="header-lazy-wrapper" data-run-module="local/lazyLoad.run">
        
            <div class="header-widget-box header-above-wrapper">
                <div class="main-page-nav container">
                    
    















    <div class="menu-hamburger  hide-on-big-screens">
        
        
        
            <div class="menuToggle">
                <span></span>
                <span></span>
                <span></span>
            </div>
        
        
        
    </div>

    <div class="menu-mobile-container menu-hamburger
        
        
        " >
        <a class="main-page-logo"
           
           title="Pulselive Kenya"
           href="https://www.pulselive.co.ke/"
        >
            <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
        </a>


        
        
        
            <div class="menuToggleInside">
                <span></span>
                <span></span>
                <span></span>
            </div>
        
        
        
        <ul class="hamburger-list-items">
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="News" href="/news" >
                            News
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Politics" href="/news/politics">
                                            Politics
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/news/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Metro" href="/news/metro">
                                            Metro
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="World" href="/news/world">
                                            World
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Entertainment" href="/entertainment" >
                            Entertainment
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                            Celebrities
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Music" href="/entertainment/music">
                                            Music
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                            Movies
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Lifestyle" href="/lifestyle" >
                            Lifestyle
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                            Fashion
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                            Beauty &amp; Health
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-weddings">
                                            Relationships &amp; Weddings
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                            Food, Travel, Arts &amp; Culture
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Sports" href="/sports" >
                            Sports
                        </a>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Business" href="/business" >
                            Business
                        </a>
                        
                            <ul class="mobile-submenu collapsed">
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="Local" href="/business/local">
                                            Local
                                        </a>
                                    </li>
                                
                                    <li class="submenu-item ">
                                        <a class="submenu-title" title="International" href="/business/international">
                                            International
                                        </a>
                                    </li>
                                
                            </ul>
                        
                    </li>
                
                
            
                
                    <li class="menu-item-mobile ">
                        <a class="nav-menu-title" title="Quizzes" href="/quizzes" >
                            Quizzes
                        </a>
                        
                    </li>
                
                
            
        </ul>
    </div>


    

    






<div class="page-logo-wrapper ">
    <a class="main-page-logo"
       id="main-page-logo"
       title="Pulselive Kenya"
       href="https://www.pulselive.co.ke/"
    >
        <picture style="--noscript-src: url(https://radp.ocdn.eu/images/60x30-KE-WHITE.svg); " class="image-wrapper"><source data-src-light="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-src-dark="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="theme-switcher-element" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" srcset="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" type="image/svg+xml"><img width="110" height="55" alt="Pulselive Kenya" title="Pulselive Kenya" src="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" data-original="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg" class="image "></picture> <link rel="preload" as="image" href="https://radp.ocdn.eu/images/60x30-KE-WHITE.svg">
    </a>
</div>

    










    <ul class="main-page-nav menu-desktop menu-justify-center   hide-on-small-screens"
        
    >
        
            
                <li id="listMenuItem-0" class="menu-item  has-subMenu">
                    <a class="menu-title" title="News" href="/news" >
                        News
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Politics" href="/news/politics">
                                        Politics
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Local" href="/news/local">
                                        Local
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Metro" href="/news/metro">
                                        Metro
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-3" class="submenu-item ">
                                    <a class="submenu-title" title="World" href="/news/world">
                                        World
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-1" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Entertainment" href="/entertainment" >
                        Entertainment
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Celebrities" href="/entertainment/celebrities">
                                        Celebrities
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Music" href="/entertainment/music">
                                        Music
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Movies" href="/entertainment/movies">
                                        Movies
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-2" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Lifestyle" href="/lifestyle" >
                        Lifestyle
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Fashion" href="/lifestyle/fashion">
                                        Fashion
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="Beauty &amp; Health" href="/lifestyle/beauty-health">
                                        Beauty &amp; Health
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-2" class="submenu-item ">
                                    <a class="submenu-title" title="Relationships &amp; Weddings" href="/lifestyle/relationships-weddings">
                                        Relationships &amp; Weddings
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-3" class="submenu-item ">
                                    <a class="submenu-title" title="Food, Travel, Arts &amp; Culture" href="/lifestyle/food-travel">
                                        Food, Travel, Arts &amp; Culture
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-3" class="menu-item  ">
                    <a class="menu-title" title="Sports" href="/sports" >
                        Sports
                    </a>
                    
                </li>
            
        
            
                <li id="listMenuItem-4" class="menu-item  has-subMenu">
                    <a class="menu-title" title="Business" href="/business" >
                        Business
                    </a>
                    
                        <ul class="list-submenu">
                            
                                <li id="listMenuItem-0" class="submenu-item ">
                                    <a class="submenu-title" title="Local" href="/business/local">
                                        Local
                                    </a>
                                    
                                </li>
                            
                                <li id="listMenuItem-1" class="submenu-item ">
                                    <a class="submenu-title" title="International" href="/business/international">
                                        International
                                    </a>
                                    
                                </li>
                            
                        </ul>
                    
                </li>
            
        
            
                <li id="listMenuItem-5" class="menu-item  ">
                    <a class="menu-title" title="Quizzes" href="/quizzes" >
                        Quizzes
                    </a>
                    
                </li>
            
        
        
    </ul>


    
    <div class="headerSocials">
        <ul class="profileList">
            
                <li class="facebook">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.facebook.com/pulselivekenya"
                        title="Follow us on Facebook"
                        target="_blank"
                    >
                        instagram
                    </a>
                </li>
            
                <li class="twitter">
                    <a
                        rel="noopener noreferrer"
                        href="https://twitter.com/pulselivekenya"
                        title="Follow us on Twitter"
                        target="_blank"
                    >
                        twitter
                    </a>
                </li>
            
                <li class="instagram">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.instagram.com/pulselivekenya"
                        title="Follow us on Instagram"
                        target="_blank"
                    >
                        instagram
                    </a>
                </li>
            
                <li class="youtube">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw"
                        title="Watch us on YouTube"
                        target="_blank"
                    >
                        youtube
                    </a>
                </li>
            
                <li class="tiktok">
                    <a
                        rel="noopener noreferrer"
                        href="https://www.tiktok.com/@pulselivekenya"
                        title="Tiktok with us"
                        target="_blank"
                    >
                        tiktok
                    </a>
                </li>
            
        </ul>
    </div>


    

    

    

    

    

    

    

    

    

    

    






<div class="search-container-wrapper ">
    <div class="search-container" data-run-module="local/project.menu_search">
        <div id="search-button">
            <div class="svg icon-search" style="background-image:url(https://ocdn.eu/radp/icons/header/search.svg)"></div>
        </div>
        <form action="/search">
            <input type="search" placeholder="I’m looking for..." name="q" required data-placeholder-source="I’m looking for..." data-required-message="Please type your query and press search">
            <button type="submit">O</button>
        </form>
    </div>
</div>

                </div>
            </div>
        
        
        
            <div class="header-widget-box header-below-wrapper">
                <div class="main-page-nav container">
                    
    





                </div>
            </div>
        
    </div>
</header>

    
    <div class="page-container " data-run-module="local/lazyLoad.run">
        
            
            <div class="header-banner container-full">
                
                    


    
        <div class="adSlot " id='div-gpt-ad-1623221635248-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_970x90_a1" data-slot-size="[[728, 90], [970, 250], [970, 90]]" ></div>
    

                
            </div>
        
        <div class="container-full right-column-300">
            <div class="container">
                <div class="page-wrapper row">
                    <div id="article" class="main-section col-md-9">
                        <div class="articleBox ">
                            <div data-article-id="9zff2m0">
                                
                                    


    

    
        <div class="container-wrapper ">
            

            
                <!-- LEFT content columns -->
                <section class="ring-grid-box-container ring-grid-container container ">
                    
                    <div class="row">
                        <div class="ring-grid-left-box col-sm-12 col-md-12 col-lg-12">
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1621854609633-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PliveKE_DT_Sticky_Footer" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                


    
        <div class="adSlot " id='div-gpt-ad-1617224545705-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/plive_dt_floater" data-slot-size="[1, 1]" ></div>
    

                            
                                
                            
                                
                            
                                


    <div class="breadcrumbs-widget ">
        
            



    
        
            <a href="https://www.pulselive.co.ke/" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    <strong>
                        RADP / Pulse Kenya
                    </strong>
                </span>
            </a>

            

            
                <span class="breadcrumbs-item-sep">&nbsp;&gt;&nbsp;</span>
            
        
    
        
            <a href="https://www.pulselive.co.ke/news" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    
                        News
                    
                </span>
            </a>

            

            
                <span class="breadcrumbs-item-sep">&nbsp;&gt;&nbsp;</span>
            
        
    
        
            <a href="https://www.pulselive.co.ke/news/local" class="breadcrumbs-link">
                <span class="breadcrumbs-item">
                    
                        Local
                    
                </span>
            </a>

            

            
        
    

        
    </div>

                            
                                






    
        
            <h1 class="article-headline ">
                <span>
                    
                        Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money [Video]
                    
                </span>
            </h1>
        
    

                            
                                



    

    
        <div class="article-author-wrapper ">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/denis-mwangi" title="Denis Mwangi"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    

                                    
                                        <span class="author-name">Denis Mwangi</span>
                                    

                                    

                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                


    

    <div class="ring-detail-article-date ">
        
            <time class="detail-article-date date-type-publicationDate" datetime="2022-05-17T17:44:16.000+03:00">
                
                    May 17, 2022 5:44 PM
                
            </time>
        
    </div>

                            
                                


 
    
    
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                
                   <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
                
            
                
                
                   <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
            
                
                
                
                   <a href="mailto:?body=https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
                
                
                
                
                
            
        
    </div>

                            
                                









     <div id="lead" class="article-perex ">
          <p>The villager marched straight towards Rigathi Gachagua who was addressing the mourners and asked the MP to fulfil his promise</p>
     </div>

                            
                                
                            
                                












    <div class="article-gallery " >
            <div  class="image-container" id="article-main-image">
                
                <picture data-image-source="article_photo" data-caption="Villager interrupts burial of Rigathi Gachagua's brother to ask for money" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/YfQktkpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQMWzQGu); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/mwUk9kpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQMWzQGugaEwBQ" srcset="https://ocdn.eu/pulscms-transforms/1/mwUk9kpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQMWzQGugaEwBQ" type="image/webp"><img width="790" height="430" alt="Villager interrupts burial of Rigathi Gachagua's brother to ask for money" title="Villager interrupts burial of Rigathi Gachagua's brother to ask for money" src="https://ocdn.eu/pulscms-transforms/1/YfQktkpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQMWzQGu" data-original="https://ocdn.eu/pulscms-transforms/1/YfQktkpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQMWzQGu" class="image "></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/mwUk9kpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzQMWzQGugaEwBQ">
            </div>

        
            <div class="imgMetaData">
                
                    <span class="caption">Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money</span>
                

                
                

                

                

                <div class="clear"></div>
            </div>
        
    </div>

                            
                                
                            
                                
                            
                                




                            
                                















    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        A resident of Ruguru village in Mathira constituency in Nyeri County interrupted Mathira MP Rigathi Gachagua as he was addressing mourners during the burial of his late brother James Gachagua. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 inText" data-run-module="local/project.inText" id='div-gpt-ad-1618787017312-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/300x250_InReadAd_PliveKE" data-slot-size="[728, 90]" ></div>
    

                            
                                
                            
                                
    

    <div class="recommendedArticles">
        <span class="title">Recommended articles</span>
        <ul>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/TEDktkpTURBXy9jNmVkM2FhYmY1ZWY4ZjNlY2E5YWNkOGY0MDI1OTliMi5qcGeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/68jk9kpTURBXy9jNmVkM2FhYmY1ZWY4ZjNlY2E5YWNkOGY0MDI1OTliMi5qcGeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Kenya Kwanza leaders hit at Azimio saying they are just after constitutional changes " title="Kenya Kwanza leaders hit at Azimio saying they are just after constitutional changes " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/TEDktkpTURBXy9jNmVkM2FhYmY1ZWY4ZjNlY2E5YWNkOGY0MDI1OTliMi5qcGeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/news">news</a>
                        <a class="link"  data-uuid-ui="ea28da85-32ec-4b21-8b8e-e01eeac8420c" data-ei="4ldrttnbdb" href="https://www.pulselive.co.ke/news/local/kenya-kwanza-leaders-hit-at-azimio-saying-they-were-just-after-constitutional-changes/s487ts6">Kenya Kwanza leaders hit at Azimio saying they are just after constitutional changes </a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/tAgktkpTURBXy80Y2UzNDQ3NTNhMTM3MGM3ZTMyOGQxM2UyMWFmNDU3ZS5wbmeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/cgMk9kpTURBXy80Y2UzNDQ3NTNhMTM3MGM3ZTMyOGQxM2UyMWFmNDU3ZS5wbmeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Simple Boy denies getting back with ex Pritty Vishy, says he paid Sh2M dowry elsewhere" title="Simple Boy denies getting back with ex Pritty Vishy, says he paid Sh2M dowry elsewhere" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/tAgktkpTURBXy80Y2UzNDQ3NTNhMTM3MGM3ZTMyOGQxM2UyMWFmNDU3ZS5wbmeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/entertainment">entertainment</a>
                        <a class="link"  data-uuid-ui="c35ab80c-83d8-4f4f-a9b0-2283962b5aa8" data-ei="4ldrttnbdb" href="https://www.pulselive.co.ke/entertainment/celebrities/stevo-simple-boy-shares-he-split-with-ex-girlfriend-pritty-vishy/ndtlplq">Simple Boy denies getting back with ex Pritty Vishy, says he paid Sh2M dowry elsewhere</a>
                    </div>
                </li>
            
                
                

                <li>
                    <div class="image">
                        
                            <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/MLZktkpTURBXy8yZTk0OWU4N2FhYjlkNjQzMDdkOTQ3Yzg4ZWUzMjkwOC5qcGeRkwVGRg); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/wI_k9kpTURBXy8yZTk0OWU4N2FhYjlkNjQzMDdkOTQ3Yzg4ZWUzMjkwOC5qcGeRkwVGRoGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Risper Faith to undergo mini-gastric bypass, 1 year after liposuction" title="Risper Faith to undergo mini-gastric bypass, 1 year after liposuction" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/MLZktkpTURBXy8yZTk0OWU4N2FhYjlkNjQzMDdkOTQ3Yzg4ZWUzMjkwOC5qcGeRkwVGRg" class="image lazyloaded" loading="lazy"></picture> 
                        
                    </div>
                    <div class="linksWrapper">
                        <a class="category" href="https://www.pulselive.co.ke/lifestyle">lifestyle</a>
                        <a class="link"  data-uuid-ui="bd3adab0-bd0a-4133-809d-a1cb494a67c6" data-ei="4ldrttnbdb" href="https://www.pulselive.co.ke/lifestyle/womens-health/risper-faith-to-undergo-mini-gastric-bypass-surgery-1-year-after-liposuction/mcrxnnc">Risper Faith to undergo mini-gastric bypass, 1 year after liposuction</a>
                    </div>
                </li>
            
        </ul>
    </div>

                            
                                















    

    <div class="article-content "
         id="article-content-body"
          >
        <div class="article-body-text" >
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            

            

            
                
                    
                    
                        
                        

                        
                            
                                
                            
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                                
                                                
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        As Rigathi was making his speech, the man who was later identified as Muchangi approached the podium and leaned into the MP’s ear to whisper a message. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        This caught the mourners by surprise forcing the newly appointed Kenya Kwanza running mate to acknowledge that he knew the ‘intruder’ to allay fears. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-image ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- image: supported -->
    
    


    
    
    
    

    <div class="imageBlock aligment-center">
		<div>
			
                <span class="image-holder" data-fancybox="images-20fe9684-72f8-432f-937c-4d1e4490ed2a" data-caption="Villager interrupts burial of Rigathi Gachagua's brother to ask for money"  >
                    <picture style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/uC9ktkpTURBXy82NTkxM2I3ZjlkMjc3YWJiYjUxYzhmNWVlOTdlNzZhZS5wbmeRlQLNAxbNAbTCww); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/z9mk9kpTURBXy82NTkxM2I3ZjlkMjc3YWJiYjUxYzhmNWVlOTdlNzZhZS5wbmeRlQLNAxbNAbTCw4GhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'436'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="790" height="436" alt="Villager interrupts burial of Rigathi Gachagua's brother to ask for money" title="Villager interrupts burial of Rigathi Gachagua's brother to ask for money" class="image lazyloaded imgWithMetaData" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'790'%20height%3D'436'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/uC9ktkpTURBXy82NTkxM2I3ZjlkMjc3YWJiYjUxYzhmNWVlOTdlNzZhZS5wbmeRlQLNAxbNAbTCww" loading="lazy"></picture> 
                </span>
			
			<div class="imgMetaData">
				
                    <span class="caption">Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money</span>
                

                

				
					<span class="copyright"> Pulse Live Kenya</span>
				
				<div class="clear"></div>
			</div>
		</div>
	</div>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The MP then reached into his blazer and handed the rugged villager a Sh1,000 note amid laughter which was a welcome comical relief during the emotional ceremony.
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        “<em>Anasema nimpange mapema kuna mahali anaenda. Ni rafiki yangu anaitwa Muchangi…tuliagana na yeye 18 years ago that kila tukionanana nampa Sh1,000</em>. <em>Sasa ameniambia amengoja kutoka 10:00 a.m. na kuna mahali anataka kwenda na ameshindwa kungojea</em>
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        <em>"</em>(He is my friend Muchangi, 18 years ago we agreed that every time we meet I'd give him Sh1,000. He was letting me know that he has been waiting since 10:00 a.m. and because he has somewhere else to go, he had to speak to me before he left)<em>,</em>” Rigathi made light of the incident. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-embedded_application ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- embedded_application: supported -->
    
    


    
    
        <div class="embeddedApp"
            data-run-module="local/common.lazyEmbeds"
            data-embed="&quot;&lt;div class=\&quot;pulsembed_embed\&quot; data-run-module=\&quot;pulsembed/pulsembed.init\&quot; data-src=\&quot;//pulsembed.eu/p2em/kTmyvu5v5/\&quot; data-height-hint=\&quot;56.5%\&quot; data-sandbox=\&quot;standard\&quot; data-author-name=\&quot;Kenyan%20Viral%20Videos\&quot; data-embed-id=\&quot;kTmyvu5v5\&quot; data-provider-name=\&quot;YouTube\&quot; data-extra-embed-params=\&quot;%7B%7D\&quot; data-embed-img=\&quot;\&quot;&gt;&lt;a href=\&quot;https://www.youtube.com/watch?v=06PAKwyVMmA\&quot; target=\&quot;_blank\&quot;&gt;Villager interrupts burial of Rigathi Gachagua&amp;#39;s brother to ask for money&lt;/a&gt;&lt;/div&gt;\n&quot;">
                <div class="ringLoader">
                    <div class="topWrapper"></div>
                    <div class="bottomWrapper"></div>
                </div>
            
        </div>
    


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-heading ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- heading: supported -->
    
    


    
    

    

    <h3 class="heading-h3 replaced-h1" id="nav-ring-9">
        Rigathi eulogises elder brother James Gachagua
    </h3>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Mathira MP Rigathi Gachagua eulogised his brother James Gachagua as the head of their family after being appointed by their late father. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Speaking during his brother’s burial on Tuesday, May 17 in Nyeri County, Gachagua said the deceased had managed to unite the family in the absence of their patriarch. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The MP, who was recently picked as the running mate to Deputy President William Ruto, said his late brother pushed him to join politics. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        When Nderitu Gachagua declared he was going to vie for the Nyeri Governor post in 2013, James on the other hand tried his luck in the Mathira parliamentary seat. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        Unfortunately, Only one of the two brothers was elected; Nderitu became the first governor of Nyeri. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                                
                                    
                                    
                                        <div class="ringCommonDetail ringBlockType-paragraph ">
                                            
                                            
                                            
                                                
                                                    
                                                    
                                                    
    <!-- paragraph: supported -->
    
    
    <p>
        The late governor would later succumb to cancer months before the 2017 General Elections. 
    </p>


                                                
                                            
                                        </div>
                                    
                                
                            
                        
                    
                
            
        </div>
    </div>

                            
                                
                            
                                
                            
                                

                            
                                
                            
                                



    <div class="taxonomies article-taxonomies ">
        
        <ul>
            
                <li>
                    
                        <a href="/topic/rigathi-gachagua" title="RigathiGachagua">
                    
                        RigathiGachagua
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/nyeri-county" title="NyeriNews">
                    
                        NyeriNews
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/kenyakwanza" title="KenyaKwanza">
                    
                        KenyaKwanza
                    
                        </a>
                    
                </li>
            
                <li>
                    
                        <a href="/topic/2022-elections-kenya" title="2022ElectionsKE">
                    
                        2022ElectionsKE
                    
                        </a>
                    
                </li>
            
        </ul>
    </div>

                            
                                



    

    
        <div class="article-author-wrapper  authorWithImage">
            <p class="authorLabel">Authors:</p>

            <div class="article-author">
                
                    
                    
                    
                    
                    
                    

                    
                        <span class="author-item">
                            <a href="https://www.pulselive.co.ke/author/denis-mwangi" title="Denis Mwangi"  class="single-author-wrapper" data-after-text="MORE FROM THE AUTHOR »">
                                
                                    
                                        <span class="author-photo">
                                            

                                            

                                            <picture data-image-source="article-author" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/E26ktkpTURBXy9jNjhjMzNmMGEzZmRkNTAyYWMyZDM3N2NjNTFmMzJlNi5qcGeSlQMAAM0EAM0FAJMFRkY); " class="image-wrapper"><source data-original="https://ocdn.eu/pulscms-transforms/1/4wvk9kpTURBXy9jNjhjMzNmMGEzZmRkNTAyYWMyZDM3N2NjNTFmMzJlNi5qcGeSlQMAAM0EAM0FAJMFRkaBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="70" height="70" alt="Denis Mwangi" title="Denis Mwangi" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'70'%20height%3D'70'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/E26ktkpTURBXy9jNjhjMzNmMGEzZmRkNTAyYWMyZDM3N2NjNTFmMzJlNi5qcGeSlQMAAM0EAM0FAJMFRkY" class="image lazyloaded" loading="lazy"></picture> 
                                        </span>
                                    

                                    

                                    

                                    
                                
                                    

                                    
                                        <span class="author-name">Denis Mwangi</span>
                                    

                                    

                                    
                                
                                    

                                    

                                    

                                    
                                        <span class="author-description">Denis is a highly professional and talented multimedia journalist with a solid experience in creating compelling news as well as distributing or delivering it using multiple digital platforms to engage readers.</span>
                                    
                                
                            </a>

                            
                        </span>
                    
                
            </div>
        </div>
    

                            
                                


 
    
    
    
    
    
    

    <div class="ring-detail-social-share ">
        
            
        

        

        
            
                
                   <a data-run-module="local/socialShare.facebook" href="javascript:void(0);" class="shareIcon ring-icon-facebook " data-gtm-social="facebook" title="Facebook" data-extrautm="utm_medium=social&utm_source=facebook&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
                
            
                
                
                   <a data-run-module="local/socialShare.twitter" href="javascript:void(0);" class="shareIcon ring-icon-twitter " data-gtm-social="twitter" title="Twitter" data-socialname="" data-extrautm="utm_medium=social&utm_source=twitter&utm_campaign=share-button" style="width: 30px; height: 30px"></a>
                
                
                
                
                
                
            
                
                
                
                   <a href="mailto:?body=https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0?utm_medium%3Demail%26utm_source%3Dtransactional%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-email " data-gtm-social="email" title="Email" style="width: 30px; height: 30px"></a>
                
                
                
                
                
            
                
                
                
                
                   <a href="whatsapp://send?text=https%3A%2F%2Fwww.pulselive.co.ke%2Fnews%2Flocal%2Fvillager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video%2F9zff2m0?utm_medium%3Dsocial%26utm_source%3Dwhatsapp%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-whatsapp " data-gtm-social="whatsapp" title="WhatsApp" style="width: 30px; height: 30px"></a>
                
                
                
                
            
                
                
                
                
                
                   <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0?utm_medium%3Dsocial%26utm_source%3Dlinkedin%26utm_campaign%3Dshare-button" class="shareIcon ring-icon-linkedin " data-gtm-social="linkedin" target="_blank" title="LinkedIn" style="width: 30px; height: 30px"></a>
                
                
                
            
        
    </div>

                            
                                



    <div class="basicWidget homepageNewsletter">
        <div class="bw-wrapper">
        
            <h3 class="main-section-title">JOIN OUR PULSE COMMUNITY!</h3>
        
            <div class="newsletterWrapper">
                <div class="socialList">
                    
                        <div class="socialIcon facebook">
                            
                                <a href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon twitter">
                            
                                <a href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon instagram">
                            
                                <a href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon youtube">
                            
                                <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                        <div class="socialIcon tiktok">
                            
                                <a href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer">
                                    <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="64" height="64" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'64'%20height%3D'64'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/nl/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                </a>
                            
                        </div>
                    
                </div>
                <div id="nlbox" class="newsletter dsk">
                    <div class="signUpContainer">
                        <div class="introMessage">
                            Our newsletter gives you access to a curated selection of the most important stories daily.
                        </div>
                        <form id="newsletter-form" method="POST" class="inputForm" action="#" data-run-module="local/project.newsletter_submit">
                            <input type="email" placeholder="Email" name="email" id="email" required>
                            <button id="submitEmail" class="submit">
                                SUBSCRIBE
                            </button>
                        </form>
                    </div>
                    <div id="error" class="error hide"></div>
                    <div id="thanksContainer" class="thanksContainer hide">
                        <div class="row" id="thanksMessage">
                            <p class="subTitle"> Welcome to the Pulse Community! We will now be sending you a daily newsletter on news, entertainment and more.   Also join us across all of our other channels - we love to be connected!</p>
                        </div>
                    </div>
                </div>
                
                    <div></div>
                    <div id="pushBox" class="pushContainer" data-run-module="local/project.push_notification">
                        <div class='onesignal-customlink-container'></div>
                        <div class="blockedText" id="pushBlocked">Unblock notifications in browser settings.</div>
                    </div>
                
            </div>
        </div>
    </div>

                            
                                
                            
                                


    
        <div class="adSlot placeholder-90 " id='div-gpt-ad-1618841981942-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/PulseKE_DT_Article_Below_Article_A" data-slot-size="[728, 90]" ></div>
    

                            
                                
    
        
            <div class="eyewitnessWdg" style="margin-top: 25px;">    <p>Eyewitness? Submit your stories now via social or: </p>    <p>    <b>Email: </b><a href="mailto:news@pulselive.co.ke">news@pulselive.co.ke</a></b></p></div>
        
    

                            
                                



    
    

    <div class="basicWidget hp-colSize-12 latest bw-v2"
        style=""
        
        
        >

        <div class="bw-wrapper">
             

            
                


    <h2 class="main-section-title">

    
    
        
    

    
        Recommended articles
    

    </h2>

            
                
    <div class="section-elements">
        <div class="items-wrapper columns-3 big-elements-0" >
        

            
            
            

            <div class="layout-wrapper wrap-element-1 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/5NDktkpTURBXy9jNmVkM2FhYmY1ZWY4ZjNlY2E5YWNkOGY0MDI1OTliMi5qcGeSlQMAEM0En80CmZMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/WZRk9kpTURBXy9jNmVkM2FhYmY1ZWY4ZjNlY2E5YWNkOGY0MDI1OTliMi5qcGeSlQMAEM0En80CmZMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Kenya Kwanza leaders hit at Azimio saying they are just after constitutional changes " title="Kenya Kwanza leaders hit at Azimio saying they are just after constitutional changes " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/5NDktkpTURBXy9jNmVkM2FhYmY1ZWY4ZjNlY2E5YWNkOGY0MDI1OTliMi5qcGeSlQMAEM0En80CmZMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Kenya Kwanza leaders hit at Azimio saying they are just after constitutional changes 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/kenya-kwanza-leaders-hit-at-azimio-saying-they-were-just-after-constitutional-changes/s487ts6" title="Kenya Kwanza leaders hit at Azimio saying they are just after constitutional changes "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-2 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/s2xktkpTURBXy8xNjdlMjRmMjI2ZTQxMzVlZWRjZjE3MTk2NDZlODM0YS5qcGeSlQM1AM0DVc0B4JMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/tcnk9kpTURBXy8xNjdlMjRmMjI2ZTQxMzVlZWRjZjE3MTk2NDZlODM0YS5qcGeSlQM1AM0DVc0B4JMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="CCTV shows how Mirema man was cornered and shot in broad daylight [Video]" title="CCTV shows how Mirema man was cornered and shot in broad daylight [Video]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/s2xktkpTURBXy8xNjdlMjRmMjI2ZTQxMzVlZWRjZjE3MTk2NDZlODM0YS5qcGeSlQM1AM0DVc0B4JMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            CCTV shows how Mirema man was cornered and shot in broad daylight [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/cctv-shows-mirema-man-moses-njoroge-muiruri-was-cornered-killed-in-broad-daylight/w611k89" title="CCTV shows how Mirema man was cornered and shot in broad daylight [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-3 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/PnWktkpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/2etk9kpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Villager interrupts burial of Rigathi Gachagua's brother to ask for money [Video]" title="Villager interrupts burial of Rigathi Gachagua's brother to ask for money [Video]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/PnWktkpTURBXy83ODUxYzE3Mjk3ZmQxMzM3YTFiMDQ4N2NjNzk3MGNmMC5wbmeSlQMtAM0CQM0BRZMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0" title="Villager interrupts burial of Rigathi Gachagua&#39;s brother to ask for money [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-4 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/N3qktkpTURBXy9kZmM5NDBiNTNlZTY3ZGIzYTgxNjkyY2UwNjQ3ZGNhYS5qcGeSlQMALM0CRc0BR5MFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/K1qk9kpTURBXy9kZmM5NDBiNTNlZTY3ZGIzYTgxNjkyY2UwNjQ3ZGNhYS5qcGeSlQMALM0CRc0BR5MFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Ledama explains why Kalonzo might rejoin Azimio" title="Ledama explains why Kalonzo might rejoin Azimio" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/N3qktkpTURBXy9kZmM5NDBiNTNlZTY3ZGIzYTgxNjkyY2UwNjQ3ZGNhYS5qcGeSlQMALM0CRc0BR5MFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Ledama explains why Kalonzo might rejoin Azimio
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/narok-senator-ledama-olekina-hints-at-kalonzo-musyoka-rejoining-azimio-coalition/ble2kkg" title="Ledama explains why Kalonzo might rejoin Azimio"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-5 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/zRcktkpTURBXy9mNTAwMjQ1ZjRlMzAyOGI4MzFmODg1ODdlNGQwNzU1ZC5qcGeSlQMAAs0ChM0Ba5MFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/3Blk9kpTURBXy9mNTAwMjQ1ZjRlMzAyOGI4MzFmODg1ODdlNGQwNzU1ZC5qcGeSlQMAAs0ChM0Ba5MFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Playing their song was a show of love - Raila responds to Sauti Sol" title="Playing their song was a show of love - Raila responds to Sauti Sol" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/zRcktkpTURBXy9mNTAwMjQ1ZjRlMzAyOGI4MzFmODg1ODdlNGQwNzU1ZC5qcGeSlQMAAs0ChM0Ba5MFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Playing their song was a show of love - Raila responds to Sauti Sol
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/raila-odinga-odm-respond-after-sauti-sol-threatened-to-sue-azimio-la-umoja-one-kenya/q3wqrsg" title="Playing their song was a show of love - Raila responds to Sauti Sol"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-6 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/AiyktkpTURBXy8xMDJjMjAzNGIyNWVkNmUxOWFmNmFkMzU3NWI0ODI2ZC5qcGeSlQMAAM0EOM0CX5MFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/jwQk9kpTURBXy8xMDJjMjAzNGIyNWVkNmUxOWFmNmFkMzU3NWI0ODI2ZC5qcGeSlQMAAM0EOM0CX5MFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Officer who woke up from 9-month coma, only to find he was dismissed from NPS " title="Officer who woke up from 9-month coma, only to find he was dismissed from NPS " src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/AiyktkpTURBXy8xMDJjMjAzNGIyNWVkNmUxOWFmNmFkMzU3NWI0ODI2ZC5qcGeSlQMAAM0EOM0CX5MFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Officer who woke up from 9-month coma, only to find he was dismissed from NPS 
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/how-officer-who-woke-up-from-9-month-coma-found-he-was-dismissed-from-nps/gzh14bw" title="Officer who woke up from 9-month coma, only to find he was dismissed from NPS "></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-7 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/eXGktkpTURBXy9kZDgzNTNjMzc0NjllOThhOTEwZTczMWZmZGJkZDk3Ny5wbmeSlQMAJc0Dmc0CBpMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/qJxk9kpTURBXy9kZDgzNTNjMzc0NjllOThhOTEwZTczMWZmZGJkZDk3Ny5wbmeSlQMAJc0Dmc0CBpMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Ruto reacts to Martha Karua's selection as Raila's running mate" title="Ruto reacts to Martha Karua's selection as Raila's running mate" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/eXGktkpTURBXy9kZDgzNTNjMzc0NjllOThhOTEwZTczMWZmZGJkZDk3Ny5wbmeSlQMAJc0Dmc0CBpMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Ruto reacts to Martha Karua&#39;s selection as Raila&#39;s running mate
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/dp-william-ruto-reacts-to-martha-karuas-selection-as-raila-odinga-running-mate/vx9rewv" title="Ruto reacts to Martha Karua&#39;s selection as Raila&#39;s running mate"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-8 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/62pktkpTURBXy9hYzZiZjM0Njc1NzE2NmRhMjU5Y2ExZjk1MDNmNTRlMC5qcGeSlQMAAc0ChM0BapMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/RqWk9kpTURBXy9hYzZiZjM0Njc1NzE2NmRhMjU5Y2ExZjk1MDNmNTRlMC5qcGeSlQMAAc0ChM0BapMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="Another suspect arrested after brutal murder of KIMC student Purity Wangechi" title="Another suspect arrested after brutal murder of KIMC student Purity Wangechi" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/62pktkpTURBXy9hYzZiZjM0Njc1NzE2NmRhMjU5Y2ExZjk1MDNmNTRlMC5qcGeSlQMAAc0ChM0BapMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            Another suspect arrested after brutal murder of KIMC student Purity Wangechi
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/another-suspect-arrested-after-brutal-murder-of-kimc-student-purity-wangechi/2nvm78h" title="Another suspect arrested after brutal murder of KIMC student Purity Wangechi"></a>
    </div>

                        
                    
                </div>

                
            </div>
        

            
            
            

            <div class="layout-wrapper wrap-element-9 ">
                
                
                

                <div class="layout-item list-item col-xs-12 story-role-article  ">
                    
                        
                        
                            
    <div class="imageBlock">
        
        
        <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/Mi0ktkpTURBXy9lNGJjMmRiYmJkNzY5MWM3MjQxNWQyNDM1ZGVjNTZiNi5qcGeSlQMoAM0CAc0BIZMFzPPMiA); "><source data-original="https://ocdn.eu/pulscms-transforms/1/Kl8k9kpTURBXy9lNGJjMmRiYmJkNzY5MWM3MjQxNWQyNDM1ZGVjNTZiNi5qcGeSlQMoAM0CAc0BIZMFzPPMiIGhMAU" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="243" height="136" alt="DP Ruto's bodyguard nursing injuries after falling off speeding vehicle [Video]" title="DP Ruto's bodyguard nursing injuries after falling off speeding vehicle [Video]" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'243'%20height%3D'136'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/Mi0ktkpTURBXy9lNGJjMmRiYmJkNzY5MWM3MjQxNWQyNDM1ZGVjNTZiNi5qcGeSlQMoAM0CAc0BIZMFzPPMiA" class="image lazyloaded" loading="lazy"></picture> 
    </div>

                        
                    
                        
                        
                            
    <div class="bw-title">
        <h3 class="title">
            DP Ruto&#39;s bodyguard nursing injuries after falling off speeding vehicle [Video]
        </h3>
    </div>

                        
                    
                        
                        
                            
    
    <div class="gradient-overlay">
        <a href="https://www.pulselive.co.ke/news/local/dp-william-rutos-bodyguard-nursing-injuries-after-falling-off-speeding-vehicle-in/9qnp9rl" title="DP Ruto&#39;s bodyguard nursing injuries after falling off speeding vehicle [Video]"></a>
    </div>

                        
                    
                </div>

                
            </div>
        
        </div>
    </div>

            
        </div>
    </div>

                            
                                
                            
                        </div>
                    </div>
                </section>
            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

    

    
        <div class="container-wrapper ">
            

            

            
        </div>
    

                                
                            </div>
                        </div>

                        
                    </div>

                    
                        
                            
                                
                                <div class="side-section col-md-3" id="content-side-section">
                                    <div>
                                        
                                            


    
        <div class="adSlot placeholder-600 mt-4 " id='div-gpt-ad-1617227624691-0' data-run-module="local/project.loadAd" data-slot-name="/53159133/pliveke_dt_article_300x250_b1" data-slot-size="[[300, 250], [300, 600], [160, 600], [120, 600]]" ></div>
    

                                        
                                            


    <div class="widget-trending basicWidget ">
        
            <h2 class="main-section-title">
                Trending
            </h2>
        

        
        <div class="widget-trending-items">
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Details of the heated 17-hour standoff on Ruto&#39;s running mate
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/v2JktkpTURBXy9lYTc1Y2U1ODEwYjJjOWJiNDJiYTM3Nzg0Mjk0MjFmOS5qcGeSlQMAAM0FAM0C0JMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/pAfk9kpTURBXy9lYTc1Y2U1ODEwYjJjOWJiNDJiYTM3Nzg0Mjk0MjFmOS5qcGeSlQMAAM0FAM0C0JMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/pAfk9kpTURBXy9lYTc1Y2U1ODEwYjJjOWJiNDJiYTM3Nzg0Mjk0MjFmOS5qcGeSlQMAAM0FAM0C0JMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Deputy President William Ruto and Mathira MP Rigathi Gachagua" title="Deputy President William Ruto and Mathira MP Rigathi Gachagua" class="image " src="https://ocdn.eu/pulscms-transforms/1/v2JktkpTURBXy9lYTc1Y2U1ODEwYjJjOWJiNDJiYTM3Nzg0Mjk0MjFmOS5qcGeSlQMAAM0FAM0C0JMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/v2JktkpTURBXy9lYTc1Y2U1ODEwYjJjOWJiNDJiYTM3Nzg0Mjk0MjFmOS5qcGeSlQMAAM0FAM0C0JMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/pAfk9kpTURBXy9lYTc1Y2U1ODEwYjJjOWJiNDJiYTM3Nzg0Mjk0MjFmOS5qcGeSlQMAAM0FAM0C0JMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/local/kithure-kindiki-and-rigathi-gachagua-disagree-on-william-ruto-running-mate-at-karen/2qqkxb2"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Busia-bound bus makes surprise detour to DCI headquarters, 2 arrested [Photo]
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/pdEktkpTURBXy9kMmRhNTc4NmEzM2MwMDM3YTNhMDVjZDBmZjg1OWI1OC5qcGeSlQMAc80IAM0EgJMFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/1HMk9kpTURBXy9kMmRhNTc4NmEzM2MwMDM3YTNhMDVjZDBmZjg1OWI1OC5qcGeSlQMAc80IAM0EgJMFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/1HMk9kpTURBXy9kMmRhNTc4NmEzM2MwMDM3YTNhMDVjZDBmZjg1OWI1OC5qcGeSlQMAc80IAM0EgJMFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Busia-bound bus makes surprise detour to DCI headquarters, 2 arrested" title="Busia-bound bus makes surprise detour to DCI headquarters, 2 arrested" class="image " src="https://ocdn.eu/pulscms-transforms/1/pdEktkpTURBXy9kMmRhNTc4NmEzM2MwMDM3YTNhMDVjZDBmZjg1OWI1OC5qcGeSlQMAc80IAM0EgJMFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/pdEktkpTURBXy9kMmRhNTc4NmEzM2MwMDM3YTNhMDVjZDBmZjg1OWI1OC5qcGeSlQMAc80IAM0EgJMFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/1HMk9kpTURBXy9kMmRhNTc4NmEzM2MwMDM3YTNhMDVjZDBmZjg1OWI1OC5qcGeSlQMAc80IAM0EgJMFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/local/busia-bound-bus-makes-surprise-detour-to-dci-headquarters-2-arrested-photo/rp2cc94"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Gov&#39;t pathologist announces results of fresh autopsy on Memusi Sankok
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/4YOktkpTURBXy9jYzc4YTBiODkyNjljMjNmYWExNDlmOThiMzEzNzZjMy5qcGeSlQMAJc0EsM0Co5MFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/-euk9kpTURBXy9jYzc4YTBiODkyNjljMjNmYWExNDlmOThiMzEzNzZjMy5qcGeSlQMAJc0EsM0Co5MFzQEszKyBoTAF" srcset="https://ocdn.eu/pulscms-transforms/1/-euk9kpTURBXy9jYzc4YTBiODkyNjljMjNmYWExNDlmOThiMzEzNzZjMy5qcGeSlQMAJc0EsM0Co5MFzQEszKyBoTAF" type="image/webp"><img width="300" height="172" alt="Kenyan government will bury bodies of coronavirus victims if not picked within 24 hrs - Chief Pathologist Johansen Oduor" title="Kenyan government will bury bodies of coronavirus victims if not picked within 24 hrs - Chief Pathologist Johansen Oduor" class="image " src="https://ocdn.eu/pulscms-transforms/1/4YOktkpTURBXy9jYzc4YTBiODkyNjljMjNmYWExNDlmOThiMzEzNzZjMy5qcGeSlQMAJc0EsM0Co5MFzQEszKw" data-original="https://ocdn.eu/pulscms-transforms/1/4YOktkpTURBXy9jYzc4YTBiODkyNjljMjNmYWExNDlmOThiMzEzNzZjMy5qcGeSlQMAJc0EsM0Co5MFzQEszKw"></picture> <link rel="preload" as="image" href="https://ocdn.eu/pulscms-transforms/1/-euk9kpTURBXy9jYzc4YTBiODkyNjljMjNmYWExNDlmOThiMzEzNzZjMy5qcGeSlQMAJc0EsM0Co5MFzQEszKyBoTAF">
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/local/government-pathologist-announces-results-of-fresh-autopsy-on-memusi-sankok/2jhb8qh"></a>
                        </div>
                    </div>
                </div>
            
                <div class="layout-wrapper">
                    
                    
                    
                    <div class="layout-item  story-role-article ">
                        
                            <div class="bw-title">
                                
                                <h3 class="title">
                                    Kibaki&#39;s trusted staffers lose jobs 
                                </h3>
                            </div>
                        
                        
                        
                            <div class="imageBlock">
                                <picture class="image-wrapper bw-image" style="--noscript-src: url(https://ocdn.eu/pulscms-transforms/1/Ya6ktkpTURBXy84NjQwZTE4Njc4MDRhODc2Y2ViN2FjMjg2YzQ4NWUwYy5qcGeSlQMAJc0EsM0Co5MFzQEszKw); "><source data-original="https://ocdn.eu/pulscms-transforms/1/v_bk9kpTURBXy84NjQwZTE4Njc4MDRhODc2Y2ViN2FjMjg2YzQ4NWUwYy5qcGeSlQMAJc0EsM0Co5MFzQEszKyBoTAF" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/webp"><img width="300" height="172" alt="Former President Mwai Kibaki" title="Former President Mwai Kibaki" class="image lazyloaded" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'300'%20height%3D'172'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/pulscms-transforms/1/Ya6ktkpTURBXy84NjQwZTE4Njc4MDRhODc2Y2ViN2FjMjg2YzQ4NWUwYy5qcGeSlQMAJc0EsM0Co5MFzQEszKw" loading="lazy"></picture> 
                            </div>
                        
                        <div class="gradient-overlay">
                            <a href="https://www.pulselive.co.ke/news/local/the-late-mwai-kibakis-trusted-staffers-lose-jobs-as-treasury-cuts-funding-to-maintain/8kqmyst"></a>
                        </div>
                    </div>
                </div>
            
        </div>
        
    </div>

                                        
                                            


    
        <div class="stickyWrapper" id="stickyWrapper" data-run-module="local/project.floatSticky" data-slot-name="/53159133/pliveke_dt_article_300x250_b3" data-slot-size="[[300, 600], [300, 250], [160, 600], [120, 600]]">
            <div class="first sticky-slot" id='div-gpt-ad-1617227699389-0'></div>
        </div>
    

                                        
                                    </div>
                                </div>
                            
                        
                    
                </div>
            </div>
        </div>
    </div>

    

    
    
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.pulselive.co.ke"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.pulselive.co.ke/news"},{"@type":"ListItem","position":3,"name":"Local","item":"https://www.pulselive.co.ke/news/local"},{"@type":"ListItem","position":4,"name":"Villager Interrupts Burial Of Rigathi Gachaguas Brother To Ask For Money Video","item":"https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0"}]}
            </script>
        
            <script type="application/ld+json">
                {"@context":"https://schema.org","@type":"NewsArticle","@id":"https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0#article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0"},"headline":"Villager interrupts burial of Rigathi Gachagua's brother to ask for money [Video]","primaryImageOfPage":{"@id":"https://www.pulselive.co.ke/news/local/villager-interrupts-burial-of-rigathi-gachaguas-brother-to-ask-for-money-video/9zff2m0#mainPhoto"},"image":["https://ocdn.eu/images/pulscms/ODI7MDA_/7851c17297fd1337a1b0487cc7970cf0.png"],"datePublished":"2022-05-17T17:44:16.000+03:00","dateModified":"2022-05-17T17:44:16.000+03:00","author":[{"@type":"Person","name":"Denis Mwangi","url":"https://www.pulselive.co.ke/author/denis-mwangi","image":{"@type":"ImageObject","url":"https://ocdn.eu/images/pulscms/N2M7MDA_/c68c33f0a3fdd502ac2d377cc51f32e6.jpg","height":1280,"width":1024}}],"publisher":{"@type":"Organization","name":"Pulselive Kenya","logo":{"@type":"ImageObject","url":"https://radp.ocdn.eu/images/60x30-KE-WHITE.svg"}},"keywords":["Rigathi Gachagua","Nyeri County","KenyaKwanza","2022 Elections Kenya"],"description":"The villager marched straight towards Rigathi Gachagua who was addressing the mourners and asked the MP to fulfil his promise","isAccessibleForFree":true}
            </script>
        
    



    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
            <div class="footer-widget-box footer-below-wrapper container">
                <div class="footer-widget-wrapper">
                    
    





    
        
    

    <script>
        window.dataLayer = window.dataLayer || [];

        const eventData = {
            event: 'pageload',
            articleAuthor: 'Denis Mwangi',
            articleCategory: 'news',
        }

        window.addEventListener('load', function () {
            window.dataLayer.push(eventData);
        });
    </script>


    











<div class="africaFooter">
    <div class="container">
        
            <div class="advertiseFooterContainer">
                <div class="advertTitle">
                    Advertise with us
                </div>
                <div class="advertBody">
                    Reach out to us at <a style="color: #ff0" href="mailto:salesteam@pulse.co.ke" rel="noopener noreferrer">salesteam@pulse.co.ke</a> or +254113897895 to advertise with us. Find out more about Pulse's products and advertising opportunities at <a href="https://pulse.africa" target="_blank" style="color: #ff0" rel="noopener noreferrer"> pulse.africa</a>   
                </div>
            </div>
        

        <div class="footer-wrapper">
            

            
                <div class="footer-menu">
                    <ul class="footer-menu-list">
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Home" href="/">
                                            Home
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Entertainment" href="/entertainment">
                                            Entertainment
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Lifestyle" href="/lifestyle">
                                            Lifestyle
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Sports" href="/sports">
                                            Sports
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Business" href="/business">
                                            Business
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="footer-menu-item">
                                    
                                        <a class="footer-menu-title" title="Quizzes" href="/quizzes">
                                            Quizzes
                                        </a>
                                    
                                </li>
                            
                        
                    </ul>
                </div>
            

            
                <div class="footer-links-wrapper" id="footer-links-menu">
                    <ul class="links-list">
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/about-us" title="About Us">
                                            About Us
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/about-us" title="About Us">
                                            About Us
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="https://pulse.africa" title="Advertise with us">
                                            Advertise with us
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/terms-of-use" title="Terms &amp; Conditions">
                                            Terms &amp; Conditions
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/info/privacy-policy" title="Privacy Policy">
                                            Privacy Policy
                                        </a>
                                    
                                </li>
                            
                        
                            
                                <li class="link-item">
                                    
                                        <a class="link-title menu-title" href="/influencer-awards/get-ready-for-the-pulse-influencer-awards-2022/n1rbe34" title="Pulse Influencer Awards">
                                            Pulse Influencer Awards
                                        </a>
                                    
                                </li>
                            
                        
                    </ul>
                </div>
            

            
                <div class="socials-wrapper">
                    <ul id="socials" class="socials-wrapper-list">
                        
                            
                                <li class="socials-wrapper-item">
                                    <span class="footer-icon 0 " >
                                        
                                        Social
                                    </span>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 1 "  href="https://www.facebook.com/pulselivekenya" title="facebook" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/facebook.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/facebook.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="facebook" title="facebook" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/facebook.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Facebook
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 2 "  href="https://twitter.com/pulselivekenya" title="twitter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/twitter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/twitter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="twitter" title="twitter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/twitter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Twitter
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 3 "  href="https://www.instagram.com/pulselivekenya/" title="instagram" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/instagram.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/instagram.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="instagram" title="instagram" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/instagram.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Instagram
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 4 "  href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="youtube" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/youtube.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/youtube.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="youtube" title="youtube" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/youtube.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Youtube
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 5 "  href="https://www.tiktok.com/@pulselivekenya" title="tiktok" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/tiktok.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/tiktok.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="tiktok" title="tiktok" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/tiktok.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Tiktok
                                    </a>
                                </li>
                            
                        
                            
                                <li class="socials-wrapper-item">
                                    <a class="footer-icon 6 "  href="https://www.pulse.com.gh/newsletter" title="newsletter" target="_blank" rel="noopener noreferrer" >
                                        
                                            <picture style="--noscript-src: url(https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/newsletter.svg); " class="image-wrapper"><source data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/newsletter.svg" srcset="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" type="image/svg+xml"><img width="60" height="60" alt="newsletter" title="newsletter" src="data:image/svg+xml;charset=utf8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20width%3D'60'%20height%3D'60'%20data-ring-placeholder%3D'1'%3E%3C%2Fsvg%3E" data-original="https://ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/img/footer/newsletter.svg" class="image lazyloaded" loading="lazy"></picture> 
                                        
                                        Newsletter
                                    </a>
                                </li>
                            
                        
                    </ul>
                </div>
            
        </div>

        

        
    </div>
</div>

                </div>
            </div>
        
    </div>
</footer>




    
    
        



    <div id="customDimensionsCategories" data-categories="kenya/local"></div>

    <script>
        const categories = document.getElementById('customDimensionsCategories').dataset.categories;

        if (categories && typeof categories === "string" && categories.length > 0) {
            window.dataLayer = window.dataLayer || [];
            window.dataLayer.push({
                'content_categories': categories
            })
        }
    </script>


    

    


    





<footer id="main-page-footer"
        class="footer-widget-container "
        
    >
    <div data-run-module="local/lazyLoad.run">
        
        
        
    </div>
</footer>




<script src="//ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build/js/menu.min.js"></script>





<script>
    const resourceBuildPath = "//ocdn.eu/ucs/static/UTheme/64270d31cc9b6a114ed7d19ca9b3064f/build";

    
        const editStoryBookmarklet = "radp-ringier-africa-digital-publishing";
    
</script>

    
    
        <script type="text/javascript"> window._taboola = window._taboola || []; window._taboola.push( {flush: true} );  </script>
    
<script type='text/javascript' src='https://ssp.mediapal.net/www/delivery/spcjs.php?id=5'></script></body>
</html>

