 
     
    
    
    <!DOCTYPE html>
    <html lang="en-US">
        <head>
            <meta charset="utf-8" />
            <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><script type="text/javascript">/* <![CDATA[ */
accConf = {"rum":{"tid":"EA-4719209","boot":"disable","cookieInfo":0,"pageType":"HTML","data":{"RTYPE":"{\"type\":\"story\",\"kind\":\"article\"}"}},"gtm":{"id":["GTM-MGFD5X","GTM-KFT7TX8"],"id-amp":["GTM-5MG6P8M","GTM-N8F3PLV"],"pageType":"HTML"},"events":{"endpointPaths":["/a8f4d8cd95e164917035b64b867a45dd"]}};
/* ]]> */</script>

        <script type="text/javascript">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</script>
        <script type="text/javascript">
        if(accConf&&accConf.rum&&accConf.rum.data)for(var key in window.dlRumData||(window.dlRumData=[]),accConf.rum.data)window.dlRumData.push({metricName:key,eventValue:accConf.rum.data[key]});
        </script>
        
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MGFD5X');</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KFT7TX8');</script>
<!-- End Google Tag Manager -->

            <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
            <title>Ethic forced to apologize and pull down their controversial song ‘Soko” after backlash [ARTICLE] - Pulse  Live Kenya</title>
            
            <meta name="DC.Identifier" content="425f82a4-fe45-49e0-8386-5bee3e68c55c" />
            
            
            <meta name="description" content="We are sorry -Ethic" />
            
            <link href="https://ocdn.eu/ucs/static/eecce0d17045db28acc5addb8f13cead/1404a3b982753f13e9f0b2a43ebd609f/build/red/desktop.css" type="text/css" rel="stylesheet">
            
            
            


<script type="text/javascript" data-static-amd-map="{&quot;embeddedapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/fe947b2d89bd70005959112f8b2ce046/build&quot;,&quot;newslivestream&quot;:&quot;https://ocdn.eu/paas-static/template-engine/c521d70663e169ce4f8f4960a2bf333e/build&quot;,&quot;dailyneeds&quot;:&quot;https://ocdn.eu/paas-static/template-engine/c50dcb3b01e2d6c52a05583e2c55de60/build&quot;,&quot;adsinit&quot;:&quot;//ty0lm9uz.onet.pl/e1BrazhqMjd9/build&quot;,&quot;pulsembed&quot;:&quot;https://ocdn.eu/paas-static/template-engine/d892502ee2f6fa99eb788614351777aa/build&quot;,&quot;onettv&quot;:&quot;https://ocdn.eu/paas-static/template-engine/5ca20bb27dddd86ea4606358c37a1a04/build&quot;,&quot;vendor&quot;:&quot;https://ocdn.eu/paas-static/template-engine/e664b902675175d7b4ea37dc48134f31/build&quot;,&quot;uststd&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f066ddd0af5c65555c5ff1273876e4f9/build&quot;,&quot;layerglass&quot;:&quot;https://ocdn.eu/paas-static/template-engine/05afb91f43a4cacccad6959d895ac7ed/build&quot;,&quot;tabele&quot;:&quot;https://ocdn.eu/paas-static/template-engine/08725d11c5641c65d7f9985ecb7b86c0/build&quot;,&quot;quizapp&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4bf940d37e48f3548c375c519c69e1da/build&quot;,&quot;uss&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4103f0ba4ad9fabb230202e95534e54e/build&quot;,&quot;usimenu&quot;:&quot;https://ocdn.eu/paas-static/template-engine/f887ddc9bceaaf47008c9fa4cc50a451/build&quot;,&quot;ustnavigation&quot;:&quot;https://ocdn.eu/paas-static/template-engine/4103f0ba4ad9fabb230202e95534e54e/build&quot;,&quot;local&quot;:&quot;//ocdn.eu/ucs/static/eecce0d17045db28acc5addb8f13cead/1404a3b982753f13e9f0b2a43ebd609f/build&quot;,&quot;localmobile&quot;:&quot;//ocdn.eu/ucs/static/eecce0d17045db28acc5addb8f13cead/1404a3b982753f13e9f0b2a43ebd609f/build&quot;}">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</script>
        <script type="text/javascript" src="https://ocdn.eu/radp/pwa/firebase.js" async defer></script>
        <!-- disbale ads script from loadinf -->
        <!-- adsConf -->

    

    <script type="text/javascript">/* <![CDATA[ */
        
        
            adsNoBanner = false;
        

        onetAds = {
    "async": 1,
    "sgn_cookie": 0,
    "whitelist": 0,
    "keywords": [
        "detal",
        "ethic-entertainment",
        "ethic",
        "ezekiel-mutua"
    ],
    "target": "PLIVEKE_URL/CATEGORY",
    "DV": "PLIVEKE_URL/CATEGORY/ethic-entertainment/POZOSTALE",
    "kropka": {
        "PU": "425f82a4-fe45-49e0-8386-5bee3e68c55c"
    },
    "keyvalues": {
        "ci": "425f82a4-fe45-49e0-8386-5bee3e68c55c"
    },
    "cmd": [],
    "adSlots": [],
    "lazy": 1,
    "lazyPercentage": 200,
    "tid": "EA-4719209",
    "noDfp": 1,
    "mobile": 0,
    "autoslot": 1,
    "no_gemius": 1,
    "cookieInfo": 1,
    "eventsapi": true
};

        if (typeof identifierEI !== "undefined")
        {
            onetAds.kropka['EI'] = identifierEI;
        }
        
        
        onetAds.cmd.push(function (dlApi){

            var idGenerator = createIdGenerator();
            var htmlblock   = document.querySelectorAll(".htmlblockslot");

            for (var i=0; i<htmlblock.length; i++) {
                configureSlot(htmlblock[i]);
            }

            function configureSlot(adDom) {

                var id      = idGenerator.get();
                var keyword = adDom.getAttribute("data-slot-keyword");

                adDom.setAttribute("id", id);

                var slot = onetAds.defineSlot('flat-autopromo', id);
                slot.setTargeting('kwrd', keyword);
            }

            function createIdGenerator() {

                var counter = 1;

                return {
                    get : get
                };

                function get() {

                    var num = counter;
                    counter++;
                    return "htmlblockslot_id_" + num;
                }
            }
        });


    /* ]]> */</script>





    <script type="text/javascript">
        var pulse2EmbedConfig = {
            default: {},
            OnettvVideo: {
                "MAIN_ELEMENT": {
                    preset: "mainVideoRADPKe",
                },
                "INTEXT": {
                    preset: "inTextVideoRADPKe",
                }
            }
        };
    </script>

        
<script id="adsinit" data-original="//sgqcvfjvr.onet.pl/YnVpbGQvezlza2x0ZTc4fWRsQXBpL2RsLmxpYntOTWFzX0EzOH0ubWluLmpz" type="text/javascript">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</script>


        
            <link rel="canonical" href="https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39" />
        
        <!-- proxyHead -->
        <!-- schemaOrg -->
        

    

    
        
            <meta property="og:title" content="Ethic group speaks after backlash from Kenyans over their controversial song ‘Soko&#39;" />
        
        
            <meta property="og:description" content="We are sorry -Ethic" />
        
        
            
                <meta property="og:image" content="https://ocdn.eu/pulscms-transforms/1/KLIktkpTURBXy83ODdlN2IzOWFjNjk0ZTA2ZmY3MGE1YjhmMTUxODNhMi5qcGeSlQMAas0EAM0CQJMFzQSwzQJ2" />
                <meta property="og:image:width" content="1200" />
                <meta property="og:image:height" content="630" />
            
            
        
        
            <meta property="og:url" content="https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39" />
        
        
            <meta property="og:type" content="article" />
        
        
            <meta property="og:site_name" content="Facebook"/>
        
        
            <meta property="og:locale" content="en_EN" />
        
        
            <meta property="article:published_time" content="2020-04-21 07:12:31+0200" />
        
        
            <meta property="fb:app_id" content="715603858641973" />
        
        
            
    <meta property="fb:pages" content="252006125219593" />    

        
    

<!-- fbConfig -->
        

    
    

    
        <meta name="twitter:card" content="summary_large_image" />
        
        <meta name="twitter:description" content="We are sorry -Ethic" />
        
        
        <meta name="twitter:title" content="Ethic forced to apologize and pull down their controversial song ‘Soko” after backlash" />
        
        <meta name="twitter:site" content="Twitter"/>
        
            
            
                <meta property="twitter:image" content="https://ocdn.eu/pulscms-transforms/1/qltktkpTURBXy83ODdlN2IzOWFjNjk0ZTA2ZmY3MGE1YjhmMTUxODNhMi5qcGeSlQMAas0EAM0CQJMFzQHgzQFo"/>
            
        
    

<!-- twConfig -->
        
    



    <script type="text/javascript">
        window.dataLayer = window.dataLayer || [];
        window.dataLayer.push({"DV":"TARGET/Part2","author1_name":"Dennis Milimo","author1_uuid":"72db854f-1b63-5abf-8522-93d44a689716","datePublished":"2020-04-21","uuid":"425f82a4-fe45-49e0-8386-5bee3e68c55c","type":"Article","license":"Pulse Live Kenya"});
        
        if(window.addEventListener) {
            window.addEventListener("load", pageSpeedForDataLayer);
        } else if (window.attachEvent) {
            window.attachEvent("onload", pageSpeedForDataLayer);
        }
        
        function pageSpeedForDataLayer() {
            setTimeout(function () {
                var te = 0,    ti = 0, teDescription = 'slow';
                if (window.performance) {
                    var g = window.performance.timing;
                    te = g.loadEventEnd - g.navigationStart;
                    ti = g.domInteractive - g.navigationStart;
                }
                if(te > 0 && te < 6e4 && ti > 0 && ti < 6e4) {                  
                    if(te < 3000) {
                        teDescription = 'fast';
                    } else if (te >= 3000 && te <= 7000) {
                        teDescription = 'medium';
                    }
                        
                    window.dataLayer.push({
                        'event': 'speed',
                        'params': {
                            'ti': ti,
                            'te': te,
                            'teDescription': teDescription
                        }
                    });
                }
            }, 3000);  
        }
    </script>
<!-- dataLayer -->


        
    <link rel="amphtml" href="https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39.amp" />
<!-- ampUrl -->
        <!-- onetNewsUrl -->

        
    <script>
        
        
        

        
    </script>

        
            
    
    

        
            
        
<script type="text/javascript">
  var isMobile = false;
</script>
<link rel="manifest" href="/manifest.json">

        
            <link rel="icon" type="image/png" href="https://ocdn.eu/radp/favicon.ico" />
        

<link rel="apple-touch-icon" href="/icon.png">       
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">

<script type="text/javascript">
  if (navigator.serviceWorker) {
    navigator.serviceWorker.register('/pwa-sw2.js', {
      scope: '/'
    });
    navigator.serviceWorker.getRegistration()
    .then(function(registration) {
        if(registration && registration.active) {
            document.cookie ="pwaMode=pwa;path=/";
            document.cookie ="WebsiteType=desktop;path=/";
        } else {
            document.cookie = "pwaMode=website;path=/";
            document.cookie ="WebsiteType=desktop;path=/";
        }
    });
  }else {
      document.cookie = "pwaMode=website;path=/";
      document.cookie ="WebsiteType=desktop;path=/";
  }


  window.addEventListener('beforeinstallprompt', function (e) {
    // Sending PWAHomeIconPrompt event when the prompt is launched.
    dataLayer.push({
      'pwaEventAction': 'PWAHomeIconPrompt',
      'pwaEventLabel': 'PWA Home Icon Prompt',
      'event': 'PWAHomeIconPrompt'
    });
    e.userChoice.then(function (res) {
      if (res.outcome === 'dismissed') {
        dataLayer.push({
          'pwaEventAction': 'PWAHomeIconCancelled',
          'pwaEventLabel': 'PWA Home Icon Cancelled',
          'event': 'PWAHomeIconCancelled'
        });
      } else if (res.outcome === 'default') {
            dataLayer.push({
                'pwaEventAction': 'PWAHomeIconDismissed',
                'pwaEventLabel': 'PWA Home Icon Dismissed',
                'event': 'PWAHomeIconDismissed'
            });
      } else {
            dataLayer.push({
                'pwaEventAction': 'PWAHomeIconAdded',
                'pwaEventLabel': 'PWA Home Icon Added',
                'event': 'PWAHomeIconAdded'
            });
      }
    });
  });
  if (document.cookie.indexOf("sessionStartMode=") === -1) {
    if (window.location.href.indexOf('pwa=1') > -1) {
        dataLayer.push({
            'pwaEventAction': 'PWAHomeSesionsStarted',
            'pwaEventLabel': 'PWA Home Sesions Started',
            'event': 'PWAHomeSesionsStarted'
        });

        document.cookie = "sessionStartMode=homeScreen;path=/"
    } else {
        document.cookie = "sessionStartMode=browser"
    }
  }
</script>
<meta name="theme-color" content="#000000">
<link rel="dns-prefetch" href="https://ocdn.eu" />
<link rel="dns-prefetch" href="https://fonts.gstatic.com" />
<link rel="dns-prefetch" href="https://google-analytics.com" />
<link rel="dns-prefetch" href="https://sgqcvfjvr.onet.pl" />
<link rel="dns-prefetch" href="https://onet.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://ls.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://csr.onet.pl" />
<link rel="dns-prefetch" href="https://kropka.onet.pl" />
<link rel="dns-prefetch" href="https://cmp.dreamlab.pl" />
<link rel="dns-prefetch" href="https://authorisation.grupaonet.pl" />
<link rel="dns-prefetch" href="https://pulsembed.eu" />
<link rel="dns-prefetch" href="https://etoto-platform.onet.pl" />
<link rel="dns-prefetch" href="https://mvp.onet.pl" />
<link rel="dns-prefetch" href="https://gapl.hit.gemius.pl" />
<link rel="dns-prefetch" href="https://player-api.dreamlab.pl" />
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net" />
<link rel="dns-prefetch" href="https://csi.gstatic.com" />

<link rel="preconnect" href="https://ocdn.eu" />
<link rel="preconnect" href="https://fonts.gstatic.com" />
<link rel="preconnect" href="https://google-analytics.com" />
<link rel="preconnect" href="https://sgqcvfjvr.onet.pl" />
<link rel="preconnect" href="https://onet.hit.gemius.pl" />
<link rel="preconnect" href="https://ls.hit.gemius.pl" />
<link rel="preconnect" href="https://csr.onet.pl" />
<link rel="preconnect" href="https://kropka.onet.pl" />
<link rel="preconnect" href="https://cmp.dreamlab.pl" />
<link rel="preconnect" href="https://authorisation.grupaonet.pl" />
<link rel="preconnect" href="https://pulsembed.eu" />
<link rel="preconnect" href="https://etoto-platform.onet.pl" />
<link rel="preconnect" href="https://mvp.onet.pl" />
<link rel="preconnect" href="https://gapl.hit.gemius.pl" />
<link rel="preconnect" href="https://player-api.dreamlab.pl" />
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" />
<link rel="preconnect" href="https://csi.gstatic.com" />
<script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[],function(){var t=document.createElement("script");t.async=!0,t.type="text/javascript";var e="https:"==document.location.protocol;t.src=(e?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(t,o)}();</script>      <script>googletag.cmd.push(function () { var o = window.location.pathname.split("/"); switch (o[1]) { case "": o[1] = "home" }void 0 === o[2] && void 0 !== o[1] && (o[1] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[2] && (o[2] += "/", token = o.join("/"), token = token.slice(0, -1), token += "/"), void 0 === o[4] && void 0 !== o[3] && (o[2] = "article", o[3] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[5] && void 0 !== o[4] && (o[3] = "article", o[4] = "", token = o.join("/"), token = token.slice(0, -1)), void 0 === o[6] && void 0 !== o[5] && (o[4] = "article", o[5] = "", token = o.join("/"), token = token.slice(0, -1)); var e = token.length; if (document.location.hostname == 'www.pulse.ng') { googletag.pubads().setTargeting('PulseNG_URL', [token]); } if (document.location.hostname == 'www.pulse.com.gh') { googletag.pubads().setTargeting('PulseGH_URL', [token]); } if (document.location.hostname == 'www.pulselive.co.ke') { googletag.pubads().setTargeting('PliveKE_URL', [token]); } console.log(token, e), googletag.pubads().enableSingleRequest(), googletag.pubads().collapseEmptyDivs(!0), googletag.enableServices() });</script>          
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "4.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d3lcz8vpax4lo2.cloudfront.net/ads-code/99b38bf6-07eb-44ab-a741-e822695d6401.js');/*]]>*/</script>       
<script type='text/javascript'>             var googletag = googletag || {};             googletag.cmd = googletag.cmd || [];             (function () {                 var gads = document.createElement('script');             gads.async = true;             gads.type = 'text/javascript';             var useSSL = 'https:' == document.location.protocol;             gads.src = (useSSL ? 'https:' : 'http:') +                 '//www.googletagservices.com/tag/js/gpt.js';             var node = document.getElementsByTagName('script')[0];             node.parentNode.insertBefore(gads, node);         })();         </script>
<script type="text/javascript" src="//ocdn.eu/ucs/static/eecce0d17045db28acc5addb8f13cead/1404a3b982753f13e9f0b2a43ebd609f/build/scripts.js" async defer></script>
        <!-- special ads disbale check -->     
        
        <script>
            var liveblog_talos_lizard_cfg={'urls':["https://liveblog-push.dreamlab.pl/ws"],oob_url:false};
        </script>

    </head>
        <div> 
            <!-- IO script tracking div  -->
    <body id="newDetail" class="desktop scheme_red content-type-Article">
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MGFD5X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KFT7TX8" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->

        


        <div class="onet-ad" id="onet-ad-flat-belkagorna"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
        
<header id="pageHeader" class="pageWrapper">
    <div class="container customSize">
        <div class="pageHeaderLogo">
            <h1><a href="//www.pulselive.co.ke"> <img class="serviceLogo switch" alt="Pulse Live Kenya" src="https://radp.ocdn.eu/logotypes/logo_desktop_kenya_new_v1.svg"> </a></h1>
        </div> 
        <nav class="siteNavigation">
            <div id="tabMenu" class="transition">
                <div id="siteNavigation" class="siteNavigation"  >
                    <div class="row">
                        <div  class="firstLevel row " data-run-module="local/main.menu">
                            <ul class="mainMenu col-xs-12 verticals">
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/video">Pulse TV</a>
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/news">News</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Local"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/news/local">
                                                Local
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-World"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/news/world">
                                                World
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/entertainment">Entertainment</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Celebs"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/entertainment/celebrities">
                                                Celebs
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Music"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/entertainment/music">
                                                Music
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/lifestyle">Lifestyle</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Fashion"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/lifestyle/fashion">
                                                Fashion
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Beauty-&amp;-Health"
                                            data-dropdown-uuid=""  data-dropdown-index="2" href="/lifestyle/beauty-health">
                                                Beauty &amp; Health
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Relationships-&amp;-Weddings"
                                            data-dropdown-uuid=""  data-dropdown-index="3" href="/lifestyle/relationships-and-weddings">
                                                Relationships &amp; Weddings
                                            </a>
                                        </li>
                                        
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Food,-Travel,-Arts-&amp;-Culture"
                                            data-dropdown-uuid=""  data-dropdown-index="4" href="/lifestyle/food-travel">
                                                Food, Travel, Arts &amp; Culture
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow " >
                                    <a href="/sports">Sports</a>
                                    
                                    <!-- SUBCATEGORIES -->
                                    <ul class="subsection">
                                        
                                        
                                        <li>
                                            <a class="item verticals__anchor dlbi-dropdown-item" data-dropdown-id="#dropdown-Football"
                                            data-dropdown-uuid=""  data-dropdown-index="1" href="/sports/football">
                                                Football
                                            </a>
                                        </li>
                                        
                                        
                                    </ul>
                                    <!-- /SUBCATEGORIES -->
                                    
                                </li>
                                
                                
                                
                                
                                <li class="parentRow nosubsection" >
                                    <a href="/bi">Business Insider</a>
                                    
                                </li>
                                
                                
                                
                            </ul>
                        </div>
                    </div>
                </div>
            </div>
        </nav>
        <div class="searchBar switch">
                <ul class="profileList">
                    
                    <li class="facebook">
                        <a href="https://www.facebook.com/pulselivekenya/" title="Follow us on Facebook" target="_blank">Facebook</a>
                    </li>  
                    
                    
                    <li class="twitter">
                        <a href="https://twitter.com/pulselivekenya" title="Follow us on Twitterze" target="_blank">Twitter</a>
                    </li>  
                    
                    
                    <li class="instagram">
                        <a href="https://www.instagram.com/pulselivekenya/" title="Follow us on Instagram" target="_blank">Instagram</a>
                    </li>  
                    
                    
                    <li class="youtube">
                        <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="Watch us on YouTube" target="_blank">YouTube</a>
                    </li>  
                    
                </ul>
                <div class="search-container menu-button search" data-search-container="">
                    <div class="svg icon-search"></div>
                </div>
        </div>
    </div>
    <div class="searchDiv">
        <form id="searchForm" class="searchForm closed" method="get" action="/search">
            <input id="searchInput" type="text" class="searchQueryInput switch" placeholder="Search" x-webkit-speech="" autocomplete="off" id="searchQuery" name="q">
        </form>  
    </div>
    <div class="menuBg"></div>
</header><!-- header -->
        

        


        <div class="onet-ad" id="onet-ad-top"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
        
        <section class="pageAligment">
            <div id="doc" data-run-module="local/main.LazyLoadIS"  data-preload="{{configuration.preLoadImages}}">
                 <!-- channelConfig -->
                


<!-- specialBanner -->
                
                <div class="pageContent pageWrapper container customSize" >
                    
                    <div class="row">
                        
                        <div class="col-xs containerCustom">
                            <div class="leftColWrapper">                              
                                
                                    
                                        <script>
  (function(window) {
    function appendOffersAndUpdateEventsConfig(eventsConfig, offerIdsToAppend) {
      window.aureusContext = window.aureusContext || {};
      window.aureusContext.offerIds = window.aureusContext.offerIds || [];
      window.aureusContext.offerIds.push(offerIdsToAppend);
      eventsConfig.EI = window.aureusContext.offerIds.toString();
    }

    var generatedOfferIds = ["2lxetapj3u"];
    if ("undefined" !== typeof window.dlApi) {
      appendOffersAndUpdateEventsConfig(window.dlApi.kropka, generatedOfferIds);
    } else if ("undefined" !== typeof window.onetAds) {
      appendOffersAndUpdateEventsConfig(window.onetAds.kropka, generatedOfferIds);
    } else {
      console.warn("Couldn't update Aureus offers - no Kropka context present.");
    }
  })(window);
</script><!-- widgetAboveArticle0 -->
                                    
                                        

<div id="aureus_lb_container">
    <div id="aureus_lb_branding">
        <div id="right"></div>
        <a href="https://pigiame.co.ke" data-uuid-ui="classifieds/electronics" data-ei="qj7ygsbda7" target="_blank"><div id="top"></div></a>
        <div id="bottom"><a href="https://www.pigiame.co.ke/electronics" data-uuid-ui="classifieds/electronics" data-ei="qj7ygsbda7" id="buy">BUY NOW</a></div>
    </div>
    <div id="aureus_lb_content">
         
            <div id="heading">Buy &amp; Sell on Kenya&#39;s Safest Online Marketplace</div>
        
        <div id="body">
            
                <div class="item">
                    <a href="https://www.pigiame.co.ke/electronics" data-uuid-ui="classifieds/electronics" data-ei="qj7ygsbda7" target="_blank"><img src="https://i.roamcdn.net/hz/pi/listing-thumb-543w/e6bd91eee9823a20702f0d3d63d412f4/-/hzfiles/pi/picture/q5926xg/9d9f2d5a1d09c26a31994ca571e03dfa1d357011.jpeg" /></a>
                    <div class="price">KES 27499</div>
                </div>
            
                <div class="item">
                    <a href="https://www.pigiame.co.ke/electronics" data-uuid-ui="classifieds/electronics" data-ei="qj7ygsbda7" target="_blank"><img src="https://i.roamcdn.net/hz/pi/listing-thumb-543w/cafe8d9dad7ebbbc412a344a4f47e531/-/hzfiles/pi/picture/qxwnkpj/830ed2223300857704dfe5c1f709b1a1698785f6.jpeg" /></a>
                    <div class="price">KES 25000</div>
                </div>
            
                <div class="item">
                    <a href="https://www.pigiame.co.ke/electronics" data-uuid-ui="classifieds/electronics" data-ei="qj7ygsbda7" target="_blank"><img src="https://i.roamcdn.net/hz/pi/listing-thumb-543w/1218019ab68fa355ba80db02150ca28a/-/hzfiles/pi/picture/qj5w62v/541cd619da5450a6aaab62904235fdbe927e4fd0.jpeg" /></a>
                    <div class="price">KES 30000</div>
                </div>
            
                <div class="item">
                    <a href="https://www.pigiame.co.ke/electronics" data-uuid-ui="classifieds/electronics" data-ei="qj7ygsbda7" target="_blank"><img src="https://i.roamcdn.net/hz/pi/listing-thumb-543w/400241370c03180efc8861d0bc4ee14e/-/hzfiles/pi/picture/q847dwp/b7999258a5c59397d18505d04a99338ca087d714.jpeg" /></a>
                    <div class="price">KES 24999</div>
                </div>
            
        </div>
    </div>
</div>
<!-- widgetAboveArticle1 -->
                                    
                                        
  <div class="onet-ad" id="onet-ad-flat-boxday5" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("flat-boxday5");
            onetAds.show("flat-boxday5");
        </script>
    </div>
<!-- widgetAboveArticle2 -->
                                    
                                        
  <div class="onet-ad" id="onet-ad-top" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("top");
            onetAds.show("top");
        </script>
    </div>
<!-- widgetAboveArticle3 -->
                                    
                                        <!-- widgetAboveArticle4 -->
                                    
                                        <!-- widgetAboveArticle5 -->
                                    
                                        <!-- widgetAboveArticle6 -->
                                    
                                        <!-- widgetAboveArticle7 -->
                                    
                                
                                <article class="articleDetail">
                                    

    <ol class="breadcrumbs">
        
            
        
            
                <li><a class="breadcrumbItem mainCategory" href="">Entertainment</a></li>
            
        
    </ol>
 <!--breadcrumbs-->
                                    <!-- reportHeader -->
                                    
                                    
                                        <header class="atricleTop">
                                            <h1 class="mainTitle">
    
        Ethic group speaks after backlash from Kenyans over their controversial song ‘Soko&#39;
    
</h1> <!-- title -->
                                            


    <div class="articleHeading">

        
        
        
        
        
        
        
        
            
                
                <div class="authDesc authDesc1">
                    
                        <a href="https://www.pulselive.co.ke/author/dennis-milimo" >
                    
                        <span class="name" itemprop="name">Dennis Milimo</span>
                    
                        </a>
                    
                </div>
            
        

        <time class="datePublished">
            
            
            
            
                
                    Today at 8:12 AM
                
            
        </time>
        
        

        <div class="sourceCopytight">
            
            
        </div>
        
    </div>
    
 <!-- sourc -->
                                             
    <div class="socialShare">
        <span class="shareTop">Tell your friends</span>
        <a data-run-module="embeddedapp/main.sharethis_facebook" href="javascript:void(0);" class="shareIcon icon-fb" data-gtm-social="facebook" title="Facebook"></a>
        <a data-run-module="embeddedapp/main.sharethis_twitter" href="javascript:void(0);" data-gtm-social="twitter" class="shareIcon icon-twitter" title="Twitter"></a>
        <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39" data-gtm-social="email" class="shareIcon icon-newsletter" title="Email"></a>
    </div>

                                        </header>
                                    
                                    
                                    <!-- teaserVideo -->

                                    
                                        
                                            <div id="teadsTv" data-run-module="local/main.scriptsLazyLoad" data-type="teadsTv" data-href="//a.teads.tv/page/87018/tag"></div>
                                        
                                    
                                    <div data-io-article-url="https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39" class="whitelistPremium">
                                        
                                            



    
        <strong id="lead" class="hyphenate lead">
            
                We are sorry -Ethic<br/>
            
        </strong>
    
<!-- lead -->
                                            
 
    
    
    

    
        
            
            <figure class="mainPhoto">

                
                    
                    

                     
                        <picture class="loaderBlock" >
                            <div class="preLoader">
                                <div class="loadBlock"></div>
                            </div>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/Rwtk9kpTURBXy83ODdlN2IzOWFjNjk0ZTA2ZmY3MGE1YjhmMTUxODNhMi5qcGeRkwXNAxTNAbyBoTAF" type="image/webp">
                            <img itemprop="url" data-original="//ocdn.eu/pulscms-transforms/1/ZS1k9kpTURBXy83ODdlN2IzOWFjNjk0ZTA2ZmY3MGE1YjhmMTUxODNhMi5qcGeRkwXNAxTNAbyBoTAB"  alt="Uproar as gengetone group Ethic releases song advocating for rape and Paedophilia"  />
                        </picture>
                    
                  

                
                    
                    
                        <figcaption class="caption hide">
                            <span class="imageDescription">Uproar as gengetone group Ethic releases song advocating for rape and Paedophilia</span>
                        </figcaption>
                    
                

                            
                
                    
                    
                    
                    
                
            </figure>
        
    
<!-- teaser -->
                                            <div class="detailContentWrapper">
                                        
                                        
                                                
                                            <div class="detailContent"> 
                                                  





    



      






    <script type="text/javascript">/* <![CDATA[ */

      if (!adsNoBanner)
        onetAds.adSlots.push('flat-intext');

    /* ]]> */</script>




<div id="detail" class="detail intext articleBody" itemprop="articleBody" data-run-module="local/main.slotBetweenParagraphs">



     
        

        
        
        
        
            
                

                

                    

                    
                    

                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate ">Gengetone Group Ethic entertainment has been forced to apologize to their fans and Kenyans at large after they were accused of releasing a song that <a href="https://www.pulselive.co.ke/entertainment/uproar-as-gengetone-group-ethic-are-accused-of-releasing-song-promoting-rape-and/w1h8e5m" id="df07bcca-3185-4b39-b586-7445aae1f31d">seems to advocate for rape and Paedophilia.</a></p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate ">In their apology, the Figa hit-makers owned up to their mistake saying they unintentionally promoted Paedophilic culture with their 'Soko' song.</p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate "><em>“We owe an apology to our fans who have been nothing but supportive throughout our Journey. It has come to our attention that our recently released Soko video has unintentionally promoted Paedophilic culture. We Are therefore sending out sincere apologies to all our fans and viewers at large. As a result, we have made sure the video has been taken down, its inaccessible and we shall not further upload it. We have noted an exchange on Twitter under Swat’s name and we move to confirm that it is an impersonation as Swat does not own a Twitter account. Over and above we sincerely apologize and we are working to release better music content in the future. We appreciate the feedback and we are also grateful for your continued patience. We love you all”</em> reads the apology from Ethic.</p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    
        <a name="image_a8eb88a9-c116-49d2-b7fa-63c98b195bb4" style="position:relative; top:-100px; display: block"></a>
    
    
    <div class="image" data-item-uuid="c5130e5b-7568-4c9d-af6e-9fca0e3031cc">
    	<div class="imageCaptionWrapper">
        <div class="imageWrapper" itemprop="image" itemscope itemtype="http://schema.org/ImageObject"
             
             
                data-uuid-photo="a8eb88a9-c116-49d2-b7fa-63c98b195bb4"
             
             
             >
            
            
            
                
            
                
                

                 
                    <picture class="loaderBlock" >
                        <div class="preLoader">
                            <div class="loadBlock"></div>
                        </div>
                        <source data-original="//ocdn.eu/pulscms-transforms/1/ODqk9kpTURBXy9hZjdmMDRmNjZkODdmMmYyYjlkMmIwODQzYjRjZjhhZi5qcGeSlQLNAxQAwsOVAgDNAvjCw4GhMAU" type="image/webp">
                        <img data-original="//ocdn.eu/pulscms-transforms/1/iaIk9kpTURBXy9hZjdmMDRmNjZkODdmMmYyYjlkMmIwODQzYjRjZjhhZi5qcGeSlQLNAxQAwsOVAgDNAvjCw4GhMAE" src="" alt="Ethic group speaks after backlash from Kenyans over their controversial song ‘Soko&#39;"  />
                    </picture>
                
              
                
                    <figcaption itemprop="caption" class="caption  hide " style="max-width: 400px;">
                        <span>
                            Ethic group speaks after backlash from Kenyans over their controversial song ‘Soko&#39; 
                        </span>
                    </figcaption>
				
                
                
                	
                	
                                   
                
                
                
	            
                                  
				


			
        </div>			
        </div>
    </div>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



        
      


            <div class="onet-ad"  data-opt-pos="5"    id="left5" data-slot="left"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #left5::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
    
    
    
 
 
    
        
    <p class="hyphenate "><strong>Face the law </strong></p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate ">The apology comes hours after Netizens teamed up to condemn the raunchy song that seemed to normalize rape and Paedophilia.</p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate "><a href="https://www.pulselive.co.ke/entertainment/ezekiel-mutua-demands-the-arrest-of-ethic-entertainment-music-group/yry3lps" id="3c978ef2-7eee-408c-915a-ec4a8d701e22">Kenya Film Classification Board</a> CEO Ezekiel Mutua took to social media to celebrate after YouTube took action against the song in Question ‘Soko’, saying his Board will take up the matter and ensure the group face the law for promoting defilement of girls.</p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate "><em>“We are pleased to report that the video Soko by Ethic Entertainment has now been taken down from YouTube following the complaint we filed yesterday. The Board will take up the matter with security agencies to ensure that the culprits face law for promoting defilement of girls”</em> reads Ezekile Mutua’s tweet.</p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    
        <a name="image_cb03c6d8-f9f1-4358-91e5-062ec2872c54" style="position:relative; top:-100px; display: block"></a>
    
    
    <div class="image" data-item-uuid="e7e7e9a0-c010-4960-8d3c-953e81ee2abf">
    	<div class="imageCaptionWrapper">
        <div class="imageWrapper" itemprop="image" itemscope itemtype="http://schema.org/ImageObject"
             
             
                data-uuid-photo="cb03c6d8-f9f1-4358-91e5-062ec2872c54"
             
             
             >
            
            
            
                
            
                
                

                 
                    <picture class="loaderBlock" >
                        <div class="preLoader">
                            <div class="loadBlock"></div>
                        </div>
                        <source data-original="//ocdn.eu/pulscms-transforms/1/ysck9kqTURBXy9kNGJkZTM2YTU5M2Q5MWNjMTRjOGIwY2ZmNzk1NjA0ZC5qcGVnkpUCzQMUAMLDlQIAzQL4wsOBoTAF" type="image/webp">
                        <img data-original="//ocdn.eu/pulscms-transforms/1/M5uk9kqTURBXy9kNGJkZTM2YTU5M2Q5MWNjMTRjOGIwY2ZmNzk1NjA0ZC5qcGVnkpUCzQMUAMLDlQIAzQL4wsOBoTAB" src="" alt="Dr Ezekiel Mutua is the Chief Executive Officer of KFCB"  />
                    </picture>
                
              
                
                    <figcaption itemprop="caption" class="caption  hide " style="max-width: 788px;">
                        <span>
                            Dr Ezekiel Mutua is the Chief Executive Officer of KFCB 
                        </span>
                    </figcaption>
				
                
                
                	
                	
                                   
                
                
                
	            
                                  
				


			
        </div>			
        </div>
    </div>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate "><strong>Not the First time</strong></p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate ">This is not the first time Ethic’s song is being pulled down from YouTube. In November last year their song ‘Tarimbo’ was also deleted from YouTube on grounds that it was advocating for rape and violence among women.</p>


    



<!-- block end -->   
                        
                    
                    

                

                    

                    
                    

                      
                                
                            <!-- block open -->



    
    
    
 
 
    
        
    <p class="hyphenate "><em>“The DCI should arrest the entire bunch of musicians called Ethic, under Article 33, for going beyond the prescribed delimitations on freedom of expression by advocating for violence against women. Any self-respecting DJ should not play these songs. No club should allow music that advocates for violence against women.” </em>wrote Ezekiel Mutua.</p>


    



<!-- block end -->   
                        
                    
                    

                

                

            
        

    

    <!-- sonda -->
    
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
    

</div><!-- detail -->
                                                <!-- detail -->
                                                <!-- liveblog -->
                                                
                                                <div class="afterDetailModules">
                                                    
                                                </div>
        
                                                <!-- detail -->
                                                 <!-- added moxTv id diff for desktop -->
                                                
                                                <div data-id="_mwayss-978f50cc641698ad9dc63615cc2410f9"></div>
                                                
                                                










<div id="articleFooterAuthorSource" class="articleFooter">

        <div class="authorsSources">
            
            
                                
            

            
                
                                
                    
                            <span class="sourcesLabel">
                                
                                    Source:
                                
                            </span>

                        <span itemprop="sourceOrganization">
                            <span itemscope itemtype="http://schema.org/Organization">
                            
                                
                                    <span itemprop="name">Pulse Live Kenya</span>
                                
                            
                            </span>
                        </span>

                    

                
            

            
            <span class="authorsClear"></span>
        </div>
	
</div>

    
<!-- detailFooter -->

                                                
<div id="relatedTopics" class="relatedTopics tagList">
    
        <span class="relatedTopic tags">
            <a href="/ethic-entertainment" title="Ethic Entertainment">
                #ETHIC ENTERTAINMENT                 
            </a>
        </span>
    
        <span class="relatedTopic tags">
            <a href="/ethic" title="Ethic">
                #ETHIC                 
            </a>
        </span>
    
        <span class="relatedTopic tags">
            <a href="/ezekiel-mutua" title="Ezekiel Mutua">
                #EZEKIEL MUTUA             
            </a>
        </span>
    
</div>

<!-- tags -->
                                                
    
    
    

    
       
        
        
        
            <div class="authorSourceProfile authorProfile">
                

                    

                        

                        
                            <div class="photoWrapper">
                                <picture class="photo">
                                    <source data-original="//ocdn.eu/pulscms-transforms/1/sKHk9kpTURBXy83ZDFmYzAyNWZlNjRiNTk4N2FjNzU1NzMxMzQ3NWQ1Yi5qcGeTlQPMyc0CvM0OHs0L-JUCAGTDw5MFZGSBoTAF" type="image/webp">
                                    <img data-original="//ocdn.eu/pulscms-transforms/1/8MQktkpTURBXy83ZDFmYzAyNWZlNjRiNTk4N2FjNzU1NzMxMzQ3NWQ1Yi5qcGeTlQPMyc0CvM0OHs0L-JUCAGTDw5MFZGQ" src="data:image/jpeg;base64,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" alt="Dennis Milimo"/>
                                </picture>
                            </div>
                        
                    
                

                <header>
                    
                            <a data-gtm="author-profile" href="https://www.pulselive.co.ke/author/dennis-milimo" >
                                <span class="name" itemprop="name">Dennis Milimo</span>
                    </a>
                    
                            <a class="moreAbout" data-gtm="author-profile" href="https://www.pulselive.co.ke/author/dennis-milimo" >More from the author <span>»</span></a>
                </header>

                
                
                <div class="clear"></div>
            </div>

        
        
        
    
<!-- authorProfile-->

                                                
                                                    <div class="socialShare socialShareBottom">
    <span class="shareTop">Tell your friends</span>
    <a data-run-module="embeddedapp/main.sharethis_facebook" href="javascript:void(0);" class="shareIcon icon-fb" data-gtm-social="facebook"></a>
    <a data-run-module="embeddedapp/main.sharethis_twitter" href="javascript:void(0);" data-gtm-social="twitter" class="shareIcon icon-twitter"></a>
    <a href="mailto:?body=https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39" data-gtm-social="email" class="shareIcon icon-newsletter"></a>
</div><!-- contentShareBottom -->
                                                
                                            </div>
                                            
                                            <div id="widgetStop"></div>
                                        </div>
                                    </div>
                                        
                                    
    
    
        
    
<!-- relatedMaterials -->
                                    <!-- sherlock -->

                                    

    
    

    

<!-- seeAlsoLinks -->

                                    
<!-- filesAttachments -->

                                    <!-- tableofcontent -->
                                    <!-- pagination -->

                                    

                                        


            <div class="onet-ad"    id="leadbanner-bottom" data-slot="flat-leadbanner"  data-run-module="local/main.addSlotAsync" >
            </div>  
            




 
<style>  
        #leadbanner-bottom::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>

                                        <div id="googleAdsCont">
                                            


        <div class="onet-ad" id="onet-ad-rectangle1"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                            


        <div class="onet-ad" id="onet-ad-rectangle3"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                        </div>
                                        <div class="onet-ad" id="onet-ad-flat-nin"></div>

                                        


        <div class="onet-ad" id="onet-ad-flat-plista"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>
                                    

                                    <!-- editorsList -->
                                    <!-- stream -->
                                    
                                        <div id="taboolaStartHook" data-run-module="local/main.scriptsLazyLoad" data-type="taboola" data-href="//cdn.taboola.com/libtrc/ringierkenya-network/loader.js"></div>
                                    
                                    
                                        
                                            <div id="fbComments" data-run-module="local/main.scriptsLazyLoad" data-type="fb" data-id="https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39">
                                                             
    <div id="fb-root" data-lazy="true"></div>
    <div data-width="100%" data-numposts="10" data-href="https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39" class="fb-comments"></div>
    <div class="forumDisclaimer" style="font-size: 0.7em;" data-lazy="true">
         
        <a href="https://www.facebook.com/policies">https://www.facebook.com/policies</a>
    </div>
    <div class="preLoaderBlock"></div>

                                            </div>
                                        
                                    
                                    
                                    


        <div class="onet-ad" id="onet-ad-flat-widget"></div>




 
<style>  
        #::before{
        content: "AD";
        font-size: .6em;
        text-align: center;
        display: block;
        color: #bfbbbb7d;
        }
</style>

                                      <!-- disbale block column  -->
                                        
                                         <!-- Load the newsletter here only under article -->
                                            <div id="newsletterLoader" data-run-module="local/main.subscribeNewsletter"  data-source="newsletterWidget" data-config="{&quot;keyField&quot;:&quot;pulselive.co.ke&quot;,&quot;listIdField&quot;:&quot;58&quot;,&quot;publicationNameField&quot;:&quot;pulselive.co.ke&quot;,&quot;slangField&quot;:&quot;Kua rada&quot;,&quot;apiUrlField&quot;:&quot;https://nl.pulse.com.gh/&quot;,&quot;privacyUrlField&quot;:&quot;https://www.pulselive.co.ke/info/terms-and-conditions-pulselivecoke/d1z0r3q&quot;}">
                                            </div>
                                            
                                                
  <div class="onet-ad" id="onet-ad-rectangle3" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("rectangle3");
            onetAds.show("rectangle3");
        </script>
    </div>
<!-- widgetRight0 -->
                                            
                                                
<section class="newsletterSignup_wdg">
<div class="topMain LazyLoadBG red" data-bg="">
    <div class="row" id="signUpContainer">
        <div class="col-sm-6"> 
           <div id="intro">
                <br>
            
              <p class="topSlang">Join the <span class="quote">"kua rada" </span>&nbsp;clique</p>
              <span id="subTitle"> Don't miss a thing , get the latest updates to fuel your conversation daily</span>
            
           </div>
            <div id="termsConditions" class="hide">
            <br><br>
            <p>By clicking again you agree to our <a class="color" target="_blank" href="https://www.pulse.com.gh/info/privacy-policy-how-we-respect-your-privacy-or-pulsecomgh/3qxd7kj">
                    Privacy Policy </a> and European users agree to data transfer policy
            </p>
           </div>
        </div>
        <div class="col-sm-6">
            <br>
            <form class="inputForm" action="#">
                <input type="email" placeholder="email" name="email" id="email" required>

                <button name="sendUpdates" id="sendUpdates" class="">
                    SEND ME UPDATES
                </button>
             <button name="submitEmail" id="submitEmail" class="hide 
               " >
                    YES SEND ME UPDATES
                </button>
            </form>

                <div id="error" class="hide">

                </div>

            </div>
        </div>

        <div class="row hide" id="thanksContainer">
            Thank you! You have successfully subscribed to receive the pulselive.co.ke newsletter
        </div>
    </div>
    <br>

    <script type="text/javascript">
        function sendMeUpdates(event) {
            return false;
        }


        function sendPrivacyEmail(event) {
            return false;
        }
    </script>

</section>
<!-- widgetRight1 -->
                                            
                                                <div class="socialButtonsWdg">

<a href="https://www.facebook.com/pulselivekenya/?ref=br_rs" rel="nofollow" target="_blank" class="facebook">LIKE PULSE KENYA</a>


<a href="https://www.instagram.com/pulselivekenya/" rel="nofollow" target="_blank" class="instagram">FOLLOW PULSE KENYA</a>

</div><!-- widgetRight2 -->
                                            
                                                
    <div class="eyewitnessWdg">    <p>Eyewitness? Submit your stories now via social or: </p>    <p><b>WhatsApp:  </b>+254708994405<br/>     <b>Email: </b><a href="mailto:eyewitness@pulselive.co.ke">eyewitness@pulselive.co.ke</a></b></p></div>
<!-- widgetRight3 -->
                                            
                                                


<section id="recommended-articles">
<div class="col-xs-12 wdgWrapper">
<div
    class="wdg threeColumn wdgStandard"
     >

    
    <div class="widgetsHeader">
        
            
        
        <h1 class="title">
            
            <span class="titleTxt">Recommended Articles</span>
            <span class="titleUnderlined">&nbsp;</span>
        </h1>
    </div>
    
    
    
    <div class="wdgItems">
        <div class="row">
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/quarantine-got-me-begging-for-dck-huddah-monroe-as-she-gets-humbled-in-quarantine/bt8nx2g">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/ceqk9kpTURBXy8zN2NlMjg2MTQ5YWQyM2Q3ZmQ2YTRmYjkxMmU4ZTBkYS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Quarantine has surely humbled me- Socialite Huddah Monroe"  data-original="//ocdn.eu/pulscms-transforms/1/DWGk9kpTURBXy8zN2NlMjg2MTQ5YWQyM2Q3ZmQ2YTRmYjkxMmU4ZTBkYS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Quarantine has surely humbled me- Socialite Huddah Monroe
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/uhuru-raila-lead-kenyans-in-mourning-archbishop-ndingi-mwana-anzeki/s76tkg6">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/tsvk9kqTURBXy9iMjg5YWQ3Mjk2YmJmYmYzNjdmNzMzMDE1N2M0Nzg0My5qcGVnkZMFzQGGzOCBoTAF" type="image/webp">
                            <img alt="Uhuru, Raila lead Kenyans in mourning Archbishop Ndingi Mwana a&#39;Nzeki"  data-original="//ocdn.eu/pulscms-transforms/1/iiOk9kqTURBXy9iMjg5YWQ3Mjk2YmJmYmYzNjdmNzMzMDE1N2M0Nzg0My5qcGVnkZMFzQGGzOCBoTAB" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Uhuru, Raila lead Kenyans in mourning Archbishop Ndingi Mwana a&#39;Nzeki
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/nyashinski-set-to-treat-his-fans-to-a-live-concert-ahead-of-his-much-anticipated/ecr18jp">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/Se2k9kpTURBXy84NTQyMTJmNGIxODU3ZjQxZWU2MmM0NDE4ZDE5NTYzNy5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Nyashinski set to treat his fans to a live concert ahead of his much-anticipated Album"  data-original="//ocdn.eu/pulscms-transforms/1/aTLk9kpTURBXy84NTQyMTJmNGIxODU3ZjQxZWU2MmM0NDE4ZDE5NTYzNy5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Nyashinski set to treat his fans to a live concert ahead of his much-anticipated Album
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/activist-boniface-mwangi-and-shaffie-weru-defends-betty-kyallo-after-kot-trolled-her/d8y5dwe">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/BzKk9kpTURBXy83NzkwNTcxNDFmYWQ5YTZkYzUxZmIzZjVkNGMzYWE4Yy5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Boniface Mwangi comes to Betty Kyallo’s defense after bitter rant on Instagram live"  data-original="//ocdn.eu/pulscms-transforms/1/1_nk9kpTURBXy83NzkwNTcxNDFmYWQ5YTZkYzUxZmIzZjVkNGMzYWE4Yy5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Boniface Mwangi comes to Betty Kyallo’s defense after bitter rant on Instagram live
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/my-brother-is-single-shouts-diamonds-sister-after-wema-sepetu-shared-this-photo/dskfcfv">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/Ovpk9kpTURBXy81YzM5YWNiOWNlNWI3NWE5N2YyOGQwYTkyYzRkNmM4OC5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="My brother is single – Shouts Diamond’s sister after Wema Sepetu shared this photo"  data-original="//ocdn.eu/pulscms-transforms/1/CdFk9kpTURBXy81YzM5YWNiOWNlNWI3NWE5N2YyOGQwYTkyYzRkNmM4OC5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        My brother is single – Shouts Diamond’s sister after Wema Sepetu shared this photo
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/pastor-james-nganga-alleged-claims-on-coronavirus-healing/7t3kxvk">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/8nnk9kpTURBXy9lYTlkZjg0NWU4NDk0NDFmMjk2NDY1NDVlM2FiMDE0MS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Ningeruhusiwa na Government nifungiwe na watu wakona Corona ungeona venye Mungu angefanya kazi – Pastor Ng’ang’a"  data-original="//ocdn.eu/pulscms-transforms/1/A1Ak9kpTURBXy9lYTlkZjg0NWU4NDk0NDFmMjk2NDY1NDVlM2FiMDE0MS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Ningeruhusiwa na Government nifungiwe na watu wakona Corona ungeona venye Mungu angefanya kazi – Pastor Ng’ang’a
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/adelle-onyango-opens-up-on-her-grief-and-losing-her-late-mum/2cykjfg">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/MR6k9kpTURBXy81ZTEzMTg0NzVjYjA1ZjdlMGE4MzJiM2MzNjU5ZWU5Yi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="I’m terribly sad about it but I own my grief – Adelle Onyango on missing her late mum"  data-original="//ocdn.eu/pulscms-transforms/1/Z9Qk9kpTURBXy81ZTEzMTg0NzVjYjA1ZjdlMGE4MzJiM2MzNjU5ZWU5Yi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        I’m terribly sad about it but I own my grief – Adelle Onyango on missing her late mum
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/eliud-kipchoges-dressing-on-gq-magazine-attracts-mixed-reactions-from-kenyans/hl9cn1s">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/6IEk9kpTURBXy8zYWZmNDdhNmMwYTI3MmVhZjczMWIxZGQwZTg3NGIzNi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Eliud Kipchoge’s dressing on GQ magazine attracts mixed reactions from Kenyans"  data-original="//ocdn.eu/pulscms-transforms/1/ahHk9kpTURBXy8zYWZmNDdhNmMwYTI3MmVhZjczMWIxZGQwZTg3NGIzNi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Eliud Kipchoge’s dressing on GQ magazine attracts mixed reactions from Kenyans
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
                <div class="col-md-4 col-xs-12">
                    






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/akothee-dismisses-claims-of-being-pregnant-with-bahatis-child/z826szj">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/oY-k9kpTURBXy81Zjc0NDhiNzMwMTFjNGUyN2U3MTBmMzY0MGVmNWMxZS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Akothee’s response after claims of being pregnant with Bahati’s child"  data-original="//ocdn.eu/pulscms-transforms/1/uH1k9kpTURBXy81Zjc0NDhiNzMwMTFjNGUyN2U3MTBmMzY0MGVmNWMxZS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Akothee’s response after claims of being pregnant with Bahati’s child
                    </h3>
                    
                    
                        <span class="itemDate">Published 03/31/2020</span> 
                    
                    
                </div>
        </div>
    </article>
</a>
                </div>
            
        
            
        
            
        
            
        
            
        
        </div>
    </div>
    
</div>
</div>
</section>
<!-- widgetRight4 -->
                                            
                                                
     <script>                              (function(window, document, undefined) {                            var script_tag = document.createElement('script');                            script_tag.src = 'https://ad.mox.tv/mox/mwayss_invocation.min.js?pzoneid=5163&height=405&width=720&tld=pulselive.co.ke&ctype=iframe';                            var container = document.querySelectorAll('[data-id=_mwayss-978f50cc641698ad9dc63615cc2410f9]')[0];                                container.setAttribute('id', (container.getAttribute('data-id')+(new Date()).getTime()));                            container.removeAttribute('data-id');                            container.parentNode.insertBefore(script_tag, container);                        })(window, document);                    </script>
<!-- widgetRight5 -->
                                            
                                                
    <div id="taboola-below-article-thumbnails"></div><script type="text/javascript">    window._taboola = window._taboola || [];    _taboola.push(            {mode: 'thumbnails-a', container: 'taboola-below-article-thumbnails', placement: 'Below Article Thumbnails', target_type: 'mix'}    );</script>
<!-- widgetRight6 -->
                                            
                                                <!-- widgetRight7 -->
                                            
                                        
                                    
                                                                    

                                    
                                     <!-- no ads bannner -->
                                                                       
                                        
                                    
                                    </article>                
                            </div>
                            <!--check if its a featured article -->   
                             <!-- disbale right column  -->
                                    
                                    <div class="rightColWrapper">
                                        <aside class="extraList">
                                                
                                                    
                                                        
  <div class="onet-ad" id="onet-ad-right" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("right");
            onetAds.show("right");
        </script>
    </div>
<!-- widgetRight0 -->
                                                    
                                                        


<section>
<div class="col-xs-12 wdgWrapper">
<div
    class="wdg wdgStandardRightColumn "
     >
    
    
    
    <div class="wdgItems">
        <div class="row">
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/celebrities-side-with-mulamwah-after-announcing-he-is-quitting-comedy-over/byc2ewf">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/EHAk9kpTURBXy9mZjBlZWI4YWRhMjlmMzI0YjM2NWZjY2Y2ZTkzMGQ3NS5wbmeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="We had just lost our baby at 3 months - Comedian Mulamwah quits comedy over cyberbullying"  data-original="//ocdn.eu/pulscms-transforms/1/6pwk9kpTURBXy9mZjBlZWI4YWRhMjlmMzI0YjM2NWZjY2Y2ZTkzMGQ3NS5wbmeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        We had just lost our baby at 3 months - Comedian Mulamwah quits comedy over cyberbullying
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/two-of-alkibas-signees-cheed-and-killy-call-it-quits-from-kings-music-records/gwg3hn2">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/7QDk9kpTURBXy8xMDU0OWVmY2ExY2I5ZjBhOWMwZjk1Y2JjYzI1MzZiNi5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Two of Alkiba’s signees call it quits from Kings Music Records"  data-original="//ocdn.eu/pulscms-transforms/1/ehZk9kpTURBXy8xMDU0OWVmY2ExY2I5ZjBhOWMwZjk1Y2JjYzI1MzZiNi5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Two of Alkiba’s signees call it quits from Kings Music Records
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/embs-weezdom-reveals-why-he-has-ditched-the-gospel-industry/9qneht6">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/5O2k9kpTURBXy9jYTllM2NjODUyNGYyNTdmOGExZTRhNDE0NGUxNzA4OS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Bahati’s signee Weezdom quits Gospel Music Industry"  data-original="//ocdn.eu/pulscms-transforms/1/Z1Fk9kpTURBXy9jYTllM2NjODUyNGYyNTdmOGExZTRhNDE0NGUxNzA4OS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Bahati’s signee Weezdom quits Gospel Music Industry
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
                    <div class="col-xs-12">
                        






<a class="itemWrapper" href="https://www.pulselive.co.ke/entertainment/alikiba-speaks-after-2-of-his-kings-music-records-signees-ditched-the-label/2cq2j1c">
    <article>
        <div class="item show">
                <div class="itemImage col-md-12 col-xs-6" >
                   
                   
                   
                  
                       <picture>
                            <source data-original="//ocdn.eu/pulscms-transforms/1/HEVk9kpTURBXy8yMTM2MTU4ZjA1MmE0NzFlMjRkNWVlMDBjNDViMjYzOS5qcGeRkwXNAYbM4IGhMAU" type="image/webp">
                            <img alt="Alikiba speaks after 2 of his Kings Music Records signees ditched the label"  data-original="//ocdn.eu/pulscms-transforms/1/kfLk9kpTURBXy8yMTM2MTU4ZjA1MmE0NzFlMjRkNWVlMDBjNDViMjYzOS5qcGeRkwXNAYbM4IGhMAE" src="data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D"  />
                        </picture>
                        
                  
                  
                </div>
                
                <div class="itemDesc col-md-12 col-xs-6">
                    <h3 class="itemTitle">
                        Alikiba speaks after 2 of his Kings Music Records signees ditched the label
                    </h3>
                    
                    
                    
                </div>
        </div>
    </article>
</a>
                    </div>
                
            
                
            
                
            
                
            
                
            
        </div>
    </div>
    
</div>
</div>
</section>
<!-- widgetRight1 -->
                                                    
                                                        
  <div class="onet-ad" id="onet-ad-right3" data-collapse="1">
        <script type="text/javascript">
            onetAds.addSlot("right3");
            onetAds.show("right3");
        </script>
    </div>
<!-- widgetRight2 -->
                                                    
                                                        
    <div class="extraList"  data-content-container="stream">
        <div id="floatingGroup" data-run-module="local/main.asideContainerDel_float">
            <div id="stickyRight" class="asideAds asideBlock">
                <div class="stickyWrapper" data-pos="1">
                    <div id='onet-ad-right2' class='onet-ad sticky-slot'></div>
                </div>
            </div>
        </div>
    </div>
<!-- widgetRight3 -->
                                                    
                                                
                                        </aside>
                                    </div>
                                    
                            
                        </div>
                    </div>
                </div>
                <!-- gallery -->
            </div>
        </section>
        <footer class='footer'>
    <div class="topFooter">
        <div class="footer pageWrapper container customSize">
            <div class="serviceFooterContainer">
                <div class="logoContainer">
                    
                        <a class="portalLogo" href="//www.pulselive.co.ke">
                            <img src="https://ocdn.eu/radp/logotypes/pulselive-kenya.svg">
                        </a>
                    
                    
                        <p class="fnote">PulseLive KE is Kenya&#39;s new media publisher. 24/7 live news &amp; videos</p>
                    
                </div>
                
                <ul class="footNav">
                    
                        
                            <li>
                                <a href="" title="Home" class="fHeader">Home</a>
                                
                                <ul class="footNavSecond">
                                    
                                        
                                        <li>
                                            <a href="/news" title="News">News</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/entertainment" title="Entertainment">Entertainment</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/lifestyle" title="Lifestyle">Lifestyle</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/sports" title="Sports">Sports</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/bi" title="Business Insider">Business Insider</a>
                                        </li>
                                        
                                    
                                </ul>
                                
                            </li>
                        
                    
                        
                            <li>
                                <a href="/sports" title="Sports" class="fHeader">Sports</a>
                                
                                <ul class="footNavSecond">
                                    
                                        
                                        <li>
                                            <a href="/sports/football" title="Football">Football</a>
                                        </li>
                                        
                                    
                                        
                                        <li>
                                            <a href="/sports/more" title="More Sports">More Sports</a>
                                        </li>
                                        
                                    
                                </ul>
                                
                            </li>
                        
                    
                    
                    <li>
                        <span class="fHeader">About Us</span>
                        <ul class="footNavSecond">
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/about-us" title="About Us">About Us</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/advertise-with-us" title="Advertise">Advertise</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/privacy-policy-pulselivecoke/vh9gdmy	" title="Privacy Policy">Privacy Policy</a>
                            </li>
                            
                            
                            
                            <li>
                                <a href="//www.pulselive.co.ke/info/terms-and-conditions-pulselivecoke/d1z0r3q" title="Terms &amp; Conditions">Terms &amp; Conditions</a>
                            </li>
                            
                            
                        </ul>
                    </li>
                    
                    
                    <li>
                        <span class="fHeader">Social</span>
                        
<div id="socialLinks" class="socialLinks serviceFooterContainer">
    <ul class="profileList">
        
        <li class="facebook icon-fb">
            <a href="https://www.facebook.com/pulselivekenya/" title="Follow us on Facebook">Facebook</a>
        </li>  
        
        
        <li class="twitter icon-twitter">
            <a href="https://twitter.com/pulselivekenya" title="Follow us on Twitterze">Twitter</a>
        </li>  
        
        
        
        <li class="instagram icon-instagram">
            <a href="https://www.instagram.com/pulselivekenya/" title="Follow us on Instagram">Instagram</a>
        </li>  
        
        
        
        <li class="youtube icon-youtube">
            <a href="https://www.youtube.com/channel/UCd27iRLqJh3aozOqzGo1ONw" title="Watch us on YouTube">YouTube</a>
        </li>  
        
        
        <li class="newsletter icon-newsletter">
            <a href="https://www.pulselive.co.ke/newsletter" title="Registration and newsletter subscription">Newsletter</a>
        </li>  
        
    </ul>
</div>

                    </li>
                    
                </ul>
                
                <div class="slideToTop" data-run-module="uss/main.slideToTop" style="opacity: 0;">
                    <a href="javascript:void(0)">
                        <span></span>
                    </a>
                </div>
            </div>
        </div>
    </div>
    <div class="bottomFooter">
        <div id="copyrights" class="container">
            &copy; 2020  Pulselive.co.ke
        </div>
    </div>

</footer>

            
        <!-- Use footer script -->
        
        
        <script type="text/javascript"></script>
         
        <script type="text/javascript"> window._taboola = window._taboola || []; _taboola.push( {flush: true} );  </script>
        <script type="text/javascript" src="https://ocdn.eu/radp/quantcast_ live kenya.js" async/></script>
        <script type="text/javascript" src="//ocdn.eu/ucs/static/eecce0d17045db28acc5addb8f13cead/1404a3b982753f13e9f0b2a43ebd609f/build/push.js" defer></script>    
        




<script>

    window._io_config = window._io_config || {};
    window._io_config["0.2.0"] = window._io_config["0.2.0"] || [];
    window._io_config["0.2.0"].push({
        "page_url": "https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39",
        "page_url_canonical": "https://www.pulselive.co.ke/entertainment/ethic-forced-to-apologize-and-pull-down-their-controversial-song-soko-after-backlash/ttnwf39",
        "page_title": "Ethic group speaks after backlash from Kenyans over their controversial song ‘Soko'",
        "page_type": "article";
        "page_language": "en",
        "article_authors": ["Dennis Milimo"],
        "article_categories": ["Kenya entertainment"],
        "article_type": "longread",
        "article_word_count": "411",
        "article_publication_date": "Tue, 21 Apr 2020 05:12:31 GMT"
    }
    );
</script>
<!-- ioScript -->
    </body>
    </div>
    </html>
